VÁLASZT függvény

Ez a cikk a Microsoft Excel VÁLASZT függvényének képletszintaxisát és használatát ismerteti.

Leírás

A függvény az érték argumentumok közül az index sorszámút adja vissza. A VÁLASZT függvényben az érték argumentumok száma legfeljebb 254 lehet. Amennyiben például az érték1; ... ; érték7 argumentum a hét napjainak neve, akkor a VÁLASZT függvény a napok egyikét adja eredményül, ha az index értékének egy 1 és 7 közötti számot ad meg.

Szintaxis

VÁLASZT(index; érték1; [érték2]; ...)

A VÁLASZT függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • index:    Kötelező megadni. A kiválasztott argumentumot határozza meg. Értéke 1 és 254 közötti egész szám, képlet vagy egy 1 és 254 közötti számot tartalmazó cellára utaló hivatkozás lehet.

    • Ha az index 1, akkor a VÁLASZT függvény az érték1 argumentumot adja vissza, ha 2, az érték2 argumentumot, és így tovább.

    • Ha az index kisebb, mint 1, vagy nagyobb, mint az érték argumentumok száma a listában, a VÁLASZT függvény #ÉRTÉK! hibaüzenetet ad eredményül.

    • Ha az index törtszám, a VÁLASZT függvény annak egész részével számol.

  • Érték1, érték2,...:     Az Érték1 kötelező, további értékek megadása választható. Legfeljebb 254 argumentum; a függvény közülük választja ki az index által megadott értéket vagy végrehajtandó tevékenységet. Az argumentumok lehetnek számok, cellahivatkozások, nevek, képletek, függvények vagy szövegek.

Megjegyzések

  • Ha tömb az index, akkor a VÁLASZT függvény végrehajtása során az összes érték kiértékelődik.

  • Az érték argumentumok nemcsak egyszerű értékek, hanem tartományhivatkozások is lehetnek.

    Példa erre az alábbi képlet:

=SZUM(VÁLASZT(2;A1:A10;B1:B10;C1:C10))

amely megfelel az alábbinak:

=SZUM(B1:B10)

amely a B1:B10 tartomány értékein alapuló eredményt fogja szolgáltatni.

Először a VÁLASZT függvény kerül kiértékelésre, és a B1:B10 hivatkozást adja eredményül, majd a SZUM függvény végrehajtása történik a B1:B10 tartományon mint argumentumon.

Példák

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Adatok

 

1.

Szegek

2.

Csavarok

3.

Alátétek

Kész

Csapszegek

Képlet

Leírás

Eredmény

=VÁLASZT(2;A2;A3;A4;A5)

A második listaargumentum értéke (az A3 cella értéke)

2.

=VÁLASZT(4;B2;B3;B4;B5)

A negyedik listaargumentum értéke (a B5 cella értéke)

Csapszegek

=VÁLASZT(3;"Széles";115;"világ";8)

A harmadik listaargumentum értéke

világ

2. példa

Adatok

23

45

12

10

Képlet

Leírás (eredmény)

Eredmény

=SZUM(A2:VÁLASZT(2;A3;A4;A5))

Az A2:A4 tartomány összegzése. A VÁLASZT függvény A4-et ad vissza a SZUM függvény tartománya második részeként.

80

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×