Szorzatösszeg képzése egy vagy több tömb megfelelő értékeiből a SZORZATÖSSZEG függvénnyel

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

SZORZATÖSSZEG használja, mint (a részei a képletet, amely a helyes működéséhez) argumentumai cellatartományok (vagy tömb). Közös szorzatát számítja ki a tömbök az elemeket, és majd összegzi az eredményt.

Ez a példa egy bevásárlólista, amelynek egyik tömbje az egyes cikkek árát, a másik tömb pedig a megvásárolt cikkmennyiségeket tartalmazza.

Szorzandó és összeadandó árak és mennyiségek

  1. A képlet létrehozásához írja be az =SZORZATÖSSZEG(B3:B6;C3:C6) kifejezést , és nyomja le az ENTER billentyűt.

A program a B oszlop minden celláját megszorozza az adott sor C oszlopban szereplő értékével, majd összegzi a szorzatokat. A vásárolt cikkek összértéke 2100,60 Ft.

  1. Írhat hosszabb képleteket, amely lehetővé teszi ugyanazt az eredményt, típus = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6, és nyomja le az ENTER billentyűt.

Az Enter lenyomása után az eredmény ugyanaz (2100,60 Ft). A program összeszorozza a B3 és a C3 cellát, majd az eredményét hozzáadja a B4 és C4 cella szorzatához és így tovább. Elképzelheti, hogy ha több száz (vagy akár több ezer) sora lenne, mennyivel könnyebb lenne a SZORZATÖSSZEG függvényt használni.

Megjegyzések: 

  • Az oszlopoknak vagy soroknak (tömböknek) egyenlő hosszúaknak kell lenniük.

  • Ha egy cellában szám helyett szöveg van, akkor a függvény nullának veszi.

Példa

Ha szeretne kicsit játszani az SZORZATÖSSZEG és tömbök, itt is Excel Online munkafüzetet különböző adatokkal, mint a jelen cikkben használt.

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

A

B

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Képlet

Eredmény

'=SZORZATÖSSZEG(A2:B4;D2:E4)

=SZORZATÖSSZEG(A2:B4;D2:E4)

Összeszorozza egymással a két tömb (A2:B4 és D2:E4) összetevőit, majd összeadja a szorzatokat. Az érték: 3*2+4*7+8*6+6*7+1*5+9*3 (156).

Teljesebb tapasztal akkor is megnyithatja a munkafüzetet az Excel programban. Kattintson az Excel ikonra a munkafüzet Az Excel Web App Excel ikonja jobb alsó sarkában, és mentse a fájlt kényelmes helyet a számítógépen nyissa meg.

Vissza a lap tetejére

Office-ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×