Szorzatösszeg képzése egy vagy több tömb megfelelő értékeiből a SZORZATÖSSZEG függvénnyel

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A SZORZATÖSSZEG függvény argumentumai (működéshez szükséges értékei) cellatartományok (vagyis tömbök). A függvény összeszorozza egymással a tömb elemeit, majd összegzi az eredményt.

Ez a példa egy bevásárlólista, amelynek egyik tömbje az egyes cikkek árát, a másik tömb pedig a megvásárolt cikkmennyiségeket tartalmazza.

Szorzandó és összeadandó árak és mennyiségek

  1. A képlet létrehozásához írja be az =SZORZATÖSSZEG(B3:B6;C3:C6) kifejezést, és nyomja meg az Enter billentyűt.

A program a B oszlop minden celláját megszorozza az adott sor C oszlopban szereplő értékével, majd összegzi a szorzatokat. A vásárolt cikkek összértéke 2100,60 Ft.

  1. Írhat hosszabb képleteket, amely lehetővé teszi ugyanazt az eredményt, típus = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6, és nyomja le az ENTER billentyűt.

Az Enter lenyomása után az eredmény ugyanaz (2100,60 Ft). A program összeszorozza a B3 és a C3 cellát, majd az eredményét hozzáadja a B4 és C4 cella szorzatához és így tovább. Elképzelheti, hogy ha több száz (vagy akár több ezer) sora lenne, mennyivel könnyebb lenne a SZORZATÖSSZEG függvényt használni.

Megjegyzések: 

  • Az oszlopoknak vagy soroknak (tömböknek) egyenlő hosszúaknak kell lenniük.

  • Ha egy cellában szám helyett szöveg van, akkor a függvény nullának veszi.

Példa

Ha szeretne kicsit játszani a SZORZATÖSSZEG függvénnyel és a tömbökkel, akkor a következő Excel Online-munkafüzetben megteheti. Ebben a munkafüzetben a cikkétől eltérő adatok vannak.

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Egy

B:

D

E

3

4

2

7

8

6

6

7

1

9

5

3

Képlet

Eredmény

'=SZORZATÖSSZEG(A2:B4;D2:E4)

=SZORZATÖSSZEG(A2:B4;D2:E4)

Összeszorozza egymással a két tömb (A2:B4 és D2:E4) összetevőit, majd összeadja a szorzatokat. Az érték: 3*2+4*7+8*6+6*7+1*5+9*3 (156).

Ha még több tapasztalatot szeretne szerezni, akkor ezt a munkafüzetet az Excelben is megnyithatja. Kattintson az Excel ikonra a munkafüzet jobb alsó sarkában  Az Excel Web App Excel ikonja , mentse a fájlt a számítógép egy tetszőleges mappájába, majd nyissa meg.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×