Szakasz beszúrása

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A Microsoft Office InfoPath-űrlapsablonjában a szakaszokat a vezérlők egyes csoportjainak a csoportosításához használhatja.

Tartalom

Mikor érdemes használni egy szakasz

Szakasz beszúrásához

Az űrlap értékei alapján szakasz elrejtése

Tanácsok az elrendezéshez

Mikor használjon szakaszt

Szakaszt akkor használjon, ha rendszerezni szeretné az űrlapsablonon a vezérlők egy csoportját. Egy biztosítási igénylőlapon például egy szakaszt használhat a szövegmezők azon csoportjának a csoportosításához, amelyek a biztosítottól gyűjtik össze a kapcsolatfelvétel adatait.

Szövegdobozok tartalmazó szakaszban

Használhatja a feltételes formázás is, hogy elrejtse vagy megjelenítse azon szakaszokat, amelyek olyan értékeken alapszanak, amit a felhasználók másutt adtak meg az űrlapon. Egy költségjelentés űrlapon például arra használhatja a feltételes formázást, hogy megjelenítse a Menedzser jóváhagyás szakaszt azoknál a felhasználóknál, akiknél a költségek összege több, mint 1000 US$. Ha a költségek ennél alacsonyabbak, ekkor ez a szakasz rejtve marad az űrlapon.

Egy szakasz beszúrása az űrlapsablonba tulajdonképp egy üres tároló beszúrását jelenti – ahhoz, hogy ennek haszna is legyen, más vezérlőket kell elhelyezni benne. Ezek a vezérlők lehetnek szövegmezők, listák vagy akár más szakaszok is.

Tipp : Alapértelmezés szerint a szakaszok szegélyei nem láthatóak az űrlapon. Ha azt szeretné, hogy a szakasz körvonala megjelenjen, ahogy a biztosítási igénylőlap példában is, akkor ezt a Szegély és mintázat párbeszédpanel segítségével állíthatja be.

Kapcsolódó vezérlőelemek

Az InfoPath több olyan vezérlőt is tartalmaz, melyek hasonlítnak a szakaszhoz, de mást célokra szolgálnak. A következő táblázat annak eldöntésére szolgál, hogy melyik vezérlő a leginkább alkalmas az űrlapsablonhoz.

Ismétlődő szakasz:     Olyan szakasz létrehozásához, melyet a felhasználók többször is beilleszthetnek az űrlapba, használja az ismétlődő szakaszt vagy más ismétlődő vezérlőt.

Választható szakasz:     Ha egy szakaszt hozzáad a sablonhoz, akkor az megjelenik, amikor a felhasználó először nyitja meg az űrlapot. A választható szakaszok alapértelmezés szerint rejtve vannak. A felhasználók eldönthetik, hogy beillesszék-e őket az űrlapba.

Adatválaszték-csoport:     Olyan szakasz beillesztéséhez, melyet egy másik szakasszal le lehet cserélni, használja az adatválaszték-csoportot. Az adatválaszték-csoport több szakaszt tartalmaz. Alapértelmezés szerint ezek közül csak egy jelenik meg az űrlapon. A felhasználók lecserélhetik a szakaszt egy másik szakasszal.

Vissza a lap tetejére

Szakasz beszúrása

A szakasz beszúrása kissé különbözik, ha új, üres űrlapsablonba szeretne szakaszt beszúrni vagy ha adatbázison, illetve külső adatforráson alapuló űrlapsablont tervez.

A következő ábra bemutatja, hogyan néz ki a szakasz a tervező mód.

Üres szakasz Tervező módban kiválasztva

A vezérlők lehetnek kötöttek vagy kötetlenek. Ha egy vezérlő kötött, össze van kapcsolva az adatforrás egy mezőjével vagy csoportjával, így a vezérlőben megadott adatok az alapul szolgáló űrlapfájlban (.xml) vannak mentve. Ha egy vezérlő kötetlen, nincs összekapcsolva mezővel vagy csoporttal, és a vezérlőben megadott adatokat nem menti a program. Ha kijelöl egy vezérlőt vagy a mutatót fölé helyezi, szöveg és egy kötés ikon jelenik meg a vezérlő jobb felső sarkában. A szöveg jelzi a csoportot vagy mezőt, amelyhez a vezérlő az adatforrásban kötődik. Az ikon azt jelzi, hogy a vezérlő megfelelően kötődik-e az adott csoporthoz vagy mezőhöz. Ha a kötés megfelelő, egy zöld ikon jelenik meg. Ha a kötéssel kapcsolatban probléma tapasztalható, kék vagy vörös ikon látható.

Az űrlapsablon az adatforráshoz, ahol a mezők és csoportok, amelyek az Adatforrás munkaablakban hierarchikus nézetben jelennek meg. Szakaszok mindig kötődnek csoportok, az űrlapsablon adatforrásban. Egyes vezérlőelemek egy szakasz egy része a szakaszcsoport mező van kötve.

A következő példában az űrlapsablon Biztosított Adatai szakasza az Adatforrás munkaablak Biztosítottcíme csoporthoz van kötve.

űrlapsablonon található vezérlősablon szakasz és a megfelelő csoporttal az adatforrásban viszonya

Szakasz beillesztése egy új, üres űrlapsablonba

Új, üres űrlapsablon létrehozásakor az Adatforrás automatikus létrehozása jelölőnégyzet alapértelmezés szerint be van jelölve a Vezérlők munkaablakban. Ez lehetővé teszi, hogy az InfoPath automatikusan létrehozzon mezőket és csoportokat az adatforrásban, amikor vezérlőket vesz fel az űrlapsablonra. Ezeket a mezőket és csoportokat mappa- és fájlikonok jelképezik az Adatforrás munkaablakban.

  1. Helyezze a kurzort az űrlapsablon azon pontjára, ahová be szeretné szúrni a vezérlőt.

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. A Vezérlők beszúrása listában jelölje ki a Szakasz elemet.

  4. A szakasz vezérlőinek hozzáadásához húzza a kívánt vezérlőket a Vezérlők munkaablakból az űrlapsablon szakaszába.

    Megjegyzés : Ne helyezzen a szakaszba olyan vezérlőt, amely már szerepel az űrlapsablonon, kivéve ha a vezérlő mezője az adatforrásban része a szakaszhoz tartozó csoportnak. Máskülönben megsérülhet a vezérlő kötése.

  5. A vezérlő címkéjének megadásához írja be a kívánt szöveget a vezérlő fölé.

Szakasz beillesztése olyan űrlapsablonba, amelyik egy létező adatforráson alapszik

Ha meglévő Extensible Markup Language (XML)-fájl, adatbázis vagy űrlapsablon tervezése, az InfoPath származik, mezők és csoportok a Adatforrás munkaablak az meglévő adatforrásból. Ebben az esetben egy szakasz ismétlődő csoport húzza az alakzatot az űrlapsablon az Adatforrás munkaablak vagy a Beszúrás a szakasz a vezérlők munkaablak használatával, ahogy az alábbi eljárás szerint adhat meg:

  1. Helyezze a kurzort az űrlapsablon azon pontjára, ahová be szeretné szúrni a vezérlőt.

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. A Vezérlők beszúrása csoportban jelölje ki a Szakasz elemet.

  4. Az Szakasz kötése párbeszédpanelen válassza ki azt a csoportot, ahol a szakasz adatait szeretné tárolni, majd kattintson az OK gombra.

  5. Adjon vezérlőket a szakaszhoz, majd kösse őket az adatforrás megfelelő mezőihez.

Vissza a lap tetejére

Olyan szakasz elrejtése, mely az űrlap értékein alapszik

A feltételes formázás nem csak a vezérlők formázásainak módosítására alkalmas. A legjobb módszer egy vezérlő elrejtésre vagy megjelenítésére egy másik vezérlőben megadott értéken alapul. A tipikus módszer erre, ha a szakasz tetején egy jelölőnégyzet van és ennek bejelölése vagy a jelölésének a törlése elrejti vagy megjeleníti a szakaszt. Ez a technika lehetővé teszi, hogy a megfelelő információt a megfelelő időpontban mutassa meg.

Ez az eljárás feltételezi azt, hogy már hozzáadott egy szakaszt az űrlapsablonhoz.

  1. Kattintson az űrlapsablonnak arra a szakaszára, amit el szeretne rejteni.

  2. Kattintson a Formátum menü Feltételes formázás parancsára.

  3. A Feltételes formázás párbeszédpanelen kattintson a Hozzáadás gombra.

  4. A Ha ez a feltétel teljesül rész alatt adja meg a kívánt feltételt. Ha például el szeretné rejteni az 1. lépésben kijelölt szakasz, amikor egy konkrét jelölőnégyzet be van jelölve, akkor jelölje ki azt a mezőt, amihez a jelölőnégyzet kötve van az első mezőben és határozza meg azt az értéket, mely a szakasz láthatóságát fogja szabályozni.

    Tipp : A jelölőnégyzeteknél a TRUE azt jelenti, hogy „kiválasztva”, „bejelölve” és a FALSE pedig a „jelöletlen” vagy „törölt”.

  5. A következő formázás alkalmazása szakaszban kattintson a Vezérlő elrejtése elemre.

  6. A feltétel mentéséhez és az űrlapsablonhoz való visszatéréshez kattintson mindkét párbeszédpanelen az OK gombra.

  7. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Tippek az elrendezéshez

Mielőtt vezérlőket illesztene be egy űrlapsablon szakaszába, tervezze meg, hogyan szerezné a vezérlőket elrendezni. Hozzáadhatja a szövegmezőket és más vezérlőket kötetlen elrendezésben is a szakaszhoz úgy, hogy oda húzza őket, ahová szeretné. Lehetőség van az elrendezés további szabályozására is - például elrendezéstábla illeszthet a szakasz belsejébe, és csak ezután helyezi el a címkéket és a vezérlőket az egyedi cellákba úgy, hogy azok elrendezése szabályos legyen. A következő példában az űrlapsablon tervezője egy két sorból és három oszlopból álló táblázatot használt a vezérlők elrendezéséhez a szakaszban.

A szövegdobozok tartalmazó elrendezéstáblázat szakasz

In addition to using layout tables, you can do one or more of the following:

  • To change the size of several sections at once, select the sections whose size you want to change, press ALT+ENTER, click the Size tab, and then make the necessary adjustments.

  • To change the border or color of a section, select it on the form template, on the Format menu, click Borders and Shading, click the Borders tab, and then make the necessary adjustments.

  • To see how the controls in your section will look with actual text in them, click Sample Data on the View menu. This helps you get a sense of what a form based on your form template will look like when a user fills it out.

  • On occasion, the text inside the controls in a section and the labels to the left of those controls may appear to be slightly out of alignment. To quickly realign them, double-click the control, click Align on the Size tab, and then click Apply. If the label and control are in different cells in a layout table, right-click the cell that contains the label, click Table Properties on the shortcut menu, and then click Center under Vertical alignment on the Cell tab.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×