Számok összeadása

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Tételezzük fel, hogy ki szeretné számítani egy áruházi készlet teljes árát, vagy a költségkeretet túl nem lépő összes részleg bruttó haszonkulcsát. A számok összeadására többféle lehetőség van. A képletekben a pluszjelet (+) használva gyorsan beírhat számokat a cellákba.

Ha például beírja az =5+10 karakterláncot, a cellában megjelenik az eredmény, azaz 15.

Egy sorban vagy oszlopban lévő összes szám összeadása

Üres cellákat nem tartalmazó, egymással szomszédos számokból álló tartomány esetén használhatja az AutoSzum Gomb képe gombot.

  1. Kattintson a számoszlop alatti vagy a számsortól jobbra levő cellára.

  2. Kattintson a Kezdőlap > AutoSzum gombra, és nyomja le az Enter billentyűt.

Nem szomszédos számok összeadása

Ha üres vagy számok helyett szöveget tartalmazó cellákból álló számtartománnyal dolgozik, használja a SZUM függvényt egy képletben. A program figyelmen kívül hagyja a képletben használt tartományban esetleg előforduló üres vagy szöveget tartalmazó cellákat.

Példa

Ebben a munkafüzetben néhány példát talál a függvény alkalmazására. A beírt képleteket megvizsgálva és módosítva, illetve saját képleteket beírva megismerheti a függvény működését.

Megjegyzés : A SZUM függvény legfeljebb 30 cella- vagy tartományhivatkozást tartalmazhat. A =SZUM(B2:B3,B5) képletben például egy tartományhivatkozás (B2:B3) és egy cella (B5) szerepel.

Számok összeadása egyetlen feltétel alapján

A SZUMHA függvény segítségével kiszámíthatja egy tartomány összegértékét egy másik tartomány értéke alapján. Az alábbi példa a B (Értékesítés) oszlop azon értékeinek összesítését mutatja be, amelyek a Béres nevű értékesítő A (Értékesítő) oszlopában szereplő értékekhez tartoznak.

Példa

Ebben a munkafüzetben néhány példát talál a SZUMHA függvény alkalmazására. A beírt képleteket megvizsgálva és módosítva, illetve saját képleteket beírva megismerheti a függvény működését.

Számok összeadása több feltétel alapján

A feladat végrehajtásához használja a SZUMHATÖBB függvényt.

Példa

Ebben a munkafüzetben néhány példát talál a függvény alkalmazására. A beírt képletet megvizsgálva és módosítva, illetve saját képleteket beírva megismerheti a függvény működését.

A függvények használata a SZUMHATÖBB képletet használó példában

=SZUMHATÖBB(D2:D11;A2:A11;"Dél";C2:C11;"Hús")

Az első képletben a SZUMHATÖBB függvényt használjuk azoknak a soroknak a keresésére, amelyekben a „Dél” érték található az A, és a „Hús” érték a C oszlopban. Három ilyen eset fordul elő: a 7., 8. és 11. sorban. A függvény először a régiókat tartalmazó A oszlopban keres a „Dél” értékre, majd az étel típusát tartalmazó C oszlopban keresi a „Hús” értéket. A függvény végül az összesítendő értékeket tartalmazó D2:D11 tartományban végez keresést, és csak a két feltételnek megfelelő értékeket összegzi az oszlopban.

=SZUM(HA((A2:A11="Dél")+(A2:A11="Kelet");D2:D11))

A SZUM és a HA függvényt tartalmazó második képlet tömbképletként van megadva (a tömb módosításához kattintson a Megnyitás az Excel programban gombra), és azokat a sorokat keressük vele, amelyekben a „Dél” vagy a „Kelet” érték egyike vagy mindegyike megtalálható az A oszlopban. Hét ilyen eset fordul elő: a 2., 4., 6., 7., 8., 9. és 11. sorban. Mivel ez tömbképlet, a + operátor nem használható értékek összeadására; ekkor az egy vagy több feltétel keresésére szolgál, amelyek közül legalább egynek teljesülnie kell. Ezután a SZUM függvény használható a feltételeket teljesítő értékek összegzésére.

Csak egyedi értékek összeadása

A feladat végrehajtására a SZUM, a HA és a GYAKORISÁG függvény kombinációja használható.

A következő példa az alábbi módon használja ezeket a függvényeket:

  • A GYAKORISÁG függvény segítségével azonosítja az egyedi értékeket egy tartományban. Egy adott érték első előfordulásakor a függvény az érték előfordulásainak számával egyenlő értéket ad eredményül. Ugyanazon érték újbóli előfordulásakor a függvény értéke 0 (nulla) lesz.

  • A HA függvénnyel minden teljesülő feltételhez az 1-es értéket rendeli.

  • A SZUM függvénnyel minden teljesülő feltételhez az egyedi értékeket rendeli.

Példa

Ebben a munkafüzetben néhány példát talál az említett függvények alkalmazására. A beírt képletet megvizsgálva és módosítva, illetve saját képleteket beírva jobban megismerheti a függvények működését.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×