SZUMHA függvény

Ez a témakör a Microsoft Excel SZUMHAfüggvény képletszintaxisát és használatát mutatja be.

Leírás

A SZUMHA függvénnyel összeadhatja azokat az értékeket egy tartomány, amelyek megfelelnek a megadott feltételeknek. Ha például egy számokat tartalmazó oszlopban csak az 5-nél nagyobb értékeket szeretné összeadni, a következő képletet használhatja:

SZUMHA(B2:B25;">5")

A következő példa a feltételt közvetlenül az összeadandó értékekre alkalmazza. Azonban lehetséges a feltételeket egy tartományra alkalmazni, és egy másik tartomány megfelelő értékeit összeadni is. Például a =SZUMH(B2:B5, "Jani", C2:C5) képlet csak azokat az értékeket adja össze a C2:C5 tartományban, ahol a B2:B5 tartomány megfelelő cellái a „Jani" értéket tartalmazzák.

Megjegyzés   Ha több feltétel alapján szeretne összeadni cellákat, a SZUMHATÖBB függvény című témakörben talál további tudnivalókat.

Szintaxis

SZUMHA(tartomány; feltételek; [összegtartomány])

A SZUMHA függvény szintaxisa a következő argumentumok foglalja magában:

  • tartomány:    Megadása kötelező. A feltételek alapján kiértékelendő cellatartomány. Az egyes tartományok cellái számok, számokat tartalmazó tömbök vagy számokra mutató nevek, illetve hivatkozások lehetnek. Az üres és a szöveges értékeket a függvény figyelmen kívül hagyja.

  • feltételek:    Megadása kötelező. Az összeadandó cellákat meghatározó, számként, kifejezésként, cellahivatkozásként, szövegként vagy függvényként megadott feltétel, például: 32, ">32", B5, 32, "32", "alma" vagy MA().

    Fontos   Bármely szöveges feltételt vagy bármely olyan feltételt, amely logikai vagy matematikai szimbólumokat tartalmaz, dupla idézőjelbe (") kell tenni. Ha a feltétel numerikus, nem szükséges a dupla idézőjel.

  • összegtartomány:    Megadása nem kötelező. A ténylegesen összeadandó cellák, ha a tartományargumentumban megadottaktól eltérő cellákat szeretne összeadni. Ha az összegtartomány argumentumot elhagyja, az Excel a tartomány argumentumban megadott cellákat adja össze (ugyanazokat, amelyekre a feltételeket alkalmazza).

Megjegyzés   

  • Használhat helyettesítő karaktereket is – kérdőjelet (?) és csillagot (*) – a feltétel argumentumban. A kérdőjel egyetlen karaktert, míg a csillag tetszőleges számú karaktert helyettesíthet. Ha magát a helyettesítő karaktert keresi, írjon tilde karaktert (~) a keresett karakter elé.

Megjegyzések

  • A SZUMHA függvény helytelen eredményt ad, ha 255 karakternél hosszabb karakterláncokat egyeztet vele az #ÉRTÉK! karakterlánccal.

  • Az összegtartomány argumentumnak nem feltétlenül kell a tartomány argumentummal azonos méretűnek és formájúnak lennie. Az összeadásban ténylegesen szereplő cellák meghatározása az összegtartomány bal felső cellájából indul ki, majd belekerülnek az összeadásba a összegtartomány argumentumnak méret és forma szempontjából megfelelő cellák. Példa:

Ha a tartomány argumentum:

...és az összeg_tartomány argumentum:

...akkor a ténylegesen összeadandó cellák:

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Ha a SZUMHA függvény tartomány és összegtartomány argumentuma eltérő számú cellát tartalmaz, akkor a munkalap újraszámítása a vártnál hosszabb időt vehet igénybe.

Példák

1. példa

Az alábbi munkafüzetben néhány példát talál a függvény alkalmazására. A beírt képleteket megvizsgálva és módosítva, illetve saját képleteket beírva jobban megismerheti a függvény működését.

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Az ingatlan értéke

Jutalék

Adatok

10 000 000 Ft

700 000 Ft

25 000 000 Ft

20 000 000 Ft

1 400 000 Ft

30 000 000 Ft

2 100 000 Ft

40 000 000 Ft

2 800 000 Ft

Képlet

Leírás

Eredmény

=SZUMHA(A2:A5;">16000000";B2:B5)

A 16 000 000 fölötti értékű ingatlanok után járó jutalékok összege

6 300 000 Ft

=SZUMHA(A2:A5;">16000000")

A 16 000 000 fölötti értékű ingatlanok értékének összege

90 000 000 Ft

=SZUMHA(A2:A5;30000000;B2:B5)

A 30 000 000 fölötti értékű ingatlanok után járó jutalékok összege

2 100 000 Ft

=SZUMHA(A2:A5;">" & C2;B2:B5)

A C2 cellában megadott érték fölötti értékű ingatlanok után járó jutalékok összege.

4 900 000

Ha jobban el szeretne mélyedni a példaadatok Excelben történő használatában, töltse le a beágyazott munkafüzetet a számítógépére, és nyissa meg az Excelben.

2. példa

Az alábbi munkafüzetben néhány példát talál a függvény alkalmazására. A beírt képleteket megvizsgálva és módosítva, illetve saját képleteket beírva jobban megismerheti a függvény működését.

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Kategória

Élelmiszer

Értékesítés

Zöldségek

Paradicsom

230 000 Ft

Zöldségek

Zeller

550 000 Ft

Gyümölcs

Cseresznye

80 000 Ft

Vaj

40 000 Ft

Zöldségek

Répa

420 000 Ft

Gyümölcs

Alma

120 000 Ft

Képlet

Leírás

Eredmény

=SZUMHA(A2:A7;"Gyümölcs";C2:C7)

A „Gyümölcs” kategória összes élelmiszerének értékesítési összege.

200 000 Ft

=SZUMHA(A2:A7;"Zöldségek";C2:C7)

A „Zöldségek” kategória összes élelmiszerének értékesítési összege.

1 200 000 Ft

=SZUMHA(B2:B7;"*a";C2:C7)

Az összes „a” végű élelmiszer értékesítési összege (alma, répa).

430 000 Ft

=SZUMHA(A2:A7;"";C2:C7)

A kategória nélkül megadott összes élelmiszer értékesítési összege.

40 000 Ft

Ha jobban el szeretne mélyedni a példaadatok Excelben történő használatában, töltse le a beágyazott munkafüzetet a számítógépére, és nyissa meg az Excelben.

Vissza a lap tetejére

Hatókör: Excel 2013, Excel Online



Hasznos volt az információ?

Igen Nem

Hogyan tehetjük jobbá?

255 karakter írható még be

Adatvédelmi okokból ne írjon elérhetőségi információt a visszajelzésébe. Olvassa el adatvédelmi szabályzatunkat.

Köszönjük a visszajelzését!

Támogatási információk

Nyelv módosítása