Képletek és függvények

SZUM függvény

SZUM függvény

Megjegyzés: Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja.

A SZUM függvény, a matematikai és trigonometriai függvények, amely összeadja az értékeket. Egyedi értékek, cellahivatkozás vagy tartományok vagy mindhárom vegyesen is hozzáadhat.

Például:

  • =SZUM(A2:A10)

  • =SZUM(A2:A10; C2:C10)

Ez a böngésző nem támogatja a videók lejátszását. Telepítse a Microsoft Silverlightot, az Adobe Flash Playert vagy az Internet Explorer 9-es verzióját.

SZUM(szám1;[szám2];...)

Argumentum neve

Leírás

szám1    (Kötelező)

Az összeadás első tagja. A szám lehet például a 4, lehet egy cellahivatkozás, például B6 vagy egy cellatartomány, például B2:B8.

szám2–255    (Nem kötelező)

Az összeadás második tagja. Ily módon megadhat legfeljebb 255 további számot.

Ez a szakasz bemutatja, hogyan lehet a SZUM függvény használata kapcsolatos ajánlott eljárásokat. A legtöbb és más funkciók használata alkalmazhatók.

Az =1+2 vagy =A+B módszer – Még ha az „=1+2+3” vagy az „=A1+B1+C2” képlet egyszerűen beírhatónak és pontosnak is tűnik, ez a módszer több szempontból is problematikus:

  1. Elírások – Gondoljon bele, hogy mi lenne, ha sokkal több vagy nagyobb értékeket kellene beírnia, például:

    • =14598,93+65437,90+78496,23

    Próbálkozzon meg ellenőrzése, hogy helyesen-e a bejegyzéseket. Sokkal egyszerűbb helyezi el ezeket az értékeket az egyes cellák, és használja a SZUM képletbe. Ezeken kívül az értékek is formázhatja, azok van a cellákban, így olvashatóbbá sokkal, majd a képlet is legyenek.

    A képletekben fixen kódolt értékek helyett használja a SZUM függvényt.  A D5 cellában szereplő képlet a következő: =SZUM(D2:D4)
  2. #ÉRTÉK! hiba – Ha szövegre hivatkozik számok helyett.

    Ha például az alábbi képletet használja:

    • =A1+B1+C1 vagy =A1+A2+A3

    Nem megfelelő képletszerkesztés példája.  A képlet a D2 cellában =A2+B2+C2

    A képlet megszakítható, ha bármelyik nem numerikus (szöveg) értékek is szerepelnek a hivatkozott cellák, amelyek #VALUE ad vissza! Hiba történt. SZUM figyelmen kívül hagyja a szöveges értékeket, és a csak a numerikus értékek összegét ad.

    Helyes képletszerkesztés.  Az =A2+B2+C2 helyett a D2 cellában szereplő képlet a következő: =SZUM(A2:C2)
  3. #HIV! hiba – Ha sorokat vagy oszlopokat töröl.

    Oszlop törlésével okozott #HIV! hiba.  A képlet a következőre változott: =A2+#HIV!+B2

    Ha töröl egy sort vagy oszlopot, a képlet nem fog frissülni a törölt elem kizárásához, és ezért #HIV! hibát ad, míg a SZUM függvény automatikusan képes igazodni az ilyen változásokhoz.

    A SZUM függvény automatikusan módosul a beszúrt vagy törölt soroknak és oszlopoknak megfelelően
  4. Nem frissülő hivatkozások sorok vagy oszlopok beszúrásakor

    =A+B+C képletek nem frissülnek, ha sorokat vesz fel

    Ha olyan sort vagy oszlopot szúr be, a képlet nem frissítik a amelyet fel szeretne venni az új sorra, ahol a SZUM függvény automatikusan frissíti (feltéve ha nem a tartományt a képletben hivatkozott kívüli). Ez különösen fontos várt frissítése a képletet, és azt nem, ha, akkor előfordulhat, hogy nem elfog hiányos eredménnyel hagyja meg.

    A példa egy oszlop beszúrásakor a =SZUM(A2:C2) képletről automatikusan a =SZUM(A2:D2) képletre bővülő SZUM képletet szemléltet
  5. SZUM egyéni cellahivatkozásokkal vagy tartományokkal

    Vessen egy pillantást az alábbi képletre:

    • =SZUM(A1;A2;A3;B1;B2;B3)

    Nem egyenlő részt jobban, ha történő beszúrásának és törlésének sorok a hivatkozott tartományon belül az azonos miatt. Akkor célszerűbb sokkal használja az egyéni tartományok, például:

    • =SZUM(A1:A3;B1:B3)

    Ezek frissülnek sorok hozzáadásakor és törlésekor.

Probléma

A probléma oka

A SZUM függvényem a ##### értéket mutatja az eredmény helyett.

Jelölje be az oszlop szélességét. ### általában azt jelenti, hogy az oszlop túl keskeny, a képlet eredményének a megjelenítéséhez.

A SZUM függvényem magát a beírt képletet mutatja szövegként az eredmény helyett.

Ellenőrizze, hogy a cella nem szöveges formátumú. Jelölje ki a cellát vagy a szóban forgó tartományt, és a Ctrl + 1 használatával jelenítse meg a Cellák formázása párbeszédpanel, majd kattintson a Szám fülre , és válassza ki a kívánt formátumot. Ha a cella szövegként formázott, és nem változtatja meg a formátum módosítása után, szükség lehet használni F2 > Enter kényszerítése a formátum módosítása.

A SZUM függvényem nem frissül.

Győződjön meg arról, hogy számítási van beállítva az automatikus. Kattintson a képletek lapon válassza a Számítási beállítások. F9 kényszeríthet ki a munkalap kiszámolása is használhatja.

Győződjön meg róla, hogy a Számítás beállítás Automatikus értékre van állítva.  Ezt a Képlet lap Számolási beállítások menüjében ellenőrizheti.

Egyes értékek kimaradnak a számításból.

Csak a hivatkozásban vagy a tartományban szereplő számértékek adhatók össze. Az üres cellákat, a logikai értékeket (például IGAZ) és a szöveget a függvény figyelmen kívül hagyja.

A várt eredmény helyett a #NÉV? hiba jelenik meg.

Ez általában azt jelzi, hogy a függvény neve hibásan lett beírva, például „=szumm(A1:A10)” a „=SZUM(A1:A10)” helyett.

A SZUM függvényem egész számot jelenít meg tizedesek helyett

Gondoskodjon arról, hogy a cellaformázás tizedeseket jelenítsen meg. Jelölje ki a kérdéses cellát vagy tartományt, a Ctrl+1 billentyűkombinációval nyissa meg a Cellák formázása párbeszédpanelt, és válassza a megfelelő formátumot a Szám lapon. Ezzel jelezheti a kívánt tizedeshelyek számát.

  1. Csak összeadni, kivonni, szorozni vagy osztani szeretnék számokat – Tekintse meg a Matematikai alapműveletek az Excelben című videosorozatunkat, vagy olvassa el Az Excel használata számológépként című témakört.

  2. Hogyan további/kevesebb tizedesjegy megjelenítéséhez? Módosíthatja a számformátumot. Jelölje ki a cellát vagy a szóban forgó tartományt, és a Ctrl + 1 használatával jelenítse meg a Cellák formázása párbeszédpanelen, majd kattintson a szám lap , és válassza ki a kívánt formátumot, ügyelve arra, hogy a kívánt tizedesjegyek számát jelzi, hogy.

  3. Hogyan adhatok hozzá vagy vonhatok ki időértékeket? – Időértékeket több különböző módon adhat össze vagy vonhat ki. Ha például a 8 és 12 óra közötti különbséget szeretné megkapni bérszámfejtési célokból, a következő képletet kell használnia: =("12:00"-"8:00")*24, amely kivonja a záró időpontból a kezdő időpontot. Vegye figyelembe, hogy az Excel az időértékeket a nap részeként számítja ki, ezért az órák összegének megkapásához 24-gyel való szorzás szükséges. Az első példában a =((B2-A2)+(D2-C2))*24 képletet használjuk a kezdéstől a befejezésig tartó órák összegének ebédszünet nélküli kiszámításához (összesen 8,5 óra).

    Ha csak órákat és perceket ad hozzá, és így szeretné megjeleníteni őket, akkor egyszerű összeadást végezhet a 24-gyel való szorzás nélkül. Ezért a második példában a =SZUM(A6:C6) képletet használjuk, mivel csak a hozzárendelt feladatok összes órájának és percének a számára van szükségünk (5:36, illetve 5 óra, 36 perc).

    Idő számítása

    További információ: Időértékek összegzése és kivonása.

  4. Hogyan szerezhető be a dátum közötti különbség? Időpontok, a felvehet és kivonása dátumokat. Az alábbiakban a gyakori példa számlálás a két dátum közötti napok számát. Egyszerűen, az = B2-A2. A billentyű lenyomásával használata a dátumok és időpontok is, hogy a befejezési dátum/idő a Kezdés, és a kezdési dátum/idő kivonása.

    Dátumok közötti különbségek számítása

    A dátumokkal való munkáról bővebben a következő témakörben olvashat: Két dátum közötti napok számának kiszámítása.

  5. Hogyan adhatom össze csak a látható cellákat? Néha, amikor manuálisan rejt el sorokat, vagy az AutoSzűrő használatával jelenít meg csak bizonyos adatokat, csak a látható cellákat is összegezni szeretné. Ehhez a RÉSZÖSSZEG függvényt használhatja. Ha összegsort használ egy Excel-táblázatban, a program az összegeket tartalmazó legördülő listában Ön által kiválasztott függvényt írja be automatikusan részösszegként. Erről bővebben az Adatok összegzése Excel-táblázatban című témakörben olvashat.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

További tudnivalók a SZUM

A SZUMHA függvény csak az, hogy a feltételnek megfelelő értékeket adja össze

A SZUMHATÖBB függvény csak az, hogy több feltételnek megfelelő értékeket adja össze

A DARABTELI függvény megszámolja, hogy a feltételnek megfelelő értékeket

A DARABHATÖBB függvény megszámolja, hogy több feltételnek megfelelő értékeket

Az Excel a képletek – áttekintés

Hibás képletek kiküszöbölése

A képletekben hibák keresése és javítása

Billentyűparancsok a Windows Excelben

Mac-alapú Excel billentyűparancsai

Matematikai és trigonometriai függvények

Az Excel függvényeinek betűrendes listája

Excel-függvények (kategória szerint)

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×