Sérült munkafüzet helyreállítása

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Ha a Microsoft Excel egy munkafüzet megnyitásakor azt észleli, hogy az sérült, automatikusan elindítja a fájlhelyreállítási módot, és megpróbálja helyreállítani a munkafüzetet. Ha a fájlhelyreállítási mód nem indul el, próbálja meg a munkafüzetet az itt leírt manuális módszerrel helyreállítani:

  1. Kattintson a Fájl > Megnyitás pontra.

  2. Kattintson a sérült munkafüzetet tartalmazó helyre és mappára.

  3. A Megnyitás párbeszédpanelen válassza ki a sérült munkafüzetet.

  4. Kattintson a Megnyitás gomb melletti nyílra, majd a Megnyitás és javítás menüpontra.

    A Megnyitás és javítás parancs

  5. Ha a lehető legtöbb adatot szeretné helyreállítani a munkafüzetből, válassza a Javítás pontot.

    Ha a Javítás funkcióval az adatokat nem sikerült helyreállítani, akkor kattintson az Adatok kinyerése gombra, amellyel kinyerheti a munkafüzet értékeit és képleteit.

Ha sem az automatikus, sem a manuális javítás nem működött, van még néhány helyreállítási módszer, amellyel menthetők lehetnek az adatok. Munkája elvesztésének elkerülése érdekében megelőző lépéseket is tehet azzal, hogy automatikus biztonsági példányt készít a munkafüzetről, vagy időről időre helyreállítási fájlt hoz létre.

Adatok visszaállítása sérült munkafüzetből

Munkafüzet biztonsági példányának mentése automatikusan

Helyreállítási fájl létrehozása meghatározott időközönként automatikusan

Adatok visszaállítása sérült munkafüzetből

Az adatok helyreállításához válasszon az alábbi módszerek közül. Ha valamelyik módszer nem sikeres, próbálkozzon egy másikkal. A munkafüzetet valamilyen harmadik féltől származó megoldással is megpróbálhatja helyreállítani.

Fontos : Ha valamilyen lemezhiba vagy hálózati hiba miatt nem lehet megnyitni a munkafüzetet, akkor helyezze át a munkafüzetet egy másik merevlemez-meghajtóra vagy egy helyi lemezre, mielőtt bármelyik alábbi helyreállítási lehetőséggel próbálkozna.

Adatok helyreállítása, ha a munkafüzet meg van nyitva az Excelben

  • A munkafüzet utolsó mentett verziójának visszaállítása:     Ha a munkafüzet szerkesztés közben, de még a módosítások mentése előtt sérül meg, akkor visszatérhet a munkafüzet utolsó mentett verziójához:

    1. Kattintson a Fájl > Megnyitás parancsra.

    2. Kattintson duplán annak a munkafüzetnek a nevére, amelyet meg szeretne nyitni az Excelben.

    3. Kattintson az Igen gombra a munkafüzet újbóli megnyitásához.

      A munkafüzet az esetleges sérülést okozó módosítások nélkül nyílik meg.

Adatok helyreállítás, ha a munkafüzetet nem lehet megnyitni az Excelben

  • Kézi újraszámítás beállítása az Excelben:     Próbálja meg automatikusról kézire állítani az újraszámítás beállítását. A program ekkor nem számítja újra a munkafüzetet, így előfordulhat, hogy sikerül megnyitnia.

    1. Kattintson a Fájl > Új pontra.

    2. Az Új lapon kattintson az Üres munkafüzet elemre.

    3. Kattintson a Fájl > Beállítások pontra.

    4. Jelölje be a Képletek kategória Számítási beállítások csoportjában a Csak kérésre választógombot, és kattintson az OK gombra.

    5. Kattintson a Fájl > Megnyitás pontra.

    6. Keresse meg a sérült munkafüzetet, és dupla kattintással nyissa meg.

  • A sérült munkafüzet csatolása külső hivatkozásokkal:    Ha csak adatokat szeretne visszanyerni a munkafüzetből, képleteket és számított értékeket nem, akkor próbáljon külső hivatkozásokkal csatlakozni a sérült munkafüzethez.

    1. Kattintson a Fájl > Megnyitás pontra.

    2. Keresse meg a sérült munkafüzetet tartalmazó mappát.

    3. Kattintson jobb gombbal a sérült munkafüzet fájlnevére, kattintson a Másolás parancsra, majd a Mégse gombra.

    4. Kattintson a Fájl > Új pontra.

    5. Az Új lapon kattintson az Üres munkafüzet elemre.

    6. Írja be az új munkafüzet A1 cellájába fájlnév =! A1, ahol fájl nevét a sérült munkafüzetet, a 3 kimásolt nevét, és nyomja le az ENTER billentyűt.

      Megjegyzés : Csak a munkafüzet nevét kell beírnia, a fájlnévhez tartozó kiterjesztést nem.

    7. Ha megjelenik az Értékek frissítése párbeszédpanel, akkor válassza ki a sérült munkafüzetet, majd kattintson az OK gombra.

    8. Ha megjelenik a Lap kiválasztása párbeszédpanel, akkor válassza ki a megfelelő munkalapot, és kattintson az OK gombra.

    9. Jelölje ki az A1 cellát.

    10. Kattintson a Kezdőlap > Másolás gombra, vagy nyomja le a Ctrl+C billentyűkombinációt.

    11. Az A1 cellával kezdve jelöljön ki egy körülbelül akkora méretű területet, amekkora az adatok tartománya a sérült munkafüzetben.

    12. Kattintson a Kezdőlap > Beillesztés gombra, vagy nyomja le a Ctrl+V billentyűkombinációt.

    13. Hagyja kijelölve a cellatartományt, és kattintson ismét a Kezdőlap > Másolás gombra, vagy nyomja le a Ctrl+C billentyűkombinációt.

    14. Kattintson a Kezdőlap > Beillesztés gomb melletti nyílra, majd az Értékek beillesztése csoportban kattintson az Értékek gombra.

      Az értékek beillesztésével eltávolítja a sérült munkafüzetre mutató hivatkozásokat, és csak az adatokat hagyja meg.

  • Az adatok kinyerése a sérült munkafüzetből makróval:    Ha a sérült munkafüzethez diagram van csatolva, próbálja meg egy makró segítségével kinyerni a diagram forrásadatait.

    1. Másolja a következő makrókódot, és illessze be egy modullapra:

      Sub GetChartValues()

      Dim NumberOfRows egész

      Dim X objektumként

      Számláló = 2

      "Kiszámítása, adatok sorok számát.

      NumberOfRows = UBound(ActiveChart.SeriesCollection(1). Értékek)

      Worksheets("ChartData"). Cellák (1, 1) = "X értékek"

      "X tengely értékei írása munkalapra.

      A Worksheets("ChartData")

      . Tartomány (. Cellák, (2, 1) _

      . Cellák (NumberOfRows + 1; 1)) = _

      Application.Transpose(ActiveChart.SeriesCollection(1). Xértékek)

      Vége

      "A diagramot az összes adatsorban ismétlése, és írja be az értékeket a

      "a munkalapon.

      Az egyes X értékeihez ActiveChart.SeriesCollection

      Worksheets("ChartData"). Cellák (1-es számláló) = X.Name

      A Worksheets("ChartData")

      . Tartomány (. Cellák (2, számláló) _

      . Cellák (NumberOfRows + 1, a számláló)) = _

      Application.Transpose(X.Values)

      Vége

      Számláló = számláló + 1

      Tovább

      End Sub

    2. Szúrjon be vagy töröljön egy munkalapot a munkafüzetben, kattintson jobb gombbal a lapfülére, és nevezze át a DiagramAdatok névre.

    3. Jelölje ki a diagramot, amelyből ki szeretné nyerni a háttéradatokat.

      Megjegyzés : A diagram munkalapra beillesztve vagy külön diagramon lehet.

    4. Futtassa a DiagramÉrtékekBeolvasása makrót.

    5. A makró a DiagramAdatok munkalapra írja a diagram adatait.

Vissza a lap tetejére

Munkafüzet biztonsági példányának mentése automatikusan

Ha biztonsági példányt hoz létre a munkafüzetről, mindig hozzáférhet az adatokhoz, ha a munkafüzetet véletlenül törölné, vagy az megsérülne.

  1. Kattintson a Fájl > Mentés másként pontra.

  2. Kattintson a Számítógép elemre, majd a Tallózás gombra.

    Tallózás gomb

  3. A Mentés másként párbeszédpanelen kattintson az Eszközök gomb melletti nyílra, majd a Beállítások pontra.

    Az Eszközök menü Beállítások pontja

  4. Az Általános beállítások párbeszédpanelen jelölje be a Biztonsági másolat is készül jelölőnégyzetet.

    Biztonsági másolat is készül jelölőnégyzet az Általános beállítások párbeszédpanelen

Vissza a lap tetejére

Helyreállítási fájl létrehozása meghatározott időközönként automatikusan

A munkafüzetről készített helyreállítási fájllal szintén gondoskodhat arról, hogy hozzáférhessen az adatokhoz, ha a munkafüzetet véletlenül törölné, vagy az megsérülne.

  1. Kattintson a Fájl > Beállítások pontra.

  2. A Mentés kategória Munkafüzetek mentése területén jelölje be az Automatikus helyreállítási adatok mentése jelölőnégyzetet, majd adja meg, hogy hány percenként legyen mentés. (Az alapértelmezett érték 10 perc.)

    Automatikus helyreállítási beállítás az Excel Beállítások párbeszédpanelének Mentés lapján

  3. Adja meg az Automatikus helyreállítási mappa mezőben, hogy hová szeretné menteni a helyreállítási fájlt.

  4. Győződjön meg róla, hogy Az automatikus helyreállítás kikapcsolása csak a munkafüzetre jelölőnégyzet nincs bejelölve.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×