Példák gyakran használt képletekre

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Az alábbi képletek egy lista vagy tár számított oszlopaiban használhatók. Az oszlophivatkozásokat nem tartalmazó példák az oszlopok alapértelmezett értékének megadására alkalmasak.

Tartalom

Feltételes képletekkel

Dátum és idő képletek

Matematikai képletek

Szöveg képletek

Feltételes képletek

Az alábbi képletek használatával ellenőrizheti egy állítás feltételének teljesülését - Igen vagy Nem értékkel tér vissza. Emellett ellenőrizhet egy alternatív értéket is (például Rendben vagy Ez így nem jó), illetve elérheti, hogy a program üres cellát vagy vízszintes vonalat jelenítsen meg a null visszatérési érték esetén.

Ellenőrizze, hogy egy szám nagyobb vagy kisebb, mint a másik szám

Az összehasonlítás végrehajtásához használja a HA függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (lehetséges eredmény)

150000

9000

=[Oszlop1]>[Oszlop2]

Nagyobb-e Oszlop1 mint Oszlop2? (1)

150000

9000

=HA([Oszlop1]<=[Oszlop2], "Rendben", "Ez így nem jó")

Az Oszlop1 kisebb vagy egyenlő-e, mint az Oszlop2? (Ez így nem jó)

Logikai érték visszaadása oszlopok tartalmának összehasonlításakor

Ha az eredmény logikai érték (Igen vagy Nem), használja az ÉS, a VAGY és a NEM függvényt.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (lehetséges eredmény)

15

1.

8

=ÉS([Oszlop1]>[Oszlop2], [Oszlop1]<[Oszlop3])

Nagyobb-e 15, mint 9 és kisebb-e, mint 8? (Nem)

15

1.

8

=VAGY([Oszlop1]>[Oszlop2], [Oszlop1]<[Oszlop3])

Nagyobb-e 15, mint 9 vagy kisebb-e, mint 8? (Igen)

15

1.

8

=NEM([Oszlop1]+[Oszlop2]=24)

15 plusz 9 nem egyenlő 24-gyel? (Nem)

Ha az eredmény egy másik számítási művelet, vagy az 1-től és a 0-tól eltérő érték, használja a HA, az ÉS és a VAGY függvényt.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (lehetséges eredmény)

15

1.

8

=HA([Oszlop1]=15, "Rendben”; "Ez így nem jó”)

Ha Oszlop1 értéke 15, akkor a visszatérési érték „Rendben”. (Rendben)

15

1.

8

=HA(ÉS([Oszlop1]>[Oszlop2], [Oszlop1]<[Oszlop3]), "Rendben”; "Ez így nem jó”;)

Ha 15 nagyobb, mint 9 és kisebb, mint 8, akkor a visszatérési érték „Rendben”. (Ez így nem jó)

15

1.

8

=HA(VAGY([Oszlop1]>[Oszlop2], [Oszlop1]<[Oszlop3]), "Rendben”; "Ez így nem jó”;)

Ha 15 nagyobb, mint 9 vagy kisebb, mint 8, akkor a visszatérési érték "Rendben”. (Rendben)

Nulla érték üres cellaként vagy kötőjelként megjelenítése

Nulla megjelenítéséhez hajtson végre egy egyszerű műveletet. Üres cella vagy vízszintes vonal megjelenítéséhez használja a HA függvényt.

C olumn1

Oszlop2

Képlet

Leírás (lehetséges eredmény)

10:

10:

=[Oszlop1]-[Oszlop2]

A második szám kivonása az elsőből. (0)

15

1.

=HA([Oszlop1]-[Oszlop2],"-",[Oszlop1]-[Oszlop2])

Nulla érték esetén kötőjel jelenjen meg a cellában (-)

Oszlopok elrejtése

Kötőjel, #HIÁNYZIK vagy NA (nincs adat) megjelenítéséhez a hibaérték helyén használja a HIBÁS függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (lehetséges eredmény)

10:

0

=[Oszlop1]/[Oszlop2]

Hibaérték az eredmény (#ZÉRÓOSZTÓ!)

10:

0

=HA(HIBÁS([Oszlop1]/[Oszlop2]),"NA",[Oszlop1]/[Oszlop2])

Hiba esetén a visszaadott érték NA lesz.

10:

0

=HA(HIBÁS([Oszlop1]/[Oszlop2]),"-",[Oszlop1]/[Oszlop2])

Hiba esetén a visszaadott érték kötőjel lesz

Vissza a lap tetejére

Dátummal és idővel kapcsolatos képletek

Az alábbi formulák használatával végezhet dátummal és idővel kapcsolatos műveleteket, melyek például napok, hónapok, vagy évek hozzáadása dátumhoz, két dátum közötti különbség kiszámítása vagy idő konvertálása decimális értékre.

Dátumok összeadása

Dátumokhoz az összeadásjellel (+) adhat hozzá napokat.

Megjegyzés : A dátumokkal kapcsolatos műveletek esetén a számított oszlop visszatérési típusának Dátum és idő típusnak kell lennie.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

2007.06.09.

3.

=[Oszlop1]+[Oszlop2]

3 nap hozzáadása a 2007.06.09. dátumhoz (2007.06.12.)

2008.12.10.

47

=[Oszlop1]+[Oszlop2]

54 nap hozzáadása a 2008.12.10. dátumhoz (2009.02.02.)

Ha hónapokat kíván egy dátumhoz adni, használja a DÁTUM, az ÉV, a HÓNAP és a NAP függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

2007.06.09.

3.

=DÁTUM(ÉV([Oszlop1]),HÓNAP([Oszlop1])+[Oszlop2],NAP([Oszlop1]))

3 hónap hozzáadása a 2007.06.09. dátumhoz (2007.09.09.)

2008.12.10.

2500

=DÁTUM(ÉV([Oszlop1]),HÓNAP([Oszlop1])+[Oszlop2],NAP([Oszlop1]))

25 hónap hozzáadása a 2008.12.10. dátumhoz. (2011.01.10.)

Ha éveket kíván egy dátumhoz adni, használja a DÁTUM, az ÉV, a HÓNAP és a NAP függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

2007.06.09.

3.

=DÁTUM(ÉV([Oszlop1])+[Oszlop2],HÓNAP([Oszlop1]),NAP([Oszlop1]))

3 év hozzáadása a 2007.06.09. dátumhoz (2010.06.09.)

2008.12.10.

2500

=DÁTUM(ÉV([Oszlop1])+[Oszlop2],HÓNAP([Oszlop1]),NAP([Oszlop1]))

25 év hozzáadása a 2008.12.10. dátumhoz. (2033.12.10.)

Napok, hónapok és évek számának dátumhoz adásához használja a DÁTUM, az ÉV, a HÓNAP és a NAP függvényt.

Oszlop1

Képlet

Leírás (eredmény)

2007.06.09.

=DÁTUM(ÉV([Oszlop1])+3,HÓNAP([Oszlop1])+1,NAP([Oszlop1])+5)

3 év, 1 hónap és 5 nap hozzáadása a 2007.06.09. dátumhoz. (2010.07.14.)

2008.12.10.

=DÁTUM(ÉV([Oszlop1])+1,HÓNAP([Oszlop1])+7,NAP([Oszlop1])+5)

1 év, 7 hónap és 5 nap hozzáadása a 2007.06.09. dátumhoz. (2008.12.10.)

Két dátum közötti különbség kiszámítása

A számolás végrehajtásához használja a DÁTUMTÓLIG függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

1995. jan. 1.

1999. jún. 15.

=DÁTUMTÓLIG([Oszlop1], [Oszlop2],"n”)

A két dátum közötti napok száma. (1626)

1995. jan. 1.

1999. jún. 15.

=DÁTUMTÓLIG([Oszlop1], [Oszlop2],"éh”)

A két dátum közti hónapok száma, az év figyelmen kívül hagyásával. (5)

1995. jan. 1.

1999. jún. 15.

=DÁTUMTÓLIG([Oszlop1], [Oszlop2],"én”)

A két dátum közti napok szám, az év figyelmen kívül hagyásával. (165)

Kétszer közötti különbség kiszámítása

Az eredmény szabványos nemzetközi időformátumbeli (óra:perc:másodperc alakú) megjelenítéséhez használja a kivonásjelet (-) és a SZÖVEG függvényt. Ebben az esetben az órák száma nem haladhatja meg a 24-et, a perceké és a másodperceké a 60-at.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

2007.06.09. 10:35 de.

2007.06.09. 3:30 du.

=SZÖVEG([Oszlop2]-[Oszlop1],"ó”)

Két időpont közötti órák száma. (4)

2007.06.09. 10:35 de.

2007.06.09. 3:30 du.

=SZÖVEG([Oszlop2]-[Oszlop1],"ó:pp”

Két időpont közötti órák és percek száma. (4:55)

2007.06.09. 10:35 de.

2007.06.09. 3:30 du.

=SZÖVEG([Oszlop2]-[Oszlop1],"ó:pp:mm”)

Két időpont közötti órák, percek és másodpercek száma (4:55:00)

Az eredmény adott időegységben mért értékének meghatározásához használja az INT, illetve az ÓRA, a PERC vagy a MPERC függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

2007.06.09. 10:35 de.

2007.06.10. 3:30 du.

=INT(([Oszlop2]-[Oszlop1])*24)

Teljes órák száma a két időpont között. (28)

2007.06.09. 10:35 de.

2007.06.10. 3:30 du.

=INT(([Oszlop2]-[Oszlop1])*1440)

Percek száma a két időpont között. (1735)

2007.06.09. 10:35 de.

2007.06.10. 3:30 du.

=INT(([Oszlop2]-[Oszlop1])*86400)

Másodpercek száma a két időpont között. (104100)

2007.06.09. 10:35 de.

2007.06.10. 3:30 du.

=ÓRA([Oszlop2]-[Oszlop1])

Két időpont közötti órák száma, ha a különbség nem több mint 24. (4)

2007.06.09. 10:35 de.

2007.06.10. 3:30 du.

=PERC([Oszlop2]-[Oszlop1])

Két időpont közötti percek száma, ha a különbség nem több mint 60. (55)

2007.06.09. 10:35 de.

2007.06.10. 3:30 du.

=MPERC([Oszlop2]-[Oszlop1])

Két időpont közötti másodpercek száma, ha a különbség nem több mint 60. (0)

Időpontok átalakítása

A szabványos időformátumban megadott órák tízes számrendszerbeli ábrázolásához használja az INT függvényt.

Oszlop1

Képlet

Leírás (eredmény)

10:35 de.

=([Oszlop1]-INT([Oszlop1]))*24

Az éjfél óta eltelt órák száma (10,583333)

12:15 du.

=([Oszlop1]-INT([Oszlop1]))*24

Az éjfél óta eltelt órák száma. (12,25)

A tízes számrendszerbeli számokkal kifejezett óraértékek az osztás műveleti jelével és a SZÖVEG függvénnyel konvertálhatók szabványos időformátumú (óra:perc:másodperc alakú) értékre.

Oszlop1

Képlet

Leírás (eredmény)

23:58

=SZÖVEG(Oszlop1/24, "óó:pp:mm”)

Éjfél óta eltelt órák, percek és másodpercek száma (00:59:55)

2:06

=SZÖVEG(Oszlop1/24; "ó:pp”)

Éjfél óta eltelt órák és percek száma (0:05)

Julián dátum beszúrása

A „Julianus-dátum” elnevezést használják az olyan dátummegadásra, amely az aktuális évből és az év eleje óta eltelt napokból álló szám. Így például 2007. január 1. megfelelője 2007001, míg 2007. december 31. megadása 2007356 ebben a rendszerben. Ez a formátum nem a Julianus-naptáron alapul.

Egy dátum a SZÖVEG és a DÁTUMÉRTÉK függvényekkel alakítható Julianus-dátummá.

Oszlop1

Képlet

Leírás (eredmény)

2007.06.23.

=SZÖVEG([Oszlop1],"éé”)&SZÖVEG(([Oszlop1]-DÁTUMÉRTÉK("1/1/”& SZÖVEG([Oszlop1],éé"”))+1),"000”)

Julianus-formátumú dátum kétjegyű évszámmal. (07174)

2007.06.23.

=SZÖVEG([Oszlop1],"éééé”)&SZÖVEG(([Oszlop1]-DÁTUMÉRTÉK("1/1/”&SZÖVEG([Oszlop1],"éé”))+1),"000”)

Dátum „Julianus-formátumban”, négyjegyű évszámmal. (2007174)

Ha egy dátumot a csillagászatban használt Julianus-dátumra kíván átalakítani, használja a 2415018,50 állandót. A képlet csak 1901. március 1. utáni dátumoknál és az 1900-as dátumrendszert használó rendszerekben működik.

Oszlop1

Képlet

Leírás (eredmény)

2007.06.23.

=[Oszlop1]+2415018,50

A dátum a csillagászatban használt Julianus-formátumban. (2454274,50)

A hét napjának dátumok megjelenítése

A SZÖVEG és a HÉT.NAPJA függvénnyel alakíthatók át a dátumok a hét napját megjelenítő szöveggé.

Oszlop1

Képlet

Leírás (lehetséges eredmény)

2007. feb. 19.

=SZÖVEG(HÉT.NAPJA([Oszlop1]); "nnnn”)

A dátumértéket nappá alakítja és a nap teljes nevét jeleníti meg szövegként. (hétfő)

2008. jan. 03.

=SZÖVEG(HÉT.NAPJA([Oszlop1]);  "nnn”)

A dátumértéket nappá alakítja és a nap rövid nevét jeleníti meg szövegként (Cs)

Vissza a lap tetejére

Matematikai képletek

A következő képletek segítségével számos matematikai műveletet végezhet el, mint amilyen például a hozzáadás, a kivonás, a szorzás, az osztás, a számok átlagának és mediánjának kiszámítása, a szám kerekítése és az értékek számlálása.

Számok összeadása

Egy sor két vagy több oszlopában lévő értékek az összeadásjel (+) vagy a SZUM függvény segítségével adhatók össze.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (eredmény)

1

1

4.

=[Oszlop1]+[Oszlop2]+[Oszlop3]

Az első három oszlop értékének összeadása. (15)

1

1

4.

=SZUM([Oszlop1],[Oszlop2],[Oszlop3])

Az első három oszlop értékének összeadása. (15)

1

1

4.

=SZUM(HA([Oszlop1]>[Oszlop2], [Oszlop1]-[Oszlop2], 10), [Oszlop3])

Ha Oszlop1 értéke nagyobb Oszlop2 értékénél, különbözetük összeadása Oszlop3 értékével; egyébként 10 és Oszlop3 értékének összege. (5)

Számok kivonása

Egy sor két vagy több oszlopában lévő értékek a kivonásjel (-) vagy negatív számokat tartalmazó SZUM függvény segítségével vonhatók ki.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (eredmény)

150000

9000

-8000

=[Oszlop1]-[Oszlop2]

9000 kivonása 15000-ből (6000)

150000

9000

-8000

=SZUM([Oszlop1], [Oszlop2], [Oszlop3])

Az első három oszlop értékének előjeles összevonása. (16000)

Százalékosan két szám közötti különbség kiszámítása

A feladat végrehajtásához a kivonásjelet (-), az osztás műveleti jelét (/) és az ABS függvényt kell használni.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

134000

4 375 000

=([Oszlop2]-[Oszlop1])/ABS([Oszlop1])

Százalékos változás (6,75% vagy 0,06746)

Számok szorzása

Egy sor két vagy több oszlopában lévő értékek a szorzásjel (*) vagy a SZORZAT függvény segítségével szorozhatók össze.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

1

2.

=[Oszlop1]*[Oszlop2]

Az első két oszlopban szereplő szám összeszorzása. (10)

1

2.

=SZORZAT([Oszlop1], [Oszlop2])

Az első két oszlopban szereplő szám összeszorzása. (10)

1

2.

=SZORZAT([Oszlop1],[Oszlop2],2)

Az első két oszlopban szereplő szám és a 2 szorzata. (20)

Cellákban szereplő számok osztása

Egy sor két vagy több oszlopában lévő értékek az osztásjel (/) segítségével oszthatók egymással.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

150000

12

=[Oszlop1]/[Oszlop2]

15000 osztása 12-vel. (1250)

150000

12

=([Oszlop1]+10000)/[Oszlop2]

15000 és 10000 összeadása, majd az összeg osztása 12-vel. (2083)

Számok átlagának kiszámítása

Az átlagot középértéknek is nevezik. Egy sor két vagy több oszlopában szereplő értékek átlagának kiszámításához használja az ÁTLAG függvényt.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (eredmény)

1

1

4.

=ÁTLAG([Oszlop1], [Oszlop2],[Oszlop3])

Az első három oszlopban lévő számok átlaga. (5)

1

1

4.

=ÁTLAG(HA([Oszlop1]>[Oszlop2], [Oszlop1]-[Oszlop2], 10), [Oszlop3])

Ha Oszlop1 nagyobb mint Oszlop2, különbségük és Oszlop3 átlaga. Különben 10 és Oszlop3 átlaga. (2,5)

A Medián számokat kiszámítása

A medián egy rendezett számsor középső értéke. Egy számhalmaz mediánjának kiszámítására szolgál a MEDIÁN függvény.

A

B

c.

d.

E

F

Képlet

Leírás (eredmény)

10:

7

1.

27

0

4.

=MEDIÁN(A; B; C; D; E; F)

Az első hat oszlopban lévő számok mediánja. (8)

Egy tartomány legkisebb és legnagyobb kiszámítása

Egy sor oszlopaiban található számok közül a MIN és a MAX függvénnyel határozhatja meg a legkisebb és a legnagyobb értéket.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (eredmény)

10:

7

1.

=MIN([Oszlop1], [Oszlop2], [Oszlop3])

A legkisebb szám. (7)

10:

7

1.

=MAX([Oszlop1], [Oszlop2], [Oszlop3])

A legnagyobb szám. (10)

Értékek száma

A DARAB függvény használható numerikus értékek számlálására.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (eredmény)

Alma

2007.12.12.

=DARAB([Oszlop1], [Oszlop2], [Oszlop3])

A numerikus értékeket tartalmazó oszlopok megszámlálása a dátum és idő értékek, valamint a szöveges értékek és a nullértékek figyelmen kívül hagyásával. (0)

$12

#ZÉRÓOSZTÓ!

1.01

=DARAB([Oszlop1], [Oszlop2], [Oszlop3])

A numerikus értékeket tartalmazó oszlopok megszámlálása a hibaértékek és logikai értékek figyelmen kívül hagyásával. (2)

Növelje vagy csökkentse a szám szorzása százalékértékkel

A számolás végrehajtásához használja a százalékjelet (%).

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

23

3%

=[Oszlop1]*(1+5%)

Az Oszlop1 értékének növelése 5%-kal. (24,15)

23

3%

=[Oszlop1]*(1+[Oszlop2])

Az Oszlop1 értékének növelése az Oszlop2 értékeként megadott 3% százalékértékkel. (23,69)

23

3%

=[Oszlop1]*(1-[Oszlop2])

Az Oszlop1 mezőben adott érték csökkentése az Oszlop2 értékeként megadott 3% százalékértékkel. (22.31)

Egy számot hatványra emelése

A művelet végrehajtásához használja a hatványoperátort (^) vagy a HATVÁNY függvényt.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

1

2.

=[Oszlop1]^[Oszlop2]

Öt második hatványa, azaz négyzete (25)

1

3.

=HATVÁNY([Oszlop1], [Oszlop2])

Öt harmadik hatványa, azaz köbe (125)

Számok kerekítése

E feladat végrehajtására a KEREK.FEL, a PÁRATLAN és a PÁROS függvények szolgálnak.

Oszlop1

Képlet

Leírás (eredmény)

20.3

=KEREK.FEL([Oszlop1],0)

A 20,3 felfelé kerekítése a legközelebbi egész számra (21)

-5,9

=KEREK.FEL([Oszlop1],0)

-5,9 felfelé kerekítése a legközelebbi egész számra. (-5)

12.5493

=KEREK.FEL([Oszlop1],2)

A 12,5493 két tizedesjegy pontosságú felfelé kerekítése. (12,55)

20,3

=PÁROS([Oszlop1])

A 20,3 felfelé kerekítése a legközelebbi páros egész számra (22)

20,3

=PÁRATLAN([Oszlop1])

A 20,3 felfelé kerekítése a legközelebbi páratlan egész számra. (21)

Egy szám lefelé kerekítéséhez használja a KEREK.LE függvényt.

Oszlop1

Képlet

Leírás (eredmény)

20.3

=KEREK.LE([Oszlop1],0)

A 20,3 lefelé kerekítése a legközelebbi egész számra. (20)

-5,9

=KEREK.LE([Oszlop1],0)

A -5,9 lefelé kerekítése a legközelebbi egész számra. (-6)

12.5493

=KEREK.LE([Oszlop1],2)

A 12,5493 két tizedesjegy pontosságú kerekítése lefelé. (12,54)

A KEREK függvénnyel van lehetőség a számok legközelebbi egész számra vagy tizedesjegyre történő kerekítésére.

Oszlop1

Képlet

Leírás (eredmény)

20.3

=KEREK([Oszlop1],0)

A 20,3 lefelé kerekítése, mivel a törtrész kisebb 0,5-nél. (20)

5,9

=KEREK([Oszlop1],0)

Az 5,9 felfelé kerekítése, mivel a törtrész nagyobb 0,5-nél. (6)

-5,9

=KEREK([Oszlop1],0)

A -5,9 lefelé kerekítése, mivel a törtrész kisebb -0,5-nél. (-6)

1,25

=KEREK([Oszlop1], 1)

A szám kerekítése a legközelebbi tizedesjegyre (azaz egy tizedesjegy pontosságra). Mivel a kerekítendő törtrész 0,05 vagy annál nagyobb, a számot felfelé kell kerekíteni. (eredmény: 1,3)

30,452

=KEREK([Oszlop1], 2)

A szám kerekítése két tizedesjegyre (két tizedesjegy pontosságra). Mivel a kerekítendő törtrész (0,002) kisebb 0,005-nél, a számot lefelé kell kerekíteni. (eredmény: 30,45)

A számok a KEREKÍTÉS, a KEREK.FEL, a KEREK.LE, az INT és a HOSSZ függvények segítségével kerekíthetők 0-nál nagyobb értékes számjegyre.

Oszlop1

Képlet

Leírás (eredmény)

5492820

=KEREK([Oszlop1],3-HOSSZ(INT([Oszlop1])))

A szám kerekítése három értékes számjegyre. (5490000)

22230

=KEREK.FEL([Oszlop1],3-HOSSZ(INT([Oszlop1])))

A szám kerekítése három értékes számjegyre. (22200)

5492820

=KEREK.FEL([Oszlop1], 5-HOSSZ(INT([Oszlop1])))

A felső szám kerekítése öt értékes jegyűre (5492900)

Vissza a lap tetejére

Szövegekkel kapcsolatos képletek

Az alábbi képletek segítségével szövegeket kezelhet, például összefűzhet vagy egyesíthet több oszlopból származó értékeket, összehasonlíthatja az oszlopok értékeit, eltávolíthat karaktereket, szóközöket és ismétlődő karaktereket.

A szöveg írásmódját módosítása

A szöveg betűinek módosítására a NAGYBETŰS, a KISBETŰ és a TNÉV függvény használható.

Oszlop1

Képlet

Leírás (eredmény)

köszegi Emília

=NAGYBETŰS([Oszlop1[)

Nagybetűkkel jelenik meg a szöveg (KÖSZEGI EMÍLIA)

köszegi Emília

=KISBETŰ([Oszlop1])

Kisbetűkkel jelenik meg a szöveg (köszegi emília)

köszegi Emília

=TNÉV([Oszlop1])

A szöveg átalakítása nagy kezdőbetűssé (Köszegi Emília)

Vezetéknév és utónév kombinálása

A vezeték- és az utónevek egyesítésére az ÖSSZEFŰZ függvényt vagy az és (&) jelet használjuk.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

Béres

Kálmán

=[Oszlop1]&[Oszlop2]

A nevek összefűzése (BéresKálmán)

Béres

Kálmán

=[Oszlop1]&" ”&[Oszlop2]

A nevek összefűzése szóközzel elválasztva (Béres Kálmán)

Béres

Kálmán

=[Oszlop2]&", ”&[Oszlop1]

A nevek összefűzése vesszővel és szóközzel elválasztva (Béres, Kálmán)

Béres

Kálmán

=ÖSSZEFŰZ([Oszlop2], ",”, [Oszlop1])

A nevek összefűzése vesszővel elválasztva. (Béres, Kálmán)

Szöveg és számok a különböző összefűzése

Szöveg és számok összefűzéséhez használja az ÖSSZEFŰZ függvényt, az és (&) operátort vagy a SZÖVEG függvényt, majd az és (&) operátort.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

Bedecs

70,56

=[Oszlop1]&" eladott ”&[Oszlop2]&" egységet.”

A megadott tartalom összefűzése kifejezéssé. (Bedecs eladott 28 egységet.)

Lukács

40%

=[Oszlop1]&" részesedése a teljes értékesítésből ”&SZÖVEG([Oszlop2],"0%”)&

A fenti adatok összefűzése mondattá (Lukács részesedése a teljes értékesítésből 40%)

Megjegyzés : A SZÖVEG függvény az Oszlop2 formázott értékét fűzi hozzá a nyers érték helyett, mely a példában 0,4.

Bedecs

70,56

=ÖSSZEFŰZ([Oszlop1]," eladott ”,[Oszlop2]," egységet.”)

A megadott tartalom összefűzése kifejezéssé. (Bedecs eladott 28 egységet.)

Szöveg és a dátum vagy időpont kombinálása

A szöveg dátummal vagy időponttal való egyesítésére a SZÖVEG függvényt és a & (és) jelet használjuk.

Oszlop1

Oszlop2

Képlet

Leírás (eredmény)

Számla kelte:

2007. jún. 5.

="Elszámolási dátum: ”&SZÖVEG([Oszlop2], "éééé.hhh.n”)

Szöveg összefűzése dátummal (Elszámolási dátum: 2007. jún. 5.)

Számla kelte:

2007. jún. 5.

=[Oszlop1]&" ”&SZÖVEG([Oszlop2], "éééé.hhh.nn”)

Különböző oszlopokból származó szöveg és dátum összefűzése egy oszlopba. (Számlázási dátum: 2007. jún. 5.)

Oszlopok tartalmának összehasonlítása

Egy oszlop másik oszloppal vagy értéklistával való összehasonlítására szolgálnak az AZONOS és a VAGY függvények.

Oszlop1

Oszlop2

Képlet

Leírás (lehetséges eredmény)

BD122

BD123

=AZONOS([Oszlop1],[Oszlop2])

Az első két oszlop tartalmának összehasonlítása. (Nem)

BD122

BD123

=AZONOS([Oszlop1], "BD122”)

Az Oszlop1 oszlop és a "BD122” karakterlánc összehasonlítása. (Igen)

Ha egy oszlop értéke vagy annak egy részét adott szöveget ellenőrzése

Annak ellenőrzésére, hogy az oszlop értéke vagy annak egy része egy adott szöveget tartalmaz-e, a HA, a SZÖVEG.TALÁL, a SZÖVEG.KERES és a SZÁM függvények szolgálnak.

Oszlop1

Képlet

Leírás (lehetséges eredmény)

Emília

=HA([Oszlop1]="Emília”, "Rendben”; "Ez így nem jó”;)

Annak ellenőrzése, hogy az Oszlop1 Emília-e. (Rendben)

Emília

=HA(SZÁM(TALÁL("m”,[Oszlop1])), "Rendben”; "Ez így nem jó”;)

Annak ellenőrzése, hogy Oszlop1 tartalmaz-e „m” betűt. (Rendben)

BD123

=SZÁM(TALÁL( "BD”,[Oszlop1]))

Annak ellenőrzése, hogy az Oszlop1 oszlop tartalmazza-e a „BD” karakterláncot. (Igen)

Nem üres oszlopok száma

A nem üres cellák megszámolására a DARAB2 függvényt használjuk.

Oszlop1

Oszlop2

Oszlop3

Képlet

Leírás (eredmény)

Értékesítés

19

=DARAB2([Oszlop1], [Oszlop2])

A nem üres oszlopok megszámlálása. (2)

Értékesítés

19

=DARAB2([Oszlop1], [Oszlop2], [Oszlop3])

A nem üres oszlopok megszámlálása. (2)

Szöveg karakterek eltávolítása

Karakterek szövegből történő eltávolításához a HOSSZ, a BAL és a JOBB függvényt használjuk.

Oszlop1

Képlet

Leírás (eredmény)

A vitamin

=BAL([Oszlop1],HOSSZ([Oszlop1])-2)

A bal oldali 7 (10-3) karaktert adja vissza. (vitamin)

B1 vitamin

=JOBB([Oszlop1], HOSSZ([Oszlop1])-9)

A jobb oldali 2 (11-9) karaktert adja vissza. (B1)

Szóközök eltávolítása elején és végén oszlop

Szóközök oszlopokból történő eltávolításához, használja a TRIM függvényt.

Oszlop1

Képlet

Leírás (eredmény)

 Hogy van?

=TRIM([Oszlop1])

A szóközök eltávolítása az elejéről és a végéről. (Hogy van?)

Egy karakter oszlopok ismétlése

Ha az oszlopon belül ismételni kívánjuk a karaktereket, a SOKSZOR függvényt használjuk.

Képlet

Leírás (eredmény)

=SOKSZOR(".”;3)

A pont megismétlése háromszor. (...)

=SOKSZOR("-";10)

A kötőjel megismétlése tízszer. (----------)

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×