Nyomtatásra optimalizált nézet tervezése

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A létrehozott Microsoft Office-űrlapsablonoknak magával az InfoPath programmal vagy webböngészővel történő online megnyitásra és kitöltésre vannak tervezve. Ugyanakkor a felhasználók ki is nyomtathatják a kitöltött űrlapot személyes rekordjaikhoz vagy archiválási célból. Emiatt fontos ellenőrizni, hogy az űrlapsablon elfogadhatóan néz-e ki nyomtatásban is. Ilyen például, ha meg szeretne győződni arról, hogy az űrlapsablon vezérlői a nyomtatott oldal margóján belülre kerülnek, és a nyomtatott űrlap szövege olvasható.

Ezenfelül a Nézetek munkaablak segítségével létrehozhatja az űrlapsablon speciális változatát – az úgynevezett nyomtatási nézetet –, amely kifejezetten nyomtatási célra van tervezve.

Ez a témakör arról szól, hogyan tervezhet nyomtatási nézetet az űrlapsablonhoz, illetve más nyomtatásbarát űrlapsablon-létrehozási technikákról.

Tartalom

Űrlapsablon és űrlap nyomtatása közti különbségek

Bevezetés a nyomtatási nézetekbe

Új nyomtatási nézet tervezése meglévő nézet alapján

Nyomtatási nézet létrehozása a Word programban való használatra

Űrlapsablon és űrlap nyomtatása közti különbségek

Az űrlapsablon nyomtatásával általános képet kaphat a vezérlők és más objektumok nyomtatásban való megjelenéséről, és ellenőrizheti a nyomtatási beállításokat, például az élőfejeket és az élőlábakat. Ha tervező mód nyomtatja ki az űrlapsablont, olyan elemek kerülhetnek a nyomtatásba, például a gombok, amelyek nem jelennek meg, ha a felhasználók az űrlapsablonon alapuló űrlapot nyomtatnak.

Amikor a felhasználók az űrlapsablonon alapuló űrlapot nyomtatnak, az InfoPath módosíthatja az űrlap elemeinek igazítását vagy eltávolíthat egyes elemeket, amelyeknek nincs jelentősége nyomtatott formában. Az ismétlődő táblázatok alatt alapértelmezésben megjelenő Elem beszúrása utasítás például nem jelenik meg nyomtatásban. Ugyanígy a gomb típusú vezérlők, listamezők vagy görgetőnyilak sem jelennek meg, mivel ezeknek az elemeknek nincs jelentőségük nyomtatott formában.

Vissza a lap tetejére

Bevezetés a nyomtatási nézetekbe

Ugyan az űrlapsablonok arra vannak tervezve, hogy elektronikus formában gyűjtsék össze az űrlapadatokat, létrehozhat nyomtatási nézetet is, amely kifejezetten nyomtatásra való. Ez hasznos lehet, ha azt szeretné, hogy a felhasználók adott elrendezésben nyomtassák az űrlapot vagy annak bizonyos részeit.

Ha az űrlapsablon több nézettel rendelkezik, minden nézethez létrehozható külön nyomtatási nézet, de akár ugyanaz a nyomtatási nézet is használható az űrlapsablon minden nézetéhez. Ha például az űrlapsablon három különböző nézetet tartalmaz, kialakítható egy olyan nyomtatási nézet, mely a három nézet legfontosabb adatait egyetlen nyomtatott oldalra gyűjti.

Ha nyomtatási nézetet szeretne létrehozni vagy meglévő nézethez csatolni, a Nézetek munkaablak A nézet nyomtatott változatának létrehozása pontjában megteheti azt. Ha erre a hivatkozásra kattint, az InfoPath a következőt teszi:

  • Új, Nyomtatható verzió név nevű üres nézetet hoz létre, ahol a név annak a nézetnek a neve, amelyen a nyomtatási nézet alapul.

  • Társítja a nyomtatási nézetet azzal a nézettel, amelyen az alapul. Ez a társítás a Nézet tulajdonságai párbeszédpanelen kerül rögzítésre a Nyomtatási beállítások lapon. Tegyük fel például, hogy az űrlapsablon Jóváhagyás nézetén alapuló nyomtatási nézetet hozott létre. Mikor a felhasználók a Jóváhagyás nézet Nyomtatás gombjára kattintanak, az InfoPath azt nyomtatja ki, ami a Nyomtatható verzió: Jóváhagyás nézetben megjelenik.

A nyomtatási nézet létrehozása után megtervezheti az űrlapot úgy, hogy ahogyan nyomtatásban szeretné majd látni. Ez azt jelenti, hogy másolhat és beilleszthet vezérlőket az űrlapsablon más nézeteiből a nyomatási nézetbe. Szükség esetén lecserélhet néhány vezérlőt a nyomtatási nézet más vezérlőire. Lecserélhet például egy legördülő listát (amely alapértelmezésben elrejti a lista bejegyzéseit) egy szokásos listára, amely alapértelmezésben megjeleníti azokat. Ekkor minden bejegyzés rajta lesz a kinyomtatott űrlapon. Megadhat egyéni nyomtatási beállításokat (például élőfejek, élőlábak és oldalmargók) is a nyomtatási nézetben a Nézet tulajdonságai párbeszédpanelen.

Vissza a lap tetejére

Új nyomtatási nézet tervezése meglévő nézet alapján

Alapértelmezésben – ha a felhasználó olyan űrlapot nyomtat, amelyhez nincsen nyomtatási nézet társítva – a felhasználó számítógépén aktuálisan megjelenő nézet kerül nyomtatásra. Ha nyomtatási nézetet hoz létre, az InfoPath azt nyomtatja ki a jelenlegi nézet helyett. Nyomtatási nézetként bármelyik létező nézet kijelölhető. A következő eljárás írja le, hogyan használható egy meglévő nézet nyomtatási nézet alapjául.

  1. Válassza a Nézet menü Nézetek kezelése parancsát.

  2. A Nézetek munkaablak Nézet kiválasztása listájában kattintson azon nézet nevére, amelyhez a nyomtatási nézetet létre kívánja hozni.

  3. A Műveletek területen kattintson A nézet nyomtatott változatának létrehozása gombra.

  4. A Nyomtatható verzió létrehozása párbeszédpanelen írja be a nézet nevét, majd kattintson az OK gombra.

  5. A Nézetek munkaablakban kattintson kétszer a nyomtatási nézetre.

  6. A Nézet tulajdonságai párbeszédpanelen adja meg a kívánt beállításokat a Nyomtatási beállítások és Oldalbeállítás lapon, majd kattintson az OK gombra. Megadhatja például az alapértelmezett margóbeállításokat a nyomtatási nézethez vagy élőfejet és élőlábat adhat hozzá.

  7. Az eredeti nézetre történő átváltáshoz kattintson a Nézetek munkaablak Nézet kiválasztása listájában a nézet nevére.

  8. A nézet minden elemének kijelöléséhez nyomja le a CTRL+A billentyűkombinációt.

  9. A kijelölés Vágólapra történő másolásához nyomja le a CTRL+C billentyűkombinációt.

  10. A nyomtatási nézetre történő átváltáshoz kattintson a Nézetek munkaablak Nézet kiválasztása listájában a nézet nevére.

  11. A kijelölés eredeti nézetből nyomtatási nézetbe történő beillesztéséhez nyomja le a CTRL+V billentyűkombinációt.

  12. Törölheti bármely vezérlőt vagy elrendezési elemet, amelyekre nincs szüksége vagy adhat hozzá további vezérlőket.

    Tipp : Ha gyorsan szeretné meghatározni, hogy a vezérlők és más tervezett elemek beleférnek-e a nyomtatott oldalba, megjeleníthet egy oldalszélesség-jelző vonalat az űrlapsablon jobb oldalán a Nézet menü Oldalszélesség-jelző vonal pontjára kattintva. Az oldalszélesség-jelző vonal az űrlapsablonon szaggatott függőleges vonalként látszik. A vonal azt jelzi, hogy hol található a nyomtatott oldal jobb oldali margója, a számítógép alapértelmezett nyomtatójára vonatkozóan.

  13. Ha oldaltörést szeretne hozzáadni a nyomtatási nézethez, kattintson arra a helyre, ahol az új oldalt kezdeni szeretné, majd a Beszúrás menüben az Oldaltörés pontra.

    Megjegyzés : Oldaltörés űrlapsablon Vízszintes szaggatott vonalként jelenik meg. Ha az űrlapsablon megtekintéséhez, akkor nem látható a szaggatott vonal vagy más feltüntetése az oldaltörést. Az oldaltörés hogyan befolyásolják az űrlapon alapul nyomtatott űrlapokat megtekintéséhez kattintson a Nyomtatási kép Gombkép a szokásos eszköztáron.

Vissza a lap tetejére

Nyomtatási nézet létrehozása a Word programban való használatra

Ha speciális űrlaptervező, akik XML-technológiák értelmez, a nyomtatási nézet hozzáadása a Word varázsló a Microsoft Office Word-alapú nyomtatási nézet létrehozása, amely űrlapadatok nyomtat közvetlenül a Wordben is használhatja. Így kihasználhatók a tartomány nyomtatási funkciók elérhető a Wordben. Ehhez a már meglévő XSL átalakító (XSLT) fájlt, amely az űrlapon található adatok alakítja formátumúvá alakítja a Word alkalmazásból történő nyomtatáshoz alkalmas kell rendelkeznie az access. Amikor a felhasználó a nyomtatási nézet a Word-alapú tartalmazó űrlap nyomtat, az űrlapon lévő adatokat nyomtatja közvetlenül a Wordben. Az XSLT-fájl a Microsoft Office Word 2003 vagy Microsoft Office Word 2007hozható létre.

Megjegyzés : Az XSLT-fájl létrehozásával kapcsolatos további információért olvassa el a a Microsoft Office InfoPath 2003 szoftver fejlesztési csomag (SDK). Az SDK tartalmaz egy, az InfoPath Word varázsló, amely lehetővé teszi, hogy a Word 2003 vagy Word 2007-es használatával kinyomtathatja az InfoPath-űrlapok adatainak nevű eszközt. Keresse meg az InfoPath 2003 SDK, tanulmányozza a Lásd még szakaszban.

  1. Válassza a Nézet menü Nézetek kezelése parancsát.

  2. A Nézetek munkaablak Műveletek területén kattintson a Nyomtatási nézet hozzáadása a Word számára elemre.

  3. Kövesse a Nyomtatási nézet hozzáadása a Word számára varázsló utasításait a Word-alapú nyomtatási nézethez használni kívánt XSLT-fájl megadásához.

  4. A Nézetek munkaablak Nézet kiválasztása listájában kattintson arra a nézetre, amelyhez a Word-alapú nyomtatási nézetet ki szeretné jelölni, majd kattintson a Nézet tulajdonságai gombra.

  5. Kattintson a Nyomtatási beállítások fülre.

  6. A Jelöljön ki egy meglévő nézetet a nézet nyomtatásához listában kattintson a Word-alapú nyomtatási nézetre.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×