Nézetek (oldalak) hozzáadása, törlése és váltása űrlapokon

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Ha az űrlaphoz különböző nézeteket tervez, akkor a felhasználók több szemszögből vehetik szemügyre az adatokat – a látottak igazodhatnak például a létrehozni kívánt űrlap vagy az azt megtekintő felhasználó típusához. Ha több nézetet használ, jó néhány előnyhöz juthat:

  • A hosszú, összetett űrlapok (például egy hosszú kérdőív) egyszerűbbé válnak: az űrlapok több oldalra oszthatók, amelyek között a Következő és a Vissza gombbal könnyen navigálhatnak a felhasználók.

  • Az egyes személyek – attól függően, hogy milyen szerepet töltenek be a vállalatnál – az űrlap különböző változatait tekinthetik meg: biztosítási igények feldolgozásához például külön nézet készíthető a biztosítottaknak, az ügynököknek és a biztosítási tanácsadóknak.

  • Az űrlap nyomtatható nézete is elkészíthető.

Az InfoPath-űrlapok valamennyi nézetben ugyanazokat az adatokat használják, következésképpen ha az űrlap egyik nézete egy e-mail cím megadására szolgáló szövegmezőt tartalmaz, akkor ez a szövegmező a másik nézetbe is átmásolható. Ha a felhasználó valamelyik nézetben megadja az e-mail címét, akkor az a másik nézetben is automatikusan megjelenik.

Tartalom

A nézetek bemutatása

Felhasználói tapasztalat

Tervezési szempontok

Az Oldalterv lap Nézetek csoportja

Nézet hozzáadása

Nézet törlése

Az alapértelmezett nézet módosítása

Nézet átnevezése

Nézetváltó gomb hozzáadása

Nézet megjelenítése űrlapbetöltési szabály használatával

A nézetek bemutatása

A felhasználói felület

A felhasználók alapértelmezés szerint a menüszalag Nézetek vagy Lapmegtekintések csoportjában választhatják ki a kívánt nézetet. A nézetek név szerint sorba rendezve láthatók, az aktív nézet pedig ki van jelölve. A listában csak azok a nézetek nem szerepelnek, amelyek esetében nincs jel a Nézet tulajdonságai párbeszédpanelen található Megjelenítés a Nézet menüben az űrlap kitöltésekor jelölőnégyzetben.

Ha nincs a nézeteket a a Nézet menü, ha az űrlap kitöltését megjelenítése jelölőnégyzet be van jelölve, nem jelennek meg a Lap nézetek csoportjában kattintson a Kezdőlap lap. Ez akkor hasznos, amelyre felhasználók elérhessék azt, amely azt szeretné, hogy töltse ki nézetekben nem helyzetekben. Például, hogy van egy űrlap, amely a jelentkező visszajelzések összegyűjtése az társítva három különböző felhasználói szerepkörök – egy recruiters, interjúbonyolítók egyet, és egy humánerőforrás-menedzserek. Egyes felhasználói szerepkör tervezhet némileg eltérő látni a képernyőn.

Megjegyzés : A nézetek egyes felhasználók elől történő elrejtése nem biztonsági szolgáltatás. Ha egy felhasználó tudja, hogyan kell hozzáférni magukhoz az XML-adatokhoz, akkor megtekintheti az űrlap adatait.

Ha nem szeretné, hogy az interjút vezető személyek átválthassanak a HR-munkatársak vagy a vezetők nézetére, akkor a HR-munkatársak és a vezetők nézetének tervezésekor nyissa meg a Nézet tulajdonságai párbeszédpanelt, és törölje a jelet a Megjelenítés a Nézet menüben az űrlap kitöltésekor jelölőnégyzetből.

Megjegyzés : A képernyő-beállítások az azt jelenti, hogy nézetváltás felhasználók számára a böngészőben űrlap kitöltése tiltható. Kattintson a fájl fülre, kattintson az információelemre, kattintson a Beállítások képernyőnés a Böngészők csoportban törölje a nézetek jelölőnégyzetből.

A nézetváltás testre szabható nézetváltó gombok felvételével az űrlapra. Erről a cikk későbbi részeiben bővebben is olvashat.

Tervezési szempontok

Új nézetek tervezésekor általában a következő feladatokat kell végrehajtani:

  1. A nézet tervének elkészítése

Meg kell tervezni az összes nézetet, illetve azt, hogyan működnek majd együtt. A következő szempontokra mindenképpen célszerű figyelni:

  • Melyik nézet jelenjen meg, amikor az űrlapot először megnyitják?

  • Szüksége van-e a felhasználóknak több nézetre? Hogyan válthatnak közöttük?

  • Szükséges-e, hogy valamelyik nézet írásvédett legyen?

  • Előfordulhat-e, hogy a felhasználók az InfoPath-űrlap valamelyik nézetét ki szeretnék nyomtatni?

  • A nézet feltöltése

Ha új nézetet ad egy űrlaphoz, akkor először egy oldalelrendezés-sablon jelenik meg. Az űrlap – a menüszalag Beszúrás lapján – elrendezéstáblázat hozzáadásával tagolható, a Kezdőlap lap Vezérlők csoportjában pedig gombokat adhat az űrlaphoz.

A megfelelő mező Mezők munkaablakból történő áthúzásával olyan vezérlőket is az új nézethez adhat, amelyek a többi nézetben található mezőket használják.

  1. A navigálási élmény testreszabása

Hogyan navigálhatnak a felhasználók az űrlapon belül? Tudja-e a felhasználó, hogy mit jelentenek a nézetváltás alapértelmezett parancsai? Megfelelők-e az alapértelmezett parancsok, vagy a felhasználók inkább közvetlenül az űrlapon megjelenő gombra kattintva válthassanak a nézetek között? Ha a felhasználó egy gombra kattint, akkor a felhasználói felület inkább lapokra osztott legyen, vagy a váltás a Vissza és a Következő gombokkal történjen? Nyomtatási nézeteknél a felhasználók kinyomtathassák-e az összes nézetet egyszerre, vagy csak az éppen aktív nézetet?

Az Oldalterv lap Nézetek csoportja

A menüszalag Oldalterv lapjának Nézetek csoportjában nézeteket adhat az űrlaphoz, törölheti azokat, illetve válthat a különböző nézetek között. A kijelölt nézet beállításainak és működésének testreszabásához a Tulajdonságok gombra kattintva nyissa meg a Nézet tulajdonságai párbeszédpanelt.

A párbeszédpanelen nyomtatási nézetet is létrehozhat, és meglévő nézethez rendelheti azt. Ehhez először létre kell hozni az űrlapnézet nyomtatásakor megjelenítendő nyomtatási nézetet, majd a Nézet tulajdonságai párbeszédpanelen egy meglévő nézethez kell rendelni. A Nézet tulajdonságai párbeszédpanel Nyomtatási beállítások és Oldalbeállítás lapján egyedi nyomtatási beállításokat (például fejlécet, láblécet vagy oldalmargót) is megadhat a nyomtatási nézethez.

Vissza a lap tetejére

Nézet hozzáadása

Új nézeteket a következőképpen adhat az űrlaphoz.

  1. Kattintson az Oldalterv lap Nézetek csoportjában található Új nézet gombra.

  2. Írja be a nézet nevét, és kattintson az OK gombra.

Nézetek hozzáadása és törlése, illetve nézetváltás űrlapokon

  1. A Nézet tulajdonságai párbeszédpanel megnyitásához kattintson az Oldalterv lap Nézetek csoportjában található Tulajdonságok gombra.

  2. A Nézet tulajdonságai párbeszédpanelen módosítsa vagy adja meg a nézet kívánt beállításait, és kattintson az OK gombra.

Nézetek hozzáadása és törlése, illetve nézetváltás űrlapokon

  1. A munkaterületen tervezze meg a nézetet úgy, hogy elrendezéstáblákat és vezérlőket ad hozzá.

Ha szeretne egy új nézetet meglévő nézet alapján, nyissa meg a meglévő nézet, nyomja le a CTRL + A jelölje ki a nézet tartalmát, és nyomja le a CTRL + C billentyűkombinációt , és másolja a kijelölést a vágólapra. Jelölje be az új nézet az Oldalterv lap nézetek csoportjának Nézet listából, törölje a már előre kitölt tartalmat a nézetben, majd nyomja le a CTRL + V billentyűkombinációval illessze be az új nézet a kijelölésre.

Vissza a lap tetejére

Nézet törlése

A törölt nézetek nem állíthatók vissza. Ha olyan űrlap alapértelmezett nézetét törli, amelynek csak egy nézete volt, az InfoPath automatikusan új alapértelmezett nézetet hoz létre. Ha olyan űrlap alapértelmezett nézetét törli, amely több nézetet is tartalmazott, akkor az InfoPath az Oldalterv lap Nézetek csoportjában található Nézet lista következő nézetét állítja be alapértelmezettnek.

  1. Az Oldalterv lap Nézetek csoportjának Nézet listájában jelölje ki a törölni kívánt nézetet.

  2. Kattintson az Oldalterv lap Nézetek csoportjában található Törlés gombra.

  3. Amikor a rendszer a törlés megerősítését kéri, kattintson az Igen gombra.

Vissza a lap tetejére

Az alapértelmezett nézet módosítása

Minden űrlapnak van alapértelmezett nézete. Amikor a felhasználók megnyitnak egy olyan űrlapot, ami az Ön űrlapján alapul, akkor ez a nézet jelenik meg. Ha egy űrlaphoz egyéni nézeteket hoz létre, akkor megadhatja, hogy az elérhető nézetek közül melyik legyen a felhasználók alapértelmezett nézete.

  1. Az Oldalterv lap Nézetek csoportjának Nézet listájában jelölje ki az alapértelmezettként megadni kívánt nézetet.

  2. Kattintson az Oldalterv lap Nézetek csoportjában található Tulajdonságok gombra.

  3. Jelölje be a Beállítás alapértelmezett nézetként jelölőnégyzetet, és kattintson az OK gombra.

Ha az űrlapnak csak egy nézete van, akkor automatikusan az lesz az alapértelmezett.

Vissza a lap tetejére

Nézet átnevezése

  1. Az Oldalterv lap Nézetek csoportjának Nézet listájában jelölje ki az átnevezni kívánt nézetet.

  2. Kattintson az Oldalterv lap Nézetek csoportjában található Tulajdonságok gombra.

  3. A Nézet tulajdonságai párbeszédpanel Nézet neve szövegmezőjébe írja be az új nevet, és kattintson az OK gombra.

Megjegyzés : Ha egyedi kódhoz társított nézetet nevez át, a kód nem biztos, hogy megfelelően működik majd. A probléma megoldásához meg kell találnia a nézet régi nevére mutató összes hivatkozást a kódban, és frissítenie kell azokat a nézet új nevével.

Vissza a lap tetejére

Nézetváltó gomb hozzáadása

A nézeteket gyakran úgy tervezik, hogy szabályokkal működjenek együtt. A szabályok segítségével automatizálhatók bizonyos, az űrlapot kitöltő személy által kezdeményezett eseményekre vagy műveletekre adott választevékenységek. Beszúrhat például egy gombot az űrlapra, létrehozhat egy szabályt, amely nézetet vált a gomb megnyomásakor, végül – a gomb beszúrása után – a szabályt a gombhoz társíthatja. Így valahányszor a felhasználó a gombra kattint, megtörténik a nézetváltás.

Pontosabban biztosítási állítást ív, létrehozhat, amely megnyitja az állítást adatok kattintáskor magas szintű nézet Megjelenítése összefoglaló gomb. Az összegző nézetben felhasználók sikerült kattintson a Részletek megjelenítése gombra a részletesebb nézethez való visszatéréshez. Hasonlóképpen ha nagyon sok űrlap, sikerült több nézet szétválasztani, és adja hozzá a következő és biztonsági másolatot a gombok és Többlapos navigációs engedélyezése a felhasználóknak Lépkedés a képernyő.

  1. Szúrjon be egy-egy gombot mindegyik nézetbe.

Az alábbiakhoz olyan űrlap szükséges, amelyhez legalább két meglévő nézet tartozik.

  1. Az Oldalterv lap Nézetek csoportjának Nézet listájában jelölje ki azt a nézetet, amelyhez gombot szeretne adni.

  2. A kurzort vigye arra a részre az űrlapon, ahová a gombot helyezni szeretné.

  3. A Kezdőlap lap Vezérlők csoportjában kattintson a Gomb elemre.

  4. Kattintson a Vezérlőelemek eszközei eszközcsoportban található Tulajdonságok fülre.

  5. A Felirat mezőbe írja be a gomb nevét, és kattintson az OK gombra.

  • Hozzon létre egy nézetváltó szabályt.

    1. Jelölje ki a gombot.

    2. A Vezérlőelemek eszközei eszközcsoport Tulajdonságok lapjának Szabályok csoportjában kattintson a Szabály hozzáadása menügombra.

      Nézetek hozzáadása és törlése, illetve nézetváltás űrlapokon

    3. Mutasson A gombra kattintáskor menüpontra, és válassza a Műveletek lista Nézetváltás parancsát.

    4. A Nézet szövegmezőben válassza ki a gombra kattintáskor megjelenítendő nézetet, és kattintson az OK gombra.

      Nézetek hozzáadása és törlése, illetve nézetváltás űrlapokon

  • Az 1. és a 2. lépés megismétlésével minden nézethez létrehozhat gombokat és azokhoz kapcsolódó szabályokat.

  • Az összes gomb felvétele és a szükséges szabályok létrehozása után célszerű ellenőrizni, hogy az űrlapon minden megfelelően működik-e.

  • Kattintson a Kezdőlap lap Űrlap csoportjában található Minta gombra.

  • A gombokra kattintva megbizonyosodhat róla, hogy a nézetváltások a kívánt módon történnek.

    Ha nem hoz létre olyan szabályt, amely az űrlap betöltésekor a felhasználói szerepkör alapján vált nézetet, akkor az a nézet jelenik meg az előnézeti ablakban, amellyel legutóbb dolgozott.

Megjegyzés : Írásvédett nézetek, a gombok nem érhetők el. Navigáció, csak olvasható nézeteket, például a megjelenítési nézet a SharePoint-listaűrlap a kép gombra, és törölje a jelet a a vezérlő tulajdonságainak szerkesztése párbeszédpanelről, a Tulajdonságok lapon, a menüszalag olvasási nézetben a kép gomb elrejtése jelölőnégyzet jelölését.

Vissza a lap tetejére

Nézet megjelenítése űrlapbetöltési szabály használatával

Egy űrlap megnyitásakor a nézet az adott felhasználóhoz vagy más feltételhez is igazodhat. Ha például olyan, felhasználói szerepköröket is tartalmazó űrlapot tervez, amelyben több nézet található, akkor hasznos lehet, ha az aktuális felhasználó szerepkörén alapuló nézet jelenik meg. Nevezetesen, használható olyan szabály, amely egy bizonyos nézetet jelenít meg, amikor az űrlapon alapuló fájlt egy adott szerepkörű felhasználó nyitja meg.

Felhasználói szerepkörök csak akkor használható, az űrlapok az InfoPath filler készült. Váltás webes csoporttagság alapuló nézetek engedélyezve van az űrlapok, fontolja meg a használó Űrlap betöltése szabály létrehozása a Felhasználói profil webszolgáltatás határozza meg a felhasználók tagságátgetUserMemberships metódusát.

Az eljárás feltételezi, hogy az űrlaphoz definiálva van egy felhasználói szerepkör. Ha egy felhasználói szerepkör sincs megadva az űrlaphoz, akkor az eljárás megkezdése előtt az Adatok lapon fel kell venni egyet.

  1. Kattintson az Adatok lap Szabályok csoportjának Űrlap betöltése gombjára.

  2. Kattintson az Új menügombra, válassza a Művelet parancsot, majd a Részletek a következőhöz szövegdobozba írja be a szabály nevét.

  3. Ha azt szeretné, hogy az űrlap egy felhasználói szerepkörön alapuló nézetet töltsön be, akkor kattintson a Feltétel szakaszban található hivatkozásra. Az első listában válassza a Felhasználó aktuális szerepköre elemet, majd adja meg a felhasználó szerepkörét.

Attól függően, hogy milyen feltételek szerint szeretné módosítani az űrlap betöltését, más beállításokat is megadhat.

Nézetek hozzáadása és törlése, illetve nézetváltás űrlapokon

  1. Kattintson az OK gombra.

  2. Kattintson a Hozzáadás gombra, majd válassza a Nézetváltás elemet.

Nézetek hozzáadása és törlése, illetve nézetváltás űrlapokon

  1. Kattintson a kívánt nézetre a Nézetek listában, és kattintson az OK gombra.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×