Microsoft Access-adatbázison alapuló űrlapsablon tervezése

Fontos: Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Működik-e a Microsoft Office Access adatbázis vagy lekérdezés adatokat, vagy a lekérdezés és adatok küldése a Microsoft Office InfoPath űrlapsablon tervezése Az adatbázis (.accdb formátumban) Microsoft Office Access 2007 vagy Access-adatbázis (.mdb formátumot) korábbi verziójában mentett alapján űrlapsablon tervezése

Tartalom

– Áttekintés

Kompatibilitási kapcsolatos szempontok

Első lépések

Az űrlapsablon tervezése

A Küldés beállításainak konfigurálása

Áttekintés

Űrlap futtatható egy elsődleges adatkapcsolatot, a fő adatkapcsolat neve és a kapcsolat tetszés szerint is tartalmaz egy vagy több másodlagos adatkapcsolatokat. A fő adatkapcsolat használatával lekérdezés vagy Access-adatbázis űrlapadatok. Másodlagos adatkapcsolat lekérdezéséhez és külső adatforrásokhoz, néhány kivétellel adatok elküldése is használhatja. Használhatja például Access-adatbázishoz másodlagos adatkapcsolat, hogy csak az adatbázis kérdezi le. Másodlagos adatkapcsolat nem vehet fel egy űrlap, amely elküld űrlap adatkönyvtárának Access-adatbázishoz.

Access-adatbázis alapuló űrlapsablon tervezésekor InfoPath a fő adatforrás és adatmezőket tartalmazó csoportokat hoz létre, és létrehoz egy lekérdezési kapcsolatot, az űrlapsablon fő adatkapcsolat is. E mezők és csoportok felelnek meg a úgy, hogy az adatok a táblázatokban az adatbázisban vannak tárolva.

A lekérdezésmezők az űrlapra korlátozhatja a rekordok, amelyek a lekérdezés mezők adatainak felelnek meg a lekérdezés eredményében a felhasználó által megadott adatokat tartalmazzák. Ha ezen a sablonon alapuló űrlap a fő adatkapcsolatot használ, az InfoPath használatával az adatokat a lekérdezési mezők létrehoz egy lekérdezést. Az InfoPath elküldi a lekérdezés az adatok kapcsolaton keresztül. Az adatbázis visszaküldi a lekérdezés eredményét az űrlapot az adatok kapcsolaton keresztül. A lekérdezés eredményét az adatok mezőkhöz kötött vezérlőelemeket az űrlap keresztül szerkeszthető adatmezők kerülnek.

Mivel az adatmezők és a lekérdezés adatszerkezetének meg kell egyeznie az adatbázisban tárolt adatokéval, nem módosíthatja ezeket a mezőket vagy csoportokat a fő adatforrásban. Csak a fő adatforrás gyökércsoportjához adhat hozzá mezőket vagy csoportokat. Az adatforrásokról további információt a Lásd még szakasz hivatkozásai révén kaphat.

Az űrlap akkor küldhet adatokat egy adatbázisba a fő adatkapcsolatán keresztül, ha az űrlapsablon, amelyre az űrlap alapul és az adatbázis megfelel a következő követelményeknek:

  • Az űrlapsablon nem böngészőkompatibilis űrlapsablon    Az InfoPath nem hoz létre egy Küldés kapcsolatot a fő adatkapcsolat böngészőkompatibilis űrlapsablon tervezésekor. Lehetővé teszi a felhasználóknak a böngészőbarát űrlapsablon alapuló űrlap adatainak tárolása, használja a webszolgáltatás működik-e az adatbázist.

  • A fő adatforrás kapcsolódó tábla minden egyes pár a bal oldali tábla elsődleges kulcsot tartalmaz.    Minden pár a kapcsolódó tábla kapcsolatainak legalább egyike tartalmaznia kell a bal oldali tábla elsődleges kulcsot.

  • Nincs az adatmezőket az űrlap tároló nagy bináris adattípus fő adatforrás    Az InfoPath letiltja az adatkapcsolatot a Küldés gombra, ha a lekérdezés tartalmazza a mezőket, amelyeket egy nagy bináris adattípusú, például képek, képek, OLE objektumok, fájlmellékleteket, az Office Access Feljegyzés adattípus vagy az SQL-szöveg adattípus tárolhat.

Az InfoPath lehetővé teszi, hogy a Küldés adatkapcsolatot, amikor engedélyezett a felhasználók számára nyújt az adatok mezőiben az adatbázist a fő adatforrás tárolt adatokhoz. Testre szabhatja az ezen a sablonon alapuló űrlapok küldés lehetőségeit.

Vissza a lap tetejére

Kompatibilitási kérdések:

Access-adatbázis alapján böngészőkompatibilis űrlapsablon nem tervezése.

Vissza a lap tetejére

Mielőtt elkezdené:

Access-adatbázis alapuló űrlapsablon tervezése sikeresen, előtt szükséges az Access-adatbázist az alábbi adatokat:

  • Az adatbázis neve és helye.

    Megjegyzés: Győződjön meg arról, hogy az adatbázis hálózati, amely a felhasználók számára hozzáférhető helyen.

  • A táblázat, amely kapja a nevét a feladatot adatokat, ha űrlapsablon lehetővé teszi a felhasználóknak adatbázishoz küldheti el. Akkor használja az alábbi táblázat az elsődleges tábla az elküldés adatkapcsolat beállításakor.

  • A táblázat, amely megadja az adatbázist, elküldi a lekérdezés eredményét, ha űrlapsablon lekérdezésére az adatbázis neve. Akkor használja az alábbi táblázat az elsődleges tábla a lekérdezés adatkapcsolat beállításakor.

  • Minden más, előfordulhat, hogy az elsődleges tábla adatainak táblák neve. A legtöbb esetben a táblának megfelelő kapcsolatokat van már folyamatban az adatbázist. Ha az elsődleges tábla és egy másik tábla közötti kapcsolatok létesítése manuálisan kell szüksége lesz a két tábla kapcsolódó mező nevét.

Vissza a lap tetejére

Űrlapsablon tervezése

A lekérdezés adatkapcsolat űrlapsablon tervezése, először kell létrehozni az űrlapsablont. Amikor létrehoz egy űrlapsablon adatbázison alapuló, az InfoPath, az űrlapsablon és az adatbázis közötti fő adatkapcsolat lekérdezés adatkapcsolat hoz létre. Ez a folyamat automatikusan létrehozza az űrlapsablon fő adatforráshoz.

Miután létrehozta az űrlapsablont, kell vezérlőelem hozzáadása az űrlapsablonhoz, és majd kötni a vezérlőt a fő adatforrás mező. Ez lehetővé teszi a felhasználóknak, hogy a lekérdezés a képernyőn a találatokat.

1. lépés: Űrlapsablon létrehozása

  1. Kattintson a Fájl menü Űrlapsablon tervezése parancsára.

  2. Űrlapsablon tervezése párbeszédpanelen az új sablon, kattintson az Űrlapsablon.

  3. A alapján listában kattintson az adatbázis, és kattintson az OKgombra.

    Az Adatkapcsolat varázsló elindul.

  4. Kattintson az Adatkapcsolat varázsló első lapján Jelölje ki az adatbázist.

  5. Az Adatforrás kijelölése párbeszédpanelen tallózással keresse meg az adatbázist.

    Megjegyzés: Ha az adatbázis hálózati helyen tárolja, nyissa meg az univerzális elnevezési konvenció (UNC) elérési útját azt a helyet. Nem tallózással keresse meg a hálózati hely keresztül csatlakoztatott hálózati meghajtón. Ha egy csatlakoztatott hálózati meghajtók használja, a felhasználók, akik ezen a sablonon alapuló űrlapok létrehozása megkeresi az adatbázist a csatlakoztatott hálózati meghajtón. Ha a felhasználó nem rendelkezik a csatlakoztatott hálózati meghajtón, a képernyőn nem találja meg az adatbázist.

  6. Kattintással jelölje ki azt az adatbázist, és kattintson a Megnyitásgombra.

  7. A Táblaválasztás párbeszédpanelen kattintson az elsődleges táblát vagy lekérdezést, amely a használni kívánt, és kattintson az OKgombra.

  8. A varázsló következő lapján jelölje be a Tábla oszlopainak megjelenítése jelölőnégyzetet.

  9. Alapértelmezés szerint minden mezője a táblázat hozzáadódik a fő adatforrás űrlapsablon. A fő adatforrás szerepeltetni nem kívánt mezők jelölőnégyzetét.

    Adja hozzá bármilyen további táblát vagy lekérdezést, a lekérdezés adatkapcsolat használni kívánt.

    Hogyan?

    1. Kattintson a Tábla hozzáadása parancsra.

    2. A Tábla vagy lekérdezés hozzáadása párbeszédpanelen kattintson a gyermektábla nevére, majd a Tovább gombra. Az InfoPath a két tábla mezőneveinek párosításával megkísérli beállítani a kapcsolatokat. Ha a felkínált párosításokat nem szeretné használni, jelölje ki a nem kívánt kapcsolatot, és kattintson a Kapcsolat törlése gombra. Kapcsolat hozzáadásához kattintson a Kapcsolat hozzáadása gombra. A Kapcsolat hozzáadása párbeszédpanelen a megfelelő oszlopban jelölje ki az összefüggő mezőket, és kattintson az OK gombra.

    3. Kattintson a Befejezés gombra.

    4. További gyermektáblák hozzáadásához ismételje ezeket a lépéseket.

  10. Kattintson a Tovább gombra.

  11. A varázsló utolsó lapján adja meg a fő adatkapcsolat nevét. Ez a név jelenik majd meg az Adatforrás munkaablak Adatforrás listájában.

  12. Űrlapsablon megfelel az Áttekintés részben, ha a Összefoglalás szakasz ezen a lapon a varázsló azt jelzi, hogy az InfoPath engedélyezve van-e az elküldés adatkapcsolat a fő adatkapcsolat.

  13. A Küldés adatkapcsolat nevének módosításához írja be egy új nevet a megfelelő mezőbe.

  14. Ha engedélyezni szeretné a felhasználóknak, hogy keresztül egy másik űrlap adataik elküldése szeretne hozzáadni az űrlapsablon később származó adatok elküldése, törölje a jelet a kapcsolat elküldése engedélyezése jelölőnégyzetet.

    Megjegyzés: Űrlapsablon nem felel meg az Áttekintés szakaszában, ha az InfoPath letiltja az adatkapcsolatot a Küldés gombra, és Írja be a Küldés gombra a kapcsolat nevét mezőben, és a Küldés gombra a kapcsolat engedélyezése jelölőnégyzet nem érhető el. Az InfoPath letiltja az adatkapcsolatot a Küldés gombra, ha a fő adatkapcsolat űrlapsablonhoz csak egy lekérdezési kapcsolatot is tartalmaz.

2. lépés: Vezérlő kötése a mezőhöz

  1. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  2. Húzzon egy vezérlőt az űrlapsablonra.

  3. A Vezérlő kötése párbeszédpanelen jelölje ki a mezőt, amely a vezérlőt kötni szeretné.

Vissza a lap tetejére

Adja meg a küldési beállításokat:

Űrlapsablon és a táblákat az Adatkapcsolat varázsló kiválasztott megfelelnek az Áttekintés részben, ha az InfoPath küldje el az adatokat a fő adatkapcsolata űrlapsablon állítja be.

Ha használni szeretné ezt az adatbázisból származó adatok elküldése, az InfoPath az űrlapsablon konfigurálása az, hogy a felhasználók is űrlapadatok azok az adatbázis, is hozzáadja a Küldés gombra a szokásos eszköztár és a Küldés parancs a fájl menü az űrlapon. Az InfoPath is konfigurálja az űrlapsablont, hogy azok űrlapok elküldésekor a felhasználók az űrlap nyitva marad, és egy megjelenő üzenet jelzi, hogy az űrlap sikerült elküldeni. Módosítsa a szöveget, amely akkor jelenik meg a Küldés gombra, és a felhasználó által beadott azt követően is módosíthatja a űrlap viselkedését.

  1. Kattintson az Eszközök menü Küldés beállításai elemére.

    1. Ha más nevet szeretne adni az űrlapküldéskor a Szokásos eszköztáron látható Küldés gombnak, valamint a Fájl menüben megjelenő Küldés parancsnak, írja be az új nevet a Küldés beállításai párbeszédpanel Felirat mezőjébe.

      Tipp: Ha szeretne Billentyűparancs hozzárendelése gomb és a parancsot, írja be az egy és jel (&) billentyűparancs használni kívánt karakter elé. ALT + B hozzárendelni, a billentyűparancs: a Küldés gomb és a parancsot, írja be például a & Küldés.

  2. Ha nem szeretné, hogy a felhasználók a Küldés parancsot vagy a Szokásos eszköztár Küldés gombját használják az űrlap kitöltésekor, akkor törölje A Küldés menüpont és a Küldés eszköztárgomb megjelenítése jelölőnégyzet jelölését.

    1. Az InfoPath az űrlapok elküldését követően alapértelmezés szerint megnyitva tartja az űrlapot, és megjelenít egy, az űrlap sikeres elküldéséről szóló üzenetet. Ennek az alapértelmezett működésnek a módosításához kattintson a Speciális gombra, majd hajtsa végre az alábbiak egyikét:

      • Ha azt szeretné, hogy a kitöltött űrlap elküldése után a program bezárja az űrlapot vagy egy új, üres űrlapot hozzon létre, jelölje ki az Elküldést követően lista kívánt elemét.

      • Ha az elküldés sikerességét egy egyéni üzenettel kívánja jelezni, jelölje be az Egyéni üzenetek használata jelölőnégyzetet, majd írja be a kívánt szöveget a Siker esetén és Sikertelenség esetén mezőbe.

        Tipp: A Sikertelenség esetén mezőbe az elküldés sikertelensége esetén elvégzendő lépéseket írja; javasolhatja például a felhasználóknak, hogy mentsék az űrlapot, és lépjenek kapcsolatba a megfelelő személlyel a további utasítások végett.

      • Ha nem kíván semmilyen üzenetet megjeleníteni az űrlap elküldését követően, törölje az Üzenetek megjelenítése a sikeres és a sikertelen végrehajtásról jelölőnégyzet jelölését.

Vissza a lap tetejére

Megjegyzés: Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×