Makró létrehozása és futtatása

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A Word alkalmazásban hoz létre, és makrók futtatása automatizálhatja a gyakran ismétlődő feladatokat. Makró ki parancsok és a megjelenő utasításokat a csoportba foglalt automatikusan a feladat végrehajtásában egyetlen paranccsal.

A gyakran ismételt feladatoknál időt takaríthat meg, ha a feladat lépéseit makróba foglalja. Először rögzítenie kell a makrót, majd a gyorselérési eszköztár egyik gombjára kattintva vagy egy billentyűkombinációt lenyomva futtathatja. Minden csak beállítás kérdése.

  1. Kattintson a Nézet > Makrók > Makró rögzítése parancsra.

    A Makró rögzítése parancs

  2. Adja meg az új makró nevét.

    Makrónév mező

  3. Ha a makrót minden új dokumentumban használni szeretné, az Elérhetőség mezőben a Minden dokumentum (Normal.dotm) lehetőség legyen kiválasztva.

    A makró rögzítési helyének kiválasztására szolgáló mező.

  4. Ha a makrót egy gombra kattintva szeretné futtatni, kattintson a Gomb gombra.

    Kattintás a makró gombhoz történő hozzárendeléséhez

  5. Kattintson az új makróra (az elnevezése valami ilyesmi lesz: Normal.NewMacros.<az Ön makróneve>), majd a Felvétel gombra.

    A makró és a Felvétel gomb

  6. Kattintson a Módosítás gombra.

    A gyorselérési eszköztár testreszabása panel Módosítás gombja

  7. Válasszon gombképet, írja be a nevet, és kattintson az OK gombra, majd újból arra.

    Gombképek a Gomb módosítása párbeszédpanelen

  8. Következhet a lépések rögzítése. Kattintson a feladat egyes lépéseinek megfelelő parancsokra, vagy nyomja le a billentyűket. A Word rögzíti a kattintásokat és a leütéseket.

    Megjegyzés : A makró rögzítése közben történő szövegkijelöléshez a billentyűzetet használja. A makrók nem rögzítik az egérrel végzett kijelölést.

  9. A rögzítés leállításához kattintson a Nézet > Makrók > Rögzítés vége parancsra.

    A Rögzítés vége parancs

A makróhoz rendelt új gomb megjelenik a gyorselérési eszköztárban.

A makró gombja a gyorselérési eszköztárban.

A makró futtatásához kattintson a gombra.

  1. Kattintson a Nézet > Makrók > Makró rögzítése parancsra.

    A Makró rögzítése parancs

  2. Adja meg az új makró nevét.

    Makrónév mező

  3. Ha a makrót minden új dokumentumban használni szeretné, az Elérhetőség mezőben a Minden dokumentum (Normal.dotm) lehetőség legyen kiválasztva.

    A makró rögzítési helyének kiválasztására szolgáló mező.

  4. Ha a makrót egy billentyűparancs lenyomásával szeretné futtatni, kattintson a Billentyűzet elemre.

    Kattintás a makró billentyűparancshoz történő hozzárendeléséhez

  5. Adja meg a billentyűkombinációt az Új billentyűparancs mezőben.

  6. Ellenőrizze, hogy a megadott billentyűkombináció hozzá van-e rendelve már valami máshoz. Ha igen, próbálkozzon egy másik kombinációval.

  7. Ha a billentyűparancsot minden új dokumentumban használni szeretné, a Módosítás mentése mezőben a Normal.dotm lehetőség legyen kiválasztva.

  8. Kattintson a Hozzárendel gombra.

  9. Következhet a lépések rögzítése. Kattintson a feladat egyes lépéseinek megfelelő parancsokra, vagy nyomja le a billentyűket. A Word rögzíti a kattintásokat és a leütéseket.

    Megjegyzés : A makró rögzítése közben történő szövegkijelöléshez a billentyűzetet használja. A makrók nem rögzítik az egérrel végzett kijelölést.

  10. A rögzítés leállításához kattintson a Nézet > Makrók > Rögzítés vége parancsra.

    A Rögzítés vége parancs

A makró futtatásához nyomja le a billentyűparancs billentyűit.

Makró futtatásához kattintson a gombra a gyorselérési eszköztáron, vagy nyomja le a hozzá tartozó billentyűparancsot. A makrót a Makrók listából is futtathatja.

  1. Kattintson a Nézet > Makrók > Makrók megjelenítése parancsra.

    A Makrók megjelenítése parancs

  2. A Makrónév mezőben látható listában kattintson a futtatni kívánt makróra.

  3. Kattintson az Indítás gombra.

Ha a dokumentumban egy olyan makrót szeretne készíteni, amelyet az összes új dokumentumban használni tud, adja hozzá a Normal.dotm sablonhoz.

  1. Nyissa meg a makrót tartalmazó dokumentumot.

  2. Kattintson a Nézet > Makrók > Makrók megjelenítése parancsra.

    A Makrók megjelenítése parancs

  3. Kattintson a Szervező gombra.

    A Szervező gomb a Makrók megjelenítése párbeszédpanelen

  4. Kattintson a Normal.dotm sablonhoz hozzáadandó makróra, és kattintson a Másolás gombra.

  1. Kattintson a Fájl > Beállítások > Menüszalag testreszabása kategóriára.

  2. A Választható parancsok helye listában válassza a Makrók listaelemet.

  3. Kattintson a kívánt makróra.

  4. A Menüszalag testreszabása csoportban kattintson arra a lapra és egyéni csoportra, amelyhez a makrót hozzá szeretné adni.

Ha még nem hozott létre egyéni csoportot, kattintson az Új csoport gombra. Ezután kattintson az Átnevezés gombra, és adjon nevet az egyéni csoportnak.

  1. Kattintson a Hozzáadás gombra.

  2. Az Átnevezés gombra kattintva kiválaszthatja a makró képét és adhat neki egy tetszőleges nevet.

  3. Kattintson mindkétszer a megjelenő OK gombra.

  1. A Fejlesztőeszközök lap Kód csoportjában kattintson a Makrók gombra.

  2. A makrónév mezőbe írja be a makró nevét.

    Megjegyzés : Adhat új makró neve megegyezik egy beépített makrót a Wordben, az új makróműveletek helyére kerül a beépített makrót. Beépített makrók listájának megtekintéséhez kattintson a Word parancsok a makró helye listában.

  3. A makró helye listában kattintson a sablon vagy a dokumentum, amelyben a makrót tárolni szeretné.

    Elérhetővé szeretné tenni a makrót minden dokumentumban, ügyeljen arra, kattintson a Normal.dotm sablonra.

  4. Kattintson a Létrehozás a Visual Basic Editor megnyitása gombra.

Miután megnyitotta a Visual Basic Editor alkalmazást, érdemes további információt a Visual Basic for Applications használata. További információ a Súgó menüben kattintson a Microsoft Visual Basic súgója , vagy nyomja le az F1 billentyűt.

Rögzítheti a tevékenységek egy sorozatát, vagy írhat makró létrehozása a Visual Basic for Applications kód a Visual Basic Editorbeírásával.

Megjegyzés : A Office Word 2007makrók használata, meg kell a Fejlesztőeszközök lap megjelenítése.

  1. Kattintson a Microsoft Office gombra Gombkép , majd A Word beállításai parancsra.

  2. Kattintson a Népszerű elemek elemre.

  3. A Word használatához az alapvető beállításokcsoportban jelölje be a Fejlesztőeszközök lap megjelenítése a szalagon jelölőnégyzetet.

    Megjegyzés : A menüszalag a Microsoft Office Fluent felhasználói felület része.

  1. Kattintson a Fejlesztőeszközök lap Kód csoportjában a Makró rögzítése gombra.

    A Fejlesztőeszközök lap Kód csoportja
  2. A makrónév mezőbe írja be a makró nevét.

    Megjegyzés : Akkor adjon új makró beépített makró nevét a Office Word 2007, az új makróműveletek helyére kerül a beépített makrót. A beépített makrók, listájának megtekintéséhez kattintson a Fejlesztőeszközök lap kód csoportjában kattintson a makrókgombra. A makró helye listában kattintson a Word parancsoklehetőséget.

  3. A makró helye mezőben kattintson a sablon vagy a dokumentumot, amelyben a makrót tárolni szeretné.

    Fontos : Elérhetővé szeretné tenni a makrót minden dokumentumban, ügyeljen arra, kattintson a Normal.dotm sablonra.

  4. A Leírás mezőben adjon rövid leírást a makróról.

  5. Hajtsa végre a megfelelő műveletet:

    • Felvétel indítása    A gyorselérési eszköztár gombjára, vagy egy billentyűparancs hozzárendelésével nélkül a makró rögzítésének megkezdéséhez kattintson az OK gombra.

    • Létrehozás gomb    A makró hozzárendelése gomb a gyorselérési eszköztáron, tegye a következőket:

      1. Kattintson a gombra.

      2. A gyorselérési eszköztár testreszabásacsoportban jelölje be a dokumentumot (vagy az összes dokumentum), amelynek meg szeretné hozzáadhatja a makrót a gyorselérési eszköztáron.

        Fontos : Elérhetővé szeretné tenni a makrót minden dokumentumban, ügyeljen arra, kattintson a Normal.dotm sablonra.

      3. A Választható parancsok helye párbeszédpanelen kattintson a kívánt makróra, és kattintson a Hozzáadásgombra.

      4. Ha testre szeretné szabni a gombra, kattintson a Módosításgombra.

      5. A Szimbólumkattintson az a gomb használni kívánt.

      6. A megjelenítendő név mezőbe írja be a megjeleníteni kívánt makró nevét.

      7. Kattintson kétszer az OK gombra a makró rögzítésének megkezdéséhez.

        A gyorselérési eszköztár a kiválasztott szimbólum jelenik meg. A beírt név jelenik meg, mutasson a kívánt szimbólumot.

    • Billentyűparancs hozzárendelése    A makró billentyűparancshoz rendelni, tegye a következőket:

      1. Kattintson a billentyűzet.

      2. A parancsok listára kattintson a kívánt makrót.

      3. Az Új billentyűparancs mezőbe írja be a használni kívánt billentyűkombinációt, és kattintson a hozzárendelésegombra.

      4. Kattintson a Bezárás gombra a makró rögzítésének megkezdéséhez.

  6. A makró szerepeltetni kívánt műveleteket.

    Megjegyzés : Makró rögzítésekor is az egérrel parancsokra és beállításokra, de nem jelölje ki a szöveget. Jelölje ki a szöveget a billentyűzet kell használnia. Szöveg kijelölése a billentyűzet használatával kapcsolatos további tudnivalókért olvassa el a szöveg kijelölésecímű témakört.

  7. A műveletek rögzítés leállításához kattintson kód csoportjában a Rögzítés gombra.

Módosítsa a makró billentyűparancsai

  1. Kattintson a Microsoft Office gombra Gombkép , majd A Word beállításai parancsra.

  2. Kattintson a Testreszabás elemre.

  3. Billentyűparancsok használatamellett kattintson a Testreszabásgombra.

  4. A Kategóriák listában kattintson a makrókgombra.

  5. A makrók listában kattintson a módosítani kívánt makrót.

  6. Az Új billentyűparancs mezőbe írja be a billentyűkombinációt, válassza a kívánt.

  7. A Foglalt billentyűk jelölőnégyzetet győződjön meg arról, hogy Ön nem hozzárendelése, amely már használja egy másik feladat elvégzéséhez billentyűkombinációt.

  8. A módosítások mentéséhez , kattintson a megfelelő, amelyhez a makrót szeretné futtatni lehetőséget.

    Fontos : Elérhetővé szeretné tenni a makrót minden dokumentumban, ügyeljen arra, kattintson a Normal.dotm sablonra.

  9. Kattintson a Bezárás gombra.

  1. A Fejlesztőeszközök lap Kód csoportjában kattintson a Makrók gombra.

    A Fejlesztőeszközök lap Kód csoportja

  2. A makrónévmezőben látható listában kattintson a futtatni kívánt makrót.

  3. Kattintson a Futtatás parancsra.

  1. A Fejlesztőeszközök lap Kód csoportjában kattintson a Makrók gombra.

    A Fejlesztőeszközök lap Kód csoportja

  2. A makrónév mezőbe írja be a makró nevét.

    Megjegyzés : Akkor adjon új makró beépített makró nevét a Office Word 2007, az új makróműveletek helyére kerül a beépített makrót. Beépített makrók listájának megtekintéséhez kattintson a Word parancsok a makró helye listában.

  3. A makró helye listában kattintson a sablon vagy a dokumentumot, amelyben a makrót tárolni szeretné.

    Elérhetővé szeretné tenni a makrót minden dokumentumban, ügyeljen arra, kattintson a Normal.dotm sablonra.

  4. Kattintson a Létrehozás a Visual Basic Editor megnyitása gombra.

Miután megnyitotta a Visual Basic Editor alkalmazást, érdemes további információt a Visual Basic for Applications használata. További információ a Súgó menüben kattintson a Microsoft Visual Basic súgója , vagy nyomja le az F1 billentyűt.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×