Makró futtatása

A makrók többféleképpen is elindíthatók a Microsoft Excelben. A makrók a feladatok automatizálására használható műveletek vagy műveletsorok. A makrók rögzítése Visual Basic for Applications programnyelven történik. Makró futtatásához kattintson a menüszalag Fejlesztőeszközök lapjának Makrók parancsára. A makróhoz rendelt futtatási módtól függően a makró egy billentyűparancsval, a gyorselérési eszköztár vagy a menüszalagon egy egyéni csoport egyik gombjára kattintva, illetve egy objektumra, képre vagy vezérlőelemre kattintva is elindítható. A makrók a munkafüzetek megnyitásakor automatikusan is futtathatók.

Teendők a makrófuttatás előtt

Mielőtt megkezdené a makrókkal a munkát, engedélyezze a Fejlesztőeszközök lapot.

  • Windows esetén válassza a Fájl > Beállítások > Menüszalag testreszabása lehetőséget.

  • Mac esetén válassza az Excel > Beállítások > Menüszalag és eszköztár lehetőséget.

  • Ezután a Menüszalag testreszabása szakasz Fő lapok csoportjában jelölje be a Fejlesztőeszközök jelölőnégyzetet, és kattintson az OK gombra.

  1. Nyissa meg a makrót tartalmazó munkafüzetet.

  2. Kattintson Fejlesztőeszközök lap Kód csoportjában a Makrók gombra.

  3. A Makrónév listában kattintson a futtatni kívánt makróra, és kattintson a Futtatás gombra.

  4. Más lehetőségek is elérhetők:

    • Egyebek – Felvehet egy billentyűparancsot vagy egy makróleírást.

    • Lépésenként – Ezzel megnyithatja a Visual Basic Editort a makró első sorához. Az F8 billentyűvel soronként lépegethet a makrókódban.

    • Szerkesztés – Ezzel megnyithatja a Visual Basic Editort, és elvégezheti a makrókódon a szükséges szerkesztéseket. Miután elvégezte a kívánt módosításokat, az F5 billentyűvel futtathatja a makrót a szerkesztőből.

Rögzítésekor felvehet a makróra egy billentyűparancsot, illetve meglévő makróhoz is hozzáadhat egyet:

  1. Kattintson a Fejlesztőeszközök lap Kód csoportjában a Makrók gombra.

  2. A Makrónév listában kattintson a billentyűparancshoz rendelni kívánt makróra.

  3. Kattintson a Beállítások gombra.

    Megjelenik a Makróbeállítások párbeszédpanel.

  4. A Billentyűparancs mezőbe írja be a billentyűparanccsal használni kívánt kis- vagy nagybetűt.

    Megjegyzések: 

    • Windows esetén a billentyűparancs formátuma kisbetű használatakor a következő: Ctrl+betű. Nagybetű használatakor pedig a következő: Ctrl+Shift+Betű.

    • Mac esetén a billentyűparancs formátuma kisbetű esetén Option+Command+betű, de a Ctrl+betű billentyűparancs is működik. Nagybetű esetén a billentyűparancs formátuma Ctrl+Shift+Betű.

    • Legyen körültekintő a billentyűparancsok hozzárendelésekor, mert azok felülbírálják az Excel esetleges velük megegyező alapértelmezett billentyűparancsait, ha a makrót tartalmazó munkafüzet meg van nyitva. Ha például a Ctrl+z billentyűparancshoz rendel egy makrót, a billentyűparanccsal nem fogja tudni többé visszavonni a műveleteket. Emiatt általában érdemes inkább a Ctrl+Shift+Nagybetű (például Ctrl+Shift+Z) billentyűparancsot használni, amivel megegyező billentyűparancs nincs használatban az Excelben.

    Az Excelben már hozzárendelt, Ctrl billentyűvel használható billentyűparancsok listáját megtalálja Az Excelben használt billentyűparancsok és funkcióbillentyűk című témakörben.

  5. A Leírás mezőben adjon rövid leírást a makróról.

  6. Kattintson az OK gombra a módosítások mentéséhez, majd a Mégse gombra a Makró párbeszédpanel bezárásához.

Ha a makrót a gyorselérési eszköztár egyik gombjával szeretné futtatni, először fel kell vennie a gombot az eszköztárra. Ennek módjáról a Makró hozzárendelése gombhoz című témakörben olvashat.

Létrehozhat egy olyan egyéni csoportot, amely új lapként jelenik meg a menüszalagon, majd a csoport egy gombjához makrót is rendelhet. Felvehet például egy „Saját makrók” elnevezésű egyéni csoportot a Fejlesztőeszközök lapra, majd az új csoporthoz hozzáadhat egy makrót (amely gombként jelenik meg). Ennek módjáról a Makró hozzárendelése gombhoz című témakörben olvashat.

Makró indítása grafikus objektum interaktív területéről

A képeken kijelölhet egy interaktív területet, amelyre kattintva futtatható a makró.

  1. A munkalapon szúrjon be egy grafikus objektumot, például egy képet, vagy rajzoljon egy alakzatot. Rajzolhat például egy Lekerekített négyszög alakzatot, majd formázással gomb kinézetet adhat neki.

    A grafikus objektumok beszúrásával kapcsolatban további információt az Alakzatok hozzáadása, módosítása és törlése című témakörben talál.

  2. Kattintson a jobb gombbal a létrehozott interaktív területre, majd válassza a helyi menü Makró-hozzárendelés parancsát.

  3. Hajtsa végre a megfelelő műveletet:

    • Ha egy meglévő makrót szeretne a gombhoz vagy grafikus objektumhoz rendelni, kattintson duplán a makróra, vagy írja be a nevét a Makrónév mezőbe.

    • A kijelölt grafikus objektumhoz rendelni kívánt új makró rögzítéséhez kattintson a Rögzítés gombra, írja be a makró nevét a Makró rögzítése párbeszédpanelen, majd kattintson az OK gombra a rögzítés megkezdéséhez. A makró rögzítésének befejezésekor kattintson a Rögzítés vége Gombkép gombra a Fejlesztőeszközök lap Kód csoportjában.

      Tipp :  Használhatja az állapotsor bal oldalán található Rögzítés vége Gombkép gombot is.

    • Meglévő makró szerkesztéséhez kattintson a makró nevére a Makrónév mezőben, majd kattintson a Szerkesztés gombra.

  4. Kattintson az OK gombra.

A Fejlesztőeszközök lapon kattintson a Visual Basic elemre a Visual Basic Editor (VBE) elindításához. A projektböngésző ablakában tallózással keresse meg, majd nyissa meg a futtatni kívánt makrót tartalmazó modult. Az adott modulban szereplő összes makró listája megtekinthető a jobb oldali panelen. Jelölje ki a futtatni kívánt makrót: ehhez helyezze a kurzort a makró egy tetszőleges pontjára, és nyomja le az F5 billentyűt, vagy válassza a menüben a Futtatás > Makró futtatása lehetőséget.

Hozzon létre egy Workbook_Open eseményt.

Az alábbi példa az Open eseményt használja egy makrónak a munkafüzet megnyitásakor történő futtatására.

  1. Nyissa meg azt a munkafüzetet, amelyhez a makrót szeretné hozzáadni, vagy hozzon létre egy új munkafüzetet.

  2. A Fejlesztőeszközök lap Kód csoportjában kattintson a Visual Basic gombra.

  3. A projektböngésző ablakában kattintson a jobb gombbal a ThisWorkbook objektumra, és kattintson a View Code (Kód megtekintése) parancsra.

    Tipp : Ha a projektböngésző ablaka nem látható, válassza a View (Nézet) menü Project Explorer (Projektböngésző) parancsát.

  4. A Code (Kód) ablak feletti Object (Objektum) listában válassza a Workbook (Munkafüzet) értéket.

    Ezzel automatikusan létrejön egy üres eljárás az Open eseményhez, például:

    Private Sub Workbook_Open()

    End Sub

  5. Vegye fel a következő kódsorokat az eljárásba:

    Private Sub Workbook_Open()
    MsgBox Date
    Worksheets("Munka1").Range("A1").Value = Date
    End Sub

  6. Váltson vissza az Excelre, és mentse a munkafüzetet makróbarát (.xlsm) munkafüzetként.

  7. Zárja be, majd nyissa meg újra a munkafüzetet. A munkafüzet ismételt megnyitásakor az Excel futtatja a Workbook_Open eljárást, amely az aktuális dátumot jeleníti meg egy üzenetpanelen.

  8. Az üzenetpanel bezárásához kattintson az OK gombra.

    Megjegyzés : A Workbook_Open eljárás futtatásának hatására a Munka1 munkalap A1 cellája is tartalmazza a dátumot.

További segítségre van szüksége?

Bármikor kérhet segítséget az Excel technikai közösségétől, illetve támogatást az Answers-közösségtől, az Excel User Voice webhelyen pedig javaslatot tehet új funkciókra vagy fejlesztésekre.

Vissza a lap tetejére

Lásd még

Makró automatikus futtatása a munkafüzetek megnyitásakor 

Feladatok automatizálása a makrórögzítővel

Makró rögzítése adott munkafüzetek megnyitásához az Excel indításakor

Az összes makró létrehozása és mentése egyetlen munkafüzetben

Makró mentése

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×