MEZŐÉRTÉK függvény

A MEZŐÉRTÉK függvénnyel a csatolt típusú adatok mezőadatai olvashatók be (ilyen például a Részvények és a Földrajzi adattípus. Vannak egyszerűbb módszerek is az online adatforrásokra hivatkozó képletek megírására, így a MEZŐÉRTÉK függvényt csak akkor tanácsos használni, ha feltételes számításokat végez a csatolt típusú adatok alapján.

Megjegyzés: 2019. március 28.: az adattípusokat minden Windows-os Office 365-előfizető számára elérhetővé tették. Ha Ön Office 365-előfizető, győződjön meg arról, hogy az Office legújabb verzióját használja.

Technikai részletek

Szintaxis

=MEZŐÉRTÉK(érték; mezőnév)

A MEZŐÉRTÉK függvény szintaxisa az alábbi argumentumokat foglalja magában:

argumentumok

Leírás

érték

A függvény az értékargumentumban megadott csatolt adattípus minden egyező mezőjét visszaadja.

mezőnév

A csatolt adatok azon mezőjének vagy mezőinek a neve, amelyet vagy amelyeket ki szeretne nyerni a csatolt adattípusból.

Leírás

Példák

A következő egyszerű példában a =MEZŐÉRTÉK(A2,"Ár") függvény a JM Smucker Co. részvény típusú adatának Price (Ár) mezőjét nyeri ki.

Egy vállalat részvényárfolyamának lekérése a következő képlettel: =MEZŐÉRTÉK(A2,"Ár")

A következő példa a MEZŐÉRTÉK függvény egy tipikusabb használatát mutatja be. Itt a HAHIBA függvénnyel vizsgáljuk, hogy nincs-e hiba. Ha nincs cégnév az A2 cellában, a MEZŐÉRTÉK képlete hibát ad vissza. Ebben az esetben semmit sem szeretnénk megjeleníteni (""). Ha viszont van cégnév a cellában, akkor a Price (Ár) értéket szeretnénk megjeleníteni az A2 cellában szereplő adatból: =HAHIBA(MEZŐÉRTÉK($A2,B$1),"").

Egy vállalat részvényárfolyamának lekérése és a hibák figyelmen kívül hagyása a következő képlettel: =HAHIBA(MEZŐÉRTÉK($A2,B$1),"")

Figyelje meg, hogy a MEZŐÉRTÉK függvénnyel munkalapcellákra is hivatkozhat a mezőnév argumentumban, így a fenti képlet a B1 mezőben keresi a Price (Ár) értéket, nem kell manuálisan beírni a képletbe a „Price” szöveget. 

Megjegyzések

Ha egy nem létező adattípusmezőből próbál adatokat beolvasni, akkor a MEZŐÉRTÉK függvény a #MEZŐ! hibátadja eredményül. Előfordulhat például, hogy az „Árak” értéket írja be, miközben az adatmező neve valójában „Ár”. Gondosan ellenőrizze a képletet, nehogy véletlenül nem létező mezőnevet írjon be. Ha meg szeretné jeleníteni egy rekordhoz a mezőnevek listáját, jelölje ki a rekord celláját, és nyomja le az Alt+Shift+F10 billentyűkombinációt.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Részvény és földrajzi típusú adatok

Online adatforrások mezőire hivatkozó képletek írása

#MEZŐ! hiba

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×