Másik programnyelv megadása űrlapsablonban

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Az űrlapsablonok csak egy nyelven írt parancsfájlokat és kezelt kódot tartalmazhatnak. Ha másik programnyelvet szeretne megadni egy adott űrlapsablonban, távolítsa el az eredeti parancsfájlt vagy kezelt kódot, adja meg az új nyelvet, írja át az eredeti parancsfájlt vagy kezelt kódot az új programnyelvben, majd vegye fel az új parancsfájlt vagy kezelt kódot az űrlapsablonra.

Megjegyzés : Az InfoPath nem tudja átalakítani a már meglévő parancsfájlt vagy kezelt kódot egyik programnyelvről a másikra.

Tartalom

Áttekintés

Másik programnyelv megadása űrlapsablonban

Áttekintés

Ha parancsfájl vagy kezelt kód használatával kell üzleti logikát adnia az űrlapsablonhoz (például összetett számítást kell elvégezni a felhasználók által az űrlapsablonon alapuló űrlapokra beírt értékek használatával), az üzleti logika több programnyelv valamelyikével is hozzáadható (akár C#, akár Microsoft Visual Basic). Miután hozzáadta az űrlapsablonhoz a parancsfájlt vagy a kezelt kódot, a későbbi változtatásokat vagy a sablonra felveendő új parancsfájlokat és kezelt kódot ugyanazon a programnyelven kell megírni.

Miközben az űrlapsablon egyre inkább megfelel az üzleti követelményeknek, szükség lehet másik programnyelv megadására az űrlapsablonban – ilyen helyzetek lehetnek például a következők:

  • A vállalat új házirendet vezet be, amelynek értelmében a Microsoft Windows-alapú összes program és a saját fejlesztésű programbővítmények csak C# nyelvűek lehetnek, a vállalat már meglévő űrlapsablonjai azonban Visual Basic nyelvűek. Az új házirend teljesítése végett valamennyi űrlapsablont át kell alakítani úgy, hogy a C# programnyelvet használják.

  • A Microsoft Office InfoPath 2003 alkalmazással készített, JScript nyelvű parancsfájlt tartalmazó űrlapsablont tett közzé. Mivel a Microsoft Office InfoPath 2007 lehetővé teszi a felhasználóknak, hogy az űrlapsablonra épülő űrlapokat webböngészőben töltsék ki, át kell alakítani az űrlapsablont böngészőbarát űrlapsablonná, majd közzé kell tenni azt egy InfoPath Forms Services szoftvert futtató kiszolgálón. Az InfoPath Forms Services azonban csak kezelt kódot tartalmazó szerelvényeket magában foglaló űrlapsablonokat tud megjeleníteni, így a parancsfájlt is tároló űrlapsablonok nem tehetők közzé InfoPath Forms Services alkalmazást futtató kiszolgálón. A megoldás érdekében kezelt kóddal rendelkező szerelvénnyé kell alakítani a parancsfájlt, hogy az űrlapsablont közzé lehessen tenni egy InfoPath Forms Services alkalmazást futtató kiszolgálón.

  • Több olyan űrlapsablon üzemeltetéséért felelős, amelynek más a tervezője – ezek az űrlapsablonok JScript nyelven írt parancsfájlokat tartalmaznak. Noha az ilyen nyelvű parancsfájlok olvashatók és írhatók, jártasabbnak érzi magát Microsoft Visual Basic Scripting Edition (VBScript) nyelvű parancsfájlok írásában. Mivel ön lesz a felelős az említett űrlapsablonok üzemeltetéséért, sokkal hatékonyabb lenne, ha a parancsfájl VBScript nyelvű lenne: ennek érdekében úgy dönt, hogy felülírja a JScript nyelvű már meglévő parancsfájlokat VBScript nyelvűekkel.

Amennyiben egy már létező űrlapsablonban szeretne másik programnyelvet megadni, először el kell távolítania a sablonból a létező parancsfájlt vagy kezelt kódot, és meg kell adnia az új programnyelvet. Ezt követően átírható a parancsfájl vagy a kezelt kód az új nyelvben a Microsoft Script Editor vagy a Microsoft Visual Studio Tools for Applications használatával, és felvehető az új parancsfájl az űrlapsablonba.

Vissza a lap tetejére

Másik programnyelv megadása űrlapsablonban

Mielőtt másik programnyelvet ad meg az űrlapsablonhoz, célszerű menteni az eredeti forráskód egy példányát szövegszerkesztőben (például a Microsoft Jegyzettömb alkalmazásban) arra az esetre, ha hivatkozni kellene rá vagy szükség lenne az eredeti kódra.

Az eredeti forráskód mentése

  1. Nyissa meg az űrlapsablont tervező módban.

  2. Mutasson az Eszközök menü Programozás pontjára, és hajtsa végre az alábbi műveletek valamelyikét:

    • Ha az űrlapsablon parancsfájlt tartalmaz, kattintson a Microsoft Script Editor parancsra.

    • Kezelt kódot tartalmazó űrlapsablon esetén válassza a Microsoft Visual Studio Tools for Applications parancsot.

  3. Kattintson a Microsoft Script Editor vagy a Microsoft Visual Studio Tools for Applications Edit (Szerkesztés) menüjének Select All (Az összes kijelölése) parancsára.

  4. Az Edit menüben kattintson a Copy (Másolás) parancsra.

  5. Illessze be a vágólapra másolt kódot egy szövegszerkesztőbe, például a Jegyzettömb programba.

  6. Mentse a fájlt a szövegszerkesztőben.

Másik programnyelv megadása űrlapsablonban

  1. Kattintson az Eszközök menü Űrlapbeállítások parancsára.

  2. Kattintson az Űrlapbeállítások párbeszédpanel Kategória listájának Programozás listaelemére.

  3. Kattintson a Programozási nyelv csoport Kód eltávolítása gombjára.

  4. A kód űrlapsablonból történő eltávolításának megerősítését kérő párbeszédpanelen kattintson az Igen gombra.

  5. Az Űrlapsablonkód nyelve listában válassza az űrlapsablonban használandó nyelvet.

    Tipp : Ha a Visual Basic vagy a C# nyelvet választja, írja be a Projekt helye a Visual Basic és C# kód számára mezőbe a projektfájlok mentési helyét.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×