Másik munkafüzetben található cellára vagy tartományra mutató külső hivatkozás létrehozása

Külső hivatkozások létrehozásával hivatkozhat egy másik munkafüzetben található cellák tartalmára. A külső hivatkozás egy másik Excel-munkafüzet munkalapjának cellájára vagy tartományára, illetve egy másik munkafüzet definiált nevére mutató hivatkozás. Hivatkozhat adott cellatartományra, a cellatartomány definiált nevére, vagy megadhat nevet a külső hivatkozáshoz.

Kapcsolódó műveletek

További tudnivalók a külső hivatkozásokról

Különböző munkafüzetben lévő cellák közötti külső hivatkozás létrehozása

Másik munkafüzetben található definiált névre mutató külső hivatkozás létrehozása

Másik munkafüzetben található cellára mutató külső hivatkozást tartalmazó név definiálása

További tudnivalók a külső hivatkozásokról

Bár a külső hivatkozások hasonlítanak a cellahivatkozásokra, van néhány alapvető különbség. Külső hivatkozást akkor célszerű használni, ha sok adattal vagy több munkafüzetben elhelyezett összetett képletekkel dolgozik. A külső hivatkozásokat máshogy kell létrehozni, továbbá máshogy jelennek meg a cellában és a szerkesztőlécen.

Hol használhatók hatékonyan a külső hivatkozások

A külső hivatkozások különösen akkor hasznosak, amikor nem célszerű ugyanabban a munkafüzetben együtt tartani nagy munkalapokat.

  • Adatok egyesítése több munkafüzetből:      Összekapcsolhatjuk több felhasználó vagy osztály munkafüzeteit, majd a megfelelő adatokat egy összesítő munkafüzetben egyesíthetjük. Így a forrásmunkafüzetek megváltoztatásakor nem kell manuálisan megváltoztatnunk az összesítő munkafüzetet.

  • Adatok kigyűjtése külön munkafüzetbe:     Az összes adatot beírhatja egy vagy több forrásmunkafüzetbe, majd létrehozhat egy olyan jelentés-munkafüzetet, amely csak az odaillő adatok külső hivatkozásait tartalmazza.

  • Nagy, összetett modellek alakítása:      Bonyolult modellt kölcsönösen függő munkafüzetekre bontva úgy dolgozhatunk a modellen, hogy nem kell az összes összefüggő lapot megnyitni. A kisebb munkafüzeteket egyszerűbb módosítani, nem követelnek olyan sok memóriát, és megnyitásuk, mentésük, valamint kiszámolásuk is gyorsabb.

Külső hivatkozás létrehozásának lehetséges módjai

Ha cellahivatkozással hoz létre külső hivatkozást, képleteket is használhat. A cellahivatkozások különféle típusai közötti váltással azt is kézben tarthatja, hogy mely cellák vannak csatolva a külső hivatkozás áthelyezése esetén. Ha például relatív hivatkozást használ, és áthelyezi a külső hivatkozást, a hivatkozó cella vagy cellák módosulnak a hivatkozás munkalapbeli helyzetének megfelelően.

Ha különböző munkafüzetek közötti külső hivatkozást hoz létre, név segítségével hivatkozzon a csatolandó cellákra. Korábban megadott nevet is használhat, de a külső hivatkozás során is létrehozhat nevet. Ha névvel hivatkozik, könnyebben vissza tudja idézni a csatolt cellák tartalmát. A nevet használó külső hivatkozások nem módosulnak, ha áthelyezi őket, mivel egy név adott cellára vagy cellatartományra hivatkozik. Ha azt szeretné, hogy áthelyezése esetén módosuljon a nevet használó külső hivatkozás, módosíthatja a külső hivatkozásban használt nevet, vagy azt a cellát, amelyre a név hivatkozik.

Másik munkafüzetre mutató külső hivatkozás összetevői

A más munkafüzetekhez külső hivatkozást tartalmazó képletek kétfélék lehetnek, attól függően, hogy a képlet adatait tartalmazó munkafüzet megnyitott vagy bezárt.

Ha a forrásmunkafüzet nyitva van, a külső hivatkozás szögletes zárójelben ([ ]) tartalmazza a munkafüzet nevét, ezt követi a munkalapnév, felkiáltójel (!), valamint a képletet meghatározó cellák. A következő képlet például a Költségvetés.xls nevű munkafüzet C10:C25 celláit adja össze.

Külső hivatkozás

=SZUM([Költségvetés.xlsx]Éves!C10:C25)

Ha a forrás nincs megnyitva, a külső hivatkozás az egész elérési utat tartalmazza.

Külső hivatkozás

=SZUM('C:\Jelentések\[Költségvetés.xlsx]Éves'!C10:C25)

Megjegyzés: Ha a másik munkalap vagy munkafüzet neve betűkön kívül egyéb karaktereket is tartalmaz, a nevet (vagy az elérési utat) szimpla idézőjelek között kell megadni.

Azok a képletek, amelyek más munkafüzetben szereplő megadott névhez tartalmaznak csatolást, a munkafüzetre úgy hivatkoznak, hogy a munkafüzet nevét egy felkiáltójel (!), majd a név követi. A következő képlet például a Költségvetés.xls nevű munkafüzet Eladások nevű tartományának a celláiban szereplő értékeket adja össze.

Külső hivatkozás

=SZUM(Költségvetés.xlsx!Eladások)

Vissza a lap tetejére

Különböző munkafüzetben lévő cellák közötti külső hivatkozás létrehozása

  1. Nyissa meg azt a munkafüzetet, amelyikben a külső hivatkozás lesz (ez a célmunkafüzet), és azt a munkafüzetet is, amelyikben a csatolandó adatok vannak (ez a forrásmunkafüzet).

  2. Kattintson a forrásmunkafüzetben, a gyorselérési eszköztáron a Mentés Gombkép gombra.

  3. Jelölje ki azt a cellát vagy azokat a cellákat, amelyek a külső hivatkozást tartalmazni fogják.

  4. Írjon be egy egyenlőségjelet (=). Ha a külső hivatkozásban számításokat vagy képleteket szeretne elhelyezni, írja be a külső hivatkozást megelőző műveleti jel (operátor) vagy függvényt.

  5. Nyissa meg a forrásmunkafüzetet, majd jelölje ki a csatolandó cellákat tartalmazó munkalapot.

  6. Jelölje ki a csatolandó cellát vagy cellákat.

  7. Térjen vissza a célmunkafüzetre, és figyelje meg, hogy az Excel hozzáadja a hivatkozást a forrásmunkafüzethez és az előző lépésben kiválasztott cellákhoz.

  8. Azt is választhatja, hogy szerkeszti vagy módosítja a képletet a célmunkalapon.

  9. Nyomja le a CTRL+SHIFT+ENTER billentyűkombinációt.

Vissza a lap tetejére

Másik munkafüzetben található definiált névre mutató külső hivatkozás létrehozása

  1. Nyissa meg azt a munkafüzetet, amelyikben a külső hivatkozás lesz (ez a célmunkafüzet), és azt a munkafüzetet is, amelyikben a csatolandó adatok vannak (ez a forrásmunkafüzet).

  2. Kattintson a forrásmunkafüzetben, a gyorselérési eszköztáron a Mentés Gombkép gombra.

  3. Jelölje ki azt a cellát vagy azokat a cellákat, amelyek a külső hivatkozást tartalmazni fogják.

  4. Írjon be egy egyenlőségjelet (=). Ha a külső hivatkozásban számításokat vagy képleteket szeretne elhelyezni, írja be a külső hivatkozást megelőző operátort vagy függvényt.

  5. A Nézet lap Ablak csoportjában kattintson az Ablakváltás lehetőségre, válassza ki a forrásmunkafüzetet, majd jelölje ki a csatolandó cellákat tartalmazó munkalapot.

    A Nézet lap Ablak csoportja

  6. Nyomja meg az F3 billentyűt, és válassza ki a csatolandó nevet.

Vissza a lap tetejére

Másik munkafüzetben található cellára mutató külső hivatkozást tartalmazó név definiálása

  1. Nyissa meg a célmunkafüzetet és a forrásmunkafüzetet.

  2. Kattintson a célmunkafüzetben a Képletek lap Definiált nevek csoportjában a Név megadása gombra.

    Az Excel menüszalagja

  3. Írja be a tartománynak adni kívánt nevet az Új név párbeszédpanel Név mezőjébe.

  4. Törölje a Hivatkozás mező tartalmát, és tartsa a kurzort a mezőben.

    Ha a név képletet tartalmaz, írja be a képletet, és vigye oda a kurzort, ahol a külső hivatkozást el szeretné helyezni. Írja be például az =SZUM() képletet, és vigye a kurzort a zárójelek közé.

  5. A Nézet lap Ablak csoportjában kattintson az Ablakváltás lehetőségre, válassza ki a forrásmunkafüzetet, majd jelölje ki a csatolandó cellákat tartalmazó munkalapot.

    A Nézet lap Ablak csoportja

  6. Jelölje ki a csatolandó cellát vagy cellatartományt.

  7. Kattintson az Új név párbeszédpanel OK gombjára.

Vissza a lap tetejére

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×