Lista, legördülő lista vagy beviteli lista feltöltése SQL Server-adatbázis adataival

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Listát, legördülő listát vagy beviteli listát tölthet fel Microsoft SQL Server-adatbázis lekérdezési adatkapcsolat adataival.

Tartalom

– Áttekintés

Első lépések

Lépés: 1: Adja hozzá a lekérdezés adatkapcsolat

Lépés: 2: Állítsa be a vezérlő

Áttekintés

A lista, legördülő lista és beviteli lista azokat az elemeket tartalmazza, amelyekből a felhasználók választhatnak adott űrlapsablonon alapuló űrlap kitöltésekor. Konfigurálhatja ezeket a vezérlőket úgy, hogy mutassák a másodlagos adatkapcsolatot egy Microsoft SQL Server-adatbázishoz. A másodlagos adatkapcsolat olyan külső adatforrással való adatkapcsolat, amelyet azért adhat űrlapsablonhoz, hogy a felhasználók az ezen az űrlapsablonon alapuló űrlapok kitöltése közben adatokat kaphassanak vagy küldhessenek külső adatforráshoz, mint például webszolgáltatáshoz.

Másodlagos adatkapcsolat, hogy az űrlapsablonhoz, a Microsoft Office InfoPath lekérdezések adatok létrehoz egy másodlagos adatforrás adatmezők és a csoportok, amely megfelel módon az adatok hozzáadásakor a adatbázisban vannak tárolva. A lekérdezés adatkapcsolat adatok lekérése a webszolgáltatás, és a másodlagos adatforrás az űrlap adatokat tárolja. Alapértelmezés szerint a másodlagos adatforrás adatai elérhető csak, miközben a felhasználó a hálózathoz csatlakozik. Mentse a lekérdezés eredményét a felhasználók számítógépén, hogy az adatok hozzáféréssel rendelkeznek az űrlap kapcsolat nélkül hálózathoz másodlagos adatkapcsolat konfigurálása

Biztonsági megjegyzés : Ha másodlagos adatkapcsolatot használ bizalmas információ külső adatforrásból való beolvasására, célszerű letiltani ezt a funkciót, így a számítógép elvesztése vagy ellopása esetén megvédheti az adatokat a jogosulatlan hozzáféréstől. A funkció letiltásakor az adatok csak akkor lesznek elérhetők, ha a felhasználó a hálózathoz csatlakozik.

Mivel a másodlagos adatforrás adatszerkezetének meg kell egyeznie az adatbázis adattárolási módjával, nem módosíthatja a másodlagos adatforrás meglévő mezőit vagy csoportjait. Az adatkapcsolatokról és adatforrásokról további információt a Lásd még szakasz hivatkozásai révén kaphat.

Vissza a lap tetejére

Mielőtt elkezdené:

Mielőtt az SQL Server-adatbázis értékeivel feltölthetné az űrlapsablon egyik vezérlőjét, a következő információkra lesz szüksége az adatbázis rendszergazdájától:

  • Az ebben az űrlapsablonban használni kívánt adatbázist tartalmazó kiszolgáló neve.

  • Az ebben az űrlapsablonban használni kívánt adatbázis neve.

  • Az adatbázishoz szükséges hitelesítés. Az adatbázis használhat Microsoft Windows vagy SQL Server hitelesítést annak meghatározására, hogyan léphetnek be a felhasználók az adatbázisba.

  • Annak a táblának neve, amely tartalmazza az űrlaphoz küldeni kívánt adatokat. Ez az elsődleges tábla. Ha több táblát is szeretne használni az adatbázisban, akkor szüksége lesz a többi gyermektábla nevére is. Szüksége lesz még a gyermektábla azon mezőinek nevére, amelyek kapcsolódnak az elsődleges tábla mezőihez.

  • Biztonságosan tárolhatja-e a lekérdezés eredményét a felhasználók számítógépén hálózat nélküli használat esetén.

Vissza a lap tetejére

1. lépés: Lekérdezési adatkapcsolat hozzáadása

Ha nem egy meglévő lekérdezést származó adatok, amelyek az űrlapon, az alábbi lépésekkel másodlagos adatkapcsolat hozzáadása űrlapsablonhoz lekérdezések adatokat. Űrlapsablon már van egy másodlagos adatkapcsolat használható, ha ez a szakasz átugrása, és nyissa meg 2 lépés: a vezérlőelem beállításához.

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban válassza ki az Új kapcsolat létrehozása a következővel és az Adatok fogadása pontokat, majd kattintson a Tovább gombra.

  4. A varázsló következő lapján jelölje be az Adatbázis (csak Microsoft SQL Server vagy Microsoft Office Access) választógombot, majd kattintson a Tovább gombra.

  5. A varázsló következő lapján kattintson az Adatbázis kijelölése gombra.

  6. Az Adatforrás kijelölése párbeszédpanelen kattintson az Új forrás gombra.

  7. A varázsló következő lapján a Milyen típusú adatforráshoz kíván csatlakozni? listában kattintson a Microsoft SQL Server elemre, majd a Tovább parancsra.

  8. A Kiszolgálónév mezőben adja meg az SQL Server-adatbázist tartalmazó kiszolgáló nevét.

  9. Az Azonosító adatok csoportban tegye a következők valamelyikét:

    • Ha az adatbázis a Microsoft Windows hálózatban használt azonosító adatok alapján határozza meg, hogy ki léphet be, majd kattintson a Windows-hitelesítés használata elemre.

    • Ha az adatbázis a rendszergazdától kapott felhasználónév és jelszó alapján határozza meg, hogy ki léphet be, kattintson Az alábbi felhasználónév és jelszó használata elemre, majd adja meg felhasználónevét és jelszavát a Felhasználónév és Jelszó mezőkben.

  10. Kattintson a Tovább gombra.

  11. A Válassza ki a kívánt adatokat tartalmazó adatbázist listában kattintson a használni kívánt adatbázis nevére, kattintson a Csatlakozás egy adott táblához pontra, utána az elsődleges tábla nevére, majd a Tovább gombra.

  12. A varázsló következő lapján adjon nevet az adatkapcsolat adatait tároló fájlnak a Fájlnév mezőben, majd a beállítások mentéséhez kattintson a Befejezés gombra.

    Ha más táblák használatát is tervezi a lekérdezési adatkapcsolatban, azokat a varázsló ezen lapján adhatja hozzá.

    További táblák hozzáadása

    1. Kattintson a Tábla hozzáadása parancsra.

    2. A Tábla vagy lekérdezés hozzáadása párbeszédpanelen kattintson a gyermektábla nevére, majd a Tovább gombra. Az InfoPath a két tábla mezőneveinek párosításával megkísérli beállítani a kapcsolatokat. Ha a felkínált párosításokat nem szeretné használni, jelölje ki a nem kívánt kapcsolatot, és kattintson a Kapcsolat törlése gombra. Kapcsolat hozzáadásához kattintson a Kapcsolat hozzáadása gombra. A Kapcsolat hozzáadása párbeszédpanelen a megfelelő oszlopban jelölje ki az összefüggő mezőket, és kattintson az OK gombra.

    3. Kattintson a Befejezés gombra.

    4. További gyermektáblák hozzáadásához ismételje ezeket a lépéseket.

  13. Kattintson a Tovább gombra.

  14. Az adatok űrlapsablonban történő tárolásához jelölje be az Adatok másolatának tárolása az űrlapsablonban jelölőnégyzetet. Ha ez a jelölőnégyzet be van jelölve, a lekérdezés eredményei az űrlapsablonban tárolódnak. Mivel az adatok az űrlapsablonban tárolódnak, az adatok elérhetők a felhasználók által kitöltött űrlapokon, akkor is, ha a számítógépeik nincsenek hálózathoz csatlakoztatva.

    Biztonsági megjegyzés : Ezt a négyzetet bejelölve a lekérdezés eredményeit az űrlapsablonba menti a rendszer. Mivel az adatok az űrlapsablonban vannak, elérhetők a felhasználók által kitöltött űrlapokban is, még abban az esetben is, ha nem csatlakoznak a hálózathoz. Ha bizalmas adatokat olvas be ezzel az adatkapcsolattal, de védeni kívánja az adatokat a számítógép elvesztése vagy ellopása esetén, tiltsa le ezt a funkciót.

  15. Kattintson a Tovább gombra.

  16. A varázsló következő lapján adjon meg egy kifejező nevet a másodlagos adatkapcsolatnak. Ha azt szeretné, hogy az űrlap megnyitásakor automatikusan kapjon adatokat, jelölje be az Automatikus adatbeolvasás az űrlap megnyitásakor jelölőnégyzetet.

Vissza a lap tetejére

2. lépés: Vezérlő konfigurálása

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Kattintson kétszer a feltölteni kívánt lista, legördülő lista vagy beviteli lista vezérlőjére.

  3. Kattintson az Adatok fülre.

  4. A Listaelemek pontban kattintson az Adatok keresése külső adatforrásban elemre.

  5. Az Adatforrás listában válassza a használni kívánt adatforrást.

  6. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  7. A Mező vagy csoport kijelölése párbeszédpanelen adja meg, hogy milyen adatok jelenjenek meg a felhasználók számára, illetve milyen adatok legyenek elküldve a külső adatforráshoz a következő módok egyikén.

    Annak meghatározása, hogy a jelenik meg a felhasználói adatok ugyanazokat az adatokat a felhasználónak küldi.

    • Kattintson egy mezőre, majd az OK gombra.

    Annak meghatározása, hogy az adatokat, a felhasználó jelenik meg, hogy a felhasználó nyújtanak az adatok másik

    Megjegyzés : Ebben példában a felhasználó számára megjelenített adatok a csoport egyik mezőjéből valók, míg a felhasználó által a külső adatforráshoz küldött adatok ugyanezen csoport másik mezőjéből származnak.

    1. Kattintson egy csoportra, majd az OK gombra.

    2. Kattintson a Tartalomvezérlő tulajdonságai párbeszédpanelen Jelölje be az XPath Gombkép érték mező melletti.

    3. A Mező vagy csoport kijelölése párbeszédpanelen kattintson arra a mezőre, amelynek adatait a felhasználó elküldi majd a külső adatforráshoz, utána kattintson az OK gombra.

    4. Kattintson a Tartalomvezérlő tulajdonságai párbeszédpanelen Jelölje be az XPath Gombkép mellett a megjelenítendő név mezőbe.

    5. A Mező vagy csoport kijelölése párbeszédpanelen kattintson arra a mezőre, amelynek adatai megjelennek majd a vezérlőben, utána kattintson az OK gombra.

  8. Ha a Kijelzett név mező hasonló kijelzett nevű értékeket tartalmaz és csak az egyedi neveket szeretné megjeleníteni, jelölje be a Csak egyedi megjelenítendő nevű bejegyzések megjelenítése jelölőnégyzetet.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×