KOCKA.ÉRTÉK függvény

Ez a cikk a Microsoft Excel KOCKA.ÉRTÉK függvényének képletszintaxisát és használatát ismerteti.

Leírás

A kockából összesített értéket adja eredményül.

Szintaxis

KOCKA.ÉRTÉK(kapcsolat; [tagkifejezés1]; [tagkifejezés2]; …)

A KOCKA.ÉRTÉK függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • Kapcsolat:    Megadása kötelező. A kocka kapcsolatának nevét tartalmazó karakterlánc.

  • Tagkifejezés:    Megadása nem kötelező. A kocka egy tagját vagy rekordját azonosító, többdimenziós kifejezést (MDX) tartalmazó karakterlánc. A Tagkifejezés argumentum egy KOCKA.HALM függvény segítségével létrehozott halmaz is lehet. A függvény segítségével egy kockát szeletekre szabdalhat, és azok összesített értékét kaphatja eredményül. Ha a Tagkifejezés argumentum nem tartalmaz mérőszámot, a függvény a kockára vonatkozó alapértelmezett mérőszámot alkalmazza.

Megjegyzés

  • Számoláskor a KOCKA.ÉRTÉK függvény átmenetileg, az adatok beolvasásáig, a "#VÁRAKOZÁS_ADATRA…" üzenetet jeleníti meg.

  • Ha a Tagkifejezés argumentum tartalma egy cellahivatkozás, és a cellahivatkozás KOCKA függvényt tartalmaz, a Tagkifejezés argumentum a hivatkozott cellában található elem kiértékeléséhez a többdimenziós kifejezést (MDX) használja a hivatkozott cellában megjelenő érték helyett.

  • Ha a kapcsolat neve nem egy, a munkafüzetben tárolt érvényes munkafüzet-kapcsolat, a KOCKA.ÉRTÉK visszatérési értéke a #NÉV? hibaüzenet lesz. Ha az OLAP-kiszolgáló nem fut, nem érhető el, vagy hibaüzenetet ad vissza, a KOCKA.ÉRTÉK szintén a #NÉV? hibaüzenetet adja eredményül.

  • Ha egy sor bármelyik eleme érvénytelen, a KOCKA.ÉRTÉK az #ÉRTÉK! hibaüzenetet adja eredményül.

  • A KOCKA.ÉRTÉK az alábbi esetekben a #HIÁNYZIK hibaüzenetet adja eredményül:

    • Helytelen a Tagkifejezés argumentum szintaxisa.

    • A kockában nem létezik a Tagkifejezés argumentumban megadott tag.

    • A rekord érvénytelen, mert a megadott értékeknél nincs metszet. (Ez akkor fordulhat elő, ha ugyanabból a hierarchiából több elem szerepel.)

    • A halmazban legalább egy olyan tag szerepel, amely a többi tagtól eltérő dimenzióhoz tartozik.

    • Előfordulhat, hogy a KOCKA.ÉRTÉK függvény a #HIÁNYZIK hibaértéket adja eredményül, ha egy kimutatás munkamenet-alapú objektumára, például számított tagra vagy névvel ellátott halmazra hivatkozik egy kapcsolat megosztása alkalmával, és a kimutatást törölte vagy képletekké alakította. (Ehhez kattintson a Beállítások lap Eszközök csoportjában az OLAP-eszközök gombra, majd a Konvertálás képletekké parancsra.)

Probléma: A null értékek nulla hosszúságú karakterláncokká alakultak

Ha a az Excelben nincs adat egy cellában, mert soha nem módosította vagy törölte a tartalmát, a cella üres értéket tartalmaz. Az üres értéket számos adatbázisrendszerben null értéknek hívják. Az üres vagy null érték azt jelenti, hogy „Nincs érték”. A képletek ugyanakkor nem adhatnak eredményül üres karakterláncot vagy null értéket, hanem csak a következő háromféle érték egyikét: számértéket, szövegértéket, amely lehet nulla hosszúságú karakterlánc is, vagy hibaértéket, például #SZÁM! vagy #ÉRTÉK!.

Ha egy képlet egy OLAP-adatbázishoz kapcsolódó KOCKA.ÉRTÉK függvényt tartalmaz, és az ebből az adatbázisból történő lekérdezés eredménye null érték, az Excel ezt egy nulla hosszúságú karakterlánccá alakítja akkor is, ha a képlet eredménye egyébként számérték lenne. Ez eredményezheti azt, hogy egy cellatartomány számértékeket és nulla hosszúságú karakterláncokat is tartalmaz, és ez befolyásolhatja azokat a képleteket, amelyek hivatkoznak a cellatartományra. Ha például az A1 és az A3 cella számot tartalmaz, az A2 cella pedig egy nulla hosszúságú karakterláncot eredményül adó KOCKA.ÉRTÉK függvényt tartalmazó képletet, az alábbi képlet az #ÉRTÉK! hibaértéket adja vissza.

=A1+A2+A3

Ennek megakadályozása végett rákereshet a nulla hosszúságú karakterláncokra a SZÖVEG.E függvény segítségével, a HA függvénnyel pedig lecserélheti őket egy 0 (nulla) értékre az alábbi példa szerint:

=HA(SZÖVEG.E(A1),0,A1)+HA(SZÖVEG.E(A2),0,A2)+HA(SZÖVEG.E(A3),0,A3)

A másik lehetőség, hogy beágyazza a KOCKA.ÉRTÉK függvényt egy olyan HA feltételbe, amely 0 értéket ad eredményül, ha a KOCKA.ÉRTÉK függvény eredménye nulla hosszúságú karakterlánc, az alábbi példában látható módon:

=HA(KOCKA.ÉRTÉK("Bevétel","[Mérőszám].[Nyereség]","[Időszak].[2004]","[Minden termék].[Italok]")="", 0, KOCKA.ÉRTÉK("Bevétel","[Mérőszám].[Nyereség]","[Időszak].[2004]","[Minden termék].[Italok]"))

A SZUM függvény esetében nincs szükség a nulla hosszúságú karakterláncok kikeresésére, mivel ez a függvény automatikusan figyelmen kívül hagyja a nulla hosszúságú karakterláncokat a visszatérési érték kiszámításakor.

Példák

=KOCKA.ÉRTÉK("Bevétel","[Mérőszám].[Nyereség]","[Időszak].[2004]","[Minden termék].[Italok]")

=KOCKA.ÉRTÉK($A$1,"[Mérőszám].[Nyereség]",D$12,$A23)

=KOCKA.ÉRTÉK("Bevétel",$B$7,D$12,$A23)

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×