Hibás képletek kiküszöbölése

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A nem várt eredményt vagy hibát adó képletek nagyon bosszantóak tudnak lenni, különösen akkor, ha nem tudja, mitévő legyen.

Számos dolog okozhat hibát. Lehet például, hogy rosszul írta be a zárójeleket, elgépelt valamit, vagy nem létező tartományok adataira mutatnak bizonyos hivatkozások. A következőkben ismertetett ajánlott eljárásokkal megelőzhetők vagy megoldhatók a képletek írásakor vagy javításakor gyakran elkövetett hibák.

Ajánlott eljárás

Kiküszöbölhető hiba

Egyenlőségjel (=) használata a függvények elején

Ha a beírt képlet nem egyenlőségjellel kezdődik, az Excel nem dátumként értelmezi, ezért nem is számítja ki. Ezt a hibát könnyű elkövetni, így sajnos elég gyakori.

Amikor például csak a SZUM(A1:A10) szöveget írja be egyenlőségjel nélkül, az Excel Online nem a képlet eredményét fogja megjeleníteni, hanem a SZUM(A1:A10) szöveges karakterláncot. Ha a 11/2 értéket írja be, a program a 02.nov vagy a 2014.11.02 dátumot jeleníti meg ahelyett, hogy elosztaná a tizenegyet kettővel.

Ennek elkerüléséhez a képleteket mindig egyenlőségjellel kell kezdeni, például így: =SZUM(A1:A10) és =11/2.

A nyitó és záró zárójelek párosítása

Győződjön meg arról, hogy minden zárójelnek megvan a párja. Függvényt is tartalmazó képletekben minden nyitó zárójelhez tartoznia kell egy záró zárójelnek, mert különben a függvény nem működik megfelelően.

A =HA(B5<0);"Nem érvényes";B5*1,05) képlet például azért nem fog működni, mert két záró zárójelet, viszont csak egy nyitó zárójelet tartalmaz.

A helyes képlet a következő: =HA(B5<0;"Nem érvényes";B5*1,05).

Az összes szükséges argumentum megadása

A legtöbb függvényhez kötelező argumentumokat is meg kell adni, mert nélkülük a függvény működésképtelen. Argumentumok nélkül csak néhány függvény (például a PI és a MA függvény) működik. A függvényt megelőző egyenlőségjel beírásakor megjelenő képletszintaxis ellenőrzésével győződjön meg arról, hogy beírta az összes szükséges argumentumot, valamint hogy nem többet és nem kevesebbet írt be belőlük.

A NAGYBETŰS függvény például csak egy szöveges karakterláncot vagy egy cellahivatkozást fogad el argumentumként az =NAGYBETŰS("szia") vagy az =NAGYBETŰS(C2) alakban.

Ezenkívül bizonyos függvényekhez (például a SZUM függvényhez) kizárólag numerikus argumentumok használhatók, míg másokhoz (például a CSERE függvényhez) legalább egy argumentum esetén szöveges értéket kell megadni. A helytelen adattípus használatakor egyes függvények esetleg nem a várt eredményt adják, vagy az #ÉRTÉK! hibaérték jelenik meg.

Formázatlan számok használata képletekben

Dollárjellel ($) vagy ezreselválasztóval (.) formázott számokat ne írjon a képletekbe, mert az előbbiek abszolút hivatkozásokat, az utóbbiak pedig argumentumelválasztókat jelölnek. Az Excel kihagyja a formázott számokat a képletszámításból. Emiatt például a $1.000 számalak helyett az 1000 alakot írja be a képletbe.

Ha formázott számokat használ az argumentumokban, nem a várt eredmény fogja kapni, de a #SZÁM! hiba is megjelenhet. Amennyiben például az =ABS(-2.134) képlettel próbálja kiszámítani -2134 abszolút értékét, az Excel Online a #SZÁM! hibát adja vissza, mert az ABS függvényhez csak egy argumentum használható.

A képlet eredményét ezreselválasztóval vagy pénznemszimbólummal is formázhatja számformátum megadásával, de csak azt követően, hogy beírta a képletet formázatlan számok használatával.

A megfelelő cellaadattípus használata

Ha a cella adatai nem használhatók fel számításhoz, a képlet esetleg nem a várt eredményt fogja adni.

Egy szövegként formázott cellába írt egyszerű képlet (=2+3) esetén például az Excel Online nem tud számítást végezni a beírt adatokkal. A cellában megjelenő érték =2+3 lesz.

A hiba kijavításához a következő lépésekkel módosítsa a cella adattípusát Szöveg típusról Általános típusra:

  1. Jelölje ki a cellát.

  2. Kattintson a Kezdőlap lap Számformátum nyilára, és válassza az Általános elemet.

  3. Az F2 billentyűvel váltson cellaszerkesztési módba, majd az Enter billentyűt megnyomva fogadja el a képletet.

Lehetséges, hogy a Szám adattípusú cellákba írt dátumok numerikus dátumértékként fognak megjelenni a várt dátumformátum helyett. A szám dátumként való megjelenítéséhez válassza a Dátum formátumot a Számformátum gyűjteményben.

Számok szorzása a csillag (*) karakterrel

Bizonyára előfordult már, hogy az x karakterrel próbált szorzást jelölni egy képletben, ám ehhez a csillag karaktert kell használnia.

Ha egy képletben az x karakter szerepel, az Excel Online nem tudja kiszámítani az eredményt. A cellában a képlet fog megjelenni, és piros pontvonalas szegély jelzi a cella körül, hogy a képlet hibás.

Képletbeli szöveg angol idézőjelek közé helyezése

Ha szöveget tartalmazó képletet ír, a szöveget angol idézőjelekkel (") kell határolni.

A ="Ma " & SZÖVEG(MA();"hhhh nn., nnnn") & " van" képlet például kombinálja a "Ma " szövegrészt a SZÖVEG és a MA függvény eredményével, így a cellában a Ma május 30., péntek van szöveg fog megjelenni.

A képletben a „Ma” szó után egy szóköz áll. Ez azért fontos, hogy a Ma szó és a május 30., szombat van szövegrész közé a program beszúrja a szükséges szóközt. Ha nem zárja idézőjelek közé a szöveget, a képlet esetleg a #NÉV? hibát jeleníti meg.

Egy képletbe legfeljebb 64 függvény ágyazható

Egy képleten belül legfeljebb 64 szintig ágyazhatók egymásba függvények.

A =HA(GYÖK(PI())<2;"Kettőnél kisebb!";"Kettőnél nagyobb!") képlet például három függvényt tartalmaz: a PI függvény a GYÖK függvénybe van ágyazva, amely pedig a HA függvénybe ágyazódik.

A nullával való osztás elkerülése

Ha egy cellát olyan cellával oszt el, amely nullát tartalmaz vagy nem tartalmaz értéket, a #ZÉRÓOSZTÓ! hiba jelenhet meg.

Az osztási művelet HAHIBA függvénybe ágyazásával elkerülhető ez a hiba. Írja be például a következő két képletet egy munkalap celláiba:

=HAHIBA(3/0,0)

=HAHIBA(3/7,0)

Az első képlet eredménye nulla lesz, mert a HAHIBA függvény felismeri, hogy a nullával való osztás hibát eredményez. A második képlet a 3/7 értéket adja vissza, mivel nincs hiba, hiszen nem történik osztás nullával.

A képletírás megkönnyítése végett érdemes tanulmányozni a képletekkel kapcsolatos tippeket és trükköket is.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×