HAHIBA függvény

Ez a cikk a Microsoft Excel HAHIBA függvényének képletszintaxisát és használatát ismerteti.

Leírás

Megadott értéket ad eredményül, ha egy képlet hibát ad; ellenkező esetben a képlet eredményét kapja. A HAHIBA függvény segítségével megtalálhatja és kezelheti a képlet lévő hibákat.

Szintaxis

HAHIBA(érték; érték_ha_hiba)

A HAHIBA függvény szintaxisa az alábbi argumentumokat foglalja magában:

  • Érték:    Megadása kötelező. Argumentum, amelyet a függvény ellenőriz, hogy hibát eredményez-e.

  • Érték_ha_hiba:    Megadása kötelező. A függvény ezt az értéket adja eredményül, ha a képlet hibát eredményez. A függvény az alábbi hibatípusok esetén alkalmazza ezt az értéket: #HIÁNYZIK, #ÉRTÉK!, #HIV!, #ZÉRÓOSZTÓ!, #SZÁM!, #NÉV? és #NULLA!.

Megjegyzések

  • Ha az Érték vagy az Érték_ha_hiba argumentum üres cella, a HAHIBA függvény ezt üres karaktersorozatként értelmezi ("").

  • Ha az Érték argumentum egy tömbképlet, a HAHIBA függvény eredménye az érték argumentumban megadott tartomány minden egyes cellájának eredményéből képzett tömb lesz. Ezt szemlélteti az alább található második példa.

Példák

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Kvóta

Eladott egység

210

35

55

0

23

Képlet

Leírás

Eredmény

=HAHIBA(A2/B2;"Számítási hiba")

Hibát keres a képlet első argumentumában (210 osztva 35-tel); nem talál hibát, ezért a képlet eredményét adja vissza.

6

=HAHIBA(A3/B3;"Számítási hiba")

Hibát keres a képlet első argumentumában (55 osztva 0-val); 0-val való osztási hibát talál, ezért az érték_ha_hiba argumentum értékét adja eredményül.

Számítási hiba

=HAHIBA(A4/B4;"Számítási hiba")

Hibát keres a képlet első argumentumában ("" osztva 23-mal); nem talál hibát, ezért a képlet eredményét adja vissza.

0

2. példa

Kvóta

Eladott egység

Arány

210

35

6

55

0

Számítási hiba

23

0

Képlet

Leírás

Eredmény

=C2

Hibát keres a képlet első argumentumaként megadott tömbképlet első elemében (A2/B2, vagyis 210 osztva 35-tel); nem talál hibát, ezért a képlet eredményét adja vissza.

6

=C3

Hibát keres a képlet első argumentumaként megadott tömbképlet második elemében (A3/B3, vagyis 55 osztva 0-val); 0-val való osztási hibát talál, ezért az érték_ha_hiba argumentum értékét adja eredményül.

Számítási hiba

=C4

Hibát keres a képlet első argumentumaként megadott tömbképlet harmadik elemében (A4/B4, vagyis "" osztva 23-mal); nem talál hibát, ezért a képlet eredményét adja vissza.

0

Megjegyzés: A példában szereplő képletet tömbképletként kell beírnia. Másolja a példát egy üres munkalapra, jelölje ki a C2:C4 tartományt, és nyomja le az F2 billentyűt, majd a CTRL+SHIFT+ENTER billentyűkombinációt.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×