HA függvény

A HA függvény az Excel egyik legnépszerűbb függvénye, és segítségével logikai összehasonlításokat végezhet egy érték és az elvárások között. Legegyszerűbb formájában a HA függvény a következőt jelenti:

  • HA(Valami igaz, akkor valami történik, ellenkező esetben pedig valami más)

Tehát a HA utasításoknak két eredménye lehet. Az első eredmény akkor áll elő, ha az összehasonlítás igaz, a második pedig akkor, ha az összehasonlítás hamis.

Ha szeretne közvetlenül a több HA utasítással való munkához ugrani, tanulmányozza a HA függvények haladóknak – Munka egymásba ágyazott képletekkel, és a gyakori hibák elkerülése című témakört.

A HA függvénnyel, amely egy logikai függvény, aszerint adhat vissza értéket, hogy egy feltétel teljesül-e.

Szintaxis

HA(logikai_vizsgálat; érték_ha_igaz; [érték_ha_hamis])

Például:

  • =HA(A2>B2;"Költségvetést meghaladó";"OK")

  • =HA(A2=B2,B4-A4,"")

Argumentum neve

Leírás

logikai_vizsgálat    (kötelező)

A vizsgálni kívánt feltétel.

érték_ha_igaz    (kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye IGAZ.

érték_ha_hamis    (nem kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye HAMIS.

Példák a HA függvényre

A D2 cellában szereplő képlet a következő: =HA(C2="Igen",1,2)
  • =HA(C2=”Igen”,1,2)

A fenti példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 = Igen, akkor 1, ellenkező esetben 2 értéket ad vissza)

A D2 cellában szereplő képlet a következő_ =HA(C2=1,"IGEN","NEM")
  • =HA(C2=1,”Igen”,”Nem”)

Ebben a példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 = 1, akkor Igen, ellenkező esetben Nem értéket ad vissza)

Ahogyan az látható, a HA függvény szöveg és értékek kiértékelésére is használható. Ezenkívül hibákat is kiértékelhet vele. Nemcsak azt ellenőrizheti, hogy valami egyenlő-e valami mással (egyetlen eredményt kapva), hanem matematikai operátorokat is használhat, és további számításokat is végrehajthat a feltételektől függően. Több HA függvényt is egymásba ágyazhat, és így több összehasonlítást is végezhet.

Megjegyzés : Ha szöveget szeretne használni a képletekben, a szöveget idézőjelekbe kell foglalni (például: "Szöveg"). Az egyetlen kivétel az IGAZ és a HAMIS érték használata, amelyet az Excel automatikusan megért.

Első lépések

A legjobb módszer a HA utasítások írásának megkezdésére, ha először végiggondolja, hogy mit kíván elérni. Milyen összehasonlítást próbál elvégezni? Sok esetben a HA utasítások megírása egyszerű, mint a logikus gondolkodás, például: „mi történik, ha ez a feltétel teljesül, és mi történik, ha nem?” Mindig célszerű meggyőződni arról, hogy lépései egy logikai folyamatot követnek, ellenkező esetben a képlet nem a várt módon fog működni. Ez különösen fontos akkor, ha összetett (beágyazott) HA utasításokat hoz létre.

További példák HA függvényre

A D2 cellában szereplő képlet a következő: =HA(C2>B2,”Költségvetést meghaladó”,”Költségvetésen belüli”)
  • =HA(C2>B2,”Költségvetésen belül”,”Költségvetést meghaladó”)

A fenti példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 nagyobb mint B2, akkor a „Költségvetést meghaladó”, ellenkező esetben a „Költségvetésen belüli” értéket adja vissza)

Az E2 cellában szereplő képlet a következő: =HA(C2>B2,C2-B2,"")
  • =HA(C2>B2;C2-B2;0)

A fenti ábrán szereplő képlet szöveges eredmény helyett egy matematikai számítást ad vissza. Tehát az E2 cellában lévő képlet a következőt jelenti: HA(A Tényleges nagyobb mint a Tervezett, akkor kivonja a tervezett összeget a tényleges összegből, ellenkező esetben nem ad vissza eredményt).

Az F7 cellában szereplő képlet a következő: HA(E7=”Igen”,F5*0.0825,0)
  • =HA(E7=”Igen”,F5*0.0825,0)

Ebben a példában az F7 cellában szereplő képlet a következőt jelenti: HA(E7 = “Igen”, akkor a teljes összeget kiszámítja az F5 * 8,25% számításban, ellenkező esetben nem esedékes értékesítési adó, ezért 0 az eredmény)

Ajánlott eljárások – állandók

Az utolsó példában az „Igen” és az értékesítési adó mértéke (0,0825) közvetlenül be van írva a képletbe. Általában nem jó ötlet közvetlenül a képletekbe beírni az állandókat (olyan értékeket, amelyeket időről időre változtatni kell), mivel később nehezen lehet őket megtalálni és módosítani. Sokkal jobb módszer az állandókat a saját cellájukba írni, ahol könnyen meg lehet őket találni, és egyszerűen meg lehet őket változtatni. Ebben az esetben ez rendben van, mivel csak egyetlen HA függvény van, az értékesítési adó mértéke pedig ritkán változik. Még ha változik is, egyszerűen lehet módosítani a képletben.

Műveleti jelek

Ha többet szeretne megtudni a képletekben használható műveleti jelekről (< kisebb, mint, > nagyobb, mint, = egyenlő, <> nem egyenlő stb.), tanulmányozza a következő cikket: Műveleti jelek és elsőbbségi sorrend.

A HA használata annak vizsgálatára, hogy egy cella üres-e

Időnként meg kell vizsgálnia, hogy egy cella nem üres-e, mivel bizonyára nem szeretné, hogy egy képlet adat nélküli eredményt jelenítsen meg.

Az E2 cellában szereplő képlet a következő: =HA(D2=1,"Igen",IF(D2=2,"Nem","Talán"))

Ebben az esetben a HA függvényt használjuk az ÜRES függvénnyel:

  • =HA(ÜRES(D2);"Üres";"Nem üres")

Ez arról tájékoztat, hogy amikor a HA(D2 üres, akkor "Üres", egyébként "Nem üres") eredményt ad vissza. Ugyanilyen módon használhatja a "Nem üres" feltételt is. A következő példában ÜRES helyett "" feltételt használunk. Az "" jelentése alapvetően "semmi".

Annak vizsgálata, hogy a cella üres-e – az E2 cellában szereplő képlet a következő: =HA(ÜRES(D2);"Üres";"Nem üres")
  • =HA(D3="";"Üres";"Nem üres")

E képlet jelentése, hogy a Ha(D3 semmi, akkor "Üres", egyébként "Nem üres") eredményt ad vissza. Íme egy példa az "" gyakori használatára annak megakadályozására, hogy egy képlet számításokat végezzen, amikor egy függő cella üres:

  • =HA(D3="";"";AzÖnKéplete())

    HA(D3 semmi, akkor semmit sem ad vissza, egyébként kiszámítja a képletet).

Példa beágyazott HA függvényre

Míg egy egyszerű HA függvénynek csak két eredménye van (True vagy False), a beágyazott HA függvényeknek 3–64 eredménye lehet.

Az "" használata üres cella kereséséhez – az E3 cellában szereplő képlet a következő: =HA(D3="";"Üres";"Nem üres")
  • =HA(D2=1,”IGEN”,HA(D2=2,”Nem”,”Talán”))

A fenti ábrán az E2 cellában lévő képlet a következőt jelenti: HA(D2 egyenlő 1-gyel, az „Igen”, ellenkező esetben HA(D2 egyenlő 2-vel, a „Nem” értéket, ellenkező esetben a „Talán” értéket adja vissza)). Ne feledje, hogy a képlet végén két záró zárójel szerepel. Ezek zárják le a két HA függvényt, ha pedig úgy adja meg a képletet, hogy nem szerepel benne mindkét záró zárójel, az Excel megkísérli kijavítani a képletet.

Figyelembe veendő szempontok

Habár az Excel akár 64 különböző HA függvény beágyazását is lehetővé teszi, mégsem ajánlott, hogy így tegyen. Miért?

  • Több HA utasítás esetén sok mindent át kell gondolni, hogy megfelelő legyen a kialakításuk, és gondoskodni kell arról, hogy a logikájuk minden egyes feltételen keresztül, egészen végig helyesen végezze a számítást. Ha nem 100%-os pontossággal végzi a HA utasítások beágyazását, akkor a képlet az idő 75%-ában működhet, de 25%-ban váratlan eredményeket ad vissza. Sajnos arra, hogy a 25%-ban helyes az eredmény, kicsi az esély.

  • Több HA utasítás esetén nagyon bonyolulttá válhat a fenntartásuk, különösen ha később valamikor visszatér, és megpróbál rájönni, hogy Ön vagy – rosszabb esetben – más mit akart tenni.

  • Több HA utasítás esetén több nyitó és záró zárójelre () van szükség, ami nehézséget okozhat a képlet kezelésében attól függően, hogy mennyire bonyolult lesz a képlet.

Gyakori problémák

Probléma

A probléma oka

0 (nulla) egy cellában

Nincs megadva az érték_ha_igaz vagy az érték_ha_hamis argumentum. Ahhoz, hogy a megfelelő értéket adja vissza a képlet, adja meg mindkét argumentum szövegét, vagy adja meg az IGAZ vagy HAMIS értéket az argumentumban.

#NÉV? hiba egy cellában

Ez általában azt jelenti, hogy a képletben elírás van.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Videó: HA függvények haladóknak

HAELSŐIGAZ függvény (Office 365, Excel 2016 és újabb)

HA függvények haladóknak – Munka egymásba ágyazott képletekkel, és a gyakori hibák elkerülése

Tanfolyamok videón: HA függvények haladóknak

DARABTELI függvény egyetlen feltételnek megfelelő értékek megszámlálásához

DARABHATÖBB függvény több feltételnek megfelelő értékek megszámlálásához

SZUMHA függvény egy feltételnek megfelelő értékek összesítéséhez

SZUMHATÖBB függvény több feltételnek megfelelő értékek összesítéséhez

ÉS függvény

VAGY függvény

FKERES függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása hibaellenőrzéssel

Logikai függvények

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×