Képletek és függvények

HA függvény

HA függvény

Megjegyzés: Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja.

A Ha függvény az Excel programban a leggyakrabban használt funkciók közül, és lehetővé teszi, hogy a logikai érték, és mi várható összehasonlítása.

Tehát a HA utasításoknak két eredménye lehet. Az első eredmény akkor áll elő, ha az összehasonlítás igaz, a második pedig akkor, ha az összehasonlítás hamis.

Ha például =IF(C2="Yes",1,2) azt jelzi, ha (C2 = Yes, és térjen vissza a egy 1, különben a program vissza egy 2).

Ez a böngésző nem támogatja a videók lejátszását. Telepítse a Microsoft Silverlightot, az Adobe Flash Playert vagy az Internet Explorer 9-es verzióját.

A HA függvénnyel, amely egy logikai függvény, aszerint adhat vissza értéket, hogy egy feltétel teljesül-e.

HA(logikai_vizsgálat; érték_ha_igaz; [érték_ha_hamis])

Például:

  • =HA(A2>B2;"Költségvetést meghaladó";"OK")

  • =HA(A2=B2,B4-A4,"")

Argumentum neve

Leírás

logikai_vizsgálat    (kötelező)

A vizsgálni kívánt feltétel.

érték_ha_igaz    (kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye IGAZ.

érték_ha_hamis    (nem kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye HAMIS.

Példák a HA függvényre

A D2 cellában szereplő képlet a következő: =HA(C2="Igen",1,2)
  • =HA(C2=”Igen”,1,2)

A fenti példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 = Igen, akkor 1, ellenkező esetben 2 értéket ad vissza)

A D2 cellában szereplő képlet a következő_ =HA(C2=1,"IGEN","NEM")
  • =HA(C2=1,”Igen”,”Nem”)

Ebben a példában a D2 cellában lévő képlet szerint: IF(C2 = 1, then return Yes, otherwise return No)jelenik meg, mint a Ha függvény segítségével is szöveget és értékeket logikai értéket. Is használható hibák kiszeretné számítani. Ön nem korlátozódik csak ellenőrizni, hogy a egyvalamihez megegyezik egy másik, és eredményül egyetlen eredményt, is matematikai operátorok és további számításokat attól függően, hogy a megadott feltételeknek. Több Ha függvények együtt is egymásba végezze el a több összehasonlítása érdekében.

A D2 cellában szereplő képlet a következő: =HA(C2>B2,”Költségvetést meghaladó”,”Költségvetésen belüli”)
  • =HA(C2>B2,”Költségvetésen belül”,”Költségvetést meghaladó”)

A fenti példában a D2 cellában lévő képlet a következőt jelenti: HA(C2 nagyobb mint B2, akkor a „Költségvetést meghaladó”, ellenkező esetben a „Költségvetésen belüli” értéket adja vissza)

Az E2 cellában szereplő képlet a következő: =HA(C2>B2,C2-B2,"")
  • =HA(C2>B2;C2-B2;0)

A fenti ábrán szereplő képlet szöveges eredmény helyett egy matematikai számítást ad vissza. Tehát az E2 cellában lévő képlet a következőt jelenti: HA(A Tényleges nagyobb mint a Tervezett, akkor kivonja a tervezett összeget a tényleges összegből, ellenkező esetben nem ad vissza eredményt).

Az F7 cellában szereplő képlet a következő: HA(E7=”Igen”,F5*0.0825,0)
  • =HA(E7=”Igen”,F5*0.0825,0)

Ebben a példában az F7 cellában szereplő képlet a következőt jelenti: HA(E7 = “Igen”, akkor a teljes összeget kiszámítja az F5 * 8,25% számításban, ellenkező esetben nem esedékes értékesítési adó, ezért 0 az eredmény)

Megjegyzés: Ha szöveget szeretne használni a képletekben, a szöveget idézőjelekbe kell foglalni (például: "Szöveg"). Az egyetlen kivétel az IGAZ és a HAMIS érték használata, amelyet az Excel automatikusan megért.

Gyakori problémák

Probléma

A probléma oka

0 (nulla) egy cellában

Nincs megadva az érték_ha_igaz vagy az érték_ha_hamis argumentum. Ahhoz, hogy a megfelelő értéket adja vissza a képlet, adja meg mindkét argumentum szövegét, vagy adja meg az IGAZ vagy HAMIS értéket az argumentumban.

#NÉV? hiba egy cellában

Ez általában azt jelenti, hogy a képletben elírás van.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Műveleti operátorok és végrehajtási sorrendje az Excel programban

A képlet beágyazott függvények használata

Ellenőrizheti, hogy a cella nem üres használata esetén

Ellenőrizheti, hogy a cella nem üres használata esetén

Videó: Speciális ha függvények

IFS függvény (Office 365, az Excel 2016 vagy újabb verzió)

Ha speciális funkciók – beágyazott képletek használata és csapdák elkerülése

Tanfolyamok, videók: Speciális ha függvények

A DARABTELI függvényt értékek feltételnek alapján számít

Számít értékek több feltétel alapján a DARABHATÖBB függvény

A SZUMHA függvénnyel számát adja eredményül értékek feltételnek alapján

A SZUMHATÖBB függvény számát adja eredményül értékek több feltétel alapján

És függvény

Vagy függvény

FKERES függvény

Az Excel a képletek – áttekintés

Hibás képletek kiküszöbölése

Képletekben lévő hibák feltárása hibaellenőrzéssel használata

Logikai függvények

Az Excel függvényeinek betűrendes listája

Excel-függvények (kategória szerint)

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×