Feltételes képletek létrehozása

Sok feladat esetében ellenőrizni kell, hogy egy-egy feltétel igaz vagy hamis-e, illetve össze kell vetni kifejezéseket logikai szempontból. Az ilyen feltételes képletek létrehozására használja az ÉS, a VAGY, a NEM és a HA függvényt.

A HA függvény például az alábbi argumentumokat használja.

képlet a HA függvénnyel

A HA függvényt használó képlet

Gombkép  logikai_vizsgálat: a vizsgálandó feltétel

Ábrafelirat 2   érték_ha_igaz: visszatérési érték, ha a feltétel teljesül.

Gombkép   érték_ha_hamis: visszatérési érték, ha a feltétel nem teljesül.

A képletek létrehozásával kapcsolatban a Képlet létrehozása és törlése című témakörben talál további információt.

Kapcsolódó műveletek

Logikai (IGAZ vagy HAMIS) értéket eredményező képlet létrehozása

Másik számítást eredményező, illetve az IGAZ vagy HAMIS értéktől eltérő eredményt adó feltételes képlet létrehozása

Logikai (IGAZ vagy HAMIS) értéket eredményező képlet létrehozása

A feladat végrehajtásához használja az ÉS, a VAGY és a NEM függvényt, illetve az operátorokat az alábbi példán látható módon.

Példa

A példa könnyebben megérthető, ha üres munkalapra másolja.

Példa másolása

  1. Jelölje ki a jelen cikkben szereplő példákat.

    Fontos : Ne jelölje ki a sor- vagy oszlopfejléceket.

    példa választása a Windows Excel 2013 súgójából

    Példa kijelölése a súgóban

  2. Nyomjuk le a CTRL+C billentyűkombinációt.

  3. Az Excelben hozzon létre egy üres munkafüzetet vagy munkalapot.

  4. A munkalapon jelölje ki az A1 cellát, és nyomja le a CTRL+V billentyűkombinációt.

Fontos : A példa megfelelő működéséhez azt a munkalap A1 cellájába kell beilleszteni.

  1. Az eredmények és az azokat eredményező képletek megjelenítése közötti váltáshoz nyomjuk meg a CTRL+` (fordított ékezet) billentyűkombinációt, vagy kattintsunk a Képletek lap Képletvizsgálat csoportjának Képletek megjelenítése gombjára.

Miután egy üres munkalapra másolta, igényeihez igazíthatja a példát.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Adatok

15

9

8

Bizgentyűk

Szerkentyűk

Képlet

Leírás (eredmény)

=ÉS(A2>A3;A2<A4)

Meghatározza, hogy az A2 cellában található érték nagyobb-e az A3 cellában található értéknél, valamint hogy az A3 és az A2 cellában található érték kisebb-e az A4 cellában található értéknél. (HAMIS)

=VAGY(A2>A3;A2<A4)

Meghatározza, hogy az A2 cellában található érték nagyobb-e az A3 cellában található értéknél, vagy az A2 cellában található érték kisebb-e az A4 cellában található értéknél. (IGAZ)

=NEM(A2+A3=24)

Meghatározza, hogy az A2 és A3 cellák értékének összege nem egyenlő-e 24-el. (HAMIS)

=NEM(A5="Bizgentyűk")

Meghatározza, hogy az A5 cellában található érték nem egyenlő-e a „Bizgentyűk” szöveggel. (HAMIS)

=VAGY(A5<>"Bizgentyűk",A6 = "Szerkentyűk")

Meghatározza, hogy az A5 cellában található érték nem egyenlő-e a „Bizgentyűk” szöveggel, illetve az A6 cellában található érték egyenlő-e a „Szerkentyűk” szöveggel. (IGAZ)

E függvények használatáról az ÉS függvény, a VAGY függvény és a NEM függvény című témakörben olvashat bővebben.

Vissza a lap tetejére

Másik számítást eredményező, illetve az IGAZ vagy HAMIS értéktől eltérő eredményt adó feltételes képlet létrehozása

A feladat végrehajtásához használja a HA, az ÉS és a VAGY függvényt, valamint az operátorokat az alábbi példában látható módon.

Példa

A példa könnyebben megérthető, ha üres munkalapra másolja.

Példa másolása

  1. Jelölje ki a jelen cikkben szereplő példákat.

Fontos : Ne jelölje ki a sor- vagy oszlopfejléceket.

példa választása a Windows Excel 2013 súgójából

Példa kijelölése a súgóban

  1. Nyomjuk le a CTRL+C billentyűkombinációt.

  2. Az Excelben hozzon létre egy üres munkafüzetet vagy munkalapot.

  3. A munkalapon jelölje ki az A1 cellát, és nyomja le a CTRL+V billentyűkombinációt.

Fontos : A példa megfelelő működéséhez azt a munkalap A1 cellájába kell beilleszteni.

  1. Az eredmények és az azokat eredményező képletek megjelenítése közötti váltáshoz nyomjuk meg a CTRL+` (fordított ékezet) billentyűkombinációt, vagy kattintsunk a Képletek lap Képletvizsgálat csoportjának Képletek megjelenítése gombjára.

Miután egy üres munkalapra másolta, igényeihez igazíthatja a példát.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Adatok

15

9

8

Bizgentyűk

Szerkentyűk

Képlet

Leírás (eredmény)

=HA(A2=15;"Rendben";"Helytelen")

Ha az A2 cellában lévő érték 15, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Rendben)

=HA(A2<>15;"Rendben";"Helytelen")

Ha az A2 cellában lévő érték nem 15, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Helytelen)

=HA(NEM(A2<=15);"Rendben";"Helytelen")

Ha az A2 cellában lévő érték 15-nél nem kisebb vagy egyenlő, a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Helytelen)

=HA(A5<>"BIZGENTYŰK";"Rendben";"Helytelen")

Ha az A5 cellában lévő érték nem „BIZGENTYŰK”, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Helytelen)

=HA(ÉS(A2>A3;A2<A4);"Rendben";"Helytelen")

Ha az A2 cellában lévő érték nagyobb az A3 cellában lévő értéknél, és az A2 cellában lévő érték ezen kívül kisebb az A4 cellában lévő értéknél, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Helytelen)

=Ha(ÉS(A2<>A3;A2<>A4);"Rendben";"Helytelen")

Ha az A2 cellában lévő érték nem egyenlő sem az A3 cellában lévő értékkel, sem az A4 cellában lévő értékkel, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Helytelen)

=HA(VAGY(A2>A3;A2<A4);"Rendben";"Helytelen")

Ha az A2 cellában lévő érték nagyobb az A3 cellában lévő értéknél, vagy kisebb az A4 cellában lévő értéknél, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Rendben)

=HA(VAGY(A5<>"Bizgentyűk";A6<>"Szerkentyűk");"Rendben";"Helytelen")

Ha az A5 cellában lévő érték nem egyenlő a „Bizgentyűk” szöveggel, vagy az A6 cellában lévő érték nem egyenlő a „Szerkentyűk” szöveggel, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Helytelen)

=HA(VAGY(A2<>A3;A2<>A4);"Rendben";"Helytelen")

Ha az A2 cellában lévő érték nem egyenlő sem az A3 cellában lévő értékkel, sem az A4 cellában lévő értékkel, akkor a visszatérési érték „Rendben”. Egyéb esetben a visszatérési érték „Helytelen”. (Rendben)

E függvények használatáról a HA függvény, az ÉS függvény és a VAGY függvény című témakörben olvashat bővebben.

Vissza a lap tetejére

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×