Függvények egymásba ágyazása a képletekben

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Ha egy függvényt használó képletben a függvény argumentuma függvénnyel van megadva, akkor ezt beágyazásnak nevezzük, és a belső függvényre a továbbiakban beágyazott függvényként hivatkozunk. A HA függvénybe az ÁTLAG és a SZUM függvényt beágyazva létrehozható olyan képlet, amely csak akkor összegez egy számhalmazt (G2:G5), ha egy másik számhalmaz (F2:F5) átlaga 50-nél nagyobb, egyébként a visszaadott értéke 0.

Beágyazott függvény

Az átlag és a SZUM függvényt a Ha függvény van beágyazva.

A függvények 64 szintig ágyazhatók egymásba egy képletben.

  1. Kattintson arra a cellára, amelybe a képletet be szeretné írni.

  2. A képlet függvénnyel történő kezdéséhez kattintson a Függvény beszúrása 4. felirat gombra a szerkesztőlécen Gombkép .

    Az Excel automatikusan beszúrja az egyenlőségjelet (= ).

  3. A függvény kategóriája mezőben válassza a Mind elemet.

    Ha jól ismeri már a függvénykategóriákat, akkor kiválaszthatja a megfelelő kategóriát.

    Ha nem biztos abban, hogy melyik függvényre van szüksége, akkor a kívánt függvényt úgy keresheti meg, hogy beír egy, a kívánt műveletre vonatkozó kérdést a Függvény keresése mezőbe (például a „számok összeadása” beírásával a SZUM függvényt kapja eredményül).

  4. Másik függvény argumentumként történő beírásához írja be a függvényt a megfelelő argumentum mezőjébe.

    A képlet Függvényargumentumok párbeszédpanelen látható részei az előző lépésben kiválasztott függvénynek megfelelően jelennek meg.

    Ha a HA függvényt választotta, a Függvényargumentumok párbeszédpanelen a HA függvény argumentumai jelennek meg. Ha másik függvényt szeretne beágyazni, akkor beírhatja a nevét az argumentummezőbe. A HA függvény Érték_ha_igaz mezőjébe beírhatja például a SZUM(G2:G5) képletet.

  5. Adja meg a képlet kitöltéséhez esetleg szükséges további argumentumokat.

    A hivatkozásként használni kívánt cellákat nemcsak beírással, hanem a cellák kijelölésével is megadhatja. A Gombkép gombra kattintva állítsa kis méretűre a párbeszédpanelt, jelölje ki a cellákat, amelyekre hivatkozni kíván, majd bontsa ki újra a párbeszédpanelt a Gombkép gombra kattintva.

    Tipp : A függvénnyel és argumentumaival kapcsolatos további tudnivalókért kattintson a Súgó a függvényről pontra.

  6. A képlet argumentumainak megadása után kattintson az OK gombra.

  1. Kattintson arra a cellára, amelybe a képletet be szeretné írni.

  2. A képlet függvénnyel történő kezdéséhez kattintson a Függvény beszúrása 4. felirat gombra a szerkesztőlécen Gombkép .

  3. A függvény beszúrása párbeszédpanel a kívánt kategória kiválasztása párbeszédpanelen válassza a mindlehetőséget.

    Ha jól ismeri már a függvénykategóriákat, akkor kiválaszthatja a megfelelő kategóriát.

  4. Adjon meg egy másik függvény argumentumként, a megfelelő argumentum mezőjébe, a képlet szerkesztő vagy közvetlenül a cellába írja be a függvény.

  5. Adja meg a képlet kitöltéséhez esetleg szükséges további argumentumokat.

  6. Miután befejezte a képlet argumentumait, nyomja le az ENTER BILLENTYŰT.

Példák

Az alábbi példában beágyazott HA függvényekkel betűvel jelzett osztályzatot társítunk pontszámhoz.

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Pontszám

45

90

78

Képlet

Leírás

Eredmény

'=HA(A2>89,"A",HA(A2>79,"B", HA(A2>69,"C",HA(A2>59,"D","F"))))

Beágyazott HA feltételek használatával betűvel kifejezett osztályzatot rendel az A2 cellában lévő pontszámhoz.

=HA(A2>89,"A",HA(A2>79,"B",HA(A2>69,"C",HA(A2>59,"D","F"))))

'=HA(A3>89,"A",HA(A3>79,"B", HA(A3>69,"C",HA(A3>59,"D","F"))))

Beágyazott HA feltételek használatával betűvel kifejezett osztályzatot rendel az A3 cellában lévő pontszámhoz.

=HA(A3>89,"A",HA(A3>79,"B",HA(A3>69,"C",HA(A3>59,"D","F"))))

'=HA(A4>89,"A",HA(A4>79,"B", HA(A4>69,"C",HA(A4>59,"D","F"))))

Beágyazott HA feltételek használatával betűvel kifejezett osztályzatot rendel az A4 cellában lévő pontszámhoz.

=HA(A4>89,"A",HA(A4>79,"B",HA(A4>69,"C",HA(A4>59,"D","F"))))

Tippek : 

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Lásd még

Videó: Egymásba ágyazott Ha függvények

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×