Függvények egymásba ágyazása a képletekben

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Ha egy függvényt használó képletben a függvény argumentuma függvénnyel van megadva, akkor ezt beágyazásnak nevezzük, és a belső függvényre a továbbiakban beágyazott függvényként hivatkozunk. A HA függvénybe az ÁTLAG és a SZUM függvényt beágyazva létrehozható olyan képlet, amely csak akkor összegez egy számhalmazt (G2:G5), ha egy másik számhalmaz (F2:F5) átlaga 50-nél nagyobb, egyébként a visszaadott értéke 0.

Beágyazott függvény

Az ÁTLAG és a SZUM függvény a HA függvénybe van ágyazva.

A függvények 64 szintig ágyazhatók egymásba egy képletben.

  1. Kattintson arra a cellára, amelybe a képletet be szeretné írni.

  2. A képlet függvénnyel történő kezdéséhez kattintson a Függvény beszúrása 4. felirat gombra a szerkesztőlécen Gomb .

    Az Excel automatikusan beszúrja az egyenlőségjelet (= ).

  3. A függvény kategóriája mezőben válassza a Mind elemet.

    Ha jól ismeri már a függvénykategóriákat, akkor kiválaszthatja a megfelelő kategóriát.

    Ha nem biztos abban, hogy melyik függvényre van szüksége, akkor a kívánt függvényt úgy keresheti meg, hogy beír egy, a kívánt műveletre vonatkozó kérdést a Függvény keresése mezőbe (például a „számok összeadása” beírásával a SZUM függvényt kapja eredményül).

  4. Másik függvény argumentumként történő beírásához írja be a függvényt a megfelelő argumentum mezőjébe.

    A képlet Függvényargumentumok párbeszédpanelen látható részei az előző lépésben kiválasztott függvénynek megfelelően jelennek meg.

    Ha a HA függvényt választotta, a Függvényargumentumok párbeszédpanelen a HA függvény argumentumai jelennek meg. Ha másik függvényt szeretne beágyazni, akkor beírhatja a nevét az argumentummezőbe. A HA függvény Érték_ha_igaz mezőjébe beírhatja például a SZUM(G2:G5) képletet.

  5. Adja meg a képlet kitöltéséhez esetleg szükséges további argumentumokat.

    A hivatkozásként használni kívánt cellákat nemcsak beírással, hanem a cellák kijelölésével is megadhatja. A Gombkép gombra kattintva állítsa kis méretűre a párbeszédpanelt, jelölje ki a cellákat, amelyekre hivatkozni kíván, majd bontsa ki újra a párbeszédpanelt a Gombkép gombra kattintva.

    Tipp: A függvénnyel és argumentumaival kapcsolatos további tudnivalókért kattintson a Súgó a függvényről pontra.

  6. A képlet argumentumainak megadása után kattintson az OK gombra.

  1. Kattintson arra a cellára, amelybe a képletet be szeretné írni.

  2. A képlet függvénnyel történő kezdéséhez kattintson a Függvény beszúrása 4. felirat gombra a szerkesztőlécen Gomb .

  3. A Függvény beszúrása párbeszédpanel Válasszon kategóriát mezőjében válassza a Mind lehetőséget.

    Ha jól ismeri már a függvénykategóriákat, akkor kiválaszthatja a megfelelő kategóriát.

  4. Másik függvény argumentumként történő beírásához írja be a függvényt az argumentum mezőjébe a Képletszerkesztőben vagy közvetlenül a cellába.

  5. Adja meg a képlet kitöltéséhez esetleg szükséges további argumentumokat.

  6. A képlet argumentumainak megadása után nyomja le az Enter billentyűt.

Példák

Az alábbi példában beágyazott HA függvényekkel betűvel jelzett osztályzatot társítunk pontszámhoz.

Másolja a mintaadatokat az alábbi táblázatból, és illessze be őket egy új Excel-munkalap A1 cellájába. Ha azt szeretné, hogy a képletek megjelenítsék az eredményt, jelölje ki őket, és nyomja le az F2, majd az Enter billentyűt. Szükség esetén módosíthatja az oszlopok szélességét, hogy az összes adat látható legyen.

Pontszám

45

90

78

Képlet

Leírás

Eredmény

'=HA(A2>89,"A",HA(A2>79,"B", HA(A2>69,"C",HA(A2>59,"D","F"))))

Beágyazott HA feltételek használatával betűvel kifejezett osztályzatot rendel az A2 cellában lévő pontszámhoz.

=HA(A2>89,"A",HA(A2>79,"B",HA(A2>69,"C",HA(A2>59,"D","F"))))

'=HA(A3>89,"A",HA(A3>79,"B", HA(A3>69,"C",HA(A3>59,"D","F"))))

Beágyazott HA feltételek használatával betűvel kifejezett osztályzatot rendel az A3 cellában lévő pontszámhoz.

=HA(A3>89,"A",HA(A3>79,"B",HA(A3>69,"C",HA(A3>59,"D","F"))))

'=HA(A4>89,"A",HA(A4>79,"B", HA(A4>69,"C",HA(A4>59,"D","F"))))

Beágyazott HA feltételek használatával betűvel kifejezett osztályzatot rendel az A4 cellában lévő pontszámhoz.

=HA(A4>89,"A",HA(A4>79,"B",HA(A4>69,"C",HA(A4>59,"D","F"))))

Tippek: 

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Videó: Beágyazott HA függvények

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×