Eszközkövetési megoldás létrehozása az InfoPathban és az Excelben

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

A Microsoft Office InfoPath segítségével adatbevitelre és adatgyűjtésre használható űrlapsablonokat hozhat létre. A Microsoft Office Excel 2007 pedig lehetővé teszi számítások elvégzését, adatok grafikonon való megjelenítését és elemzését. E két program és az XML használatával könnyedén létrehozhat egyszerű, hatékony, kódírást nem igénylő üzleti megoldásokat a vállalat eszközeinek nyomon követésére.

Az eszközkövetési megoldás áttekintése

Tartalom

Eszköznyilvántartó megoldások létrehozása – bevezetés

1. lépés: Az Eszköznyilvántartás űrlapsablon testreszabása

2. lépés: A sémafájl leképezése és a tábla elrendezésének testreszabása az Excelben

3. lépés: Kimutatást és kimutatásdiagramot tartalmazó összefoglaló jelentés létrehozása

4. lépés: Eszközadatok gyűjtése a felhasználóktól

5. lépés: Űrlapok importálása az Excelbe

Záró gondolatok: Fontolja meg SharePoint-lista vagy Access-adatbázis használatát.

Eszköznyilvántartó megoldás létrehozása - bevezetés

Lehetősége van XML-adatcserére az InfoPath és az Excel között. Bár az Infopath exportálás parancsa egyszerű módja az űrlapadatok Excelbe való küldésének, egy nagyobb rugalmasságot biztosító megközelítést is alkalmazhat. Ha az InfoPath XML-sémafájlt (.xsd) az Excelben részletesen leképezi, majd az InfoPath űrlapfájlokat (.xml) az Excelbe importálja, testre szabhatja adatainak elrendezését, és az Excel funkcióit még jobban ki tudja használni a hatékonyabb adatkezeléshez és adatelemzéshez.

Ebben a témakörben az InfoPath Eszköznyilvántartás példa-űrlapsablonját használjuk, hogy bemutassuk, miként működhet együtt az InfoPath, az XML és az Excel. Tegyük fel, hogy minden évben a szervezet az egyes alkalmazottak irodájában található eszközöket leltárba veszi. Ezután egy Excel-jelentés futtatásával eldöntheti, hogy a következő évre miként ossza fel a szervezet a berendezésekre fordítandó költségvetést. A következő diagram áttekintést nyújt arról, hogy miként gyűjtheti és követheti nyomon az eszközadatokat, és hogyan készíthet jelentést róluk.

a

1. Az Eszköznyilvántartás űrlapsablon elkészült.

2. A sémafájlt a program leképezte egy Excel-táblázatra és a táblázat elrendezése testre van szabva.

3. A rendszer létrehozott egy kimutatást és egy kimutatásdiagramot tartalmazó összefoglaló jelentést.

4. Az Eszköznyilvántartás űrlapsablon segítségével adatokat gyűjthet a felhasználóktól.

5. A rendszer minden űrlapadatot exportál egy Excel-táblázatba és frissíti a kimutatást és a kimutatásdiagramot.

Ez a megoldás a következő felhasználói szerepköröket és termékeket igényli:

Teljes támogatás ikon = Szükséges Nincs támogatás ikon = Nem szükséges

Szoftverkövetelmények

Szerepkörök

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Megoldástervező

Teljes támogatás ikon

Teljes támogatás ikon

Teljes támogatás ikon

Önálló döntéshozó

Teljes támogatás ikon

Teljes támogatás ikon

Teljes támogatás ikon

Alkalmazottak

Teljes támogatás ikon

Teljes támogatás ikon

Nincs támogatás ikon

Vissza a lap tetejére

1. lépés: Az Eszköznyilvántartás űrlapsablon testreszabása

Az InfoPath Eszköznyilvántartás űrlapsablonja lehetővé teszi az adott alkalmazott irodájában található eszközökről, az alkalmazott részlegéről, az eszközkategóriákról és az egyes eszközök részletes adairól való adatgyűjtést. Ebben a megoldásban egy űrlaptervező elküldi az űrlapsablont az önálló döntéshozó e-mail címére az Office Outlook 2007 használatával.

Az eszközkövetési sablon

1. Feladat: Az Eszköznyilvántartás űrlapsablon megnyitása és testreszabása

Mivel nem tehet közzé e-mail címlista címzettjei számára olyan űrlapsablont, melynek Rich Text mezővezérlői csatolt képeket tartalmaznak, egy kis módosítást kell tennie az Eszköznyilvántartás mintasablonűrlapon.

  1. Kattintson a Fájl menü Űrlapsablon tervezése parancsára.

  2. Az Űrlapsablon tervezése párbeszédpanelen az Űrlapsablon megnyitása lehetőség alatt kattintson a Minta testreszabása elemre.

  3. Az Első lépések párbeszédpanelen kattintson a Példa – Eszköznyilvántartás ikonra, majd az Űrlapfeladatok résznél kattintson az Űrlap megtervezése lehetőségre.

  4. Kattintson a jobb gombbal az assetNotes vezérlőre, mutasson a Rich Text mező tulajdonságai lehetőségre, kattintson a Megjelenítés fülre, majd az Alkalmazható formázások rész alatt vegye ki a jelölést a Csatolt képek jelölőnégyzetből.

2. feladat: A küldési beállítások meghatározása

A következő feladat a küldési beállítások meghatározása annak érdekében, hogy az alkalmazottak egyedi névvel ellátott űrlapfájlt (.xml) tudjanak küldeni az önálló döntéshozó e-mail címére, csatolt fájlként.

  1. Kattintson az Eszközök menü Küldés beállításai elemére.

  2. A Küldés beállításai párbeszédpanelen jelölje be az Űrlap küldésének engedélyezése a felhasználóknak jelölőnégyzetet.

  3. Kattintson az Űrlapadatok küldése egyetlen cél megjelölésével elemre, majd a listából válassza ki az E-mail lehetőséget.

  4. Kattintson a Hozzáadás gombra.

    Ekkor megjelenik az Adatkapcsolat varázsló.

  5. A Címzett mezőbe írja be az önálló döntéshozó aliasát, aki majd az összes elküldött űrlapot meg fogja kapni.

  6. Egyedi tárgysor megadásához a Tárgy mezőben:

    • Kattintson a Képlet beszúrása Gombkép gombra.

    • Írja be a következő képletet:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Kattintson a Képlet ellenőrzése gombra, majd kattintson az OK gombra kétszer.

  • A Bevezetés mezőbe írjon be egy megfelelő üzenetet vagy adjon meg fontos utasításokat ehhez a megoldáshoz.

  • Kattintson a Tovább gombra.

  • A varázsló következő lapján kattintson az Űrlapadatok küldése mellékletként elemre, majd jelölje be az Űrlapsablon csatolásával... lehetőséget, hogy a felhasználók meg tudják majd nyitni az űrlap jelölőnégyzetet.

    Ezzel biztosíthatja, hogy alkalmazottak hozzáférhessenek az űrlap-sablonfájlhoz (.xsn) abban az esetben, ha nem tudnának hozzáférni a fájlt tartalmazó hálózati helyhez.

  • Ha egyedi fájlnevet szeretne minden egyes űrlapfájlnak (.xml) adni, akkor a Melléklet neve mezőben:

    1. Kattintson a Képlet beszúrása Gombkép gombra.

    2. Írja be a Tárgy sorban alkalmazott képletet.

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Kattintson a Képlet ellenőrzése gombra, majd kattintson az OK gombra kétszer.

  • Kattintson a Tovább gombra.

  • A varázsló következő lapján, az Adja meg az adatkapcsolat nevét mezőben adjon meg leíró nevet ehhez az adatküldési kapcsolatnak.

  • Az Összegzés szakaszban ellenőrizze, hogy minden adat helyes-e, majd kattintson a Befejezés gombra.

  • Mentse az űrlapot egy nyilvános hálózatra, hogy mind az önálló döntéshozó, mind az alkalmazottak hozzá tudjanak férni.

Vissza a lap tetejére

2. lépés: A sémafájl leképezése és a tábla elrendezésének testreszabása az Excelben

Az InfoPath és az Excel közötti kapcsolat beállításához három feladatot kell végrehajtania: cserélje le a sémafájlt az Eszköznyilvántartás űrlapsablonra, képezze le ezt a sémafájlt az Excelben, majd szabja testre az összes importált űrlapadatfájl tárolására kijelölt Excel-táblázat alapértelmezett elrendezését.

1. Feladat: Nyerje ki a sémafájlt az InfoPath rendszeréből.

  1. Az InfoPath rendszerében nyissa meg az Eszköznyilvántartás űrlapsablonfájlt.

  2. Kattintson az Eszközök menü Aktuális űrlap megtervezése parancsára.

  3. A Fájl menüben kattintson a Mentés forrásfájlokként parancsra.

  4. A Tallózás a mappák között párbeszédpanelen válasszon egy mappát vagy hozzon létre egy új mappát ahol a sémafájlt tárolni kívánja.

Jegyezze meg, hogy melyik mappába menti a forrásfájlokat, és hogy mi az űrlap XML-adatainak sémadefinícióját tartalmazó sémafájl neve (ez jelen esetben myschema.xsd).

2. feladat: Képezze le az InfoPath-sémafájlt az Excelben.

  1. Hozzon létre egy új Excel-fájlt, majd mentse az önálló döntéshozó által elérhető helyre.

  2. Ha az Excelben nem látható a Fejlesztőeszközök fül, tegye a következőket:

    1. Kattintson a Microsoft Office-gombra Gombkép , majd Az Excel beállításai gombra.

    2. A Népszerű elemek kategória Alapvető beállítások az Excel használatához csoportjában jelölje be a Fejlesztőeszközök lap megjelenítése a szalagon jelölőnégyzetet, és kattintson az OK gombra.

      Megjegyzés : A menüszalag a Microsoft Office Fluent felhasználói felület része.

  3. A Fejlesztőeszközök lap XML csoportjában kattintson a Forrás gombra.

    A menüszalag XML csoportja

    Megjelenik az XML-forrás munkaablak.

  4. Kattintson az XML-megfeleltetések lehetőségre, majd az XML-megfeleltetések párbeszédablakban kattintson a Hozzáadás gombra.

  5. Windows Vista rendszerű számítógépen:    

    1. A Címsorban kattintson a myschema.xsd fájlt tartalmazó meghajtóra vagy a szakasz 2. lépése 1. feladatánál létrehozott mappára: Nyerje ki a sémafájlt az InfoPath alkalmazásból.

      Microsoft Windows XP rendszerű számítógépen:   

    2. A Hely listán kattintson a myschema.xsd fájlt tartalmazó meghajtóra vagy a szakasz 2. lépése 1. feladatánál létrehozott mappára: Nyerje ki a sémafájlt az InfoPath alkalmazásból.

  6. Kattintson a fájlra, majd a Megnyitás gombra.

  7. Miután a Több gyökér párbeszédpanel megjelenik, kattintson a myschema.xsd fájlban megadott assetTracking gyökércsomópontra, majd kattintson az OK gombra.

    Az XML-megfeleltetés megjelenik az XML-forrás munkaablakban.

  8. Húzza a(z) ns1:asset ismétlődő XML típusú csomópontelemet arra a munkalaphelyre, ahol az Excel-táblázatot meg szeretné jeleníteni.

    Az inopath sémafájl megfeleltetése az Excelben

3. feladat: Az Excel-táblázat elrendezésének testreszabása

Alapértelmezés szerint az Excel az XML-elemneveket használja oszlopfejlécekként a táblázathoz. Az oszlopfejléceket azonban módosíthatja az oszlopfejléc-cellák szerkesztésével.

  1. Az alapértelmezett oszlopfejlécek módosításához tartsa kiválasztottként az Excel-táblázatot, keresse meg a következő , kiválasztott megtartani, keresse meg a következő karakterlánc-előtagot, és távolítsa el: ns1:asset. Például módosítsa az ns1:assetID elemet, és adja neki a Szám (azaz Szám) elnevezést.

    Táblázatfejlécek testreszabása az Excelben

  2. Az oszlopszélesség módosításához kattintson Az összes kijelölése gombra, majd kattintson duplán bármely oszlopfejléc szegélyére.

Vissza a lap tetejére

3. lépés: Kimutatást és kimutatásdiagramot tartalmazó összefoglaló jelentés létrehozása

Az önálló döntéshozók az összefoglaló adatok elemzéséhez, vizsgálatához és vizuális megjelenítéséhez kimutatás- és kimutatásdiagram-jelentéseket használhatnak. A kimutatás- és kimutatásdiagram-jelentések beállításával célszerű már előre használni ezt az esetet, így egyszerű művelet lesz az önálló döntéshozó számára a jelentés futtatása a kész adatokkal.

  1. Jelölje ki az Excel-táblázat egy celláját.

  2. A Beszúrás lap Táblázatok csoportjában kattintson a Kimutatás gombra, majd az almenü Kimutatás parancsára.

    Az Excel menüszalagja

    Megjelenik a Kimutatás létrehozása párbeszédpanel.

  3. Ha új munkalapra szeretné helyezni a kimutatást az A1 cellánál kezdve, jelölje be az Új munkalapra választógombot, majd kattintson az OK gombra.

    Az Excel hozzáad egy üres kimutatást a megadott helyen, és megjeleníti a Kimutatás mezőlistát, ahol hozzáadhat mezőket, létrehozhat elrendezést, és testre szabhatja a kimutatást.

  4. Az adatokat magában foglaló, táblázatok közötti jelentés létrehozásához húzza az Azonosító mezőt az értékek területére, a Részleg mezőt az oszlopfeliratok területére, a Kategória mezőt a sorcímkék területére, és a Felelős mezőt a jelentésszűrő területére.

  5. Kattintson a kimutatásra.

  6. A Beszúrás lap Diagramok csoportjában kattintson az Oszlopdiagram típusra.

    Az Excel menüszalagja

  7. A Kétdimenziós sáv csoportban válassza a Csoportosított sáv elemet.

  8. Módosítsa a kimutatásdiagram méretét és helyét tetszés szerint.

Üres kimutatás és kimutatásdiagramok

Vissza a lap tetejére

4. lépés: Gyűjtsön eszközadatokat a felhasználóktól.

Most, hogy az űrlapsablon készen áll rá, hogy az alkalmazottak kitöltsék, már csak közzé kell tennie az űrlapot és elküldeni minden alkalmazottnak. Mikor az alkalmazottak elküldik a kitöltött űrlapot, XML-adatfájlként (.xml) egy e-mail üzenet mellékleteként fognak megérkezni az önálló döntéshozó e-mail fiókjába. Ekkor az önálló döntéshozó az üzeneteket az Outlookban egy erre a célra kijelölt InfoPath-mappába helyezi. Ebben az esetben javasoljuk, hogy adjon meg a felhasználók részére egy határidőt az űrlapok kitöltésére, hogy az önálló döntéshozó a jelentést a határidő lejáratakor minden kitöltött űrlapon futtathassa.

Adatok megadása az eszközkövető űrlapjain

  1. Nyissa meg az 1. lépésben mentett űrlapsablont az InfoPath alkalmazásban: Tervezze meg az Eszköznyilvántartás űrlapsablont.

  2. Kattintson az Eszközök menü Aktuális űrlap megtervezése parancsára.

  3. Kattintson a Fájl menü Közzététel parancsára.

  4. A Közzétételi varázslóban kattintson az E-mail címlista címzettjei elemre, majd a Tovább gombra.

  5. A varázsló következő oldalán az Űrlapsablon neve mezőben adja meg az űrlapsablon nevét és kattintson a Tovább gombra. A kiküldött e-mail üzenetekben az űrlapsablon neve lesz feltüntetve az e-mail üzenet tárgyaként.

  6. Másik lehetőségként a varázsló következő lapján létrehozhat az Outlook-mappákban megjelenő oszlopokat, melyek segítenek rendszerezni az e-mail üzeneteket.

  7. Kattintson a Tovább gombra.

  8. Kattintson a Közzététel gombra.

  9. Miután a Közzététel varázsló közzétette az űrlapsablont, megnyílik egy, az űrlapot tartalmazó e-mail üzenet.

  10. Töltse ki az üzenetet, írja be az alkalmazott nevét vagy használjon egy terjesztési listát, és küldje el az üzenetet.

Az Outlookban az önálló döntéshozó az összes beküldött XML-űrlapot kétféleképpen rendezheti:

  • Ha az üzenet első megnyitásakor megjelenik az InfoPath űrlapmappák üzenetablak, kattintson az Űrlapmappa létrehozása lehetőségre.

  • Hozzon létre az Outlookban egy szabályt, amely alapján az összes kapcsolódó InfoPath-űrlapot egy InfoPath-mappába helyezi a rendszer.

    További tudnivalókért olvassa el az üzenetkezelés szabályok használatávalcímű témakört.

Vissza a lap tetejére

5. lépés: Űrlapok importálása az Excelbe

Mivel a 2. és 3. lépésekben már létrehozta az Excel-munkafüzetet, egyszerű lesz az önálló döntéshozónak az űrlapadatokat exportálni és áttekinteni. A döntéshozónak már csak az XML-fájlokat (.xml) kell exportálni az Outlookból, ezután minden űrlapfájlt (.xml) importálni az Excel-munkafüzetbe, végül frissíteni az adatokat.

1. Feladat: Az űrlapok exportálása az Outlookból egy Windows-mappába

  1. Az Outlook alkalmazásban jelölje ki azt a mappát, amely az alkalmazottaktól kapott űrlapokat tartalmazza, majd a CTRL+A billentyűkombinációval jelölje ki az összes űrlap formátumú e-mail üzenetet.

  2. Kattintson a jobb gombbal a kijelölésre, mutasson az InfoPath-műveletekre, majd kattintson az Űrlapok exportálása lehetőségre.

  3. Az Űrlapok exportálása párbeszédpanelen válasszon egy mappát, majd kattintson az OK gombra.

2. feladat: Importálja az űrlapokat az Excelbe.

  1. A 2. lépésben létrehozott munkafüzetben: Képezze le a sémafájlt és szabja testre a táblázat elrendezését az Excelben, válassza ki az egyik megfeleltetett cellát az Excel-táblázatban.

  2. A Fejlesztőeszközök lap XML csoportjában kattintson az Importálás gombra.

    A menüszalag XML csoportja

    Megjelenik az XML importálása párbeszédpanel.

  3. Windows Vista rendszerű számítógépen:    

  4. Hajtsa végre a megfelelő műveletet:

    • Ha a fájlok folyamatosan helyezkednek el, nyomja le a SHIFT billentyűt, majd kattintson a lista legelső, utána pedig a legutolsó fájljára.

    • Ha a fájlok nem folyamatosan helyezkednek el, nyomja le a CTRL billentyűt, majd kattintson a lista importálni kívánt fájljaira egyenként.

  5. Kattintson az Importálás gombra.

    Az importált adatok Excel-táblázata

Alapértelmezés szerint az Excel felülírja a megfeleltetett cellákban található adatokat, és éppen ez az üzleti megoldás kívánt végeredménye. Ugyanakkor az önálló döntéshozó akár többször is importálhatja az adatokat az ütemezett határidő lejárata előtt, hogy felmérje a haladást.

Megjegyzés : Az Excelben az adatokat az Új adatok hozzáfűzése a meglévő XML-táblázatokhoz lehetőség használatával is hozzáfűzheti (a Fejlesztőeszközök lapon az XML csoportban kattintson a Tulajdonságok leképezése lehetőségre), ez más megoldásoknál is megfelelő lehet.

További tudnivalókért lásd: az Excel súgótémakörök importálása XML-adatok és hozzáfűző vagy megfeleltetett XML-adatok felülírása.

3. feladat: A Kimutatás és a kimutatásdiagramok frissítése

  • Kattintson a kimutatás egyik cellájára.

  • A Beállítások lap Adatok csoportjában kattintson Az összes frissítése lehetőség melletti nyílra, majd kattintson a Frissítés gombra.

    Az Outlook menüszalagja

Végleges kimutatás és kimutatásdiagramok

Az Excel-munkafüzet ezután már az összes olyan adatot és összefoglaló jelentést tartalmazza, amely a jövő évi, berendezésre felhasználható költségvetés felosztásához szükséges. Természetesen szükség szerint további elemzéseket is végezhet az Excel-munkafüzetben, mint például az adatok rendezése, szűrése vagy feltételes formázása.

Vissza a lap tetejére

Záró gondolatok: Fontolja meg SharePoint-lista vagy Access-adatbázis használatát.

Másik lehetőségként fontolja meg XML-fájlok helyett egy SharePoint-lista vagy Access-adatbázis használatát az InfoPath és az Excel közötti adatátvitelhez.

Használjon SharePoint-listát.

Az InfoPath alkalmazásból egyszerűen használhat SharePoint-listát írásvédett adatforrásként. A következő két lehetőség közül választhat:

  • A SharePoint-listából exportálhatja az adatokat az Excelbe, ezáltal automatikusan létrejön egy adatkapcsolat az Excellel.

  • Az Excelből hozzon létre külön adatkapcsolatot a SharePoint-listával.

Miután létrejött az adatkapcsolat, az Excelben frissítve az adatokat, naprakész adatokat szerezhet.

A SharePoint-listát adatok hozzáadására és módosítására, az InfoPath-űrlapot listaelemek megjelenítésére használhatja (összetett vagy hosszú elemet célszerű függőleges elrendezésben megjeleníteni), végül az Excelt az adatok további elemzésére használhatja.

Az InfoPath, egy SharePoint-lista és az Excel kombinálása

1. Adott elemet egyszerű áttekintésre az InfoPath alkalmazásban is megjeleníthet.

2. Adatok hozzáadását és módosítását SharePoint-listában is végezheti.

3. Frissítse és készítse naprakészen jelentéseit az Excelben.

További információt az Adatkapcsolat hozzárendelése SharePoint-dokumentumtárhoz vagy -listához vagy az Adatok importálása SharePoint-listából című témakörben talál.

Használjon Access-adatbázist.

Az InfoPath alkalmazásból olvasási és írási kapcsolatot hozhat létre az Access-adatbázissal. Az Excelben létrehozhat külön adatkapcsolatot az Access-adatbázishoz, amelyet frissítve naprakész adatokat szerezhet. Ha szükséges, beállíthatja, hogy a kapcsolat automatikusan frissüljön egy munkafüzet megnyitásakor, vagy beállíthatja az időnkénti (például 5 percenként történő) frissítést is.

Az Access-adatbázist az InfoPath és az Excel között közvetítőként használhatja. Ha az Accessbe elküld egy InfoPath-űrlapot, akkor frissíti az Access-adatbázist. Ha az Excelben frissíti az adatkapcsolatot, akkor beolvassa az Accessből a frissített adatokat. Ebben az értelemben közvetetten küldi az InfoPath alkalmazásból az adatokat egy Excel-munkafüzetbe.

Az InfoPath, az Access és az Excel kombinálása

1. Jelenítse meg és küldje el az űrlapokat az Access-adatbázisba.

2. Tárolja adatait Access-adatbázisban.

3. Frissítse és készítse naprakészen jelentéseit az Excelben.

További információt a Microsoft Access-adatbázison alapuló űrlapsablon tervezése című témakörben talál.

Tipp : Tudta, hogy létrehozhat InfoPath-űrlapokat közvetlenül az Access 2007 alkalmazásban is? Ha számítógépén telepítve van az Outlook 2007 és az InfoPath 2007 program, akkor az Adatgyűjtés e-mail üzenetekkel varázsló használatával közvetlenül az Access 2007 programból gyűjthet adatot különböző felhasználóktól. További információt az Access 2007 Súgó Adatgyűjtés e-mail üzenetekkel című témakörében talál.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×