Egymásra épülő lista létrehozása

Az egymásra épülő listákkal a felhasználók gyorsabban tölthetik ki az űrlapokat, és a felhasználók által megadott adatok pontossága is biztosított. A cikkből megtudhatja, hogyan hozhat létre egymásra épülő listákat, és hogyan töltheti fel azokat adatokkal. A Microsoft Office InfoPath alkalmazásban olyan adatokkal is feltölthet egy listát, amelyek egy űrlap, egy Extensible Markup Language (XML) dokumentum vagy egy Microsoft Office Access-adatbázis értékeit használják.

Tartalom

Mi az egymásra épülő lista?

1. lépés: Egymásra épülő lista beillesztése

2. lépés: Az adatok megadása

Mi az egymásra épülő lista?

Az egymásra épülő lista olyan lista, amelyben a választások a felhasználó által egy másik listában kiválasztott értékektől függően változnak. Például ha a felhasználó az illusztráción is látható módon rákattint a Kategóriák mező Fűszerek elemére, a Termékek mezőben megjelenik a fűszerek listája.

Egymásra épülő lista – példa

Az alábbi szakaszok bemutatják, hogyan tervezhet két, egymásra épülő listával ellátott űrlapsablont, amelyen a második lista szűrését az első listából a felhasználó által választott érték határozza meg. Ha az első lista értéke megváltozik, a szűrő automatikusan érvényes lesz a második listára, amelynek megváltoznak az értékei.

Kompatibilitási kérdések:

A szűrők csak az InfoPath alkalmazásban kitöltésre kerülő űrlapsablonok esetében használhatók. A szűrők nem használhatók böngészőkompatibilis űrlapsablonokban.

Vissza a lap tetejére

1. lépés: Egymásra épülő lista beillesztése

Az egymásra épülő lista létrehozásához illesszen be két listát az űrlapsablonba.

Megjegyzés : Ha egymásra épülő listát illeszt be az űrlapsablonba, győződjön meg arról, hogy a két lista nem képezi egy ismétlődő szakasz vagy ismétlődő táblázat részét.

  1. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  2. A Vezérlők munkaablak Vezérlők beszúrása lehetőségénél kattintson a Legördülő lista elemre. Amikor a felhasználó kitölt egy, az űrlapsablonon alapuló űrlapot, a legördülő lista kijelölése meghatározza a második listában elérhető választási lehetőségeket.

  3. Kattintson a Lista lehetőségre. Az űrlapsablonban most már szerepelnie kell egy legördülő listának és egy egyszerű listának.

    Listát és legördülő listát tartalmazó űrlap

  4. Kattintson duplán a 2. lépésben az űrlapsablonba illesztett legördülő listára.

  5. A Legördülő lista tulajdonságai párbeszédpanelen kattintson az Adatok lapra.

  6. A Mezőnév mezőbe írja be a következőt: lista1, majd kattintson az OK gombra.

  7. Kattintson duplán a 3. lépésben az űrlapsablonba illesztett listára.

  8. A Listapanel tulajdonságai párbeszédpanelen kattintson az Adatok lapra.

  9. A Mezőnév mezőbe írja be a következőt: lista2Egymasraepulo, majd kattintson az OK gombra.

Vissza a lap tetejére

2. lépés: Az adatok megadása

Most, hogy beillesztette a listákat az űrlapsablonba, meg kell adnia a megjelenítendő adatokat. Ezután egy szűrőt (szűrő) kell alkalmaznia, amely meghatározza, hogy a második lista választási lehetőségei hogyan változzanak az első listában a felhasználó által kiválasztott lehetőségek függvényében.

Ebből a szakaszból megtudhatja, hogyan kapcsolhatja össze a listákat az adatokkal három alapvető módszerrel: az adatok hozzáadásával az űrlaphoz; az űrlapot egy meglévő, adatokat tartalmazó XML-dokumentumhoz csatlakoztatva; vagy az űrlapot egy adatokat tartalmazó adatbázishoz csatlakoztatva. Az egymásra épülő lista befejezéséhez az alábbi listában kattintson rá a használni kívánt módszerre.

Adatok gyűjtése az űrlapból

Csatlakoztatás XML-dokumentumhoz

Csatlakoztatás adatbázishoz

Adatok gyűjtése az űrlapból

Ebben a szakaszban megtanulhatja, hogyan tölthetők fel adatokkal a listák az űrlapról. Ehhez először úgy kell beállítania az űrlapsablon mezőit, hogy megadhassa a kategóriák nevét, és minden kategóriához a termékek egy csoportját.

Mezők beállítása az űrlapsablonban

  1. Ha az Adatforrás munkaablak nem látható, kattintson a Nézet menü Adatforrás parancsára.

  2. Az Adatforrás munkaablakban kattintson jobb gombbal a sajátMezők csoportra, majd a Hozzáadás elemre.

  3. A Mező vagy csoport hozzáadása párbeszédpanelen a Név mezőbe írja be a KategóriákÉsTermékek megnevezést.

  4. A Típus listában kattintson a Csoport elemre.

  5. Jelölje be az Ismétlődő jelölőnégyzetet, és kattintson a OK gombra.

  6. A Adatforrás munkaablakban kattintson a jobb gombbal a KategóriákÉsTermékek csoportra.

  7. A Mező vagy csoport hozzáadása párbeszédpanelen található Név mezőbe írja be a Kategória megnevezést, majd kattintson az OK gombra. Ez a mező fogja tartalmazni az első listában megjelenő kategóriák nevét.

  8. Kattintson a jobb gombbal a KategóriákÉsTermékek csoportra, majd a Hozzáadás lehetőségre.

  9. A Mező vagy csoport hozzáadása párbeszédpanelen található Név mezőbe írja be a Termék megnevezést.

  10. Jelölje be az Ismétlődő jelölőnégyzetet, majd kattintson az OK gombra. Ez a mező fogja tartalmazni a második listában megjelenő termékek nevét.

Mivel ez a lista az űrlap adatait tartalmazza, az adatokat hozzá kell adni az űrlaphoz. Ehhez létre kell hoznia a Termék és a Kategória mezők alapértelmezett értékeit.

Tipp

Olyan listákat is létrehozhat, amelyek megjelenítik a felhasználók által az űrlapon beírt értékeket. Ehhez társítania kell a listát az űrlap vezérlőihez kötött mezőkkel. Ha egy felhasználó értékeket ad meg a vezérlőkben, a lista választási lehetőségei megváltoznak.

Alapértelmezett értékek létrehozása

  1. Kattintson az Eszközök menü Alapértelmezett értékek parancsára.

  2. Az Alapértékek szerkesztése párbeszédpanel KategóriákÉsTermékek csoportjában válassza a Kategória mezőt (ne szüntesse meg a jelölőnégyzet jelölését), majd az Alapértelmezett érték mezőbe írja be a Tenger gyümölcsei értéket.

  3. Jelölje ki a Termék mezőt (ügyeljen arra, hogy ne szüntesse meg a jelölőnégyzet jelölését), majd az Alapérték mezőbe írja be a Rákhús megnevezést.

  4. Kattintson a jobb gombbal a Termék mezőbe, majd kattintson az Másik Termék hozzáadása a jelenlegi alatt lehetőségre. Így egy második terméket adhat hozzá alapértelmezett értékként a Tenger gyümölcsei kategóriához.

  5. Kattintson a jobb gombbal a Termék mező második példányára (ügyeljen arra, hogy ne szüntesse meg a jelölőnégyzet jelölését), majd az Alapértelmezett érték mezőbe írja be a Lazac megnevezést.

  6. Kattintson a jobb gombbal a KategóriákÉsTermékek csoportra, majd az Másik KategóriákÉsTermékek hozzáadása a jelenlegi fölött lehetőségre. Így egy második kategóriát adhat hozzá alapértelmezett értékként.

  7. Az előző lépések segítségével adja meg a Kategória és Termék mezők második példányának alapértelmezett értékeit a Tejtermékek, a Cheddar és a Csokoládés tej csoportokhoz.

  8. Kattintson az OK gombra.

Most, hogy megadta a Termék és Kategória mező alapértelmezett értékét, csatlakoztathatja az első listát a most megadott adatokhoz.

Az első lista csatlakoztatása az adatokhoz

  1. Kattintson duplán a korábban az űrlapsablonba illesztett legördülő listára.

  2. Kattintson az Adatok fülre.

  3. A Legördülő lista tulajdonságai párbeszédpanel Listaelemek lehetőségénél kattintson az Adatok keresése az űrlap adatforrásában elemre.

  4. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  5. A Mező vagy csoport kijelölése párbeszédpanel KategóriákÉsTermékek csoportjában kattintson a Kategória mezőre, és kattintson kétszer az OK gombra.

Most csatlakoztassa a második listát az adatokhoz. Az adatkapcsolat létrehozása közben alkalmazzon egy szűrőt a második listára. Ez a szűrő az első listánál kiválasztott kategória alapján a megfelelő termékekkel tölti fel a második listát. A szűrő összehasonlítja az első listában kiválasztott értéket (lista1 mező) az űrlapon elmentett kategóriák listájával (Kategória mező).

A második lista csatlakoztatása az adatokhoz

  1. Kattintson duplán a korábban az űrlapsablonba illesztett egyszerű listára.

  2. Kattintson az Adatok fülre.

  3. A Listapanel tulajdonságai párbeszédpanel Listaelemek lehetőségénél kattintson az Adatok keresése az űrlap adatforrásában elemre.

  4. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  5. A Mező vagy csoport kijelölése párbeszédpanel KategóriákÉsTermékek csoportjában kattintson a Termék mezőre, és kattintson az Adatok szűrése gombra.

  6. Az Adatok szűrése párbeszédpanelen kattintson a Hozzáadás gombra.

  7. A Szűrőfeltételek megadása párbeszédpanelen kattintson a Mező vagy csoport kijelölése lehetőségre az első mezőben.

  8. A Mező vagy csoport kijelölése párbeszédpanelen kattintson a lista1 mezőre, majd az OK gombra.

  9. A Szűrőfeltételek megadása párbeszédpanelen kattintson a Mező vagy csoport kijelölése lehetőségre a harmadik mezőben.

  10. A Mező vagy csoport kijelölése párbeszédpanelen kattintson a Kategória mezőre, majd az OK gombra az összes megnyitott párbeszédpanel bezárásához.

Most, hogy a második listát is a megfelelő adathoz kötötte, ellenőrizze, hogy a listák megfelelően működnek-e.

A listák tesztelése

  1. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  2. A legördülő listában kattintson a Tenger gyümölcsei elemre. Az egyszerű listában egy üres sornak, a Rákhús és a Lazac elemeknek kell megjelennie.

    Megjegyzés : Az üres sor lehetővé teszi, hogy a felhasználók töröljék a választásukat a listában.

Ha a listák nem működnek megfelelően, ellenőrizze, hogy a második listán alkalmazott szűrő valóban a lista1 és a Kategória mező összehasonlítását végzi-e.

Vissza a szakasz elejére

Csatlakoztatás XML-dokumentumhoz

Ebben a szakaszban megtanulhatja, hogyan hozhat létre adatkapcsolatot egy termék- és kategóriaértékeket tartalmazó XML-dokumentummal. Az XML-dokumentum lesz a másodlagos adatforrás. Az adatkapcsolat létrehozásához létre kell hoznia az XML-dokumentumot, társítania kell az űrlap listáit az XML-dokumentummal, és egy szűrőt kell alkalmaznia a második listára, hogy a termékek listája a megfelelő módon változzon.

Mielőtt az űrlapot egy másodlagos adatforráshoz társítja, létre kell hoznia az XML-dokumentumot.

Az XML-dokumentum létrehozása

  1. Indítsa el a Jegyzettömböt vagy egy másik szövegszerkesztőt.

  2. Másolja ki, majd illessze be az alábbi XML-kódot a szövegszerkesztőbe:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Mentse a fájlt ListaAdat.xml néven.

Most, hogy a létrehozott XML-dokumentumot, csatlakoztathatja az űrlapsablonhoz. Ez egy másodlagos adatforrást hoz létre.

Az XML-dokumentum csatlakoztatása az űrlapsablonhoz

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban kattintson az Adatok fogadása elemre, majd a Tovább gombra.

  4. A varázsló következő lapján kattintson az XML-dokumentum lehetőségre, majd a Tovább gombra.

  5. A varázsló következő lapján kattintson a Tallózás lehetőségre, válassza ki az elmentett ListaAdat.xml fájlt, majd kattintson a Megnyitás gombra.

  6. A varázsló következő oldalán kattintson az Adatok felvétele az űrlapsablonba vagy vezérlősablonba erőforrásfájlként lehetőségre, majd a Tovább gombra.

  7. A varázsló következő oldalán, az Adja meg az adatkapcsolat nevét mezőbe írja be a listaAdatXMLfájl értéket.

  8. Jelölje be az Automatikus adatbeolvasás az űrlap megnyitásakor jelölőnégyzetet. Ez garantálja, hogy a mező adatai az űrlap minden megnyitásánál elérhetők lesznek ahelyett, hogy a felhasználónak le kellene kérdeznie őket.

  9. Kattintson a Befejezés gombra.

  10. Az Adatkapcsolatok párbeszédpanelen kattintson a Bezárás lehetőségre.

Most már készen áll, hogy az űrlapsablon első listáját csatlakoztassa az XML-dokumentum adataihoz.

Az első lista csatlakoztatása az adatokhoz

  1. Kattintson duplán a korábban az űrlapsablonba illesztett legördülő listára.

  2. Kattintson az Adatok fülre.

  3. A Legördülő lista tulajdonságai párbeszédpanel Listaelemek lehetőségénél kattintson az Adatok keresése külső adatforrásban elemre.

  4. Az a Adatforrás mezőben kattintson a listaAdatXMLfájl elemre.

  5. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  6. A Mező vagy csoport kijelölése párbeszédpanel KategóriákÉsTermékek csoportjában kattintson a Kategóriák mezőre.

    Megjegyzés : A Mező vagy csoport kijelölése párbeszédpanel sárga háttérszíne jelzi, hogy másodlagos adatforrással dolgozik.

  7. Kattintson az OK gombra, majd a még nyitva lévő másik párbeszédpanel OK gombjára.

Most a második listát is csatlakoztatnia kell az XML-dokumentumhoz. Az adatkapcsolat létrehozása közben alkalmazzon szűrőt a második listára. Ez a szűrő az első listánál kiválasztott kategória alapján a megfelelő termékekkel tölti fel a második listát. A szűrő összehasonlítja az első listában kiválasztott értéket (lista1 mező) az űrlapon elmentett kategóriák listájával (Kategória mező).

A második lista csatlakoztatása az adatokhoz

  1. Kattintson duplán a korábban az űrlapsablonba illesztett egyszerű listára.

  2. Kattintson az Adatok fülre.

  3. A Listapanel tulajdonságai párbeszédpanel Listaelemek lehetőségénél kattintson az Adatok keresése külső adatforrásban elemre.

  4. Az a Adatforrás mezőben kattintson a listaAdatXMLfájl elemre.

  5. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  6. A Mező vagy csoport kijelölése párbeszédpanel KategóriákÉsTermékek csoportjában bontsa ki a Termék csoportot, és kattintson a Termék mezőre.

  7. Kattintson az Adatok szűrése gombra.

  8. Az Adatok szűrése párbeszédpanelen kattintson a Hozzáadás gombra.

  9. A Szűrőfeltételek megadása párbeszédpanelen kattintson a Mező vagy csoport kijelölése lehetőségre az első mezőben.

  10. A Mező vagy csoport kijelölése párbeszédpanelen található Adatforrás mezőben válassza a lehetőséget.

  11. Kattintson a lista1 elemre, majd az OK gombra.

  12. A Szűrőfeltételek megadása párbeszédpanelen kattintson a Mező vagy csoport kijelölése lehetőségre a harmadik mezőben.

  13. A Mező vagy csoport kijelölése párbeszédpanel Adatforrás mezőjében kattintson a listaAdatXMLFájl (másodlagos) lehetőségre, majd a Kategóriák elemre.

  14. Az OK gombra kattintva zárja be az összes megnyitott párbeszédpanelt.

Most, hogy elvégezte mindkét lista XML-dokumentumhoz való csatlakoztatását és beállította a szűrőt, ellenőrizze, hogy a listák megfelelően működnek-e.

A listák tesztelése

  1. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  2. A legördülő listában kattintson a Tenger gyümölcsei elemre. Az egyszerű listában egy üres sornak, a Rákhús és a Lazac elemeknek kell megjelennie.

    Megjegyzés : Az üres sor lehetővé teszi, hogy a felhasználók töröljék a választásukat a listában.

Ha a listák nem működnek megfelelően, ellenőrizze, hogy a második listán alkalmazott szűrő valóban a lista1 és a Kategória mező összehasonlítását végzi-e.

Vissza a szakasz elejére

Csatlakoztatás adatbázishoz

Ebben a szakaszban megtanulhatja, hogyan hozhat létre adatkapcsolatot egy Access-adatbázisban két táblázatához. Ehhez az űrlapsablon listáit társítania kell az adatbázissal, majd egy szűrőt kell alkalmaznia a második listára, hogy a második listában megjelenő lista az első listában kiválasztott értéknek megfelelően változzon. Ebben a példában feltételezzük, hogy az Access-adatbázis a Kategóriák és Termékek táblázatokat tartalmazza, és hogy a két táblázat a Kategóriaazonosító mező alapján kapcsolódik egymáshoz, amely mindkét táblázatban szerepel.

Kategóriák tábla    

Kategóriaazonosító

KategóriaNév

1

Hal

2

Tejtermékek

Termékek tábla    

TermékAZ

Kategóriaazonosító

TermékNév

1

1

Rákhús

2

1

Lazac

3

2

Csokoládés tej

4

2

Cheddar

Az űrlapsablon csatlakoztatása az adatforráshoz

Első lépésként létre kell hoznia egy adatkapcsolatot az űrlapsablon és az adatbázis táblázatai között. Mivel csak megjeleníti az adatbázis adatait, és nem módosítja őket közvetlenül, az Access-adatbázis egy másodlagos adatforrás lesz az űrlapsablon számára.

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban kattintson az Adatok fogadása elemre, majd a Tovább gombra.

  4. A varázsló következő lapján jelölje be az Adatbázis (csak Microsoft SQL Server vagy Microsoft Office Access) választógombot, majd kattintson a Tovább gombra.

  5. A varázsló következő lapján kattintson az Adatbázis kijelölése gombra, majd tallózzon a számítógép merevlemezén a Access-adatbázishoz, és kattintson rá duplán.

  6. A Táblázat kijelölése párbeszédpanelen kattintson az első listában megjeleníteni kívánt adatokat tartalmazó táblázatra (a példában a Kategóriák tábla), majd az OK gombra. Ezzel ez a táblázat lesz az adatkapcsolat elsődleges táblázata.

  7. Kattintson a varázsló Tábla hozzáadása gombjára.

  8. A Tábla vagy lekérdezés hozzáadása párbeszédpanelen kattintson a második listában megjeleníteni kívánt adatokat tartalmazó táblázatra (a példában a Termékek tábla) listában, majd a Tovább gombra.

  9. A Kapcsolat szerkesztése párbeszédpanelen győződjön meg arról, hogy a csatlakozó mezők helyesek. Ebben a példában a táblák a Kategóriaazonosító mező alapján kapcsolódnak egymáshoz.

    Tipp : Ha a csatlakozó mezők helytelenek, jelölje ki a mezőket, és kattintson a Kapcsolat törlése lehetőségre. Kattintson a Kapcsolat hozzáadása lehetőségre, jelölje ki a megfelelő mezőket, és kattintson az OK gombra.

  10. Kattintson a Befejezés gombra.

    Megjegyzés : Ebben a példában a kategóriák táblázat egy-a-sokhoz kapcsolatban áll a termékek táblázattal, ami azt jelenti, hogy minden egyes kategóriához sok termék kapcsolódhat. Az adatbázisban az ilyen típusú kapcsolatokat általában kulcsmezőkkel hozzák létre. Ebben az esetben a Kategóriaazonosító kulcsmező lehetővé teszi, hogy az Access a termékek megfelelő készletét a megfelelő kategóriával társítsa össze.

  11. A varázslóban tekintse át az adatforrás szerkezetét. Két, egymáshoz kapcsolódó táblázatnak kell megjelennie: Az elsődleges és a másodlagos táblázatnak. A tábla egyes mezőinek megjelenítéséhez jelölje be a Tábla oszlopainak megjelenítése jelölőnégyzetet. Miután végzett az adatszerkezet megtekintésével, kattintson a Tovább gombra.

  12. Törölje az Adatok másolatának tárolása az űrlapsablonban négyzet jelölését, majd kattintson a Tovább gombra.

  13. A varázsló következő lapján, az Adja meg az adatkapcsolat nevét mezőben adja meg az adatküldési kapcsolat nevét.

  14. Jelölje be az Automatikus adatbeolvasás az űrlap megnyitásakor jelölőnégyzetet.

  15. Kattintson a Befejezés gombra, majd az Adatkapcsolatok párbeszédpanelen kattintson a Bezárás lehetőségre.

Az első lista csatlakoztatása adatokhoz

Most, hogy adatkapcsolatot hozott létre a másodlagos adatforráshoz, csatlakoztathatja az űrlap első listáját az adatbázis táblázataihoz.

  1. Kattintson duplán a korábban az űrlapsablonba illesztett legördülő listára.

  2. Kattintson az Adatok fülre.

  3. A Legördülő lista tulajdonságai párbeszédpanel Listaelemek lehetőségénél kattintson az Adatok keresése külső adatforrásban elemre.

  4. Az Adatforrás mezőben győződjön meg arról, hogy az Ön által létrehozott adatkapcsolat van-e kijelölve.

  5. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  6. A Mező vagy csoport kijelölése párbeszédpanelen kattintson a legördülő listában megjeleníteni kívánt adatokat tartalmazó táblázat nevére (a példában a d:Kategóriák), majd az OK gombra.

    Megjegyzés : A Mező vagy csoport kijelölése párbeszédpanel sárga háttérszíne jelzi, hogy másodlagos adatforrással dolgozik.

  7. Kattintson az Érték mező melletti XPath kijelölése Gombkép gombra.

  8. A Mező vagy csoport kijelölése párbeszédpanelen ellenőrizze, hogy az csatlakozó mező (ebben a példában :Kategóriaazonosító) ki van kijelölve, és kattintson az OK gombra. Amikor a felhasználó kiválaszt egy elemet a listából, ezt az értéket menti a program.

  9. Kattintson a Megjelenítendő név mező melletti XPath kijelölése Gombkép gombra.

  10. A Mező vagy csoport kijelölése párbeszédpanelen kattintson a legördülő listában megjeleníteni kívánt mező nevére (a példában a :KategóriaNév).

  11. Kattintson az OK gombra, majd a még nyitva lévő másik párbeszédpanel OK gombjára.

A második lista csatlakoztatása adatokhoz

Most a második listát is csatlakoztatnia kell az adatbázishoz. Az adatkapcsolat létrehozása közben alkalmazzon szűrőt a második listára. Ez a szűrő az első listánál kiválasztott értékek alapján a megfelelő értékkel tölti fel a második listát.

  1. Kattintson duplán az űrlapsablon egyszerű listájára.

  2. Kattintson az Adatok fülre.

  3. A Listapanel tulajdonságai párbeszédpanel Listaelemek lehetőségénél kattintson az Adatok keresése külső adatforrásban elemre.

  4. Az Adatforrás mezőben győződjön meg arról, hogy az Ön által létrehozott adatkapcsolat van-e kijelölve.

  5. Kattintson a Bejegyzések mező melletti XPath kijelölése Gombkép gombra.

  6. A Mező vagy csoport kijelölése párbeszédpanelen bontsa ki az elsődleges csoportot (ebben a példában :Kategóriák), majd kattintson arra a másodlagos csoportra, amely megfelel az egymásra épülő listában megjeleníteni kívánt adatokat tartalmazó táblázatnak (a példában Termékek).

  7. Kattintson az Adatok szűrése gombra.

  8. Az Adatok szűrése párbeszédpanelen kattintson a Hozzáadás gombra.

  9. A Szűrőfeltételek megadása párbeszédpanel első mezőjében ellenőrizze, hogy a másodlagos táblázat csatlakozó mezője (ebben a példában Termékek) ki van kijelölve.

    Fontos : Ha a csatlakozó mezők nevet mindkét táblázatban egyezik, győződjön meg arról, hogy a helyes mezőt választja ki. A program összerendezi az egyes táblázatok mezőit a listában, emiatt a környező mezőnevek alapján meghatározhatja, hogy melyik a helyes. Ebben a példában kiválasztjuk a Kategóriaazonosító mezőt, amely a Termékek táblázat más mezőivel együtt jelenik meg.

  10. A harmadik mezőben kattintson a Mező vagy csoport kijelölése lehetőségre.

  11. A Mező vagy csoport kijelölése párbeszédpanelen levő Adatforrás mezőben válassza a lehetőséget, majd válassza a lista1 mezőt, ezt követően kattintson az OK gombra.

    Így beállított egy szűrőt, amely a legördülő listában (lista1) kiválasztott értéket összehasonlítja az egyszerű listában található értékekkel.

  12. Kattintson egymás után háromszor az OK gombra, és térjen vissza a Lista tulajdonságai párbeszédpanelhez.

  13. Kattintson az Érték mező melletti XPath kijelölése Gombkép gombra.

  14. A Mező vagy csoport kijelölése párbeszédpanelen jelölje ki azt az értéket, amelyet el szeretne menteni, amikor a felhasználó kijelölést végez a listában. Ebben a példában szeretnénk későbbi felhasználás céljából elmenteni a TermékAZ mezőt. Ezért jelölje ki a :TermékAZ csoportot, majd kattintson az OK gombra.

  15. Kattintson a Megjelenítendő név mező melletti XPath kijelölése Gombkép gombra.

  16. A Mező vagy csoport kijelölése párbeszédpanelen kattintson a listában megjeleníteni kívánt mező nevére (a példában a :TermékNév).

  17. Kattintson az OK gombra, majd a még nyitva lévő másik párbeszédpanel OK gombjára.

A listák tesztelése

Most, hogy a második listát is az adatbázishoz kötötte és beállította a szűrőt, ellenőrizze, hogy megfelelően működnek-e a listák.

  1. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

  2. Válasszon ki egy értéket a legördülő listából. Az egyszerű listában a választott csatlakozó mezőtől függően a másodlagos táblázat megfelelő értékeinek kell megjelennie.

Tipp : Ha a listák nem működnek megfelelően, ellenőrizze, hogy a második listán alkalmazott szűrő valóban a lista1 és a CategoryID mező összehasonlítását végzi-e.

Vissza a szakasz elejére

Vissza a lap tetejére

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×