Egyedi értékek megszámolása az ismétlődések között

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Tegyük fel, azt szeretné, megtudhatja, hogy hány egyedi számérték vagy szöveg tartományban vannak. Például ha egy oszlopban találhatók a szöveges értékeket Bradley, Kránitz, tartalmazza, Kránitz, két egyedi értékek is – Bradley és Kránitz. Ha a tartomány rendelkezik, a számokat az 5, 6, 7, 6, egyedi értékei 5, 6 és 7.

Ha csak az egyedi értékeket szeretné meghatározni, használja az alábbi függvények kombinációját a munkalapon látható példa alapján:

  • A HA függvény segítségével 1-es értéket rendelhet minden igaz feltételhez.

  • A SZUM függvénnyel összeadhatja az egyedi értékeket.

  • Az egyedi értékek megszámlálásához használja a GYAKORISÁG függvényt. Ez a függvény figyelmen kívül hagyja a szöveges értékeket és a nullát. Egy adott érték első előfordulásakor az érték előfordulásainak számával egyenlő értéket ad eredményül. Ugyanazon érték újbóli előfordulásakor a függvény eredménye 0 (nulla) lesz.

  • A HOL.VAN függvénnyel lekérheti egy szöveges érték adott tartományon belüli pozícióját. A GYAKORISÁG függvény az eredményül kapott érték alapján kiértékeli a megfelelő szövegértékeket.

  • A HOSSZ függvénnyel megkeresheti az üres cellákat. Az üres cellák hossza (karaktereinek száma) nulla (0).

Példa

A függvényeket használó képletek példáival úgy tud dolgozni, ha a táblázatot az Excelben egy üres munkalap A1 cellájába másolja.

Adatok

Adatok

986

Harmath

Kránitz

563

67

789

235

Harmath

Kránitz

689

789

Kránitz

143

56

237

67

235

Képlet

Leírás (eredmény)

=SZUM(HA(GYAKORISÁG(A2:A10;A2:A10)>0;1))

Az A2:A10 cellatartományban található egyedi számértékeket számolja meg úgy, hogy az üres cellákat és a szöveges értékeket nem számolja (4)

=SZUM(HA(GYAKORISÁG(HOL.VAN(B2:B10;B2:B10;0),HOL.VAN(B2:B10;B2:B10;0))>0,1))

A B2:B10 cellatartományban található egyedi szöveges és számértékeket számolja meg (a tartomány nem tartalmazhat üres cellákat) (7)

=SZUM(HA(GYAKORISÁG(HA(HOSSZ(A2:A10)>0,HOL.VAN(A2:A10;A2:A10;0);""); HA(HOSSZ(A2:A10)>0;HOL.VAN(A2:A10;A2:A10;0);""))>0;1))

Az A2:A10 cellatartományban található egyedi szöveges és számértékeket számolja meg úgy, hogy az üres cellákat és a szöveges értékeket nem számolja (6)

Megjegyzések: 

  • Ebben a példában szereplő képletek tömbképletként kell megadni. Jelölje ki a képletet tartalmazó cellákat, nyomja le az F2 billentyűt, és nyomja le a Ctrl + Shift + Enter billentyűkombinációt.

  • Ha lépésről lépésre követni szeretné egy függvény kiértékelését, jelölje ki a képletet tartalmazó cellát, majd kattintson a Képletek lap Képletvizsgálat csoportjában a Képletkiértékelő gombra.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×