Egyedi értékek megszámolása az ismétlődések között

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Tegyük fel, azt szeretné, megtudhatja, hogy hány egyedi számérték vagy szöveg tartományban vannak. Például ha egy oszlopban találhatók a szöveges értékeket Harmath, Kránitz, tartalmazza, Kránitz, két egyedi értékek is – Harmath és Kránitz. Ha a tartomány rendelkezik, a számokat az 5, 6, 7, 6, egyedi értékei 5, 6 és 7.

Ha csak az egyedi értékeket szeretné meghatározni, használja az alábbi függvények kombinációját a munkalapon látható példa alapján:

  • A Ha függvény segítségével 1-es értéket rendelhet minden igaz feltételhez.

  • Kövesse a SZUM függvénnyel összeadhatja az egyedi értékeket.

  • A gyakoriság függvény segítségével egyedi értékek megszámolása. Ez a függvény figyelmen kívül hagyja a szöveget és nulla értékek. Az adott érték első előfordulásának azt adja eredményül egy adott érték előfordulásainak száma megegyezik. Minden előfordulásakor ugyanezt az értéket, az első után a függvény 0 értéket adja eredményül.

  • Használja a Hol.van függvény egy szöveges érték helyének tartományban való visszatéréshez. A gyakoriság függvény az eredményül kapott értékkel használja, a megfelelő szöveges értékek ki szeretné számítani.

  • Használja a LEN függvény üres cellák kereséséhez. Üres cellák hosszúságúak egy (karaktert száma) 0.

Példa

A függvényeket használó képletek példáival úgy tud dolgozni, ha a táblázatot az Excelben egy üres munkalap A1 cellájába másolja.

Adatok

Adatok

986

Harmath

Kránitz

563

67

789

235

Harmath

Kránitz

689

789

Kránitz

143

56

237

67

235

Képlet

Leírás (eredmény)

=SZUM(HA(GYAKORISÁG(A2:A10;A2:A10)>0;1))

Az A2:A10 cellatartományban található egyedi számértékeket számolja meg úgy, hogy az üres cellákat és a szöveges értékeket nem számolja (4)

=SZUM(HA(GYAKORISÁG(HOL.VAN(B2:B10;B2:B10;0),HOL.VAN(B2:B10;B2:B10;0))>0,1))

A B2:B10 cellatartományban található egyedi szöveges és számértékeket számolja meg (a tartomány nem tartalmazhat üres cellákat) (7)

=SZUM(HA(GYAKORISÁG(HA(HOSSZ(A2:A10)>0,HOL.VAN(A2:A10;A2:A10;0);""); HA(HOSSZ(A2:A10)>0;HOL.VAN(A2:A10;A2:A10;0);""))>0;1))

Az A2:A10 cellatartományban található egyedi szöveges és számértékeket számolja meg úgy, hogy az üres cellákat és a szöveges értékeket nem számolja (6)

Megjegyzések: 

  • Ebben a példában szereplő képletek tömbképletként kell megadni. Jelölje ki a képletet tartalmazó cellákat, nyomja le az F2 billentyűt, és nyomja le a Ctrl + Shift + Enter billentyűkombinációt.

  • Ha lépésről lépésre követni szeretné egy függvény kiértékelését, jelölje ki a képletet tartalmazó cellát, majd kattintson a Képletek lap Képletvizsgálat csoportjában a Képletkiértékelő gombra.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×