Dokumentum adatai munkaablak tervezése az InfoPath alkalmazással

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Ez a cikk azt ismerteti, hogy a Microsoft Office InfoPath alkalmazással hogyan hozhat létre Microsoft Office Word 2007-, Microsoft Office Excel 2007- és Microsoft Office PowerPoint 2007-dokumentumokkal társított Dokumentum adatai munkaablakot.

Tartalom

A Dokumentum adatai munkaablakok ismertetése

Dokumentum adatai munkaablak tervezése

Egyéni Dokumentum adatai munkaablak létrehozása vagy szerkesztése SharePoint típusú tartalmakhoz

Dokumentum adatai munkaablak hozzáadása dokumentumokhoz

A Dokumentum adatai munkaablakok ismertetése

Az Office Word 2007-, az Office Excel 2007- és az Office PowerPoint 2007-dokumentumokban megjelenő Dokumentum adatai munkaablak használatával a felhasználók megtekinthetik és módosíthatják az egyes fájlok vagy dokumentumkezelő kiszolgálóra (például Windows SharePoint Services 3.0-alapú dokumentum-munkaterületi webhelyre vagy tárba) mentett tartalomtípusok tulajdonságait. Ezek a leíró adat is ismert tulajdonságok a fájlokat leíró vagy azonosító adatok. A felhasználók ezek alapján rendszerezhetik, azonosíthatják és kereshetik a dokumentumokat.

A dokumentum adatai munkaablak Microsoft Office InfoPath 2007 űrlap, amely is, és megjelenik a dokumentumon belül. Nem szükséges az InfoPath telepítve van a számítógépén 2007-es Microsoft Office rendszer dokumentum a dokumentum adatai munkaablak megjelenítéséhez, de Office InfoPath 2007 Tervező, vagy a dokumentum adatai munkaablak testreszabásához szükséges. Ha például szeretne testre szabni a dokumentum adatai munkaablak jeleníthet meg egy külső forrásból, például egy webszolgáltatásból adatokat, Office InfoPath 2007 a szeretné, hogy a dokumentum adatai munkaablak tervezése az kell használnia.

A dokumentum adatai munkaablak szabásával is felvehet logikájának, például az adatok érvényesítése, és fontos, hogy szervezete egyéni tulajdonságok hozzáadása. Ezenkívül általános mezőket tartalmazó vezérlősablon létrehozásával rendezheti a hatékony is felhasználhatja a dokumentum adatai munkaablak különböző 2007-es Office kiadás dokumentumtípusok szervezeten belül.

Vissza a lap tetejére

Dokumentum adatai munkaablak tervezése

Egyéni dokumentum adatai munkaablak tervezésekor használhatja az Office Word 2007, Office Excel 2007és Office PowerPoint 2007több dokumentum, vagy több dokumentum adatai munkaablak tervezése is. Például egy adott projekthez tartozó egyes dokumentumok esetén érdemes használni a dokumentum adatai munkaablak, az adott dokumentumokhoz csak használt egyedi mezők.

Akkor is, ha a szervezet több dokumentum adatai munkaablak használ, minden egyes tartalmazhat több közös tulajdonságok. Közös tulajdonságok egyszerűen vezérlősablonok, amikor a dokumentum adatai munkaablak tervezése, akkor fontolja meg vezérlősablonok. Létrehozásával és használatával vezérlősablonok, biztosíthatja, hogy fő metaadatok a szervezet nem következetes a hang, a struktúra és a működését. Például a szervezet minden dokumentum adatai munkaablak nevű szerző mellett a Beosztás mező felvenni lehet szükség. Ezeket a mezőket közös használó vezérlősablon megtervezésével egyszerűen újra felhasználhatja több dokumentum adatai munkaablak sablon részt.

Az alábbi eljárás ismerteti, hogy miként készíthet Dokumentum adatai munkaablakot az 2007-es Office kiadás-dokumentumokhoz.

  1. Kattintson a Fájl menü Űrlapsablon tervezése parancsára.

  2. Az Űrlapsablon tervezése párbeszédpanelen Az új sablon típusa csoportban jelölje be az Űrlapsablon választógombot.

  3. A Mit vegyen alapul mezőben jelölje ki az Üres ikont, majd kattintson az OK gombra. Ezt a lehetőséget választva az InfoPath definiálhatja az adatforrást az űrlapsablon tervezése folyamán.

    Az űrlapsablont elkészítheti XML-dokumentum vagy XML-séma (például a Dublin Core Properties) alapján. Sőt, a tervezéshez használhat webszolgáltatást, adatbázist vagy kapcsolattár-beállításokat is. Adatforráson alapuló űrlapsablonok tervezéséről további információkat a Lásd még szakaszban lévő hivatkozásokra kattintva olvashat.

  4. Tervezze meg az űrlapsablont Dokumentum adatai munkaablakként.

    Közös mezőket tartalmazó vezérlősablon létrehozásával akár a Dokumentum adatai munkaablak 2007-es Office kiadás-dokumentumtípusok közötti, szervezeten belüli újrafelhasználását is hatékonyan összehangolhatja. Ha létrehozott egy vezérlősablont, és felvette azt a Vezérlők munkaablakba, az alábbi eljárást követve beszúrhatja az űrlapsablonba.

    1. Helyezze a kurzort az űrlapsablon azon pontjára, ahová be szeretné szúrni a vezérlősablont.

    2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

    3. A Vezérlők beszúrása listából válassza ki az Egyéni elemet, majd kattintson annak a vezérlősablonnak a nevére, amelyet be szeretne szúrni.

      Vezérlősablon az űrlapsablon egy szakaszában vezérlőn belül jelenik meg. Az űrlapsablonon ismeri a vezérlősablon is fel, mert a szavakat szakasz (Vezérlősablon: név) jelennek meg a szakasz sorfelirataként jeleníti meg, ha nevem rész a sablonfájl nevét.

      Vezérlősablonra utaló címke az űrlapsablonon

  5. Nevezze át az űrlapsablon alapértelmezett nézetét és más nézeteit.

    Hogyan?

    1. Válassza a Nézet menü Nézetek kezelése parancsát.

    2. A Nézetek munkaablakban jelölje ki az átnevezni kívánt nézetet, majd kattintson a Nézet tulajdonságai gombra.

    3. Kattintson az Általános fülre.

    4. A Nézet neve mezőben adjon új nevet a nézetnek.

    Megjegyzés : Ha az űrlapsablon csak egy nézetet tartalmaz, akkor is érdemes azt a nézetet egyszerű névvel ellátni (például Egyéni tulajdonságok), mert a Dokumentum adatai munkaablak megtekintésekor a név megjelenik a Tulajdonságnézetek és -beállítások listában.

  6. Egy megosztott hálózati mappában tegye közzé a Dokumentum adatai munkaablakot.

    Hogyan?

    1. Kattintson a Fájl menü Közzététel parancsára.

    2. A Közzététel varázslóban kattintson a Hálózati hely elemre, majd a Tovább gombra.

    3. A varázsló következő lapján kattintson a Tallózás gombra.

    4. Tallózással keresse meg azt a megosztott hálózati mappát, amelyben az űrlapsablont közzé szeretné tenni, és kattintson az OK gombra.

    5. A varázsló következő lapján ellenőrizze, hogy az Űrlapsablon neve mezőben látható elérési út és sablonnév helyes-e, majd kattintson a Tovább gombra.

    6. A varázsló következő lapján, ha egy új elérési utat kell a megosztott hálózati meghajtón, például egy nyilvános egységes erőforrás megnevezés (URL), írja be a mezőbe az elérési utat, és kattintson a Tovább gombra.

    7. A varázsló következő lapján kattintson a Közzététel gombra.

      Ha az űrlapsablon közzététele sikerült, erről a varázsló utolsó lapján megerősítést kap.

    A Dokumentum adatai munkaablak SharePoint-webhelyen is közzétehető. Erről részletes információkat a Lásd még szakaszban lévő hivatkozásokra kattintva olvashat.

Vissza a lap tetejére

Egyéni Dokumentum adatai munkaablak létrehozása vagy szerkesztése SharePoint típusú tartalmakhoz

Ha dokumentum tartalomtípus vagy a (Microsoft Office SharePoint Server 2007 alkalmazást futtató kiszolgálókon elérhető) Dublin Core metaadatmezők alapján webhelytartalom-típust hoz létre, a SharePoint-tulajdonságok követéséhez a rendszer automatikusan létrehoz egy Dokumentum adatai munkaablakot. Ezt az Office InfoPath 2007 segítségével ugyanúgy testreszabhatja, mint bármely más InfoPath-űrlapsablont. A Dokumentum adatai munkaablak testreszabásához például az alábbi műveleteket végezheti el:

  • Különböző funkciók, például adatérvényesítés vagy feltételes formázás felvétele

  • Másodlagos adatkapcsolat hozzáadása a Dokumentum adatai munkaablakhoz, majd vezérlők felvétele az adatforrás mezőiből származó adatok megjelenítéséhez

  • Új nézet létrehozása, majd vezérlősablon hozzáadása olyan mezőkkel, amelyek révén a cég nyomon követheti az adatokat

    Megjegyzés : Ha egy Dokumentum adatai munkaablak SharePoint-tartalomtípussémán alapul, a munkaablak nem szabható testre olyan mezők felvételével, amelyek nem tartoznak a sémába. Ha a tartalomtípus-sémába mezőket szeretne felvenni (vagy abból mezőket szeretne eltávolítani), a tartalomtípus oszlopait kell módosítania.

Egyéni Dokumentum adatai munkaablak létrehozása vagy szerkesztése

  1. Kattintson a Fájl menü Űrlapsablon tervezése parancsára.

  2. Az Űrlapsablon tervezése párbeszédpanelen Az új sablon típusa csoportban jelölje be az Űrlapsablon választógombot.

  3. A Mit vegyen alapul listában jelölje ki az XML vagy séma elemet, és kattintson az OK gombra.

    Megjegyzés : Ne jelölje be a Csak böngészőkompatibilis funkciók engedélyezése jelölőnégyzetet, mert a Dokumentum adatai munkaablak nem egy webhely, hanem csak egy 2007-es Office kiadás-dokumentum részeként fog megjelenni.

  4. Az Adatforrás varázslóban írja be a SharePoint-kiszolgáló URL-címét, és kattintson a Tovább gombra.

  5. A Lista vagy webhely kijelölése listában jelölje ki a megfelelő tartalomtípust, és kattintson a Tovább gombra.

  6. Kattintson a Befejezés gombra.

    Megnyílik a tartalomtípus-sémának megfelelő Dokumentum adatai munkaablak.

  7. Végezze el a kívánt módosításokat a Dokumentum adatai munkaablakon, majd mentse az űrlapsablont.

    Megjegyzés : Mivel a Dokumentum adatai munkaablak az űrlapsablon fő adatforrását képező tartalomtípus-sémán alapul, a munkaablakot nem szabhatja testre olyan mezők felvételével, amelyek nem tartoznak a sémába. Ha a Dokumentum adatai munkaablakba úgy szeretne mezőket felvenni (vagy mezőket eltávolítani belőle), hogy új mezőket ad a tartalomtípus-sémához, a sémához kell oszlopokat adnia (vagy abból kell oszlopokat eltávolítania).

  8. Kattintson a Fájl menü Közzététel parancsára.

  9. A Közzétételi varázsló lapján jelölje be a Dokumentum adatai munkaablak sablonjaként SharePoint-webhely vagy -lista tartalomtípushoz (javasolt) választógombot, majd kattintson a Tovább gombra.

    Megjegyzés : A Dokumentum adatai munkaablak sablonjaként SharePoint-webhely vagy -lista tartalomtípushoz (javasolt) választógomb csak akkor jelenik meg a varázslónak ezen a lapján, ha a 3. lépésben az XML vagy séma elemet választotta.

  10. A varázsló következő lapján kattintson a Közzététel gombra.

    Ha az űrlapsablon közzététele sikerült, erről a varázsló utolsó lapján megerősítést kap.

Vissza a lap tetejére

Dokumentum adatai munkaablak hozzáadása dokumentumokhoz

Az egyéni Dokumentum adatai munkaablak létrehozását követően a használat előtt hozzá kell azt rendelnie egy dokumentumhoz. Ehhez első lépésként aktiválja a menüszalag Fejlesztőeszközök lapját azokban a programokban, amelyekben használni kívánja a Dokumentum adatai munkaablakot. Ezután megadhatja a Dokumentum adatai munkaablak helyét egy URL, UNC vagy URN elérési úttal. Továbbá választhatja a Dokumentum adatai munkaablak dokumentum megnyitásakor történő automatikus megjelenítését, és megadhatja, hogy a létrehozott egyéni tulajdonságok megjelenjenek-e alapértelmezés szerint a dokumentum megnyitásakor.

A következő eljárás azt ismerteti, hogy miként társítható a Dokumentum adatai munkaablak Office Word 2007, Office Excel 2007 vagy Office PowerPoint 2007 alkalmazásban készült dokumentumokkal.

  1. Kattintson a Microsoft Office Gombkép , majd A Programnév beállításai gombra. (A Programnév annak a programnak a neve, amelyben dolgozik. Kattintson például A Word beállításai gombra.)

  2. A Programnév beállításai párbeszédpanelen válassza a Népszerű elemek kategóriát, jelölje be a Fejlesztőeszközök lap megjelenítése a szalagon jelölőnégyzetet, és kattintson az OK gombra.

    A menüszalag a Microsoft Office Fluent felhasználói felület része.

  3. Az Office Fluent menüszalagon kattintson a Fejlesztőeszközök fülre, majd a Dokumentumpanel gombra.

  4. A Dokumentum adatai párbeszédpanel Egyéni sablon megadása (URL, UNC vagy URN) mezőbe írja be a dokumentummal társítani kívánt Dokumentum adatai munkaablak helyét.

  5. Ha a dokumentumban alapértelmezés szerint meg szeretné jeleníteni az egyéni tulajdonságokat, az Alapértelmezésként megjelenik listában válassza az Egyéni tulajdonságok elemet.

  6. Ha a Dokumentum adatai munkaablakot alapértelmezés szerint meg szeretné jeleníteni, jelölje be a Mindig jelenjen meg a Dokumentum adatai munkaablak a dokumentum megnyitásakor és első mentésekor jelölőnégyzetet.

Megtekintés és a tulajdonságainak módosítása a dokumentum adatai munkaablak Office Word 2007, Office Excel 2007és Office PowerPoint 2007dokumentumok mellett a Office Word 2007 felhasználók felveheti tulajdonságok a dokumentum adatai munkaablak a tulajdonság szabályozza a dokumentum maga. Például a cég címét több példányával felvehetők mint tulajdonság szabályozza a dokumentum. Ezek a vezérlők tulajdonság frissíti az adatokat a dokumentum adatai munkaablak formában.

További információkat arról, hogy miként adhat tulajdonságokat az Office Word 2007-dokumentumokhoz, a Lásd még szakaszban lévő hivatkozásokra kattintva olvashat.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×