Cellákban lévő karakterek számlálása a Mac Excel 2016-ban

Ha meg kell számolnia, hogy hány karakter van egy cellában, a HOSSZ függvényt használhatja. A függvény beszámítja a betűket, a számokat, az egyéb karaktereket és minden szóközt. Vegyük például a következő mondatot: „38 fok van, úgyhogy elmegyek strandra”. Ez (az idézőjelek nélkül) 37 karakter – 29 betű, 2 szám, 5 szóköz, valamint egy vessző.

  • Úgy használhatja a függvényt, hogy beírja a szerkesztőlécbe az =HOSSZ(cella) karaktersorozatot, és lenyomja az Enter billentyűt. A példákban a cella szóval a leszámlálni kívánt cellára (pl. B1) utalunk.

  • Ha egynél több cellában szeretné megszámolni a karaktereket, írja be a képletet, majd másolja be azt a többi cellába.

  • Ha összesíteni szeretné több cella karakterszámát, használja a SZUM függvényeket a HOSSZ függvénnyel. Például: =SZUM((HOSSZ(1. cella);HOSSZ(2. cella);(HOSSZ(3. cella)))). A példában a HOSSZ függvény megszámolja, hogy hány karakter van az egyes cellákban, a SZUM függvény pedig összeadja az eredményt.

  • Ha azt szeretné megszámolni, hogy hányszor szerepel egy konkrét karakter a cellákban, akkor használja a HOSSZ függvényt a HELYETTE függvénnyel együtt. Ha például tudni szeretné, hogy hány kis Z betű található egy adott cellában, akkor használja a következő képletet: =HOSSZ(cella1)-HOSSZ(HELYETTE(cella1,"z",""))

Tegyen egy próbát!

Írja be az alábbi adatokat egy új Excel-munkalapra. Kezdje az A1 cellában.

Szöveges karakterláncok

Képletek

Árvíztűrő tükörfúrógép

Árvíztűrő tükörfúrógép ÁRVÍZTŰRŐ

Árvíztűrő tükörfúrógép ÁRVÍZTŰRŐ TÜKÖRFÚRÓGÉP

Egy cella karaktereinek megszámolása

  1. Kattintson a B2 cellára.

  2. Írja be a cellába az =HOSSZ(A2) képletet, és nyomja meg az Enter billentyűt.

A képlet megszámolja az A2 cellában található karaktereket, amelyek száma 19, beleértve a szóközöket is. Ha az utolsó pont után is vannak szóközök, a képlet azokat is beleszámolja.

Több cella karaktereinek megszámolása

  1. A B2 cella másolásához nyomja le a CONTROL + C billentyűkombinációt.

  2. A képlet a B3:B4 cellákba való beillesztéséhez nyomja le a CONTROL + V billentyűkombinációt

Ez a művelet a B3 és a B4 cellába másolja a képletet, a függvény pedig mindhárom cellában megszámolja a karaktereket (26 és 44).

A karakterszám összesítése

  1. Kattintson a B6 cellára.

  2. Írja be a cellába az =SZUM(HOSSZ(A2);HOSSZ(A3);HOSSZ(A4)) képletet, és nyomja le az Enter billentyűt.

Ez a művelet megszámolja, hogy hány karakter van a három cellában, és összeadja az értékeket. Az eredmény 89.

Konkrét karakterek megszámolása az egyes cellákban

  1. Kattintson a C4 cellára.

  2. Írja be a cellába a =HOSSZ(A4)-HOSSZ(HELYETTE(A4,"z","")) képletet, és nyomja le az Enter billentyűt.

Ez megszámolja az A4 cellában található kis Z betűket, amelyek száma 1.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×