Beágyazott képlet kiértékelése lépésenként

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Időnként előfordulhat ismertetése, hogy egy beágyazott képlet hogyan számítja ki a végeredményt oka nehéz több köztes számításokat és logikai ellenőrzések is van. A Képletkiértékelő párbeszédpanel használatával megtekintheti a beágyazott képlet kiértékelése abban a sorrendben, a képlet különböző részei. Ha például a képlet =Ha(átlag(F2:F5) > 50,SUM(G2:G5),0) könnyebben megérthető, ha megjelenik a következő köztes eredmények:

A párbeszédpanelen látható lépések

Leírás

=HA(ÁTLAG(F2:F5)>50;SZUM(G2:G5);0)

Kezdetben a beágyazott képlet látható. Az ÁTLAG és a SZUM függvény a HA függvénybe van ágyazva.

=HA(40>50;SZUM(G2:G5);0)

Az F2: F5 cellatartomány az 55, a 35, a 45 és a 25 értéket tartalmazza, és ezért az átlag(F2:F5) függvény eredménye 40.

=HA(Hamis;SZUM(G2:G5);0)

40 nem nagyobb, mint 50, ezért a Ha függvény (a logikai_vizsgálat argumentumban) az első argumentumban szereplő kifejezés hamis.

0

A Ha függvény a harmadik argumentum (az érték_ha_hamis argumentum) értékét adja eredményül. A SZUM függvény nem értékelni, mivel a második argumentum, ha a Ha függvény (érték_ha_igaz argumentumot), és csak akkor, ha a kifejezés igaz értéke adja vissza.

  1. Jelölje ki a kiértékelni kívánt cellát. Egyszerre csak egy cellát lehet kiértékelni.

  2. Képletek lap Képletvizsgálat csoportjában kattintson a Képletkiértékelő gombra.

    A Képletek lapon található Képletvizsgálat csoport

  3. Kattintson a Kiértékelés gombra az aláhúzott hivatkozás megvizsgálásához. A kiértékelés eredménye dőlt formázással jelenik meg.

    Ha a képlet aláhúzott része egy másik képletre mutató hivatkozás, a Belelépés gombra kattintva jelenítse meg a másik képletet a Kiértékelés mezőben. A Visszaugrás gombra kattintva lépjen vissza az előző cellába és képletre.

    Megjegyzés: A Belelépés gomb nem használható a képletben második alkalommal megjelenő hivatkozás esetében, illetve ha a képlet külön munkafüzetben lévő cellára hivatkozik.

  4. Addig folytassa a műveletet, amíg a képlet minden részét ki nem értékeli.

  5. A kiértékelés újbóli megjelenítéséhez kattintson az Újraindítás gombra.

    A kiértékelés befejezéséhez kattintson a Bezárás gombra.

    Megjegyzések: 

    • Használja a Ha és a választ függvényt tartalmazó képletek egyes részeinek kiértékelése nem, és a #hiányzik hibaérték jelenik meg a kiértékelés mezőben.

    • Ha a hivatkozás üres, zérus érték (0) jelenik meg a Kiértékelés mezőben.

    • Körkörös hivatkozást tartalmazó képletek előfordulhat, hogy nem felmérése a várt módon működik. Körkörös hivatkozások tetszés szerint is engedélyezhető számítások (közelítés).

    • Alkalmazás a következő függvények minden alkalommal, amikor a munkalap módosul, és emiatt a Képletkiértékelő más eredményt, ami a cellában megjelenik eszköz: VÉL, ELTOLÁS, cella, indirekt, most, ma, véletlen.között, információk és SZUMHA (az egyes alkalmazási helyzetek).

Office-ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×