Beágyazott képlet kiértékelése lépésenként

Sokszor nehéz átlátni, hogy egy beágyazott képlet hogyan számítja ki a végeredményt, hiszen az alkalmazás számos közbenső számítást és logikai tesztet végez e folyamat során. A Képletkiértékelő párbeszédpanel segítségével azonban megtekintheti a beágyazott képlet különböző részeit a számítások sorrendje szerint kiértékelve. Ha például az = ha (átlag (F2: F5) képletet >50, SZUM (G2: G5), 0) képlettel könnyebben értelmezhető, ha az alábbi közbenső eredményeket látja:

A párbeszédpanelen látható lépések

Leírás

=HA(ÁTLAG(F2:F5)>50;SZUM(G2:G5);0)

Kezdetben a beágyazott képlet látható. Az ÁTLAG és a SZUM függvény a HA függvénybe van ágyazva.

=HA(40>50;SZUM(G2:G5);0)

Az F2:F5 cellatartomány az 55, a 35, a 45 és a 25 értéket tartalmazza, ezért az ÁTLAG(F2:F5) függvény eredménye 40 lesz.

=HA(Hamis;SZUM(G2:G5);0)

a 40 nem nagyobb, mint 50, ezért a ha függvény első argumentumában (a logical_test argumentumban) található kifejezés hamis.

0

A HA függvény a harmadik (az érték_ha_hamis) argumentum értékét adja eredményül. A SZUM függvény kiértékelése nem történik meg, mert a ha függvény második argumentuma (value_if_true argumentum), és a függvény csak akkor ad vissza, ha a kifejezés igaz.

  1. Jelölje ki a kiértékelni kívánt cellát. Egyszerre csak egy cellát lehet kiértékelni.

  2. Képletek lap Képletvizsgálat csoportjában kattintson a Képletkiértékelő gombra.

    A Képletek lapon található Képletvizsgálat csoport

  3. Kattintson a Kiértékelés gombra az aláhúzott hivatkozás megvizsgálásához. A kiértékelés eredménye dőlt formázással jelenik meg.

    Ha a képlet aláhúzott része egy másik képletre mutató hivatkozás, a Belelépés gombra kattintva jelenítse meg a másik képletet a Kiértékelés mezőben. A Visszaugrás gombra kattintva lépjen vissza az előző cellába és képletre.

    Megjegyzés: A Belelépés gomb nem használható a képletben második alkalommal megjelenő hivatkozás esetében, illetve ha a képlet külön munkafüzetben lévő cellára hivatkozik.

  4. Addig folytassa a műveletet, amíg a képlet minden részét ki nem értékeli.

  5. A kiértékelés újbóli megjelenítéséhez kattintson az Újraindítás gombra.

    A kiértékelés befejezéséhez kattintson a Bezárás gombra.

    Megjegyzések: 

    • A ha és a választ függvényt használó képletek egyes részeinek kiértékelése nem történik meg, és a #N /a érték megjelenik a kiértékelés mezőben.

    • Ha a hivatkozás üres, nulla érték (0) jelenik meg a Kiértékelés mezőben.

    • A körkörös hivatkozásokat tartalmazó képletek nem feltétlenül a várt módon jelennek meg. Ha a körkörös hivatkozásokat szeretné használni, akkor engedélyezzea közelítést.

    • Az alábbi függvényeket a program újraszámítja a munkalap minden egyes módosításakor, és a képlet kiértékelése eszköz segítségével eltérő eredményt adhat a cellában látható tartalomból: Rand, ELTOLÁS, cella, indirekt, ma, RANDBETWEEN, info és SZUMHA (néhány esetben forgatókönyvek).

Megjegyzés:  Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Hasznos volt ez az információ az Ön számára? Itt találja az eredeti angol nyelvű cikket.

Lásd még

Hibás képletek kiküszöbölése

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×