Adatkapcsolat hozzárendelése SharePoint-dokumentumtárhoz vagy -listához

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Másodlagos adatkapcsolat hozzáadása űrlapsablonhoz mindkét lekérdezés egy dokumentumtár vagy lista adatainak is, vagy egy dokumentumtárba, a Microsoft Windows SharePoint Services-kiszolgáló adatok elküldése.

A cikk tartalma

Áttekintés

Mielőtt elkezdené

Lekérdezési adatkapcsolat hozzáadása

Küldési adatkapcsolat hozzáadása

Áttekintés

A másodlagos adatkapcsolat az űrlaphoz adott, külső adatforrással létesített bármilyen adatkapcsolat. Ez nem azonos az űrlapsablon tervezése során kialakított, adatbázison, webszolgáltatáson vagy kapcsolattárban definiált beállításokon alapuló fő adatkapcsolattal. Csak akkor kell másodlagos adatkapcsolatot beállítani, ha a fő adatkapcsolatot nem lehet lekérdezni vagy rajta keresztül adatokat küldeni.

Ha egy másodlagos adatkapcsolat rendel az űrlapsablont, amelyet lekérdezések adatokat, a Microsoft Office InfoPath létrehoz egy másodlagos adatforrás adatmezők és a csoportok, amely megfelel módon, hogy az adatok tárolása a dokumentumtár vagy lista található. A külső adatforrásban és az adatforrás az űrlapsablon közötti kapcsolat.

Másodlagos adatforrás az adatok struktúrájának meg kell egyeznie a úgy, hogy az adatok a dokumentumtár vagy lista van tárolva, mert már meglévő mezők vagy a másodlagos adatforrás csoportok nem módosíthatók.

Egy kapcsolatot, hogy a SharePoint lekérdezések adatainak dokumentumtár vagy lista automatikusan adja vissza összes elemet a dokumentumtár vagy lista. Ha lekérdezés adatkapcsolatot használ a lista feltöltéséhez mező legördülő lista vagy kombinált lista vezérlőelem és a vezérlő túl sok elemet tartalmaz, vagy meg szeretné jeleníteni a csak a megadott feltételnek megfelelő elemeket, használhatja a szűrőt a vezérlő elemek számának korlátozása. További információt a Lásd még szakasz vezérlőben megjelenítendő adatok szűrése mutató hivatkozásokat talál.

Az egyes lekérdezési adatkapcsolatok úgy is konfigurálhatók, hogy a lekérdezés eredményét a program elmentse, és a felhasználók akkor is hozzáférjenek az adatokhoz, amikor az űrlap nem csatlakozik a hálózathoz. Az adatok jellegétől függően előfordulhat, hogy a lekérdezés eredményének megjelenítését csak akkor engedélyezze, amikor a felhasználók csatlakozva vannak a hálózathoz.

Biztonsági megjegyzés : Ha másodlagos adatkapcsolatot használ bizalmas információ külső adatforrásból való beolvasására, célszerű letiltani ezt a funkciót, így a számítógép elvesztése vagy ellopása esetén megvédheti az adatokat a jogosulatlan hozzáféréstől. A funkció letiltásakor az adatok csak akkor lesznek elérhetők, ha a felhasználó a hálózathoz csatlakozik.

Ha lekérdezési adatkapcsolatot vesz fel egy űrlapsablonra, a sablonon alapuló űrlapok alapértelmezés szerint az adatkapcsolatot használják, amikor egy felhasználó megnyitja azokat. Az űrlapsablont az alábbi módok valamelyikével be is állíthatja a lekérdezési adatkapcsolat használatára:

  • Szabály hozzáadása    Beállíthatja, hogy egy szabályt, amely adatkapcsolattal a lekérdezési szabály a feltétel bekövetkezik.

  • A felvétele gombra    Az űrlapsablont, amelyet kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolata vehet egy gombot.

  • Egyéni kód használata    Ha egy szabályt, vagy a gomb nem vehet fel, egyéni kódot segítségével adatok beolvasása a lekérdezés adatkapcsolata. Egyéni kódot használatához a fejlesztők egyéni kódot szeretne létrehozni.

Amikor küldési adatkapcsolatot ad hozzá az űrlapsablonhoz, akkor konfigurálható úgy az űrlapsablon, hogy a felhasználók elküldhessék az űrlapadataikat, és meghatározhatók az űrlapsablon alapján létrehozott űrlapok küldési beállításai.

Vissza a lap tetejére

Mielőtt elkezdené

A másodlagos adatkapcsolat űrlapsablonhoz való hozzáadása előtt a rendszergazdától be kell szerezni a következő adatokat:

  • A SharePoint-webhely címe és az eléréséhez szükséges engedélyek

  • Annak megerősítése, hogy a webhely úgy van konfigurálva, hogy a felhasználók a dokumentumtárból vagy -listából megkaphatják az adatokat

  • Annak megerősítése, hogy a dokumentumtárból vagy -listából származó adatokat a felhasználók kapcsolat nélküli felhasználás céljából tárolhatják a számítógépükön

Vissza a lap tetejére

Lekérdezési adatkapcsolat hozzáadása

Annak érdekében, hogy a felhasználók lekérdezhessenek adatokat egy olyan webhely dokumentumtárából vagy -listájából, amelyik Microsoft Windows SharePoint Services alkalmazást futtató kiszolgálón található, a következőket kell elvégezni az űrlapsablonban:

  1. Másodlagos adatkapcsolat hozzáadása

  2. Az űrlapsablonban konfigurálása a másodlagos adatkapcsolat használatához.

1. lépés: Másodlagos adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban válassza ki az Új kapcsolat létrehozása a következővel pontot, az Adatok fogadásapontot, majd kattintson a Tovább gombra.

  4. A varázsló következő lapján válassza a Küldés SharePoint-alapú tárba vagy listába típusú adatkapcsolat lehetőséget, majd kattintson a Tovább gombra.

    Az Adatkapcsolat varázsló adatforrásként az adja meg a SharePoint-webhely lapjára.

  5. A varázsló következő lapján írja be a SharePoint-webhelyen a dokumentumtár vagy lista URL-CÍMÉT, és kattintson a Tovább gombra. Dokumentum-listát szeretne használni az URL-cím http://www.adventureworks.com/EmployeeListSharePoint-webhelyen, akkor írja be például a http://www.adventureworks.com/EmployeeList.

  6. A varázsló következő lapján a Lista vagy tár kiválasztása listában kattintson a használni kívánt listára vagy tárra, majd kattintson a Tovább gombra.

  7. A varázsló következő lapján jelölje be a fogadni kívánt értékek melletti jelölőnégyzetet. Ha az űrlapsablont közzéteszik a dokumentumtárban és azt szeretné, hogy az űrlapsablonon alapuló űrlapok az űrlapról metaadatokat rögzítsenek, jelölje be a Csak az aktív űrlaphoz tartozó adatokat tartalmazza jelölőnégyzetet.

  8. Kattintson a Tovább gombra.

  9. A lekérdezés eredményének az űrlapsablonban való tárolása érdekében jelölje be az Adatok másolatának tárolása az űrlapsablonban jelölőnégyzetet. Ennek hatására a program a lekérdezés eredményét az űrlapsablonban tárolja. Mivel az adatokat az űrlapsablon tárolja, az adatok akkor is elérhetők a felhasználók által kitöltött űrlapokban, amikor a számítógép nem kapcsolódik a hálózathoz.

    Biztonsági megjegyzés : Ezt a négyzetet bejelölve a lekérdezés eredményeit az űrlapsablonba menti a rendszer. Mivel az adatok az űrlapsablonban vannak, elérhetők a felhasználók által kitöltött űrlapokban is, még abban az esetben is, ha nem csatlakoznak a hálózathoz. Ha bizalmas adatokat olvas be ezzel az adatkapcsolattal, de védeni kívánja az adatokat a számítógép elvesztése vagy ellopása esetén, tiltsa le ezt a funkciót.

  10. Kattintson a Tovább gombra.

  11. A varázslóban Írja be egy nevet az adatkapcsolat mezőben, a következő lapon írja be a másodlagos adatkapcsolat leíró neve. Az adatforrás az adatforrás munkaablak listájában megjelenő neve. Ha azt szeretné, hogy a lekérdezés futtatásához automatikusan, valahányszor a felhasználó megnyitja az űrlapot, jelölje be a automatikusan beolvashatja az adatokat az űrlap ismételt megnyitásakor jelölőnégyzetet.

2. lépés: Az űrlapsablonban konfigurálása a másodlagos adatkapcsolat használatához

Ha azt szeretné, hogy az űrlapsablon után a felhasználó megnyitja az űrlapot az adatkapcsolat használandó alapuló űrlapokat, szabály hozzáadása az űrlapsablont, amelyet az adatkapcsolat feltételek teljesülése esetén használja, vagy gomb felvétele az űrlapsablont, amelyet kattintva a felhasználók a adatkapcsolattal.

Szabály hozzáadása

Az űrlapsablonhoz szabályt lehet hozzáadni annak érdekében, hogy adatokat nyerjen a lekérdezési adatkapcsolatból, valahányszor a szabály feltétele teljesül. Az alábbi eljárás feltételezi, hogy létrehozott egy lekérdezési adatkapcsolatot az űrlapsablonban, továbbá az űrlapsablonban konfigurált egy vezérlőt, amely megjeleníti az adatkapcsolatból származó adatokat.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Kattintson duplán a vezérlőre, ahol meg szeretné jeleníteni a lekérdezés eredményét.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályok csoportban kattintson a Szabályok gombra.

  5. A Szabályok párbeszédpanelen kattintson a Hozzáadás gombra.

  6. A Név mezőbe írja be a szabály nevét.

  7. A szabály futtatását kiváltó feltétel megadásához kattintson a Feltétel megadása gombra, és írja be a feltételt. A szabály akkor fut, amikor a feltétel teljesül. Feltétel megadása híján a szabály mindannyiszor aktiválódik, amikor a felhasználó módosítja az értéket a vezérlőben vagy elmozdítja arról az egérmutatót.

  8. Kattintson a Művelet hozzáadása gombra.

  9. A Művelet listában kattintson a Lekérdezés adatkapcsolat használatával elemre.

  10. Az Adatkapcsolat listában kattintson a használni kívánt lekérdezési adatkapcsolatra, és kattintson az OK gombra a nyitott párbeszédpanelek bezárásához.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Gomb hozzáadása

Az űrlapsablonhoz hozzá lehet adni egy gomb vezérlőelemet, amelyre kattintva a felhasználók használhatják a lekérdezési adatkapcsolatot. Az alábbi eljárás feltételezi, hogy az űrlapsablonhoz már létrehozta a lekérdezési adatkapcsolatot.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy gombot az űrlapsablonra.

  4. Kattintson kétszer arra a gomb vezérlőelemre, amelyet az imént adott az űrlapsablonhoz.

  5. Kattintson az Általános fülre.

  6. A Művelet listában kattintson a Frissítés elemre.

  7. A Címke mezőbe írja be az űrlap gombján megjeleníteni kívánt nevet.

  8. Kattintson a Beállítások gombra.

  9. A Frissítés párbeszédpanelen kattintson az Egy másodlagos adatforrás elemre.

  10. A Válassza ki a másodlagos adatforrást listában kattintson a lekérdezési adatkapcsolathoz tartozó másodlagos adatforrásra, majd kattintson az OK gombra a nyitott párbeszédpanelek bezárásához.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Küldési adatkapcsolat hozzáadása

Annak érdekében, hogy a felhasználók elküldhessenek a dokumentumtárba űrlapokat, amelyek az űrlapsablonon alapulnak, a következőket kell tennie:

  1. Az űrlapsablonhoz hozzá kell adni egy másodlagos adatkapcsolatot, amely elküldi az adatokat.

  2. Konfigurálja az űrlapsablont úgy, hogy a felhasználók elküldhessék űrlapadataikat a dokumentumtárba.

1. lépés: Másodlagos adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban kattintson az Új kapcsolat létrehozása a következővel parancsra, kattintson az Adatok küldése elemre, és ezután a Tovább gombra.

  4. A Hogyan szeretné adatait továbbítani? szakaszban kattintson a SharePoint-webhelyen lévő dokumentumtárba elemre és ezután a Tovább gombra.

  5. Az Adatkapcsolat varázsló Dokumentumtár mezőjébe írja be a SharePoint-dokumentumtár URL-címét.

  6. A Fájlnév mezőbe pedig írja be azt a nevet, amellyel az űrlapra lehet majd hivatkozni a dokumentumtárban.

    Tipp : Használhat képletet is annak biztosítására, hogy minden űrlapnév egyedi legyen.

    Hogyan?

    1. Kattintson a Képlet beszúrása Gombkép gombra.

    2. A Képlet beszúrása párbeszédpanelen a következőket teheti:

      • Ha a képletben egy mezőt szeretne használni, kattintson a Mező vagy csoport beszúrása lehetőségre, majd a Mező vagy csoport kijelölése párbeszédpanelen arra a mezőre, amelyiket használni szeretné, végül az OK gombra.

      • Ha a képletben függvényt szeretne használni, kattintson a Függvény beszúrása lehetőségre, majd a Függvény beszúrása párbeszédpanelen arra a függvényre, amelyiket használni szeretné, végül az OK gombra

        Tipp : A függvény csak a paramétereket, ha jelölje ki a függvényt a Függvény beszúrása párbeszédpanel, kattintson az OK gombra , és ezt követően a képlet mezőben a Képlet beszúrása párbeszédpanelen kattintson duplán a függvény a felvétele után, és kattintson a mező vagy csoport. Függvényekkel kapcsolatos további információkra mutató hivatkozások a Lásd még című szakaszban találhat.

      • Ha értéket vagy matematikai műveleti jelet szeretne a képletbe illeszteni, írja az értéket vagy a műveleti jelet a Képlet mezőbe.

    Művelet

    Szimbólum

    Hozzáadás

    +

    Kivonás

    -

    Szorzás

    *

    Osztás

    /

    • Megjegyzés : Ha a képlet a hányados (/) operátorral, ellenőrizze, hogy van egy hely előtt és után az osztás operátor. Ha az osztás operátor nem rendelkezik a térköz előtte és utána InfoPath értelmezése előfordulhat, hogy "/" elválasztó XPath helyét a lépések, hanem egy hányados operátor.

    • Ha a képlet szintakszisának helyességét szeretné ellenőrizni, kattintson a Képlet beszúrása párbeszédpanel Képlet ellenőrzése gombjára.

      A képletekről további információt a Lásd még szakasz hivatkozásait követve kaphat.

  7. Ha engedélyezni szeretné a dokumentumtárban található azonos nevű űrlapok felülírását, jelölje be a Felülírás engedélyezése, ha a fájl már létezik jelölőnégyzetet.

  8. Kattintson a Tovább gombra.

  9. A varázsló következő lapján, az Adja meg az adatkapcsolat nevét mezőben adjon meg leíró nevet ehhez az adatküldési kapcsolatnak.

A másodlagos küldési adatkapcsolat hozzáadása után úgy kell konfigurálni az űrlapsablont, hogy a felhasználók elküldhessék az űrlapadataikat ennek a küldési adatkapcsolatnak a segítségével.

2. lépés: Küldés engedélyezése az űrlapsablonon

Amikor engedélyezi a felhasználó számára az űrlap elküldését, az InfoPath hozzáad egy Küldés gombot a Szokásos eszköztárhoz és egy Küldés parancsot a Fájl menühöz. Az űrlapsablon számára testreszabhatja a küldési lehetőségeket is a következők szerint:

  • Módosíthatja a Küldés gomb szövegét.

  • Módosíthatja a Küldés gombhoz tartozó gyorsbillentyűt.

  • Létrehozhatja az űrlap elküldésekor a felhasználók számára megjelenítendő üzenetet.

  • Meghatározhatja, hogy az űrlap elküldése után az űrlap nyitva maradjon vagy bezáródjon, illetve hogy egy üres űrlap megnyíljon-e.

  • Kattintson az Eszközök menü Küldés beállításai elemére.

  • Küldés beállításai párbeszédpanelen jelölje be a engedélyezése a felhasználóknak az űrlap elküldése jelölőnégyzetet, kattintson a Küldés célhelyének egyetlen űrlap adatainak gombra, és a listában válassza a SharePoint-dokumentumtárban.

  • Az Adja meg a küldéshez használandó adatkapcsolatot listában kattintson a SharePoint-tárhoz rendelt küldési adatkapcsolat nevére.

    1. Ha más nevet szeretne adni az űrlapküldéskor a Szokásos eszköztáron látható Küldés gombnak, valamint a Fájl menüben megjelenő Küldés parancsnak, írja be az új nevet a Küldés beállításai párbeszédpanel Felirat mezőjébe.

      Tipp : Ha billentyűparancsot kíván rendelni ehhez a gombhoz és a parancshoz, írjon egy „és” (&) jelet a billentyűparancsként használandó karakter elé (az ALT+D billentyűkombináció választása esetén például írja a Küldés nevet Kül&dés formában).

  • Ha nem szeretné, hogy a felhasználók a Küldés parancsot vagy a Szokásos eszköztár Küldés gombját használják az űrlap kitöltésekor, akkor törölje A Küldés menüpont és a Küldés eszköztárgomb megjelenítése jelölőnégyzet jelölését.

    1. Az InfoPath az űrlapok elküldését követően alapértelmezés szerint megnyitva tartja az űrlapot, és megjelenít egy, az űrlap sikeres elküldéséről szóló üzenetet. Ennek az alapértelmezett működésnek a módosításához kattintson a Speciális gombra, majd hajtsa végre az alábbiak egyikét:

      • Ha azt szeretné, hogy a kitöltött űrlap elküldése után a program bezárja az űrlapot vagy egy új, üres űrlapot hozzon létre, jelölje ki az Elküldést követően lista kívánt elemét.

      • Ha az elküldés sikerességét egy egyéni üzenettel kívánja jelezni, jelölje be az Egyéni üzenetek használata jelölőnégyzetet, majd írja be a kívánt szöveget a Siker esetén és Sikertelenség esetén mezőbe.

        Tipp : A Sikertelenség esetén mezőbe az elküldés sikertelensége esetén elvégzendő lépéseket írja; javasolhatja például a felhasználóknak, hogy mentsék az űrlapot, és lépjenek kapcsolatba a megfelelő személlyel a további utasítások végett.

      • Ha nem kíván semmilyen üzenetet megjeleníteni az űrlap elküldését követően, törölje az Üzenetek megjelenítése a sikeres és a sikertelen végrehajtásról jelölőnégyzet jelölését.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×