Adatkapcsolat hozzárendelése Microsoft SQL Server adatbázishoz

Fontos: Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Az űrlapsablonhoz hozzá lehet adni egy másodlagos adatkapcsolatot, amely lekérdez egy Microsoft SQL Server adatbázist. Olyan másodlagos adatkapcsolatot nem lehet hozzáadni az űrlapsablonhoz, amelyik űrlapadatot küld egy adatbázisba. Ha másodlagos adatkapcsolatot szeretne használni arra, hogy űrlapadatot küldjön egy adatbázisba, akkor használjon egy, az adatbázissal együttműködő webszolgáltatáshoz rendelt adatkapcsolatot. A webszolgáltatáshoz rendelt adatkapcsolat hozzáadásáról bővebb tájékoztatást a Lásd még szakasz hivatkozásait követve kaphat.

A másodlagos adatkapcsolat adatbázishoz rendeléséhez a következőket kell tenni:

1. lépés: Másodlagos adatkapcsolat hozzáadása az űrlapsablonhoz:    Ez a lépés létrehozza a másodlagos adatforrást, amelynek mezői és csoportjai megfelelnek annak, ahogyan az adatokat az adatbázis tárolja. Az űrlapsablon úgy konfigurálható, hogy az űrlap első megnyitásakor lehetővé tegyék, hogy az űrlap használja ezt az adatkapcsolatot.

2. lépés: Az űrlapsablonban konfigurálása az adatkapcsolat használatához:    Ha azt szeretné, hogy a felhasználók az űrlap megnyitása után használják ezt az adatkapcsolatot, az űrlapsablonhoz hozzá kell adni egy szabályt vagy egy gombot, hogy a felhasználók adatokat szerezzenek az adatkapcsolaton keresztül.

A témakör tartalma

– Áttekintés

Első lépések

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

Lépés: 2: Az Adatkapcsolat használata az űrlapsablon konfigurálása

Áttekintés

Külső adatforráson alapuló űrlapsablon létrehozásakor a Microsoft Office InfoPath létrehoz egy fő adatkapcsolat, amely a külső adatforráshoz van hozzárendelve. Az InfoPath ezután létrehozza az űrlapsablonhoz a fő adatforrást annak alapján, ahogyan a külső adatforrás az adatokat tárolja. Azonban előfordulhat, hogy a fő adatkapcsolatnál használt külső adatforrás nem tartalmazza azokat az értékeket, amelyeket meg szeretne jeleníteni az űrlapsablon vezérlőiben. Lehet, hogy ezek az értékek egy másik külső adatforrásban találhatók, például egy másik SQL Server adatbázisban. A másik külső adatforrásból származó adatok megszerzéséhez másodlagos adatkapcsolatot is hozzáadhat az űrlapsablonhoz.

A másodlagos adatkapcsolat olyan adatkapcsolat, amelyet egy űrlapsablonhoz ad hozzá. Ez az adatkapcsolat lehet lekérdezési adatkapcsolat vagy küldési adatkapcsolat. Lekérdezési adatkapcsolatot csak SQL Server adatbázishoz rendelt másodlagos adatkapcsolatként lehet űrlapsablonhoz hozzáadni. Ezt az adatkapcsolatot csak akkor kell hozzáadni az űrlapsablonhoz, ha a fő adatkapcsolathoz rendelt külső adatforrástól eltérő adatforrásból van szükség adatokra. Küldési adatkapcsolat nem rendelhető hozzá SQL Server adatbázishoz másodlagos adatkapcsolatként.

Lekérdezés adatkapcsolat-adatbázishoz való hozzáadásakor InfoPath létrehoz egy másodlagos adatforrás adatmezők és a csoportok, amely megfelel módon, hogy az adatokat az adatbázisban vannak tárolva. Másodlagos adatforrás az adatok struktúrájának meg kell egyeznie a úgy, hogy az adatok az adatbázistáblák van tárolva, mert a mezők és a másodlagos adatforrás csoportok nem módosíthatók. Beállíthatja, hogy minden lekérdezés származó adatok mentse az eredményeket, hogy a felhasználó fér hozzá az adatokat az űrlap kapcsolat nélkül hálózathoz. Attól függően, hogy az adatok jellegét érdemes a lekérdezés eredményének megjelenítése, csak akkor, amikor a felhasználók a hálózathoz csatlakozik.

Biztonsági megjegyzés: Ha másodlagos adatkapcsolatot használ bizalmas információ külső adatforrásból való beolvasására, célszerű letiltani ezt a funkciót, így a számítógép elvesztése vagy ellopása esetén megvédheti az adatokat a jogosulatlan hozzáféréstől. A funkció letiltásakor az adatok csak akkor lesznek elérhetők, ha a felhasználó a hálózathoz csatlakozik.

Ha lekérdezési adatkapcsolatot vesz fel egy űrlapsablonra, a sablonon alapuló űrlapok alapértelmezés szerint az adatkapcsolatot használják, amikor egy felhasználó megnyitja azokat. Az űrlapsablont az alábbi módok valamelyikével be is állíthatja a lekérdezési adatkapcsolat használatára:

  • Szabály hozzáadása    Beállíthatja, hogy egy szabályt, amely adatkapcsolattal a lekérdezési szabály a feltétel bekövetkezik.

  • A felvétele gombra    Az űrlapsablont, amelyet kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolata gomb is adhat.

  • Egyéni kód használata    Ha egy szabályt, vagy a gomb nem vehet fel, egyéni kódot segítségével adatok beolvasása a lekérdezés adatkapcsolata. Egyéni kódot használatához a fejlesztők egyéni kódot szeretne létrehozni.

Vissza a lap tetejére

Mielőtt elkezdené:

Az SQL Server adatbázishoz rendelt másodlagos adatkapcsolat űrlapsablonhoz való hozzáadása előtt az adatbázis rendszergazdájától be kell szerezni a következő adatokat:

  • Az űrlapsablonnal használt adatbázist tartalmazó kiszolgáló neve.

  • Az ebben az űrlapsablonban használni kívánt adatbázis neve.

  • Az adatbázis által megkövetelt hitelesítés. Az adatbázis használhatja a Microsoft Windows hitelesítést vagy az SQL-kiszolgáló hitelesítést annak meghatározásakor, hogy a felhasználók hogyan férhetnek hozzá az adatbázishoz.

  • A tábla neve, amely az űrlapnak küldendő adatokat tartalmazza. Ez az elsődleges tábla. Ha egynél több táblát szeretne használni az adatbázisban, akkor szükség van a többi gyermektábla nevére is. Szükség van a gyermektáblák azon mezőinek a nevére is, amelyek kapcsolatban vannak az elsődleges tábla mezőivel.

  • Biztonságosan tárolhatók-e a lekérdezés eredményei az űrlapban a kapcsolat nélküli felhasználás céljából?

Vissza a lap tetejére

1. lépés: Másodlagos adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban válassza ki az Új kapcsolat létrehozása a következővel és az Adatok fogadása pontokat, majd kattintson a Tovább gombra.

  4. A varázsló következő lapján jelölje be az Adatbázis (csak Microsoft SQL Server vagy Microsoft Office Access) választógombot, majd kattintson a Tovább gombra.

  5. A varázsló következő lapján kattintson az Adatbázis kijelölése gombra.

  6. Az Adatforrás kijelölése párbeszédpanelen kattintson az Új forrás gombra.

  7. A Milyen típusú adatforráshoz kíván csatlakozni? listában kattintson a Microsoft SQL Server lehetőségre, majd kattintson a Tovább gombra.

  8. A Kiszolgálónév mezőben adja meg az adatbázist tartalmazó kiszolgáló nevét.

  9. Az Azonosító adatok részben tegye a következőt:

    • Ha az adatbázis a Microsoft Windows hálózatban használt azonosító adatok alapján határozza meg, hogy ki léphet be, majd kattintson a Windows-hitelesítés használata elemre.

    • Ha az adatbázis a rendszergazdától kapott felhasználónév és jelszó alapján határozza meg, hogy ki léphet be, kattintson Az alábbi felhasználónév és jelszó használata elemre, majd adja meg felhasználónevét és jelszavát a Felhasználónév és Jelszó mezőkben.

  10. Kattintson a Tovább gombra.

  11. A varázsló következő lapján A kívánt adatokat tartalmazó adatbázis kiválasztása listában kattintson a használni kívánt adatbázisra, jelölje be a Csatlakozás egy adott táblához jelölőnégyzetet, kattintson az elsődleges tábla nevére, majd a Tovább gombra.

  12. A varázsló következő lapján a Fájlnév mezőben adja meg az adatkapcsolat adatait tartalmazó fájl nevét.

  13. A beállítások mentéséhez kattintson a Befejezés gombra.

  14. A lekérdezési adatkapcsolatban használni kívánt további táblák hozzáadása.

    Hogyan?

    1. Kattintson a Tábla hozzáadása parancsra.

    2. A Tábla vagy lekérdezés hozzáadása párbeszédpanelen kattintson a gyermektábla nevére, majd a Tovább gombra. Az InfoPath a két tábla mezőneveinek párosításával megkísérli beállítani a kapcsolatokat. Ha a felkínált párosításokat nem szeretné használni, jelölje ki a nem kívánt kapcsolatot, és kattintson a Kapcsolat törlése gombra. Kapcsolat hozzáadásához kattintson a Kapcsolat hozzáadása gombra. A Kapcsolat hozzáadása párbeszédpanelen a megfelelő oszlopban jelölje ki az összefüggő mezőket, és kattintson az OK gombra.

    3. Kattintson a Befejezés gombra.

    4. További gyermektáblák hozzáadásához ismételje ezeket a lépéseket.

  15. Kattintson a Tovább gombra.

  16. Ha azt szeretné, hogy a lekérdezési adatkapcsolat eredménye elérhető legyen akkor is, amikor az űrlap nem csatlakozik a hálózathoz, jelölje be az Adatok másolatának tárolása az űrlapsablonban jelölőnégyzetet.

    Biztonsági megjegyzés: Ennek hatására a program a számítógépre menti az adatokat, amikor az űrlap ezt az adatkapcsolatot használja. Ha az űrlap az adatkapcsolaton keresztül bizalmas adatokat kap, akkor az adatok védelme érdekében érdemes lehet ezt a szolgáltatást letiltani, mert a számítógép elvesztése vagy ellopása esetén az adatok illetéktelen kezekbe kerülhetnek.

  17. Kattintson a Tovább gombra.

  18. A varázsló következő lapján adjon meg egy kifejező nevet a másodlagos adatkapcsolatnak. Ha azt szeretné, hogy az űrlap megnyitásakor automatikusan kapjon adatokat, jelölje be az Automatikus adatbeolvasás az űrlap megnyitásakor jelölőnégyzetet.

Vissza a lap tetejére

2. lépés: Az űrlapsablonban konfigurálása az adatkapcsolat használatához

Ha azt szeretné, hogy az űrlapsablonon alapuló űrlapok ezt az adatkapcsolatot használják az űrlap megnyitása után, akkor hozzáadhat egy szabályt az űrlapsablonhoz, hogy adott feltételek teljesülése esetén használja ezt az adatkapcsolatot, vagy hozzáadhat egy gombot az űrlapsablonhoz, amelyre kattintva a felhasználó használhatja ezt az adatkapcsolatot.

Szabály hozzáadása

Az űrlapsablonhoz szabályt lehet hozzáadni annak érdekében, hogy adatokat nyerjen a lekérdezési adatkapcsolatból, valahányszor a szabály feltétele teljesül. Az alábbi eljárás feltételezi, hogy létrehozott egy lekérdezési adatkapcsolatot az űrlapsablonban, továbbá az űrlapsablonban konfigurált egy vezérlőt, amely megjeleníti az adatkapcsolatból származó adatokat.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Kattintson kétszer arra a vezérlőre, amelyhez szabályt kíván hozzáadni.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályok csoportban kattintson a Szabályok gombra.

  5. A Szabályok párbeszédpanelen kattintson a Hozzáadás gombra.

  6. A Név mezőbe írja be a szabály nevét.

  7. A szabály futtatását kiváltó feltétel megadásához kattintson a Feltétel megadása gombra, és írja be a feltételt. A szabály akkor fut, amikor a feltétel teljesül. Feltétel megadása híján a szabály mindannyiszor aktiválódik, amikor a felhasználó módosítja az értéket a vezérlőben vagy elmozdítja arról az egérmutatót.

  8. Kattintson a Művelet hozzáadása gombra.

  9. A Művelet listában kattintson a Lekérdezés adatkapcsolat használatával elemre.

  10. Az Adatkapcsolat listában kattintson a használni kívánt lekérdezési adatkapcsolatra, és kattintson az OK gombra a nyitott párbeszédpanelek bezárásához.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Gomb hozzáadása

Az űrlapsablonhoz hozzá lehet adni egy gomb vezérlőelemet, amelyre kattintva a felhasználók adatokat olvashatnak be a lekérdezési adatkapcsolat segítségével.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy gomb vezérlőelemet az űrlapsablonra.

  4. Kattintson duplán az űrlapsablonhoz hozzáadott gomb vezérlőelemen.

  5. Kattintson az Általános fülre.

  6. A Művelet listában kattintson a Frissítés elemre.

  7. A Címke mezőbe írja be az űrlap gombján megjeleníteni kívánt nevet.

  8. Kattintson a Beállítások gombra.

  9. A Frissítés párbeszédpanelen kattintson az Egy másodlagos adatforrás elemre.

  10. A Válassza ki a másodlagos adatforrást listában kattintson a lekérdezési adatkapcsolathoz rendelt másodlagos adatforrásra.

  11. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  12. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Megjegyzés: Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×