Adatkapcsolat hozzáadása kapcsolattár beállításainak használatával

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Tartalom

Áttekintés

Mielőtt elkezdené:

Lekérdezési adatkapcsolat hozzáadása

Küldési adatkapcsolat hozzáadása

Áttekintés

Ha több hasonló adatkapcsolatok használó űrlapsablonok tervez, akkor fontolja meg egy adatkapcsolatfájl helyett külső adatforrás minden űrlapsablon származó adatok. Ezzel a módszerrel frissítenie kell csak egy adatkapcsolatfájl kapcsolódó űrlapsablonok csoportja a kapcsolat adatait megváltozásakor. Ha például áthelyezésekor a űrlapsablonok próba hálózatról gyártási hálózathoz, frissítenie kell az csatlakozási beállítások csak egyszer a kapcsolat tárban helyett az adatkapcsolat egyes űrlapsablon frissítése. Ha egy adatkapcsolatfájl használó űrlapsablon alapján űrlap az adatkapcsolatot használ, az adatkapcsolat automatikusan frissül az új beállítások.

Egy adatkapcsolatfájl, amely tartalmazza a külső adatforrás kapcsolati adatok .xml vagy .udcx fájl kiterjesztésű XML-fájlban. Ez a fájl egy adatkapcsolattár Microsoft Office SharePoint Server 2007-kiszolgáló tárolja. Egy adatkapcsolatfájl létrejön egy fejlesztő által vagy egy már létező űrlapsablon az adatkapcsolat alakításával egy adatkapcsolatfájl kattintson a Konvertálás gombra a Adatkapcsolatok párbeszédpanel (eszközök menü).

Az adatkapcsolatfájlok használatával járó előnyök egyebek mellett:

  • Egy adatkapcsolatfájlt több űrlap használhat, ezért nem kell ugyanazt az adatkapcsolatot újra és újra létrehozni minden űrlapsablonhoz.

  • Ha egy külső adatforrás helye vagy kapcsolati beállításai megváltoznak, csak az adatkapcsolatfájlt kell frissíteni és nem minden űrlapot külön-külön.

  • Az adatkapcsolatfájl alternatív hitelesítési információkat tartalmazhat, amelyeket a kiszolgáló akkor használhat, amikor a felhasználó a webböngésző segítségével tölt ki egy űrlapot.

  • Böngészőkompatibilis űrlapsablonon alapuló, böngészőben kitöltött űrlapok más tartományokban lévő kiszolgálókhoz csak az adatkapcsolatfájlokat használó adatkapcsolatokon keresztül csatlakozhatnak.

Megjegyzés : A Microsoft Office InfoPath adatkapcsolatfájljainak formátuma Universal Data Connection 2.0-s verziójú. Ez a verzió a Microsoft Office FrontPage és a Microsoft Office Excel által használt 1.0-s verzió újabb készlete. Az InfoPath az 1.0-s fájlformátumú adatkapcsolatfájlok használatára nem képes.

Ha adatkapcsolatot ad hozzá űrlapsablonhoz az adatkapcsolattár beállításainak segítségével, akkor másodlagos adatkapcsolatot hoz létre az adott űrlapsablonban. Ez az adatkapcsolat különbözik a fő adatkapcsolattól, melyet akkor hozott létre, amikor megtervezte az adatbázis-, webszolgáltatás- vagy adatkapcsolattár beállítási alapú űrlapsablont. Csak akkor kell hozzáadni másodlagos adatkapcsolatot, ha nem tud adatot küldeni vagy fogadni a fő adatkapcsolaton keresztül.

Vissza a lap tetejére

Mielőtt elkezdené:

Ha adatkapcsolatot szeretne hozzáadni űrlapsablonhoz az adatkapcsolattárban tárolt beállítások segítségével, a következő adatokat kell megtudnia a webhelygazdától:

  • Az adatkapcsolattár helyét tartalmazó Microsoft Office SharePoint Server 2007 alkalmazást futtató kiszolgáló helyét

  • A használni kívánt adatkapcsolattárbeli adatkapcsolatfájl nevét

  • Tartalmaz-e az adatkapcsolatfájl lekérdezési vagy küldési adatkapcsolat-beállítást

  • Beállítható-e az űrlapsablon a lekérdezési eredmények biztonságos tárolására kapcsolat nélküli használathoz lekérdezési adatkapcsolat-beállítások esetén

Vissza a lap tetejére

Lekérdezési adatkapcsolat hozzáadása

Ha adatkapcsolatot szeretne hozzáadni az űrlapsablonhoz adatkapcsolattár beállításainak segítségével, kövesse az alábbi lépéseket:

  1. Adja hozzá a másodlagos adatkapcsolatot az űrlapsablonhoz.

  2. Kössön vezérlőket a lekérdezési és adatmezőkhöz a másodlagos adatforrásban.

  3. Állítsa be az űrlapsablont úgy, hogy szabály vagy gomb segítségével használja az adatkapcsolatot.

1. lépés: Másodlagos adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban kattintson a Kapcsolatok keresése a Microsoft Office SharePoint Server kiszolgálón elemre, majd a Tovább gombra.

  4. A varázsló következő lapján a Webhely listában kattintson a kapcsolattárat tartalmazó, az Office SharePoint Server 2007 szolgáltatást futtató kiszolgálón lévő webhely nevére.

    A saját webhely nem szerepel a listán

    Saját webhely hozzáadásához tegye a következőt:

    1. Kattintson a Webhelyek kezelése gombra.

    2. A Webhelyek kezelése párbeszédpanelen kattintson a Hozzáadás gombra.

    3. Az URL-cím mezőbe írja be az adatkapcsolattár helyét.

    4. A Megjelenítendő név mezőben adja meg az adatkapcsolattár nevét. Ez a név fog megjelenni az Adatkapcsolat varázsló Webhely listájában.

    5. Kattintson az OK gombra.

    6. Kattintson a Bezárás gombra.

  5. Kattintson az adatkapcsolattár nevére az adatkapcsolatfájlok listájának megtekintéséhez, kattintson az ehhez az adatkapcsolathoz használni kívánt adatkapcsolatfájl nevére, majd a Tovább gombra.

  6. Az adatkapcsolatfájl kapcsolati beállításaitól függően a varázsló következő lapján mintaértékeket kell megadni minden paraméterhez.

    Hogyan adhatók meg mintaértékek?

    1. A Paraméterek táblában jelöljön ki egy paramétert, és kattintson a Mintaérték beállítása gombra.

    2. A Mintaérték mezőbe írjon be egy olyan értéket, amelyet a felhasználók megadhatnak, és kattintson az OK gombra.

    3. A Paraméterek tábla minden paramétere esetében ismételje meg ezeket a lépéseket, majd kattintson a Tovább gombra.

    Technikai megjegyzés

    Amikor az Adatkapcsolat varázslóban adatkapcsolatot állít be egy webszolgáltatáshoz, a Microsoft Office InfoPath kapcsolódik a szolgáltatáshoz, és kéri a WSDL- (Web Service Description Language) fájlt. A WSDL-fájl tartalmazza a webszolgáltatás által használt sémát. A webszolgáltatás válaszul a kérésre elküldi a fájlt az InfoPath alkalmazásnak. Az InfoPath a fájlban lévő információk alapján felveszi a megfelelő mezőket és csoportokat az űrlapsablonban a másodlagos adatforrásba. Ha az InfoPath ismeretlen elemtípust talál a WSDL-fájlban, mintaadatok használatával meghatározza az elemtípus definícióját, majd felveszi a megfelelő mezőket és csoportokat a másodlagos adatforrásba.

  7. Ha azt szeretné, hogy a lekérdezés eredménye akkor is elérhető legyen, ha az űrlap nincs a hálózatra csatlakoztatva, jelölje be az Adatok másolatának tárolása az űrlapsablonban jelölőnégyzetet.

    Biztonsági megjegyzés : Ezt a négyzetet bejelölve a lekérdezés eredményeit az űrlapsablonba menti a rendszer. Mivel az adatok az űrlapsablonban vannak, elérhetők a felhasználók által kitöltött űrlapokban is, még abban az esetben is, ha nem csatlakoznak a hálózathoz. Ha bizalmas adatokat olvas be ezzel az adatkapcsolattal, de védeni kívánja az adatokat a számítógép elvesztése vagy ellopása esetén, tiltsa le ezt a funkciót.

  8. Kattintson a Tovább gombra.

    A varázsló következő oldala ezen adatkapcsolat beállításait jeleníti meg összefoglalva.

  9. Adjon meg egy kifejező nevet az adatkapcsolathoz. Ez a név jelenik majd meg az Adatforrás listában az Adatforrás munkaablakban.

  10. Ha engedélyezni szeretné, hogy az ezen az űrlapsablonon alapuló űrlapok megnyitáskor használhassák ezt az adatkapcsolatot, jelölje be az Automatikus adatbeolvasás az űrlap megnyitásakor jelölőnégyzetet.

Vissza a lap tetejére

2. lépés: Vezérlő hozzáadása az adatok felhasználók számára történő megjelenítéséhez

  1. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  2. Húzzon egy vezérlőt az űrlapsablonra.

  3. A Vezérlő kötése párbeszédpanelen válassza ki azt a mezőt, amelyhez kötni szeretné a vezérlőt, majd kattintson az OK gombra.

3. lépés: Az űrlapsablon konfigurálása adatkapcsolat használatához

Ha azt szeretné, hogy a felhasználók adatokat tudjanak beolvasni ebből az adatkapcsolatból az űrlap megnyitása után, hozzáadhat egy szabályt az űrlapsablonhoz, amely az adatkapcsolatot használja adott feltétel teljesülése esetén, vagy hozzáadhat egy gombot is az űrlapsablonhoz, amelyre kattintva a felhasználók használhatják az adatkapcsolatot.

Szabály hozzáadása

Szabályt adhat hozzá az űrlapsablonhoz, amely mindig futtatja a lekérdezési adatkapcsolatot, ha a szabályban megadott feltétel teljesül. A következő lépések azt feltételezik, hogy már hozott létre lekérdezési adatkapcsolatot az űrlapsablonhoz és hogy beállította az űrlapsablonon vezérlőt az adatkapcsolat adatainak megjelenítéséhez.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Kattintson kétszer arra a vezérlőre, amelyhez szabályt kíván hozzáadni.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályok csoportban kattintson a Szabályok gombra.

  5. A Szabályok párbeszédpanelen kattintson a Hozzáadás gombra.

  6. A Név mezőbe írja be a szabály nevét.

  7. A szabály futtatását kiváltó feltétel megadásához kattintson a Feltétel megadása gombra, és írja be a feltételt. A szabály akkor fut, amikor a feltétel teljesül. Feltétel megadása híján a szabály mindannyiszor aktiválódik, amikor a felhasználó módosítja az értéket a vezérlőben vagy elmozdítja arról az egérmutatót.

  8. Kattintson a Művelet hozzáadása gombra.

  9. A Művelet listában kattintson a Lekérdezés adatkapcsolat használatával elemre.

  10. Az Adatkapcsolat listában kattintson a használni kívánt lekérdezési adatkapcsolatra, majd a párbeszédpanelek bezárásához az OK gombra.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Gomb hozzáadása a lekérdezési adatkapcsolat használatához

Hozzáadhat egy olyan gomb vezérlőelemet az űrlapsablonhoz, amelyre az űrlap űrlapsablon alapján történő kitöltése után rákattinthatnak a felhasználók. Kattintásra ez a gomb be tudja olvasni az adatokat a lekérdezési adatkapcsolatból.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy gombot az űrlapsablonra.

  4. Kattintson kétszer arra a gomb vezérlőelemre, amelyet az imént adott az űrlapsablonhoz.

  5. Kattintson az Általános fülre.

  6. A Művelet listában kattintson a Frissítés elemre.

  7. A Címke mezőbe írja be az űrlap gombján megjeleníteni kívánt nevet.

  8. Kattintson a Beállítások gombra.

  9. A Frissítés párbeszédpanelen kattintson az Egy másodlagos adatforrás elemre.

  10. A Válassza ki a másodlagos adatforrást listában kattintson a lekérdezési adatkapcsolathoz rendelt másodlagos adatforrásra.

  11. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  12. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Küldési adatkapcsolat hozzáadása

Ha az adatkapcsolatfájl küldési adatkapcsolat-beállításokat tartalmaz, beállíthatja az űrlapsablont úgy, hogy a felhasználók ezen az adatkapcsolaton keresztül küldhessék el űrlapadataikat. Ha konfigurálja az űrlapsablont úgy, hogy a felhasználók elküldhessék űrlapadataikat, az InfoPath hozzáad egy Küldés gombot a Szokásos eszköztárhoz, illetve egy Küldés parancsot a Fájl menühöz. Az űrlapsablon küldési beállításait a Küldés beállításai párbeszédpanelen (Eszközök menü) adhatja meg. A küldési beállítások ugyanúgy konfigurálhatók, mintha egy másodlagos lekérdezési adatkapcsolatot adna hozzá. További információkra mutató hivatkozásokat a módosított űrlapsablon közzétételével kapcsolatban a Lásd még szakaszban találhat.

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban kattintson a Kapcsolatok keresése a Microsoft Office SharePoint Server kiszolgálón elemre, majd a Tovább gombra.

  4. A varázsló következő lapján a Webhely listában kattintson a kiszolgáló nevére a kapcsolattárban.

    A saját webhely nem szerepel a listán

    Saját webhely hozzáadásához tegye a következőt:

    1. Kattintson a Webhelyek kezelése gombra.

    2. A Webhelyek kezelése párbeszédpanelen kattintson a Hozzáadás gombra.

    3. Az URL-cím mezőbe írja be az adatkapcsolattár helyét.

    4. A Megjelenítendő név mezőben adja meg az adatkapcsolattár nevét. Ez a név fog megjelenni az Adatkapcsolat varázsló Webhely listájában.

    5. Kattintson az OK gombra.

    6. Kattintson a Bezárás gombra.

  5. Kattintson az adatkapcsolattár nevére az adatkapcsolatfájlok listájának megtekintéséhez, kattintson az ehhez a küldési adatkapcsolathoz használni kívánt adatkapcsolatfájl nevére, majd a Tovább gombra.

  6. Ha a beállítások webszolgáltatáshoz történő küldési adatkapcsolatra vonatkoznak, az InfoPath érzékelheti, hogy a webszolgáltatás mely paraméterei fogadhatnak adatot. Beállíthatja a küldési adatkapcsolatot úgy, hogy az összes adatot vagy az adatok egy részét küldje az űrlapsablonba.

    Hogyan?

    1. A Paraméterek listából kattintson arra paraméterre, amely az űrlap adatait fogja fogadni.

    2. Az űrlap összes adatának ehhez a paraméterhez történő küldéséhez, beleértve a gyökérelemet és az esetleges feldolgozási utasításokat is, tegye a következőt:

      1. Kattintson a Teljes űrlap (XML-dokumentum a feldolgozási utasításokkal együtt) elemre.

      2. Az adatok karakterláncként történő küldéséhez jelölje be az Adatok küldése karakterláncként jelölőnégyzetet. Ezt a jelölőnégyzetet digitálisan aláírt adatok küldésekor jelölje be. A legtöbb esetben nem szükséges bejelölnie ezt a négyzetet.

    3. Ha ehhez a paraméterhez mezőt vagy csoportot szeretne megadni, tegye a következőt:

      1. A Paraméterbeállítások lehetőségben kattintson a Mező vagy csoport elemre.

      2. Kattintson a Gombkép módosításagombra.

      3. A Mező vagy csoport kijelölése párbeszédpanelen kattintson arra a mezőre vagy csoportra, amelynek az adatait el szeretné küldeni, majd kattintson az OK gombra.

      4. A Belefoglalás lista Csak szöveg és gyermekelemek elemét választva a program csak a mező vagy a csoport tartalmát fogja elküldeni. Az XML-részfa a kijelölt elemmel együtt elemet választva a rendszer elküldi a tartalmat, illetve a kijelölt mezőt vagy csoportot is.

    4. Ismételje meg ezeket a lépéseket minden paraméternél.

  7. Kattintson a Tovább gombra.

  8. A varázsló következő lapján, az Adja meg az adatkapcsolat nevét mezőben adjon meg leíró nevet ehhez az adatküldési kapcsolatnak.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×