Adatkapcsolat hozzáadása kapcsolattár beállításainak használatával

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

A témakör tartalma

– Áttekintés

Első lépések

Lekérdezés adatkapcsolat hozzáadása

Küldés adatkapcsolat hozzáadása

Áttekintés

Ha több hasonló adatkapcsolatok használó űrlapsablonok tervez, akkor fontolja meg egy adatkapcsolatfájl helyett külső adatforrás minden űrlapsablon származó adatok. Ezzel a módszerrel frissítenie kell csak egy adatkapcsolatfájl kapcsolódó űrlapsablonok csoportja a kapcsolat adatait megváltozásakor. Ha például áthelyezésekor a űrlapsablonok próba hálózatról gyártási hálózathoz, frissítenie kell az csatlakozási beállítások csak egyszer a kapcsolat tárban helyett az adatkapcsolat egyes űrlapsablon frissítése. Ha egy adatkapcsolatfájl használó űrlapsablon alapján űrlap az adatkapcsolatot használ, az adatkapcsolat automatikusan frissül az új beállítások.

Egy adatkapcsolatfájl, amely tartalmazza a külső adatforrás kapcsolati adatok .xml vagy .udcx fájl kiterjesztésű XML-fájlban. Ez a fájl egy adatkapcsolattár Microsoft Office SharePoint Server 2007-kiszolgáló tárolja. Egy adatkapcsolatfájl létrejön egy fejlesztő által vagy egy már létező űrlapsablon az adatkapcsolat alakításával egy adatkapcsolatfájl kattintson a Konvertálás gombra a Adatkapcsolatok párbeszédpanel (eszközök menü).

Adatkapcsolatfájljainak használatának előnyei többek között:

  • Különböző űrlapok használható az azonos adatkapcsolatfájl, így nem kell azonos adatokat kapcsolat létrehozása az egyes űrlapsablon elölről kezdenie a munkát.

  • Ha módosítja a külső adatforrás hely vagy a kapcsolat beállításait, frissítenie kell csak az adatkapcsolatfájl, nem minden űrlapsablon.

  • Az adatkapcsolatfájl tartalmazhat helyettesítő hitelesítési adatait, amikor a felhasználó által webböngészőn keresztül kitölt űrlap a kiszolgáló által használt.

  • Böngészőbarát űrlap sablonon alapuló űrlapok, a böngészőben kitöltött kiszolgálókon csak az adatkapcsolatok adatkapcsolatfájljainak használó egy másik tartományban csatlakozhat.

Megjegyzés: A Microsoft Office InfoPath adatkapcsolatfájljainak, kövesse az adatkapcsolat univerzális 2.0-s fájlformátumot használja. Ez a verziója felülbírálja az 1,0 fájlformátumot használja a Microsoft Office FrontPage és a Microsoft Office Excel. Az InfoPath adatkapcsolatfájljainak 1.0 verziójú fájlformátumban nem használható.

Adatkapcsolat hozzáadása űrlapsablonhoz adatkapcsolattár beállításainak segítségével, amikor egy másodlagos adatkapcsolat űrlapsablonon hoz létre. Az adatkapcsolat eltér a fő adatkapcsolat adatbázis, webes szolgáltatás vagy adatkapcsolattár beállításainak alapján űrlapsablon tervezésekor létrehozott. Vegyen fel egy másodlagos adatkapcsolat csak akkor, ha közben nem tudja, vagy küldje el az adatok a legfontosabb adatok kapcsolaton keresztül.

Vissza a lap tetejére

Előzetes tennivalók

Adatkapcsolat hozzáadása űrlapsablonhoz, amelyeket adatkapcsolattár beállításainak használatával, a rendszergazda a következő információra van szüksége:

  • A hely Microsoft Office SharePoint Server 2007, amely tartalmazza a webhelyet, amely magában foglalja a adatkapcsolattár operációs rendszert futtató kiszolgáló

  • A használni kívánt adatkapcsolattár adatkapcsolatfájl neve

  • Hogy tartalmaz-e az adatkapcsolatfájl beállítások egy lekérdezési kapcsolatot vagy a Küldés adatkapcsolat

  • E beállíthatja az űrlapsablont biztonságosan tárolni a lekérdezés eredményében a kapcsolat nélküli használatra a képernyőn, ha a beállítások az alábbiak lekérdezés adatkapcsolat

Vissza a lap tetejére

Lekérdezés adatkapcsolat hozzáadása

Adatkapcsolat hozzá kívánja adni az űrlapsablon egy kapcsolattár beállításainak használatával, hajtsa végre az alábbi eljárások valamelyikét:

  1. A másodlagos adatkapcsolat hozzáadása az űrlapsablonhoz.

  2. Vezérlők kötése a másodlagos adatforrás lekérdezés és az adatok mezőiben.

  3. Állítsa be az űrlapsablon az Adatkapcsolat használata a gomb vagy szabály használatával.

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

  1. Kattintson az eszközök menü Adatkapcsolatokat.

  2. Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadásgombra.

  3. Az Adatkapcsolat varázsló kattintson a Keresés az egy Microsoft Office SharePoint Server-kapcsolatot, és kattintson a Tovább gombra.

  4. A varázsló, kattintson a lista, a következő lapon kattintson a webhely-kiszolgáló Office SharePoint Server 2007 együtt a kapcsolat a tár nevére.

    A webhely nem szerepel a listában

    A webhely felvétele a listára, tegye a következőket:

    1. Kattintson a webhelyek kezeléseelemre.

    2. A Webhelyek kezelése párbeszédpanelen kattintson a Hozzáadásgombra.

    3. URL-címe mezőbe írja be a adatkapcsolattár helyét.

    4. A megjelenítendő név mezőbe írja be a adatkapcsolattár nevét. Ez a neve meg fog jelenni a hely listában az Adatkapcsolat varázsló.

    5. Kattintson az OK gombra.

    6. Kattintson a Bezárás gombra.

  5. Kattintson a nevére a adatkapcsolattár adatkapcsolatfájljainak listáját, kattintással jelölje ki azt az adatkapcsolat használni kívánt adatkapcsolatfájl, és kattintson a Tovább gombra.

  6. Attól függően, hogy a kapcsolatbeállításokat az adatkapcsolatfájl a varázsló következő lapján kérhetik, hogy az egyes paraméterek mintaértékekre adja meg.

    Adja meg a minta értékek hogyan?

    1. Jelöljön ki egy paramétert a Paraméterek táblában, és kattintson a Minta érték beállításagombra.

    2. A minta érték mezőbe írja be egy értéket, hogy a felhasználó lehet használni ezt a mezőt, és kattintson az OKgombra.

    3. Ismételje meg az egyes paraméterek a Paraméterek táblában, és kattintson a Továbbgombra.

    Műszaki megjegyzés

    Az Adatkapcsolat varázslóból származó adatok webszolgáltatás konfigurálásakor a Microsoft Office InfoPath a webszolgáltatás csatlakozik, és kéri a Web Service leírás Language (WSDL) fájlt. WSDL fájl tartalmaz a séma a webes szolgáltatás által használt. A webszolgáltatás válaszol a kérést küld a InfoPath ezt a fájlt. Az InfoPath az adatokat használja ezt a fájlt a megfelelő mezők és csoportok hozzáadása a másodlagos adatforrás az űrlapsablon. Az InfoPath-ismeretlen elemtípus talál a WSDL-fájl, ha az InfoPath mintaadatok használja az ismeretlen elemtípus definícióját határozza meg, és hozzáadja a megfelelő mezőkre, és a csoportok a másodlagos adatforrás.

  7. Ha szeretné elérhetővé tenni, ha az űrlap nem hálózathoz csatlakozik a lekérdezés eredményeit, jelölje be a a tárolóban lévő adatok az űrlapsablon másolatának jelölőnégyzetet.

    Biztonsági megjegyzés: A lekérdezés eredményében a jelölőnégyzet bejelölésével az űrlapsablon tárol. Mivel az űrlapsablon tárolja az adatokat, érhető el a felhasználók kitöltése, a űrlapokat, ha a számítógépére nem kapcsolódik a hálózathoz. Ha bizalmas adatokat az adatkapcsolat származó, érdemes az adatok abban az esetben a számítógép elvész vagy ellopják védelme a funkció kikapcsolásához.

  8. Kattintson a Tovább gombra.

    A varázsló következő lapján jeleníti meg a beállításokat az adatkapcsolat összefoglalását.

  9. Írja be az adatkapcsolat leíró nevét. Ez a név megjelennek az Adatforrás az Adatforrás munkaablak listájában.

  10. Az adatkapcsolat használatára, amikor megnyitja őket a képernyőn sablonon alapuló űrlapok engedélyezéséhez jelölje be az adatokat az űrlap megnyitásakor automatikusan lekérése jelölőnégyzetet.

Vissza a lap tetejére

Lépés: 2: Az adatok megjelenítéséhez a felhasználók vezérlő hozzáadása

  1. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  2. Húzzon egy vezérlő az űrlapsablon.

  3. A Vezérlő kötése párbeszédpanelen jelölje ki a vezérlőt kötni szeretné a mezőt, és kattintson az OKgombra.

3 lépés: Az Adatkapcsolat használata az űrlapsablon konfigurálása

Ha azt szeretné, hogy a felhasználóknak, hogy az adatok beolvasása az adatkapcsolat, az űrlap megnyitása után, a szabály hozzáadása űrlapsablonhoz feltételek teljesülése esetén az adatkapcsolatot használ, vagy gomb hozzáadása űrlapsablonhoz kattintva a felhasználók az adatok ka használata szakaszra.

Add a rule

Egy szabályt is adhat az űrlapsablont, amelyet a lekérdezés adatkapcsolat futtat, valahányszor a szabály a feltétel nem teljesül. Az alábbi eljárás feltételezi, hogy az űrlapsablon lekérdezés adatkapcsolat létrehozott és beállított egy vezérlőt az űrlapon megjeleníteni az adatokat az adatforrásból.

  1. Ha az űrlapsablon több nézet van, kattintson a Nézet menü megnyitásához a nézet és a vezérlő, amelyre a másodlagos adatforrás adatainak megjelenítéséhez kattintson a nézet nevére .

  2. Kattintson duplán a vezérlő, amely egy szabályt, amely a hozzáadni kívánt.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályokcsoportban kattintson a szabályokelemre.

  5. A szabályok párbeszédpanelen kattintson a Hozzáadásgombra.

  6. A név mezőbe írja be a szabály nevét.

  7. A szabály futnia kell a megadott feltétel megadásához kattintson a Feltétel megadása, és írja be a feltétel. A szabály a feltétel bekövetkezésekor fog futni. Ha nem állít be egy feltétel, valahányszor a felhasználó megváltoztatja a vezérlő értékét, és kattintson a vezérlő távolabb partnerlistájukra kurzor áthelyezése a szabály futtathatók.

  8. Kattintson a művelet hozzáadásagombra.

  9. A művelet listában kattintson a lekérdezés adatkapcsolat használatával.

  10. Az Adatkapcsolat listában válassza a lekérdezés adatkapcsolatot, amely a használni kívánt, és kattintson az OK gombra kattintva zárja be az összes párbeszédpanelen.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

A lekérdezés adatkapcsolat használata gomb felvétele

Egy vezérlő is adhat az űrlapsablon, hogy a felhasználók az űrlapon egy űrlapot kitöltő parancsra. Való kattintáskor, erre a gombra is adatok visszakeresése a lekérdezés adatkapcsolat.

  1. Ha az űrlapsablon több nézet van, kattintson a Nézet menü megnyitásához a nézet és a vezérlő, amelyre a másodlagos adatforrás adatainak megjelenítéséhez kattintson a nézet nevére .

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy vezérlő űrlapsablon.

  4. Kattintson duplán a közvetlenül a felvétele után az űrlapsablonon ikonja.

  5. Kattintson az Általános fülre.

  6. A művelet listában kattintson a frissítésparancsra.

  7. A címke mezőbe írja be a nevet, amelyet meg szeretné jeleníteni a az űrlapon gombra.

  8. Kattintson a Beállítások ikonra.

  9. Kattintson egy másodlagos adatforrásfrissítése párbeszédpanelen.

  10. A másodlagos adatforrás kiválasztása listában kattintson a lekérdezés adatkapcsolat társított másodlagos adatforrás.

  11. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  12. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Küldés adatkapcsolat hozzáadása

Ha az adatkapcsolatfájl Küldés adatkapcsolat beállításainak tartalmaz, beállíthatja az űrlapsablon engedélyezése a felhasználóknak, hogy azok űrlapadatok végig az adatkapcsolat. A felhasználók saját űrlapadatok űrlapsablon állítja be, az InfoPath hozzáadja az Küldés gomb a szokásos eszköztár és a Küldés parancs a fájl menüben. A Küldés gombra az űrlapsablon beállítások beállíthatja a Küldés beállításai párbeszédpanelen (eszközök menü). A Küldés beállításokat az adott dokumentumkészletből ugyanúgy, mintha a másodlagos adatkapcsolat, amely Küldés adatkapcsolat felvett. További információt a Küldés adatkapcsolat hozzáadása űrlapsablonhoz a Lásd még szakasz hivatkozásait.

  1. Kattintson az eszközök menü Adatkapcsolatokat.

  2. Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadásgombra.

  3. Az Adatkapcsolat varázsló kattintson a Keresés az egy Microsoft Office SharePoint Server-kapcsolatot, és kattintson a Tovább gombra.

  4. A varázsló, kattintson a lista, a következő lapon kattintson a webhelyhez és a kapcsolat a tár nevére.

    A webhely nem szerepel a listában

    A webhely felvétele a listára, tegye a következőket:

    1. Kattintson a webhelyek kezeléseelemre.

    2. A Webhelyek kezelése párbeszédpanelen kattintson a Hozzáadásgombra.

    3. URL-címe mezőbe írja be a adatkapcsolattár helyét.

    4. A megjelenítendő név mezőbe írja be a adatkapcsolattár nevét. Ez a neve meg fog jelenni a hely listában az Adatkapcsolat varázsló.

    5. Kattintson az OK gombra.

    6. Kattintson a Bezárás gombra.

  5. Kattintson a nevére a adatkapcsolattár adatkapcsolatfájljainak listájának megtekintéséhez kattintson a használni kívánt adatkapcsolatfájl nevére elküldése az adatkapcsolat, és kattintson a Tovább gombra.

  6. Ha elküldése webszolgáltatásnak Küldés adatkapcsolat a beállításokat, az InfoPath észlelését milyen paramétereket a webszolgáltatás az adatokat olvashat be. Beállíthatja, hogy az adatok vagy egy részében az adatok elküldése az űrlapsablon származó adatok Küldés gombra.

    Hogyan?

    1. Kattintson a Paraméterek listában, amely az űrlapról származó adatokat kapja paraméter.

    2. Az összes ehhez a paraméterhez, beleértve a legfelső szintű elemet, valamint a bármely feldolgozási utasítások az űrlap adatainak elküldése a következőképpen:

      1. Kattintson a teljes űrlap (XML-dokumentum, beleértve a feldolgozási utasítások).

      2. Az adatok karakterláncként elküldéséhez jelölje be a adatok küldése karakterláncként jelölőnégyzetet. A szokásos jelölje be ezt a jelölőnégyzetet a digitálisan aláírt adatok elküldése. A legtöbb esetben törölje a jelet a jelölőnégyzetből.

    3. Mező vagy csoport ehhez a paraméterhez megadásához tegye a következőket:

      1. A paraméter beállításokcsoportban kattintson a mező vagy csoport.

      2. Kattintson a Gombkép módosításagombra.

      3. A mező vagy csoport kijelölése párbeszédpanelen kattintson a mező vagy csoport, amelynek adatait el szeretné küldeni, és kattintson az OKgombra.

      4. A Belefoglalás listában kattintson a csak a szöveg és a gyermek elemek küldése csak a mező vagy csoport tartalmát, vagy kattintson a mind a tartalmat, és a kijelölt csoport vagy mező elküldése XML-részfa, többek között a kijelölt elem gombra.

    4. Ismételje meg ezeket a lépéseket mindegyik paraméter.

  7. Kattintson a Tovább gombra.

  8. A varázslóban Írja be egy nevet az adatkapcsolat mezőben, a következő lapon írja be egy jól értelmezhető nevet ennek elküldése származó adatok.

Vissza a lap tetejére

Office-ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×