Adatkapcsolat hozzáadása a Microsoft Access-adatbázishoz

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Ha a felhasználók lesz szüksége az adatok Microsoft Office Access 2007 (.accdb formátumban) adatbázisból vagy az Access adatbázis (.mdb formátumot) a a Microsoft Office InfoPath-űrlap sablonon alapuló űrlapok kitöltése korábbi verziójában mentett, másodlagos adatkapcsolat vehet űrlapsablonhoz lekérdezése Access-adatbázisba.

Másodlagos adatkapcsolat is hozzáadhat, de az adott adatkapcsolat csak is lekérdezés Access-adatbázis. A másodlagos adatkapcsolat adatkapcsolatnak űrlap az Access-adatbázisok nem vehet fel.

Ha azt szeretné, hogy a felhasználóknak, hogy azok űrlapadatok Access-adatbázishoz, Access-adatbázis alapuló űrlapsablon tervezése, és engedélyezheti az elküldés adatkapcsolat a fő adatkapcsolat. Azt is megteheti felveheti a másodlagos adatkapcsolat webszolgáltatás működik-e az Access-adatbázisba.

További információt az Access-adatbázis alapuló űrlapsablonok tervezése és a másodlagos adatkapcsolat hozzáadása a Lásd még című szakaszban webszolgáltatás mutató hivatkozásokat talál.

Tartalom

– Áttekintés

Kompatibilitási kapcsolatos szempontok

Első lépések

Lépés: 1: Adja hozzá a másodlagos adatkapcsolat

Lépés: 2: Az Adatkapcsolat használata az űrlapsablon konfigurálása

Áttekintés

A másodlagos adatkapcsolat egy űrlapsablon hozzáadni kívánt kapcsolatot. Másodlagos adatkapcsolat eltér a fő adatbázisból származó adatok, amelyek adatbázis vagy webszolgáltatás alapuló új űrlapsablon tervezésekor hozhatók létre. Egy űrlapsablon fő adatkapcsolat egy külső adatforrásból származó adatokat olvashat be és űrlap adatainak egy külső adatforrással is küldhet. Űrlapsablon azonban csak egy fő adatkapcsolat is rendelkezik.

Megadhatja, hogy minél több másodlagos adatkapcsolat hozzáadása űrlapsablonhoz van szüksége. Tegyük fel például, hogy egy Access-adatbázist, amely tartalmazza az alkalmazottak adatait tároló tábla és az ügyfél adatait tároló egy másik tábla. Az alkalmazottak tábla adatokat beolvasó másodlagos adatkapcsolat is felvehet, és is hozzáadhat egy másik másodlagos adatkapcsolat táblából adatokat az ügyfél az Access-adatbázisba.

Bár a másodlagos adatkapcsolat hozzáadása űrlapsablonhoz is űrlapadatok egy külső adatforrással egy webszolgáltatás vagy a Windows SharePoint Services-tárba, például egy Access-adatbázisból származó adatok beolvasásához csak használhatja a másodlagos adatkapcsolat. A másodlagos adatkapcsolat adatkapcsolatnak űrlap az Access-adatbázisok nem vehet fel.

Lekérdezés adatkapcsolat vesz fel egy adatbázist, az InfoPath létrehoz egy másodlagos adatforrás , amely tartalmazza az adatmezők és a csoportok, amelyek megfelelnek a módját, hogy az adatokat az adatbázisban vannak tárolva. Másodlagos adatforrás az adatok struktúrájának meg kell egyeznie a úgy, hogy az adatok az adatbázistáblák van tárolva, mert a mezők és a másodlagos adatforrás csoportok nem módosíthatók.

Beállíthatja, hogy minden lekérdezés kapcsolathoz menti az eredményeket, hogy a felhasználó fér hozzá az adatokat az űrlap kapcsolat nélkül hálózathoz. Attól függően, hogy az adatok jellegét érdemes lehet a lekérdezés eredményének megjelenítése, csak akkor, amikor a felhasználók a hálózathoz csatlakozik.

Biztonsági megjegyzés : Ha másodlagos adatkapcsolatot használ bizalmas információ külső adatforrásból való beolvasására, célszerű letiltani ezt a funkciót, így a számítógép elvesztése vagy ellopása esetén megvédheti az adatokat a jogosulatlan hozzáféréstől. A funkció letiltásakor az adatok csak akkor lesznek elérhetők, ha a felhasználó a hálózathoz csatlakozik.

Ha lekérdezési adatkapcsolatot vesz fel egy űrlapsablonra, a sablonon alapuló űrlapok alapértelmezés szerint az adatkapcsolatot használják, amikor egy felhasználó megnyitja azokat. Az űrlapsablont az alábbi módok valamelyikével be is állíthatja a lekérdezési adatkapcsolat használatára:

  • Szabály hozzáadása    Beállíthatja, hogy egy szabályt, amely adatkapcsolattal a lekérdezési szabály a feltétel bekövetkezik.

  • A felvétele gombra    Az űrlapsablont, amelyet kattintva a felhasználók adatok beolvasása a lekérdezés adatkapcsolata vehet egy gombot.

  • Egyéni kód használata    Ha egy szabályt, vagy a gomb nem vehet fel, egyéni kódot segítségével adatok beolvasása a lekérdezés adatkapcsolata. Egyéni kódot használatához a fejlesztők egyéni kódot szeretne létrehozni.

Vissza a lap tetejére

Kompatibilitási kérdések:

Access-adatbázisok egy böngészőkompatibilis űrlapsablonnem vehet fel egy kapcsolatot.

Vissza a lap tetejére

Mielőtt elkezdené:

Access-adatbázis másodlagos adatkapcsolat hozzáadása az űrlapsablonhoz, mielőtt információra van szüksége a következő:

  • Az adatbázis neve és helye.

    Megjegyzés : Ha az Access-adatbázisba a hálózati hely van tárolva, ellenőrizze, hogy az adatbázis érhető el a felhasználók.

  • A táblát vagy lekérdezést, amely fogja szolgáltatni ezen a sablonon alapuló űrlapok adatok neve. Akkor használja a tábla vagy lekérdezés az elsődleges tábla vagy lekérdezés a lekérdezés adatkapcsolat konfigurálásakor.

  • Táblák vagy lekérdezések az elsődleges tábla vagy lekérdezés további adatokat szolgáltató neve. A legtöbb esetben a táblának megfelelő kapcsolatokat van már folyamatban az adatbázist. Ha manuálisan az elsődleges tábla vagy lekérdezés és egy másik tábla vagy lekérdezés közötti kapcsolatok létrehozására, szüksége lesz a kapcsolódó mező azoknak a táblát vagy lekérdezést is.

Vissza a lap tetejére

1. lépés: Másodlagos adatkapcsolat hozzáadása

  1. Kattintson az Eszközök menü Adatkapcsolatok parancsára.

  2. Az Adatkapcsolatok párbeszédpanelen kattintson a Hozzáadás gombra.

  3. Az Adatkapcsolat varázslóban válassza ki az Új kapcsolat létrehozása a következővel és az Adatok fogadása pontokat, majd kattintson a Tovább gombra.

  4. A varázsló következő lapján jelölje be az Adatbázis (csak Microsoft SQL Server vagy Microsoft Office Access) választógombot, majd kattintson a Tovább gombra.

  5. A varázsló következő lapján kattintson az Adatbázis kijelölése gombra.

  6. Az Adatforrás kijelölése párbeszédpanelen tallózással keresse meg az adatbázist.

    Megjegyzés : Ha az adatbázis hálózati helyen tárolja, nyissa meg a univerzális elnevezési konvenció (UNC) elérési útvonalát. Nem tallózással keresse meg a hálózati hely keresztül csatlakoztatott hálózati meghajtón. Ha egy csatlakoztatott hálózati meghajtók használja, a felhasználók, akik ezen a sablonon alapuló űrlapok létrehozása megkeresi az adatbázist a csatlakoztatott hálózati meghajtón. Ha a felhasználó nem rendelkezik a csatlakoztatott hálózati meghajtón, a képernyőn nem találja meg az adatbázist.

  7. Kattintással jelölje ki azt az adatbázist, és kattintson a Megnyitásgombra.

  8. A Táblaválasztás párbeszédpanelen kattintson az elsődleges táblát vagy lekérdezést, amely a használni kívánt, és kattintson az OKgombra.

  9. A varázsló következő lapján jelölje be a Tábla oszlopainak megjelenítése jelölőnégyzetet.

    Alapértelmezés szerint minden mezője a táblából vagy lekérdezésből a fő adatforrás űrlapsablon hozzáadódnak.

  10. A másodlagos adatforrás szerepeltetni nem kívánt mezők jelölőnégyzetét.

    Az adatkapcsolat hozzá bármilyen további táblát vagy lekérdezést.

    Hogyan?

    1. Kattintson a Tábla hozzáadása parancsra.

    2. A Tábla vagy lekérdezés hozzáadása párbeszédpanelen kattintson a gyermektábla nevére, majd a Tovább gombra. Az InfoPath a két tábla mezőneveinek párosításával megkísérli beállítani a kapcsolatokat. Ha a felkínált párosításokat nem szeretné használni, jelölje ki a nem kívánt kapcsolatot, és kattintson a Kapcsolat törlése gombra. Kapcsolat hozzáadásához kattintson a Kapcsolat hozzáadása gombra. A Kapcsolat hozzáadása párbeszédpanelen a megfelelő oszlopban jelölje ki az összefüggő mezőket, és kattintson az OK gombra.

    3. Kattintson a Befejezés gombra.

    4. További gyermektáblák hozzáadásához ismételje ezeket a lépéseket.

  11. Kattintson a Tovább gombra.

  12. Ha azt szeretné, hogy a lekérdezési adatkapcsolat eredménye elérhető legyen akkor is, amikor az űrlap nem csatlakozik a hálózathoz, jelölje be az Adatok másolatának tárolása az űrlapsablonban jelölőnégyzetet.

    Biztonsági megjegyzés : A felhasználó számítógépén a jelölőnégyzet bejelölésével az adatokat tárolja, amikor a képernyő használja az adatkapcsolat. Ha az űrlap kényes adatok lekérése az adatkapcsolat, érdemes lehet letiltani ezt a funkciót, az adatok abban az esetben a számítógép elvész vagy ellopják védelmet.

  13. Kattintson a Tovább gombra.

  14. A varázsló következő lapján írja be a másodlagos adatkapcsolat leíró nevét, és ellenőrizze az Összegzés szakaszban található adatok helyességét.

  15. Az űrlap megnyitásakor automatikusan letöltse a szükséges adatokat az űrlap beállításához jelölje be a automatikusan beolvashatja az adatokat az űrlap ismételt megnyitásakor jelölőnégyzetet.

Vissza a lap tetejére

2. lépés: Az űrlapsablonban konfigurálása az adatkapcsolat használatához

Ha azt szeretné, hogy az adott az űrlapsablon után a felhasználó megnyitja az űrlapot az adatkapcsolat használandó alapuló űrlapokat, egy szabály is adhat az űrlapsablont, amelyet az adatkapcsolat feltételek teljesülése esetén használja, vagy gomb felvétele az űrlapsablont, amelyet a felhasználók kattinthat az adatkapcsolat használatára.

Szabály hozzáadása

A szabályok hozzáadhatja az űrlapsablont, amelyet az adatok beolvasásához lekérdezés adatkapcsolatból, amikor a szabály a feltétel nem teljesül szolgál. Például vehet egy szövegdobozt, hogy egy felhasználó az adott adatok beolvasása a külső adatforrás kitölthetik az űrlapsablon. Ezután felvehet egy szabályt, amely az adatkapcsolat használja, a ellentmondó adatok beírásakor a szövegmezőbe.

A következő eljárás feltételezi, hogy az űrlapsablon lekérdezés adatkapcsolat létrehozott és beállított vezérlőelemhez (kívül gomb) az űrlapon megjeleníteni az adatokat az adott adatkapcsolat.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Kattintson kétszer arra a vezérlőre, amelyhez szabályt kíván hozzáadni.

  3. Kattintson az Adatok fülre.

  4. Az Érvényesítés és szabályok csoportban kattintson a Szabályok gombra.

  5. A Szabályok párbeszédpanelen kattintson a Hozzáadás gombra.

  6. A Név mezőbe írja be a szabály nevét.

  7. A szabály futtatását kiváltó feltétel megadásához kattintson a Feltétel megadása gombra, és írja be a feltételt. A szabály akkor fut, amikor a feltétel teljesül. Feltétel megadása híján a szabály mindannyiszor aktiválódik, amikor a felhasználó módosítja az értéket a vezérlőben vagy elmozdítja arról az egérmutatót.

  8. Kattintson a Művelet hozzáadása gombra.

  9. A Művelet listában kattintson a Lekérdezés adatkapcsolat használatával elemre.

  10. Az Adatkapcsolat listában kattintson a használni kívánt lekérdezési adatkapcsolatra, és kattintson az OK gombra a nyitott párbeszédpanelek bezárásához.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Gomb hozzáadása

Az űrlapsablonhoz hozzá lehet adni egy gomb vezérlőelemet, amelyre kattintva a felhasználók adatokat olvashatnak be a lekérdezési adatkapcsolat segítségével.

  1. Ha az űrlapsablon több nézetet tartalmaz, kattintson a Nézet menü Nézet neve parancsára, és nyissa meg azt a nézetet, amelyen a másodlagos adatforrásból származó adatokat megjelenítő vezérlő található.

  2. Ha a Vezérlők munkaablak nem látható, kattintson a Beszúrás menü További vezérlők parancsára, vagy nyomja le az ALT+I, C billentyűkombinációt.

  3. Húzzon egy gomb vezérlőelemet az űrlapsablonra.

  4. Kattintson duplán az űrlapsablonhoz hozzáadott gomb vezérlőelemen.

  5. Kattintson az Általános fülre.

  6. A Művelet listában kattintson a Frissítés elemre.

  7. A Címke mezőbe írja be az űrlap gombján megjeleníteni kívánt nevet.

  8. Kattintson a Beállítások gombra.

  9. Tegye a következők egyikét a Frissítés párbeszédpanelen:

    • Másodlagos adatkapcsolat rendelkező összes külső adatforrásokhoz az űrlapsablonhoz a legfrissebb adatok fogadásához kattintson az összes másodlagos adatforrás.

    • Adja meg a gomb a legfrissebb adatokat fogadjon másodlagos adatkapcsolat a külső adatforrás az űrlapsablonon, kattintson egy másodlagos adatkapcsolat, és válassza a másodlagos adatforrás a Válassza ki a másodlagos adatforrás listában.

  10. Kattintson az OK gombra az összes megnyitott párbeszédpanel bezárásához.

  11. A módosítások teszteléséhez kattintson a Minta gombra a szokásos eszköztáron, vagy nyomja le a CTRL+SHIFT+B billentyűkombinációt.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×