Adatbázismodell (egyedkapcsolati diagram) létrehozása

Adatbázismodell (egyedkapcsolati diagram) létrehozása

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Az Adatbázismodell diagram sablonjával egy új modellt hozhat létre vagy visszafejthet egy létező adatbázist egy modellbe akár relációs, akár objektumrelációs modellezési elv segítségével. Használja az Egyedkapcsolat rajzsablont az SQL92-n vagy korábbi szabványokon alapuló adatbázisok modellezésére. Használja az Objektumreláció rajzsablont, mely kiegészítő alakzatokkal is rendelkezik a típusokkal történő munkához az SQL99-en vagy későbbi szabványokon alapuló adatbázisok modellezéséhez.

Adatbázismodell példája

Az Adatbázismodell diagram sablonjával egy új modellt hozhat létre vagy visszafejthet egy létező adatbázist egy modellbe akár relációs, akár objektumrelációs modellezési elv segítségével. Használja az Egyedkapcsolat rajzsablont az SQL92-n vagy korábbi szabványokon alapuló adatbázisok modellezésére. Használja az Objektumreláció rajzsablont, mely kiegészítő alakzatokkal is rendelkezik a típusokkal történő munkához az SQL99-en vagy későbbi szabványokon alapuló adatbázisok modellezéséhez.

Ez a cikk azt írja le, hogyan hozhat létre egy adatbázismodellt és hogy mit tud tenni azzal a modellel, miután létrehozta.

Nem találja az az adatbázis modell funkciói?

A Microsoft Visio egyes verziói nem rendelkeznek az adatbázismodell szolgáltatással. Ha nem találja az ebben a cikkben ismertetett szolgáltatásokat, valószínűleg a Visio olyan verziójával rendelkezik, amely nem tartalmazza ezeket.

  • A Microsoft Visio Standard nem tartalmazza az Adatbázismodell-diagram sablont.

  • A Microsoft Visio Professional és Premium kiadása az Adatbázismodell-diagram sablonon támogatja a visszafejtés szolgáltatást (vagyis modell létrehozását a Visio programban meglévő adatbázis segítségével), de nem támogatja a modellalapú rendszerépítés szolgáltatást (azaz SQL-kód generálását Visio adatbázismodellből).

  1. Ha adatbázismodell-diagramot szeretne megnyitni, a következő lehetőségek közül választhat:

    Új adatbázismodell-diagramban létrehozása üres lapból

    Ha még nincs adatbázisa, melyet kiindulópontnak használhatna, létrehozhat egy üres Adatbázismodellt, melyhez hozzáadhatja saját táblázatait és kapcsolatait.

    1. Kattintson a Fájl fülre.

    2. Kattintson az Új fülre, majd a Szoftverek és adatbázisok ikonra, végül kattintson duplán az Adatbázismodell-diagram ikonra.

    3. Az Adatbázis lap Kezelés csoportjában kattintson a Megjelenítési beállítások gombra.

    4. Az Adatbázis dokumentum beállításai párbeszédpanelen válassza ki a használni kívánt szimbólumkészletet, illetve más táblázati és egyedkapcsolati beállításokat, majd kattintson az OK gombra.

    Meglévő adatbázis kiindulási pontként használata

    Ha már van olyan adatbázis, melyet modellezni szeretne, hogy jobban megértse kezelését vagy hogy ezt egy új modell létrehozásának kiindulási pontjaként használja fel, elindíthatja a Visszafejtés varázslót az adatbázis sémájának vagy szerkezetének kinyeréséhez egy új modell létrehozásához.

    A varázsló elindítása előtt:

    1. Ha Microsoft Excel munkafüzetet fejt vissza, a varázsló elindítása előtt meg kell nyitnia a munkafüzetet, és el kell neveznie az oszlopfejléceket tartalmazó cellacsoportot (vagy -tartományt). Ha több munkalapot kíván használni, csak nevezze meg az oszlopcella csoportokat minden munkalapon. Ezeket a tartományokat a varázsló táblázatokként kezeli. Ha többet szeretne megtudni a cellacsoportok elnevezésének módjáról, keresse meg az Excel súgójában a Név megadása a cellahivatkozásokhoz és tartományokhoz című témakört.

    2. A hatékonyabb működés érdekében állítsa az alapértelmezett illesztőprogramot ahhoz a céladatbázishoz, melyet vissza kíván fejteni a Visszafejtés varázsló futtatása előtt. Ez a lépés biztosítja, hogy a varázsló az eredeti adattípusokat helyesen térképezze fel és hogy minden, a varázsló által beolvasott kód helyesen jelenjen meg a Kód ablakban.

    3. Kattintson a Fájl fülre.

    4. Kattintson az Új fülre, majd a Szoftverek és adatbázisok ikonra, végül kattintson duplán az Adatbázismodell-diagram ikonra.

    5. Az Adatbázis lap Modell csoportjában kattintson a Visszafejtés gombra.

    6. A Visszafejtés varázsló első képernyőjén tegye a következőket:

      1. Jelölje ki az adatbázis-illesztőprogramot az adatbázis-kezelő rendszer (DBMS) számára. Ha még nem társította a Visio adatbázis-illesztőprogramot egy adott ODBC-adatforrással, kattintson a Beállítás gombra.

        Megjegyzés : Excel munkalap visszafejtéséhez használja az általános ODBC-illesztőt.

      2. Válassza ki az éppen frissítés alatt álló adatbázis adatforrását. Ha még nem hozott létre adatforrást a már meglévő adatbázishoz, kattintson az Új menüpontra.

        Ha új forrást hoz létre, annak neve bekerül az Adatforrások listába.

      3. Ha elégedett a beállításokkal, kattintson a Tovább gombra.

    7. Ha az adott illesztőhöz tartozó párbeszédpanelek jelennek meg, kövesse azok útmutatásait.

      Például az Adatforrás csatlakoztatása párbeszédpanelen írja be a felhasználónevet és a jelszót, majd kattintson az OK gombra.

      Megjegyzés : Ha az általános ODBC-illesztőt használja, arról is kaphat hibaüzenetet, hogy a visszafejtett információ nem teljes. A legtöbb esetben ez nem probléma - csak kattintson az OK gombra és folytassa a varázsló futtatását.

    8. Jelölje be a beolvasni kívánt adattípusok jelölőnégyzeteit, majd kattintson a Tovább gombra.

      Megjegyzés : Nem biztos, hogy minden elem elérhető (ezek szürkítve jelennek meg), mert nem minden adatbázis-kezelő rendszer támogatja a varázsló által beolvasott minden típusú elemet.

    9. Jelölje be a beolvasni kívánt táblák (és nézetek, ha vannak ilyenek) jelölőnégyzeteit, vagy kattintson Az összes kijelölése elemre az összes beolvasásához, majd kattintson a Tovább gombra.

      Megjegyzés : Ha éppen visszafejt egy Excel munkalapot és nem lát semmit ezen a listán, valószínűleg meg kell neveznie a fejlécoszlopokat tartalmazó cellatartományt a munkafüzetben.

    10. Ha bejelölte a Tárolt eljárások jelölőnégyzetet, válassza ki a beolvasni kívánt eljárásokat, vagy kattintson Az összes kijelölése elemre az összes beolvasásához, majd kattintson a Tovább gombra.

    11. Válassza ki, hogy kívánja-e, hogy a visszafejtett elemek automatikusan hozzáadódjanak az aktuális oldalhoz.

      Megjegyzés : Választhatja azt, hogy a varázsló automatikusan létrehozza a rajzot a visszafejtett elemek Táblázatok és nézetek ablakban történő listázásán túl. Ha nem szeretné a rajzot automatikus létrehozását, húzza el az elemeket a Táblázatok és nézetek ablakból a rajzoldalra, hogy saját maga állíthassa össze az adatbázismodelljét.

    12. Tekintse át a beállításokat és ellenőrizze, hogy a kívánt adatokat fogja-e beolvasni, majd kattintson a Befejezés gombra.

      A varázsló beolvassa a kijelölt adatokat és megjegyzéseket jelenít meg a feladattal kapcsolatban a Kimenet ablakban.

    Importálása és meglévő modell pontosítása

    Ha már rendelkezik meglévő VisioModeler vagy PLATINUM ERwin modellel, valószínűleg át tudja importálni azt egy Visio adatbázismodell-diagram létrehozásához. Ez a lehetőség csak a VisioModeler 2.0 vagy későbbi szótármodell (.imd) fájlok és PLATINUM ERwin 2.6, 3.0, és 3.52 .erx fájlok esetében érhető el.

    1. Kattintson a Fájl fülre.

    2. Kattintson az Új fülre, majd a Szoftverek és adatbázisok ikonra, végül kattintson duplán az Adatbázismodell-diagram ikonra.

    3. Az Adatbázis lap Modell csoportjában kattintson az Importálás gombra, majd a modelltípusra.

    4. Írja be az importálni kívánt fájl nevét és elérési útját vagy kattintson a Tallózás gombra a modellfájl helyének meghatározásához, majd kattintson a Megnyitásgombra.

    5. Az Importálás párbeszédpanelen, kattintson az OK gombra.

      A Visio importálja a fájlt, a művelet végrehajtása pedig a Kimenet ablakban követhető nyomon. Az importált táblák a Táblák és nézetek ablakban jelennek meg.

    6. A Táblázatok és nézetek ablakban, jelölje ki a modellezni kívánt táblázatokat, majd húzza őket a rajzlapra.

  2. Az adatbázismodell-diagram létrehozása után a diagram pontosítása következik. Hozzáadhat vagy testreszabhat táblázatokat és nézeteket, kapcsolatokat hozhat létre és testreszabhatja az oszlopokat és adattípusokat.

    Táblák

    Az Egyed alakzat segítségével létrehozhat egy táblázatot a diagramon belül.

    1. Az Egyedkapcsolat vagy az Objektumrelációs rajzsablonról húzzon egy Egyed alakzatot a rajzlapra.

    2. Kattintson duplán az alakzatra az Adatbázis adatlapja ablak megnyitásához.

    3. A Kategóriák lapon kattintson a Definíció mezőre és adja meg a tábla nevét.

    4. A Kategóriák lapon kattintson az Oszlopok gombra, írjon be egy nevet és válassza ki az adattípust.

    5. Jelölje be a Kötelező jelölőnégyzetet azon oszlopokhoz, melyek nem rendelkezhetnek null értékkel.

    6. Jelölje be az EK (elsődleges kulcs) jelölőnégyzetet azon oszlopokhoz, melyek egyértelműen azonosítanak minden sort az adatbázis-táblázatban.

    7. A Kategóriák lapon kattintson az Indexek, Eseményindítók, Ellenőrzés vagy a Bővített elemre ezeknek a választható elemeknek a létrehozásához.

    Oszlopok

    Használja az Adatbázis adatlapja ablakot az oszloptulajdonságok hozzáadásához vagy módosításához, beleértve adattípusokat és elsődleges kulcsokat.

    1. Kattintson duplán a diagramban található táblázatra.

    2. Az Adatbázis adatlapja ablak Kategóriák listájában kattintson az Oszlopok elemre.

    3. Kattintson az első üres Fizikai név cellára, és írjon be egy nevet.

    4. Egy oszlop adattípusának megváltoztatásához kattintson az oszlop Adattípus mezőjére és válasszon ki egy adattípust a listából vagy írja be a listába. Például beírhatja a következőket: decimal(8,2) vagy char(30).

    5. Az üres értékek elkerülése érdekében jelölje be a Kötelező jelölőnégyzetet.

    6. Ha azt szeretné megadni, hogy az oszlop elsődleges kulcs, jelölje be a PK jelölőnégyzetet.

    7. További oszloptulajdonságok is elérhetők azokon kívül, amelyek az Oszlopok kategóriára kattintva jelennek meg. Ezek szerkesztéséhez jelölje ki az oszlopot, majd kattintson a Szerkesztés gombra.

    Kapcsolatok

    A Kapcsolatok elsődleges és idegen kulcsokat használnak, hogy lehetővé tegyék az adatbázisok számára, hogy kapcsolatot létesítsenek az egyik táblázatban található sor és egy vele kapcsolatban álló másik táblázat egy sora között. Ezeket a kapcsolatokat megjelenítheti a diagramban. Sőt, beállíthatja számosságukat (például egy-a-többhöz) és használhatja akár a szarkaláb, relációs vagy IDEF1X jelölést a számosság megjelenítéséhez. Nem jeleníthet meg több-a-többhöz kapcsolatokat ezen jelölések egyikével sem az Adatbázismodell-diagram sablonban.

    1. Kapcsolat létrehozása táblázatok között:

      1. Bizonyosodjon meg arról, hogy mindkét táblázat látható a diagramban. Ha egy már meglévő adatbázisból fejtette vissza a modellt, szükséges lehet egyik vagy másik vagy mindkettő áthúzása a Táblázatok és Nézetek ablakból a rajzlapra.

      2. Kattintson duplán arra a táblázatra, melyet a kapcsolat elsődleges kulcs oldalán kíván megjelölni.

      3. Az Adatbázis adatlapja ablak Kategóriák listájában kattintson az Oszlopok elemre.

      4. A rácson kattintson arra az oszlopra, melyet kizárólagosan szeretne használni a táblázatban lévő sorok azonosítására és jelölje be az EK (elsődleges kulcs) jelölőnégyzetet, hogy azt állítsa be elsődleges kulcsnak.

      5. Az Objektumrelációs vagy Egyedkapcsolat rajzsablonból húzzon el egy Kapcsolat alakzatot és helyezze el egy üres helyre a lapon.

      6. A magasabb végét kapcsolja hozzá a szülőtáblát tartalmazó táblához.

      7. Kapcsolja a másik végét a gyerektáblához.

        Ha a második táblázat még nem tartalmaz oszlopot az elsődleges kulcs nevével, a modellező alkalmazás idegen kulcsként hozzáadja.

        Megjegyzés : Ha a kapcsolatvonalak eltűnnek, az Adatbázis lap Kezelés csoportjában kattintson a Megjelenítési beállítások gombra. A Kapcsolatok lap Megjelenítés csoportjában jelölje be a Kapcsolatok jelölőnégyzetet.

    2. A kapcsolat számosságának beállítása:

      1. Kattintson duplán a kapcsolatra.

      2. Az Adatbázis adatlapja ablakban, a Kategóriák listán kattintson az Egyéb elemre.

      3. A Számosság oldalon válassza ki a kapcsolatnak legjobban megfelelő számosságot. Az egy-a-többhöz kapcsolatokhoz, a legjobb választás vagy a Nulla vagy több vagy az Egy vagy több. Az egy-a-többhöz kapcsolatokhoz, a legjobb választás vagy a Nulla vagy egy vagy a Pontosan egy.

  3. A diagram további pontosításához (mint például indexek, ellenőrző záradékok vagy eseményindítók létrehozása) az alábbiakat teheti:

    Index létrehozása

    Az indexek javítják az adatbázis teljesítményét vagy sebességét egy lekérdezés lefuttatásakor.

    1. Nyissa meg az adatbázismodell-diagramot.

    2. Kattintson duplán arra a táblára, amelyhez indexet kíván adni, majd az Adatbázis adatlapja ablak Kategóriák listájában kattintson az Indexek elemre.

    3. Kattintson az Új kategóriára.

    4. Írja be az új index nevét az Index hozzáadása párbeszédpanelen, majd kattintson az OK gombra.

    5. Az Index típusa lista megfelelő beállításának kiválasztásával adja meg, hogy egyedi vagy nem egyedi indexet kíván-e létrehozni.

    6. A Megjeleníthető oszlopok listában jelölje ki az indexbe helyezendő oszlopok nevét, majd kattintson a Hozzáadás > gombra.

    7. Az Indexelt oszlopok listában jelölje be az Asc jelölőnégyzetet, ha növekvő rendezési sorrendű indexet kíván létrehozni vagy törölje a jelet a négyzetből, ha csökkenő rendezési sorrendű indexet kíván létrehozni.

      Az adatbázismodell-diagram frissítése kész.

    Nézetek létrehozása:

    A nézetre egy mentett lekérdezésnek is tekinthető. A nézetek különösen praktikusak, ha ugyanazokhoz az adatokhoz kell rendszeresen hozzájutnia különböző adatbázisokból vagy ha az adatokat elérhetővé kívánja tenni felhasználók számára anélkül, hogy lehetővé tenné számukra az aktuális táblázatok módosítását.

    Az Egyedkapcsolat vagy Objektumrelációs rajzsablonról húzza a Nézet alakzatot a rajzlapra.

    Táblák és nézetek bővített tulajdonságainak beállítása

    Az adatbáziskezelő-rendszertől függően lehetősége nyílik a táblázatok vagy nézetek bővített attribútumainak beállítására a tárolási helyük meghatározása érdekében.

    Kattintson duplán arra a táblára vagy nézetre, amelynek bővített attribútumait be szeretné állítani, majd az Adatbázis adatlapja ablak Kategóriák listájában kattintson a Bővített elemre.

    Ellenőrző záradékok létrehozása

    Az ellenőrző záradékok használatával megbizonyosodhat arról, hogy az adott oszlopba bevitt adatok egy bizonyos értékhatáron belül helyezkednek el. Például létrehozhat egy ellenőrző záradékot, mely előírja, hogy a „Kor” nevű oszlopban található adatok 65 felett legyenek.

    1. Kattintson duplán a táblára az Adatbázis adatlapja ablak megnyitásához.

    2. A Kategóriákoldalon kattintson az Oszlopok mezőre, majd kattintson arra az oszlopra, melyhez hozzá szeretne adni egy ellenőrző záradékot.

    3. Kattintson a Szerkesztés gombra.

    4. Az Oszlop tulajdonságai párbeszédpanel Ellenőrzés oldalán írja be a kívánt korlátozásokat.

      Ezzel az ellenőrző záradék felkerült a Kód ablakban a Helyi kód listára.

    Hozzon létre tárolt eljárások és a felhasználó által definiált függvények

    Használja a tárolt eljárásokat és a felhasználó által definiált függvényeket az ismétlődő műveletek végrehajtásához többször is használható kódcsomagok létrehozására. A kettő közötti főbb különbség, hogy a felhasználó által definiált függvény egy értékkel tér vissza, míg a tárolt eljárás egy kódot futtat le értékkel történő visszatérés nélkül.

    1. Az Adatbázis lap Megjelenítés/elrejtés csoportjában jelölje be a Kód jelölőnégyzetet a Kód ablak megjelenítéséhez.

    2. Kattintson a Globális kód, majd az Új elemre.

    3. A KódszerkesztőTulajdonságok oldalán kattintson a létrehozni kívánt kódtípusra és írjon be egy nevet a kód számára.

    4. A Szövegtörzs lapon adja meg a kódot, majd kattintson az OK gombra.

    Eseményindítók létrehozása

    Az eseményindítók a bennük megadott SQL kódot lefuttatják, mikor egy bizonyos esemény történik az adatbázisban.

    1. Kattintson duplán a táblára az Adatbázis adatlapja ablak megnyitásához.

    2. A Kategóriák oldalon kattintson az Eseményindító elemre majd a Hozzáadás gombra.

    3. A Tulajdonságok lapon írjon be egy nevet az eseményindító számára.

    4. A Szövegtörzs lapon adja meg a kódot, majd kattintson az OK gombra.

      Az eseményindító hozzáadódik a Kód ablakhoz a Helyi kód oldalon.

Ez a cikk azt írja le, hogyan hozhat létre egy adatbázismodellt és hogy mit tud tenni azzal a modellel, miután létrehozta. Első lépésként, a Fájl menüben mutasson rá az Új, majd a Szoftver és adatbázis elemre, eztán kattintson az Adatbázismodell-diagram elemre.

Nem találja az az adatbázis modell funkciói?

Elképzelhető, hogy a Microsoft Office Visio program Ön által használt változata nem tartalmazza a keresett szolgáltatást. A Visio változatának a megnevezése a Súgó menü Microsoft Office Visio névjegye menüpontjára kattintva tekinthető meg. A változat neve a párbeszédpanelben található szöveg felső sorában található.

  • A Microsoft Office Visio Standard nem tartalmazza az adatbázismodell-diagram sablonokat.

  • A Microsoft Office Visio Professional az adatbázismodell-diagram sablonon támogatja a visszafejtés szolgáltatást (vagyis egy létező adatbázis segítségével egy modell létrehozását a Visio programban), de nem támogatja a modellalapú rendszerépítés szolgáltatást (azaz Visio adatbázis modellből SQL kód generálását).

  • A Visio for Enterprise Architects programban az adatbázismodell-szolgáltatások teljes köre megtalálható, beleértve a kód visszafejtését és modellalapú rendszerépítést is. A Visio for Enterprise Architects a Visual Studio Professional és Visual Studio Team System szerepkör-alapú kiadásaival elérhető exkluzív MSDN előfizetést tartalmaz.

  1. Ha adatbázismodell-diagramot szeretne megnyitni, a következő lehetőségek közül választhat:

    Új adatbázismodell-diagramban létrehozása üres lapból

    Ha még nincs adatbázisa, melyet kiindulópontnak használhatna, létrehozhat egy üres Adatbázismodellt, melyhez hozzáadhatja saját táblázatait és kapcsolatait.

    1. A Fájl menüben mutasson az Új, majd a Szoftverek és adatbázisok pontra és kattintson az Adatbázismodell-diagram parancsra.

    2. Az Adatbázis menüben mutasson a Beállítások pontra, majd kattintson a Dokumentum parancsra.

    3. Az Adatbázis dokumentum beállításai párbeszédpanelen válassza ki a használni kívánt szimbólumkészletet, illetve más táblázati és egyedkapcsolati beállításokat, majd kattintson az OK gombra.

    Meglévő adatbázis kiindulási pontként használata

    Ha már van olyan adatbázis, melyet modellezni szeretne, hogy jobban megértse kezelését vagy hogy ezt egy új modell létrehozásának kiindulási pontjaként használja fel, elindíthatja a Visszafejtés varázslót az adatbázis sémájának vagy szerkezetének kinyeréséhez egy új modell létrehozásához.

    Megjegyzés : A varázsló elindítása előtt:

    1. Ha egy Microsoft Office Excel munkafüzetet fejt vissza, a varázsló elindítása előtt meg kell nyitnia a munkafüzetet és el kell neveznie az oszlopfejléceket tartalmazó cellacsoportot (vagy -tartományt). Ha több munkalapot kíván használni, csak nevezze meg az oszlopcella csoportokat minden munkalapon. Ezeket a tartományokat a varázsló táblázatokként kezeli. Ha többet szeretne megtudni a cellacsoportok elnevezésének módjáról, keresse meg a Microsoft Office Excel Súgójában a Név megadása a cellahivatkozásokhoz és tartományokhoz című témakört.

    2. A hatékonyabb működés érdekében állítsa az alapértelmezett illesztőprogramot ahhoz a céladatbázishoz, melyet vissza kíván fejteni a Visszafejtés Varázsló futtatása előtt. Ez a lépés biztosítja, hogy a varázsló az eredeti adattípusokat helyesen térképezze fel és hogy minden, a varázsló által beolvasott kód helyesen jelenjen meg a Kód ablakban.

    3. A Fájl menüben mutasson az Új, majd a Szoftverek és adatbázisok pontra és kattintson az Adatbázismodell-diagram parancsra.

    4. Kattintson az Adatbázis menü Visszafejtés parancsára.

    5. A Visszafejtés varázsló első képernyőjén tegye a következőket:

      1. Jelölje ki a Microsoft Office Visio adatbázis-illesztőprogramot az adatbázis-kezelő rendszere (DBMS - database management system) számára. Ha még nem társította a Visio adatbázis-illesztőprogramot egy speciális ODBC-adatforrással, kattintson a Beállítás gombra.

        Megjegyzés : Excel munkalap visszafejtéséhez használja az általános ODBC-illesztőt.

      2. Válassza ki az éppen frissítés alatt álló adatbázis adatforrását. Ha még nem hozott létre adatforrást a már meglévő adatbázishoz, kattintson az Új menüpontra.

        Ha új forrást hoz létre, annak neve bekerül az Adatforrások listába.

      3. Ha elégedett a beállításokkal, kattintson a Tovább gombra.

    6. Ha az adott illesztőhöz tartozó párbeszédpanelek jelennek meg, kövesse azok útmutatásait.

      Az Aktuális adatforrás párbeszédpanelben például írja be a felhasználónevet és jelszót, majd kattintson az OK gombra. Ha az adatforrás nem jelszóval védett, csak kattintson az OK gombra.

      Megjegyzés : Ha az általános ODBC-illesztőt használja, arról is kaphat hibaüzenetet, hogy a visszafejtett információ nem teljes. A legtöbb esetben ez nem probléma - csak kattintson az OK gombra és folytassa a varázsló futtatását.

    7. Jelölje be a beolvasni kívánt adattípusok jelölőnégyzeteit, majd kattintson a Tovább gombra.

      Megjegyzés : Nem biztos, hogy minden elem elérhető (ezek szürkítve jelennek meg), mert nem minden adatbázis-kezelő rendszer támogatja a varázsló által beolvasott minden típusú elemet.

    8. Jelölje be a beolvasni kívánt táblák (és nézetek, ha vannak ilyenek) jelölőnégyzeteit, vagy kattintson Az összes kijelölése elemre az összes beolvasásához, majd kattintson a Tovább gombra.

      Megjegyzés : Ha éppen visszafejt egy Excel munkalapot és nem lát semmit ezen a listán, valószínűleg meg kell neveznie a fejlécoszlopokat tartalmazó cellatartományt a munkafüzetben.

    9. Ha az 5. lépésben bejelölte a Tárolt eljárások jelölőnégyzetet, válassza ki a beolvasni kívánt eljárásokat, vagy kattintson Az összes kijelölése elemre az összes beolvasásához, majd kattintson a Tovább gombra.

    10. Válassza ki, hogy kívánja-e, hogy a visszafejtett elemek automatikusan hozzáadódjanak az aktuális oldalhoz.

      Megjegyzés : Választhatja azt, hogy a varázsló automatikusan létrehozza a rajzot a visszafejtett elemek Táblázatok és nézetek ablakban történő listázásán túl. Ha nem szeretné a rajzot automatikus létrehozását, húzza el az elemeket a Táblázatok és nézetek ablakból a rajzoldalra, hogy saját maga állíthassa össze az adatbázismodelljét.

    11. Tekintse át a beállításokat és ellenőrizze, hogy a kívánt adatokat fogja-e beolvasni, majd kattintson a Befejezés gombra.

      A varázsló beolvassa a kijelölt adatokat és megjegyzéseket jelenít meg a feladattal kapcsolatban a Kimenet ablakban.

    Importálása és meglévő modell pontosítása

    Ha már rendelkezik meglévő VisioModeler vagy PLATINUM ERwin modellel, valószínűleg át tudja importálni azt egy Visio adatbázismodell-diagram létrehozásához. Ez a lehetőség csak a VisioModeler 2.0 vagy későbbi szótármodell (.imd) fájlok és PLATINUM ERwin 2.6, 3.0, és 3.52 .erx fájlok esetében érhető el.

    1. A Fájl menüben mutasson az Új, majd a Szoftverek és adatbázisok pontra és kattintson az Adatbázismodell-diagram parancsra.

    2. Mutasson az Adatbázis menü Importálás pontjára, majd kattintson a <modelltípus> importálása parancsra.

    3. Írja be az importálni kívánt fájl nevét és elérési útját vagy kattintson a Tallózás gombra a modellfájl helyének meghatározásához, majd kattintson a Megnyitásgombra.

    4. Az Importálás párbeszédpanelen, kattintson az OK gombra.

      A Visio importálja a fájlt, a művelet végrehajtása pedig a Kimenet ablakban követhető nyomon. Az importált táblák a Táblák és nézetek ablakban jelennek meg.

    5. A Táblázatok és nézetek ablakban, jelölje ki a modellezni kívánt táblázatokat, majd húzza őket a rajzlapra.

  2. Az adatbázismodell-diagram létrehozása után a diagram pontosítása következik. Hozzáadhat vagy testreszabhat táblázatokat és nézeteket, kapcsolatokat hozhat létre és testreszabhatja az oszlopokat és adattípusokat.

    Táblák

    Az Egyed alakzat segítségével létrehozhat egy táblázatot a diagramon belül.

    1. Az Egyedkapcsolat vagy az Objektumrelációs rajzsablonról húzzon egy Egyed alakzatot a rajzlapra.

    2. Kattintson duplán az alakzatra az Adatbázis adatlap ablak megnyitásához.

    3. A Kategóriák lapon kattintson a Definíció mezőre és adja meg a tábla nevét.

    4. A Kategóriák lapon kattintson az Oszlopok gombra, írjon be egy nevet és válassza ki az adattípust.

    5. Jelölje be a Kötelező jelölőnégyzetet azon oszlopokhoz, melyek nem rendelkezhetnek null értékkel.

    6. Jelölje be az EK (elsődleges kulcs) jelölőnégyzetet azon oszlopokhoz, melyek egyértelműen azonosítanak minden sort az adatbázis-táblázatban.

    7. A Kategóriák lapon kattintson az Indexek, Eseményindítók, Ellenőrzés vagy a Bővített elemre ezeknek a választható elemeknek a létrehozásához.

    Oszlopok

    Használja az Adatbázis adatlapja ablakot az oszloptulajdonságok hozzáadásához vagy módosításához, beleértve adattípusokat és elsődleges kulcsokat.

    1. Kattintson duplán a diagramban található táblázatra.

    2. Az Adatbázis adatlapja ablak Kategóriák részében kattintson az Oszlopok mezőre.

    3. Kattintson az első üres Fizikai név cellára és írjon be egy nevet.

    4. Egy oszlop adattípusának megváltoztatásához kattintson az oszlop Adattípus mezőjére és válasszon ki egy adattípust a listából vagy írja be a listába. Például beírhatja a következőket: decimal(8,2) vagy char(30).

    5. Az üres értékek elkerülése érdekében jelölje be a Kötelező jelölőnégyzetet.

    6. Ha azt szeretné megadni, hogy az oszlop elsődleges kulcs, jelölje be a PK jelölőnégyzetet.

    7. További oszloptulajdonságok is elérhetők azokon kívül, amelyek az Oszlopok kategóriára kattintva jelennek meg. Ezek szerkesztéséhez jelölje ki az oszlopot, majd kattintson a Szerkesztés gombra.

    Kapcsolatok

    A Kapcsolatok elsődleges és idegen kulcsokat használnak, hogy lehetővé tegyék az adatbázisok számára, hogy kapcsolatot létesítsenek az egyik táblázatban található sor és egy vele kapcsolatban álló másik táblázat egy sora között. Ezeket a kapcsolatokat megjelenítheti a diagramban. Sőt, beállíthatja számosságukat (például egy-a-többhöz) és használhatja akár a szarkaláb, relációs vagy IDEF1X jelölést a számosság megjelenítéséhez. Nem jeleníthet meg több-a-többhöz kapcsolatokat ezen jelölések egyikével sem az Adatbázismodell-diagram sablonban.

    1. Kapcsolat létrehozása táblázatok között:

      1. Bizonyosodjon meg arról, hogy mindkét táblázat látható a diagramban. Ha egy már meglévő adatbázisból fejtette vissza a modellt, szükséges lehet egyik vagy másik vagy mindkettő áthúzása a Táblázatok és Nézetek ablakból a rajzlapra.

      2. Kattintson duplán arra a táblázatra, melyet a kapcsolat elsődleges kulcs oldalán kíván megjelölni.

      3. Az Adatbázis adatlapja ablak Kategóriák részében kattintson az Oszlopok mezőre.

      4. A rácson kattintson arra az oszlopra, melyet kizárólagosan szeretne használni a táblázatban lévő sorok azonosítására és jelölje be az EK (elsődleges kulcs) jelölőnégyzetet, hogy azt állítsa be elsődleges kulcsnak.

      5. Az Objektumrelációs vagy Egyedkapcsolat rajzsablonból húzzon el egy Kapcsolat alakzatot és helyezze el egy üres helyre a lapon.

      6. A magasabb végét kapcsolja hozzá a szülőtáblát tartalmazó táblához.

      7. Kapcsolja a másik végét a gyerektáblához.

        Ha a második táblázat még nem tartalmaz oszlopot az elsődleges kulcs nevével, a modellező alkalmazás idegen kulcsként hozzáadja.

        Megjegyzés : Ha a kapcsolatvonalak eltűnnek, az Adatbázis menüben mutasson a Beállítások pontra, majd kattintson a Dokumentum parancsra. A Kapcsolatok oldalon a Megjelenítés alatt jelölje be a Kapcsolatok jelölőnégyzetet.

    2. A kapcsolat számosságának beállítása:

      1. Kattintson duplán a kapcsolatra.

      2. Az Adatbázis adatlapja ablakban, a Kategóriák lapon, kattintson az Egyéb gombra.

      3. A Számosság oldalon válassza ki a kapcsolatnak legjobban megfelelő számosságot. Az egy-a-többhöz kapcsolatokhoz, a legjobb választás vagy a Nulla vagy több vagy az Egy vagy több. Az egy-a-többhöz kapcsolatokhoz, a legjobb választás vagy a Nulla vagy egy vagy a Pontosan egy.

  3. A diagram további pontosításához (mint például indexek, ellenőrző záradékok vagy eseményindítók létrehozása) az alábbiakat teheti:

    Index létrehozása

    Az indexek javítják az adatbázis teljesítményét vagy sebességét egy lekérdezés lefuttatásakor.

    1. Nyissa meg az adatbázismodell-diagramot.

    2. Kattintson duplán arra a táblázatra, amelyhez indexet kíván adni, majd az Adatbázis adatlapja ablak Kategóriák listájában kattintson az Indexek elemre.

    3. Kattintson az Új kategóriára.

    4. Írja be az új index nevét az Index hozzáadása párbeszédpanelen, majd kattintson az OK gombra.

    5. Az Index típusa lista megfelelő beállításának kiválasztásával adja meg, hogy egyedi vagy nem egyedi indexet kíván-e létrehozni.

    6. A Megjeleníthető oszlopok listában jelölje ki az indexbe helyezendő oszlopok nevét, majd kattintson a Hozzáadás > gombra.

    7. Az Indexelt oszlopok listában jelölje be az Asc jelölőnégyzetet, ha növekvő rendezési sorrendű indexet kíván létrehozni vagy törölje a jelet a négyzetből, ha csökkenő rendezési sorrendű indexet kíván létrehozni.

      Az adatbázismodell-diagram frissítése kész.

    Nézetek létrehozása:

    A nézetre egy mentett lekérdezésnek is tekinthető. A nézetek különösen praktikusak, ha ugyanazokhoz az adatokhoz kell rendszeresen hozzájutnia különböző adatbázisokból vagy ha az adatokat elérhetővé kívánja tenni felhasználók számára anélkül, hogy lehetővé tenné számukra az aktuális táblázatok módosítását.

    Az Egyedkapcsolat vagy Objektumrelációs rajzsablonról húzza a Nézet alakzatot a rajzlapra.

    Táblák és nézetek bővített tulajdonságainak beállítása

    Az adatbáziskezelő-rendszertől függően lehetősége nyílik a táblázatok vagy nézetek bővített attribútumainak beállítására a tárolási helyük meghatározása érdekében.

    Kattintson duplán arra a táblára vagy nézetre, amelynek bővített attribútumait be szeretné állítani, majd az Adatbázis adatlapja ablak Kategóriák listájában kattintson a Bővített elemre.

    Ellenőrző záradékok létrehozása

    Az ellenőrző záradékok használatával megbizonyosodhat arról, hogy az adott oszlopba bevitt adatok egy bizonyos értékhatáron belül helyezkednek el. Például létrehozhat egy ellenőrző záradékot, mely előírja, hogy a „Kor” nevű oszlopban található adatok 65 felett legyenek.

    1. Kattintson duplán a táblára az Adatbázis adatlapja ablak megnyitásához.

    2. A Kategóriákoldalon kattintson az Oszlopok mezőre, majd kattintson arra az oszlopra, melyhez hozzá szeretne adni egy ellenőrző záradékot.

    3. Kattintson a Szerkesztés gombra.

    4. A lapon Jelölje be az Oszlop tulajdonságai párbeszédpanel adja meg a kívánt kényszereket. További információt a választási lehetőségek oszlop- és tulajdonságai párbeszédpanel (ellenőrzés lap)látható.

      Az ellenőrző záradék hozzáadódik a Kód ablakhoz a Helyi kód oldalon.

    Hozzon létre tárolt eljárások és a felhasználó által definiált függvények

    Használja a tárolt eljárásokat és a felhasználó által definiált függvényeket az ismétlődő műveletek végrehajtásához többször is használható kódcsomagok létrehozására. A kettő közötti főbb különbség, hogy a felhasználó által definiált függvény egy értékkel tér vissza, míg a tárolt eljárás egy kódot futtat le értékkel történő visszatérés nélkül.

    1. Mutasson az Adatbázis menü Nézet pontjára, majd kattintson a Kód parancsra a Kód ablak megnyitásához.

    2. Kattintson a Globális kód, majd az Új elemre.

    3. A KódszerkesztőTulajdonságok oldalán kattintson a létrehozni kívánt kódtípusra és írjon be egy nevet a kód számára.

    4. A Szövegtörzs lapon adja meg a kódot, majd kattintson az OK gombra.

    Eseményindítók létrehozása

    Az eseményindítók a bennük megadott SQL kódot lefuttatják, mikor egy bizonyos esemény történik az adatbázisban.

    1. Kattintson duplán a táblára az Adatbázis adatlapja ablak megnyitásához.

    2. A Kategóriák oldalon kattintson az Eseményindító elemre majd a Hozzáadás gombra.

    3. A Tulajdonságok lapon írjon be egy nevet az eseményindító számára.

    4. A Szövegtörzs lapon adja meg a kódot, majd kattintson az OK gombra.

      Az eseményindító hozzáadódik a Kód ablakhoz a Helyi kód oldalon.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×