A tábla argumentum használata a keresőfüggvényekben

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Amikor az FKERES vagy a VKERES függvényt használja egy képletben, meg kell adnia egy „tábla” argumentumot, amely nem más, mint egy cellatartomány, pl. D2:F39. A függvény ebben a tartományban keresi a megadott adatot.

A tábla argumentum az FKERES és a VKERES függvénynek mindig a második argumentuma (az első a keresett érték). Ezek a függvények a tábla argumentum nélkül nem működnek.

Az első argumentum lehet egy konkrét érték, például „41” vagy „lukács”, de lehet cellahivatkozás is, pl. F2. Az első argumentum a következőképpen nézhet ki:

=FKERES(F2;...

A tábla argumentum mindig a keresett értéket követi, így:

=FKERES(F2;B4:D39; ...

A tábla argumentumban megadott cellatartomány relatív és abszolút cellahivatkozással is megadható. Ha a képletet más cellákba másolja majd, abszolút cellahivatkozásokat kell használnia (a $ jellel):

=FKERES(F2;$B$2:BD$39; ...

Ha a tábla argumentumban megadott cellák a munkafüzet másik munkalapján vannak, az argumentumba fel kell venni a lap nevét a végén felkiáltójellel. Ennek szintaxisa:

=FKERES(F2;Munka2!$C$14:E$42; ...

A keresett értékeket tartalmazó oszlop a harmadik megadandó argumentum. Ez a keresési oszlop. Ha a keresett értékek a D oszlopban (tehát a megadott tábla harmadik oszlopában) vannak, az utolsó argumentum értéke 3 lesz.

=FKERES(F2;B4:D39;3)

A képlet negyedik, nem kötelező, de ajánlott argumentuma az „igaz” vagy „hamis”. Használja a „hamis” argumentumot, ha pontos egyezést keres.

=FKERES(F2;B4:D39;3;Hamis)

Ha az Igaz értéket adja meg, vagy egyáltalán nem adja meg a negyedik argumentumot, akkor a függvény az első argumentumként megadott értékhez legközelebb álló találatot adja vissza. Ha az első argumentum „Lukács”, és megadja az Igaz értéket, akkor az FKERES függvény a „Lukács”, „Lukácsi” stb. értéket is visszaadhatja. Ha azonban a Hamis értéket adja meg, akkor a függvény csak a „Lukács" értéket, tehát a pontos találatot adhatja vissza, és legtöbbször éppen ez a cél.

Az Igaz érték használata még trükkösebb, ha a harmadik argumentumként megadott keresési oszlop nincs növekvő sorrendbe (A-tól Z-ig, illetve a legkisebbtől a legnagyobb számig) rendezve, ilyenkor ugyanis helytelen lehet az eredmény.

További információt az FKERES és a VKERES függvényről a Keresési és hivatkozási függvények (segédlet) című témakörben találhat.

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×