A tábla argumentum használata a keresőfüggvényekben

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

Amikor létrehoz egy képlet az FKERES és VKERES függvénnyel, írja be a tábla argumentum, amely egy cellatartományt, például D2:F39. A függvény megkeresi a tartományt az adatok, akkor próbálja megtalálni.

A tábla argumentum az FKERES és a VKERES függvénynek mindig a második argumentuma (az első a keresett érték). Ezek a függvények a tábla argumentum nélkül nem működnek.

Az első argumentum lehet egy konkrét érték, például „41” vagy „lukács”, de lehet cellahivatkozás is, pl. F2. Az első argumentum a következőképpen nézhet ki:

=FKERES(F2;...

A tábla argumentum mindig a keresett értéket követi, így:

=FKERES(F2;B4:D39; ...

A tábla argumentumban megadott cellatartomány relatív és abszolút cellahivatkozással is megadható. Ha a képletet más cellákba másolja majd, abszolút cellahivatkozásokat kell használnia (a $ jellel):

=FKERES(F2;$B$2:BD$39; ...

Ha a tábla argumentumban megadott cellák a munkafüzet másik munkalapján vannak, az argumentumba fel kell venni a lap nevét a végén felkiáltójellel. Ennek szintaxisa:

=FKERES(F2;Munka2!$C$14:E$42; ...

A keresett értékeket tartalmazó oszlop a harmadik megadandó argumentum. Ez a keresési oszlop. Ha a keresett értékek a D oszlopban (tehát a megadott tábla harmadik oszlopában) vannak, az utolsó argumentum értéke 3 lesz.

=FKERES(F2;B4:D39;3)

A képlet negyedik, nem kötelező, de ajánlott argumentuma az „igaz” vagy „hamis”. Használja a „hamis” argumentumot, ha pontos egyezést keres.

=FKERES(F2;B4:D39;3;Hamis)

Ha az Igaz értéket adja meg, vagy egyáltalán nem adja meg a negyedik argumentumot, akkor a függvény az első argumentumként megadott értékhez legközelebb álló találatot adja vissza. Ha az első argumentum „Lukács”, és megadja az Igaz értéket, akkor az FKERES függvény a „Lukács”, „Lukácsi” stb. értéket is visszaadhatja. Ha azonban a Hamis értéket adja meg, akkor a függvény csak a „Lukács" értéket, tehát a pontos találatot adhatja vissza, és legtöbbször éppen ez a cél.

Az Igaz érték használata még trükkösebb, ha a harmadik argumentumként megadott keresési oszlop nincs növekvő sorrendbe (A-tól Z-ig, illetve a legkisebbtől a legnagyobb számig) rendezve, ilyenkor ugyanis helytelen lehet az eredmény.

További információt az FKERES és VKERES függvénnyel olvassa el a keresési és hivatkozási függvények (segédlet)című témakört.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×