A közzétett űrlapsablon áthelyezése egy új SharePoint-tárban

Fontos : Ez a cikk gépi fordítással lett lefordítva, lásd a jognyilatkozatot. A cikk angol változatát itt találhatja meg.

Tartalom

– Áttekintés

Első lépések

Űrlapsablon munka másolatának beszerzése

Lépés: 1: Az új dokumentumtár az űrlapsablon közzététele

Lépés: 2: Másolja a vágólapra, és az űrlapokra újrakapcsolása

Áttekintés

Elképzelhető, hogy miután az űrlapsablont publikálta egy dokumentumtárban és a felhasználók kitöltötték azokat, a sablont át kell helyeznie egy másik dokumentumtárba. Ilyen eset például, ha át kell helyeznie az űrlapsablont egy nagyobb kapacitású kiszolgálóra, hogy több felhasználó tudja kitölteni az űrlapokat ugyanabban az időben. A felhasználók egy része már kitöltötte az eredeti dokumentumtárban található sablonon alapuló űrlapokat. Ezért amikor a sablont áthelyezi az új dokumentumtárba, a már létező űrlapokat is át kell helyeznie, valamint a régi dokumentumtár archiválása vagy törlése előtt ellenőriznie kell, hogy az már létező űrlapok az új dokumentumtárban is működnek.

Tipp : Mielőtt áthelyezné az űrlapsablont az új dokumentumtárba, készítsen tervet, amely többek között informálja a felhasználókat, hogy űrlapjaik új dokumentumtárba kerültek áthelyezésre. A felhasználóknak az új űrlapok létrehozásához és a létező űrlapok módosításához ezentúl az új dokumentumtárat kell használniuk. A terv tartalmazza a régi dokumentumtár archiválásának vagy törlésének folyamatleírását is.

Mielőtt az űrlapsablont és a létező sablonokat áthelyezi az új dokumentumtárba, a sablon munka-másolatát közzé kell tennie az új dokumentumtárban. A munka-másolat vagy a számítógépen található vagy egy változatkezelő program tárolja, mint amilyen például a Microsoft Visual SourceSafe.

Tipp : Ha nincsen munka-másolata az űrlapsablonról, a számítógépre menthet egy másolatot a sablonról az eredeti dokumentumtárból.

Miután közzétette a munka-másolatot az új dokumentumtárban, a régi dokumentumtárban található összes űrlapot át kell másolni az új dokumentumtárba és az űrlapokat újra kell csatolni az újonnan közzétett űrlapsablonhoz.

Ha szükséges, hogy bizonyos változtatásokat hajtson végre az űrlapsablon áthelyezésével kapcsolatban, akkor tegye meg azt, mielőtt az űrlapsablont közzéteszi. Például, ha a külső adatforrás címét megváltozik - amit az űrlapsablon alapján készült űrlapok használnak - az űrlapsablon áthelyezésének eredményeként. Ebben az esetben meg kell változtatnia az adatkapcsolatokat az űrlapsablonban a külső adatforráshoz, mielőtt közzétenné az űrlapsablont. Az adatkapcsolatok módosításáról további információt a Lásd még szakasz hivatkozásait követve kaphat.

Megjegyzés : Űrlapsablon közzététel nem ugyanaz, mint egy űrlapsablon mentése. Űrlapsablon közzététele, a közzétételi varázsló hozzáadja a Közzététel helye és a képernyőn megjelenő utasításokat követve az űrlapsablon feldolgozása az, hogy a felhasználó ezen a sablonon alapuló űrlapok nyithat meg. Űrlapsablon mentésekor menti az űrlapsablon egy példányát, akárcsak egy fájlt a számítógépre való mentéskor. Ha meg szeretné űrlapsablon töltheti ki a felhasználók számára is elérhetővé a közzétételi varázsló mindig kell használni.

Vissza a lap tetejére

Mielőtt elkezdené:

Mielőtt az új dokumentumtárba áthelyezi az űrlapsablont és a sablonon alapuló, már létező űrlapokat, a következőket kell ellenőriznie:

  • Az űrlapsablon munka-másolata:     Ez az űrlapsablonnak az a másolata, amelyet módosít és közzétesz az új dokumentumtárban. A munka-másolat vagy a számítógépen található vagy egy változatkezelő program tárolja, mint amilyen például a Microsoft Visual SourceSafe.

  • Bármely új külső adatforrás helye:     Ha a sablon alapján elkészült űrlapok olyan külső adatforrást használnak, amelynek az elérési helye megváltozott, akkor szüksége van a külső adatforrás új elérési helyére. Ellenőriztesse le a rendszergazdával, hogy Önnek és a felhasználóinak megfelelő jogosultságaik vannak-e a külső adatforrás használatához. Ha az űrlapsablon a külső adatforráshoz való kapcsolódása során adatkapcsolati fájlban található beállításokat is használ, ellenőrizze, hogy az adatkapcsolati fájl frissítve lett-e a külső adatforrások új elérési helyeivel.

  • Megfelelő jogosultság Windows SharePoint Services 3.0 alkalmazást futtató kiszolgálón:     Az űrlapsablon közzétételéhez, valamint a már létező űrlapoknak a régi dokumentumtárból az újba történő áthelyezéséhez megfelelő jogosultságokkal kell rendelkezzen. Ellenőriztesse a rendszergazdával, hogy a szükséges jogosultságokkal rendelkezik-e.

Vissza a lap tetejére

Munka-másolat készítése az űrlapsablonról

Ha olyan űrlapsablont szeretne módosítani, amelyről nincs munka-másolata, viszont korábban már közzétette azt egy megosztott hálózati mappában, vagy egy dokumentumtárában, akkor mentse le az űrlapsablon másolatát a közzététel helyéről a saját gépére.

Tipp : Mérlegelje egy, a Microsoft Visual SourceSafe alkalmazáshoz hasonló változatkezelő program használatát, mellyel az űrlapsablonok munka-másolatait kezelheti.

Az űrlapsablon másolatának elmentése a dokumentumtárból a saját gépre

  1. Nyissa meg egy internetböngészőben azt a dokumentumtárat, amelyben közzé lett téve az űrlapsablon.

  2. Kattintson a Beállítások menü Beállítások parancsára, majd az Űrlaptár beállításai elemre.

  3. Kattintson az Általános beállítások szakasz Speciális beállítások gombjára.

  4. A Dokumentumsablon csoportban kattintson a Sablon szerkesztése lehetőségre.

    Az űrlapsablon ekkor megnyílik a Microsoft Office InfoPath programban.

  5. A Microsoft Office InfoPath párbeszédpanelen kattintson az Igen gombra.

  6. Kattintson a Fájl menü Mentés másként parancsára.

  7. Kattintson a Microsoft Office InfoPath párbeszédpanelen az OK gombra.

  8. A Mentés másként párbeszédpanelen keresse meg azt a helyet, ahová el szeretne menteni az űrlapsablon egy másolatát, majd kattintson a Mentés gombra.

Az űrlapsablon másolatának elmentése a megosztott hálózati helyről a saját gépre

  1. Kattintson a Fájl menü Űrlapsablon tervezése parancsára.

  2. Az Űrlapsablon megnyitása részben kattintson a Saját számítógépen elemre.

  3. Keresse meg a közzétett űrlapsablon megosztott hálózati mappáját, kattintson az űrlapsablonra, majd kattintson a Megnyitás gombra.

  4. Kattintson a Fájl menü Mentés másként parancsára.

  5. Kattintson a Microsoft Office InfoPath párbeszédpanelen az OK gombra.

  6. A Mentés másként párbeszédpanelen válasszon ki egy, az eredeti közzétételi helytől eltérő helyet a munkapéldány számára, majd kattintson a Mentés gombra.

Vissza a lap tetejére

1. lépés: Az űrlapsablon közzététele az új dokumentumtárban

  1. Nyissa meg az űrlapsablon egy munka-másolatát tervező módban.

  2. Kattintson a Fájl menü Közzététel parancsára.

  3. A Közzététel varázslóban jelölje be az InfoPath Forms Services szolgáltatást nem feltétlenül tartalmazó SharePoint-kiszolgálóra választógombot, majd kattintson a Tovább gombra.

  4. Az Adja meg a SharePoint- vagy InfoPath Forms Services-alapú webhely címét mezőben adja meg annak a SharePoint-webhelynek az elérési helyét, ahol az az új dokumentumtár található, ahová az űrlapsablonját át szeretné helyezni, majd kattintson a Tovább gombra.

  5. A varázsló következő oldalán kattintson a Dokumentumtár elemre, majd a Tovább gombra.

  6. Kattintson az Új dokumentumtár létrehozása elemre, majd a Tovább gombra.

  7. A varázsló követező lapján adja meg az új dokumentumtár nevét és leírását, majd kattintson a Tovább gombra.

  8. Válassza ki azokat a mezőket az űrlapsablonban, amelyek a dokumentumtár alapértelmezett nézetében oszlopként kell megjelenjenek.

    Hogyan?

    1. Kattintson a Hozzáadás gombra.

    2. Kattintson a dokumentumtárhoz oszlopként hozzáadni kívánt mezőre, majd hajtsa végre az alábbiak egyikét:

      • Írja be a kívánt nevet az Oszlopnév mezőbe.

      • Jelölje ki a webhelyoszlopot a Webhely oszlopcsoport listában, válasszon egy nevet az Oszlopnév listában, majd kattintson az OK gombra.

        Megjegyzés : Ha egy adat dokumentumtárban való megjelenítéséhez ismétlődő mezőt választott, a Függvény lista egy elemének kijelölésével meghatározhatja a mező dokumentumtárban való megjelenítésének módját. Választhatja az összes érték egyesítését, a mezőben található első, illetve utolsó elem megjelenítését, valamint akár a mező összes előfordulásának számát is megjelenítheti.

    3. Kattintson az OK gombra.

    A dokumentumtár könyvtárainak oszlopaiban megjelenő adatokról további információt a Lásd még szakasz hivatkozásait követve találhat.

  9. Kattintson a Tovább gombra.

  10. A varázsló következő oldalán ellenőrizze, hogy az információk helyesek-e, majd kattintson a Közzététel gombra.

  11. A dokumentumtár megnyitásához és az űrlapsablon kitöltési folyamatának teszteléséhez jelölje be a Dokumentumtár megnyitása jelölőnégyzetet és kattintson a Bezárás gombra.

    A dokumentumtár ekkor megnyitja a webböngészőt. A lista eszköztáron az Új elemre kattintva a Microsoft Office InfoPath programban megnyílik egy, ezen a sablonon alapuló űrlap.

Miután a dokumentumsablont közzétette az új dokumentumtárba, a már létező, a régi sablonon alapuló űrlapokat másolja át a régi dokumentumtárból az újba. A másolás befejezése után az űrlapokat újracsatolhatja az űrlapsablon új verziójához. Ha nem csatolja újra a űrlapokat, akkor a felhasználók nem tudják ezeket az űrlapokat megnyitni.

Vissza a lap tetejére

2. lépés: A létező űrlapok másolása és ismételt csatolása

Az eljárás feltétele, hogy mindkét dokumentumtár Windows SharePoint Services 3.0 alkalmazást futtató kiszolgálón legyen.

  1. Nyissa meg a régi dokumentumtárat a webböngészőben.

  2. A Nézet menüben kattintson a Tallózó nézet parancsra.

  3. A CTRL gomb nyomva tartása mellett válassza ki az összes, áthelyezni kívánt űrlapot, majd kattintson a jobb egérgombbal az űrlapokra.

  4. Az Internet Explorer párbeszédpanelen kattintson az Igen gombra, majd a Másolás parancsra a helyi menüben.

  5. Nyissa meg az új dokumentumtárat.

  6. A Nézet megadása alatt kattintson a Tallózó nézet elemre.

  7. Jobb gombbal kattintson a mappa ablakának egy üres területére.

  8. Az Internet Explorer párbeszédpanelen kattintson az Igen gombra, majd a Beillesztés parancsra a helyi menüben.

  9. A Nézet menüben kattintson a Dokumentumok újbóli csatolása parancsra.

  10. Az Újracsatolás oszlopban jelölje be az összes űrlapot, amelyet az új űrlapsablonhoz szeretne csatolni.

  11. A lista eszköztáron kattintson az Kiválasztott dokumentumok újracsatolására.

Miután a létező űrlapokat újracsatolta az új űrlapsablonhoz, a felhasználók módosíthatják az új dokumentumtárba másolt űrlapokat vagy kitölthetnek újakat az újonnan közzétett űrlapsablon alapján.

Vissza a lap tetejére

Megjegyzés : Gépi fordítás jognyilatkozata: Ez a cikk számítógép által, emberi közreműködés nélkül lett lefordítva. A Microsoft ezeket a gépi fordításokat azért nyújtja, hogy az angol nyelvet nem beszélők minél több tartalomhoz tudjanak hozzáférni a Microsoft termékeivel, szolgáltatásaival és technológiáival kapcsolatban. A gépi fordítás miatt előfordulhat, hogy a szöveg szóhasználati, szintaktikai vagy helyesírási hibákat tartalmaz.

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×