A #ZÉRÓOSZTÓ! hiba javítása

A Microsoft Excel a #ZÉRÓOSZTÓ! hibát jeleníti meg, ha egy szám nullával (0) van osztva. Ez előfordulhat egyszerű képlet (például =5/0) beírásakor, és akkor is, ha egy képlet üres vagy nullát tartalmazó cellára hivatkozik (lásd az alábbi képet).

Példák #ZÉRÓOSZTÓ! hibát okozó képletekre.

A hiba kijavításához végezze el az alábbi lépések egyikét:

  • Biztosítsa, hogy a függvényben vagy a képletben használt osztó ne legyen nulla vagy üres cella.

  • Olyan cellahivatkozást adjon meg a képletben, amelyik nem nulla (0) értékű vagy nem üres cellára mutat.

  • Írja be a #HIÁNYZIK hibaértéket a képletben osztóként hivatkozott cellába, így képleteredményként a #HIÁNYZIK hiba jelenik meg, ami azt jelenti, hogy az osztó nem áll rendelkezésre.

A #ZÉRÓOSZTÓ! hiba gyakran nem kerülhető el, hiszen a megadott képletet adatbevitelre várnak Öntől vagy más felhasználótól. Ilyen esetekben célszerű nem megjeleníteni a hibaüzenetet – a rendelkezésre álló hibakezelési módszerekkel elrejtheti őket, amíg az alkalmazás adatbevitelre várakozik.

Nevező kiértékelése 0-ra vagy érték nélkül

Ha el szeretné rejteni a #ZÉRÓOSZTÓ! hibát, akkor a legegyszerűbb, ha a HA függvénnyel kiértékeli a nevezőt. Ha a nevező 0, vagy ha nincs érték, akkor a képlet eredménye ne a #ZÉRÓOSZTÓ! hibaérték (amelyet amúgy eredményül adna) legyen, hanem a 0 vagy semmilyen érték.

Ha a hibát visszaadó képlet például =A2/A3, akkor a =HA(A3;A2/A3;0) képlettel nulla (0), a =HA(A3;A2/A3;””) képlettel pedig üres karakterlánc jeleníthető meg. Egyéni üzenetet is megjeleníttethet, például ilyesmit: =HA(A3;A2/A3;”Bevitelre vár”). Az első példából vett KVÓCIENS függvénnyel például ilyet képletet adhat meg: =HA(A3;KVÓCIENS(A2;A3);0). Ez azt jelzi az Excelnek, hogy HA(A3 létezik, akkor adja vissza a képlet eredményét, ellenkező esetben pedig hagyja figyelmen kívül).

Példák a #ZÉRÓOSZTÓ! hiba javítására.

A #ZÉRÓOSZTÓ! hiba elrejtése a HAHIBA függvénnyel

Ezt a hibát úgy is elrejtheti, ha az osztási műveletet beágyazza a HAHIBA függvénybe. Az A2/A3-nál maradva a képlet =HAHIBA(A2/A3;0). Ez azt jelzi az Excelnek, hogy ha a képlet kiértékelése hibához vezet, akkor a 0 értéket jelenítse meg, ellenkező esetben pedig a képlet tényleges eredményét.

Az Excel 2007 előtti Excel-verziókban használja a HA(HIBÁS()) módszert: =HA(HIBÁS(A2/A3);0;A2/A3) (Lásd: Ellenőrző függvények).

Megjegyzés: a HAHIBA és a HA(HIBÁS()) hibakezelő az összes hiba megjelenítését kihagyja, nem csak a #ZÉRÓOSZTÓ! hibáét. Hibakezelő alkalmazása előtt győződjön meg arról, hogy a képlet helyes, ellenkező esetben előfordulhat, hogy veszi észre a hibás működést.

Tipp : Ha az Excelben be van kapcsolva a hibaellenőrzés, kattintson a hibát jelző cella melletti Gombkép gombra. Ha elérhető, kattintson a Számolási lépések megjelenítése parancsra, és válassza az adatoknak megfelelő megoldást.

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel kérdését az Excel közösségi fórumában

Segítsen az Excel továbbfejlesztésében

Vannak javaslatai azzal kapcsolatban, hogy hogyan javíthatjuk az Excel következő verzióját? Ha igen, tanulmányozza a témaköröket az Excel User Voice webhelyen.

Lásd még

HA függvény

HAHIBA függvény

Ellenőrző függvények

A képletek áttekintése az Excelben

Képlethibák kiküszöbölése

Képletek gyakori hibáinak kijavítása hibaellenőrzéssel

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×