A SZUMHA függvény

Ez a témakör a Microsoft Office Excel SZUMHAfüggvény képletszintaxisát és használatát mutatja be.

Leírás

A SZUMHA függvénnyel összeadhatja azokat az értékeket egy tartomány, amelyek megfelelnek a megadott feltételeknek. Ha például egy számokat tartalmazó oszlopban csak az 5-nél nagyobb értékeket szeretné összeadni, a következő képletet használhatja:

=SZUMHA(B2:B25;">5")

A következő példa a feltételt közvetlenül az összeadandó értékekre alkalmazza. Azonban lehetséges a feltételeket egy tartományra alkalmazni, és egy másik tartomány megfelelő értékeit összeadni is. Például a =SZUMH(B2:B5, "Jani", C2:C5) képlet csak azokat az értékeket adja össze a C2:C5 tartományban, ahol a B2:B5 tartomány megfelelő cellái a „Jani" értéket tartalmazzák.

Megjegyzés   Ha több feltétel alapján szeretne összeadni cellákat, a A SZUMHATÖBB függvény című témakörben talál további tudnivalókat.

Szintaxis

SZUMHA(tartomány; feltételek; [összegtartomány])

A SZUMHA függvény szintaxisa a következő argumentumok használja:

  • tartomány:    Megadása kötelező. A feltételek alapján kiértékelendő cellatartomány. Az egyes tartományok cellái számok, számokat tartalmazó tömbök vagy számokra mutató nevek, illetve hivatkozások lehetnek. Az üres és a szöveges értékeket a függvény figyelmen kívül hagyja.

  • feltételek:    Megadása kötelező. Az összeadandó cellákat meghatározó, számként, kifejezésként, cellahivatkozásként, szövegként vagy függvényként megadott feltétel, például: 32, ">32", B5, 32, "32", "alma" vagy MA().

    Fontos   Bármely szöveges feltételt vagy bármely olyan feltételt, amely logikai vagy matematikai szimbólumokat tartalmaz, dupla idézőjelbe (") kell tenni. Ha a feltétel numerikus, nem szükséges a dupla idézőjel.

  • összegtartomány:    Megadása nem kötelező. A ténylegesen összeadandó cellák, ha a tartományargumentumban megadottaktól eltérő cellákat szeretne összeadni. Ha az összegtartomány argumentumot elhagyja, az Excel a tartomány argumentumban megadott cellákat adja össze (ugyanazokat, amelyekre a feltételeket alkalmazza).

Megjegyzés   

  • Az összegtartomány argumentumnak nem feltétlenül kell a tartomány argumentummal azonos méretűnek és formájúnak lennie. Az összeadásban ténylegesen szereplő cellák meghatározása az összegtartomány bal felső cellájából indul ki, majd belekerülnek az összeadásba a összegtartomány argumentumnak méret és forma szempontjából megfelelő cellák. Példa:

Ha a tartomány argumentum:

...és az összeg_tartomány argumentum:

...akkor a ténylegesen összeadandó cellák:

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

  • Használhat helyettesítő karaktereket is – kérdőjelet (?) és csillagot (*) – a feltétel argumentumban. A kérdőjel egyetlen karaktert, míg a csillag tetszőleges számú karaktert helyettesíthet. Ha magát a helyettesítő karaktert keresi, írjon tilde karaktert (~) a keresett karakter elé.

1. példa

A példa könnyebben megérthető, ha üres munkalapra másolja.

Példa másolása

  1. Jelölje ki a cikkben látható példát. Ha a példa másolását az Excel Online-ban végzi, egyszerre csak egy cellát másoljon és illesszen be.
    Important: A sor- és oszlopazonosítókat ne vegye bele a kijelölésbe.

    Példa kijelölése a súgóban

    Példa kijelölése a súgóban

  2. Nyomja le a CTRL+C billentyűkombinációt.

  3. Hozzon létre egy üres munkafüzetet vagy munkalapot.

  4. Jelölje ki a munkalapon az A1 cellát, és nyomja le a CTRL+V billentyűkombinációt. Ha Excel Online-ban dolgozik, ismételje meg a másolási és beillesztési műveletet a példában lévő minden cella esetében.
    Important: A megfelelő működéshez a példát a munkalap A1 cellájába kell beillesztenie.

  5. Az eredmények és az azokat eredményező képletek megjelenítése közötti váltáshoz nyomja le a CTRL+` (fordított ékezet) billentyűkombinációt, vagy kattintson a Képletek lap Képletvizsgálat csoportjának Képletek megjelenítése gombjára.

Miután a példát egy üres munkalapra másolta, igényeinek megfelelően módosíthatja.

1

2

3

4

5

6


7


8



9



10

A

B

C

Az ingatlan értéke

Jutalék

Adatok

100000

7000

250000

200000

14000

300000

21000

400000

28000

Képlet

Leírás

Eredmény

=SZUMHA(A2:A5;">160000";B2:B5)

A 160000 fölötti értékű ingatlanok után járó jutalékok összege

63000

=SZUMHA(A2:A5;">160000")

A 160000 fölötti értékű ingatlanok értékének összege

900000

=SZUMHA(A2:A5;300000;B2:B3)

A 300000 fölötti értékű ingatlanok után járó jutalékok összege

21000

=SZUMHA(A2:A5;">" & C2;B2:B3)

A C2 cellában megadott érték fölötti értékű ingatlanok után járó jutalékok összege.

49000

2. példa

A példa könnyebben megérthető, ha üres munkalapra másolja.

Példa másolása

  1. Jelölje ki a cikkben látható példát. Ha a példa másolását az Excel Online-ban végzi, egyszerre csak egy cellát másoljon és illesszen be.
    Important: A sor- és oszlopazonosítókat ne vegye bele a kijelölésbe.

    Példa kijelölése a súgóban

    Példa kijelölése a súgóban

  2. Nyomja le a CTRL+C billentyűkombinációt.

  3. Hozzon létre egy üres munkafüzetet vagy munkalapot.

  4. Jelölje ki a munkalapon az A1 cellát, és nyomja le a CTRL+V billentyűkombinációt. Ha Excel Online-ban dolgozik, ismételje meg a másolási és beillesztési műveletet a példában lévő minden cella esetében.
    Important: A megfelelő működéshez a példát a munkalap A1 cellájába kell beillesztenie.

  5. Az eredmények és az azokat eredményező képletek megjelenítése közötti váltáshoz nyomja le a CTRL+` (fordított ékezet) billentyűkombinációt, vagy kattintson a Képletek lap Képletvizsgálat csoportjának Képletek megjelenítése gombjára.

Miután a példát egy üres munkalapra másolta, igényeinek megfelelően módosíthatja.

1

2

3

4

5

6

7

8


9


10



11



12

A

B

C

Kategória

Étel

Értékesítés

Zöldségek

Paradicsom

2300

Zöldségek

Zeller

5500

Gyümölcs

Cseresznye

800

Vaj

400

Zöldségek

Répa

4200

Gyümölcs

Alma

1200

Képlet

Leírás

Eredmény

=SZUMHA(A2:A7;"Gyümölcs";C2:C7)

A „Gyümölcs” kategória összes ételének értékesítési összege.

2000

=SZUMHA(A2:A7;"Zöldségek";C2:C7)

A „Zöldségek” kategória összes ételének értékesítési összege.

12000

=SZUMHA(B2:B7;"*a";C2:C7)

Az „a” végű összes étel értékesítési összege (alma, répa).

5400

=SZUMHA(A2:A7;"";C2:C7)

A kategória nélkül megadott összes étel értékesítési összege.

400

Hatókör: Excel 2007



Hasznos volt az információ?

Igen Nem

Hogyan tehetjük jobbá?

255 karakter írható még be

Adatvédelmi okokból ne írjon elérhetőségi információt a visszajelzésébe. Olvassa el adatvédelmi szabályzatunkat.

Köszönjük a visszajelzését!

Támogatási információk

Nyelv módosítása