A #HIV! hiba javítása

Megjegyzés:  Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja .

A #REF! hiba jeleníti meg, amikor a képletet, amely nem érvényes cellára hivatkozik. Ez történik leggyakrabban, amely a képletekben hivatkozott cellák törölt, vagy beillesztett fölé.

Példa – Oszlop törlésével okozott #HIV! hiba

A következő példa a =SZUM(B2,C2,D2) képletet használja az E oszlopban.

Az explicit cellahivatkozásokat használó képletek, mint amilyen például a =SZUM(B2,C2,D2), egy oszlop törlése esetén #HIV! hibát okoznak.

Ha törli a B oszlop volt, C, D, illetve azt okozhat #REF! Hiba történt. Ebben az esetben azt is törli a C oszlop (2007 értékesítés), és a képlet most beolvassa =SUM(B2,#REF!,C2). Közvetlen cellahivatkozásokat ilyen használatakor (Ha egyenként mindegyik cellára hivatkozik, vesszővel elválasztva) és a hivatkozott sor vagy oszlop törlése, az Excel nem találja meg, így a #REF adja vissza! Hiba történt. Ennek az oka elsődleges miért közvetlen cellahivatkozások használata a függvények nem ajánlott.

Példa egy oszlop törlésével okozott #HIV! hibára.

Megoldás

  • Ha véletlenül törölt sorokat vagy oszlopokat, akkor a Visszavonás gombra vagy a gyorselérési eszköztárra kattintva (illetve a CTRL+Z billentyűkombinációval) azonnal visszaállíthatja őket.

  • Módosítsa a képletet, hogy az egyes cellák, például =SUM(B2:D2)helyett tartományhivatkozásból használja. Most már sikerült törölni bármely oszlop a SZUM tartományon belül, és az Excel automatikusan módosítja a képletet. A sorok összegét =SUM(B2:B5) is használhatja.

Példa – Helytelen tartományhivatkozásokat tartalmazó FKERES függvény

A következő példában az =FKERES(A8,A2:D5,5,HAMIS) képlet #HIV! hibát ad vissza, mivel az 5. oszlopban keresi a visszaadandó értéket, a tartományhivatkozás azonban A:D, amely csak 4 oszlopot tartalmaz.

Példa az FKERES képletre helytelen tartománnyal.  A képlet a következő: =FKERES(A8,A2:D5,5,HAMIS).  Az FKERES tartományában nincs ötödik oszlop, ezért az 5-ös érték #HIV! hibát okoz.

Megoldás

Állítsa be a nagyobb méretű lesz, vagy az oszlop keresési érték a hivatkozás tartományának megfelelő csökkentése. =VLOOKUP(a8,a2:E5,5,FALSE) lesz érvényes hivatkozás tartománnyá, módon = VLOOKUP(A8,A2:D5,4,FALSE).

Példa – Helytelen sor- vagy oszlophivatkozással rendelkező INDEX függvény

Ebben a példában az =INDEX(B2:E5,5,5) képlet #HIV! hibát ad vissza, mert az INDEX tartománya 4 sorból és 4 oszlopból áll, a képlet azonban az 5. sorból és az 5. oszlopból kéri az eredmény visszaadását.

Példa INDEX képletre érvénytelen tartományhivatkozással.  A képlet a következő: =INDEX(B2:E5,5,5), de a tartomány mindössze 4 sorból és 4 oszlopból áll.

Megoldás

A sor vagy oszlop hivatkozásokat módosítani, amelyek kezdése az INDEX a keresési tartományt így. =Index(B2:E5,4,4) érvénytelen eredményt adja vissza.

Példa – Hivatkozás bezárt munkafüzetre az INDIREKT függvénnyel

A következő példában egy INDIREKT függvény egy bezárt munkafüzetre kísérel meg hivatkozni, és ez #HIV! hibát okoz.

Példa egy bezárt munkafüzetre való KÖZVETLEN hivatkozással okozott #HIV! hibára.

Megoldás

A hivatkozott munkafüzet megnyitása

OLE-problémák

Ha egy #HIV! hibát okozó objektumcsatolási és -beillesztési (OLE-) hivatkozást használt, akkor indítsa el a hivatkozás által meghívott programot.

Megjegyzés: Az OLE egy olyan technológia, amellyel információkat oszthat meg a programok között.

DDE-problémák

Ha már használta a Dynamic Data Exchange (DDE) tematikus, amely ad eredményül #REF! Hiba, az első ellenőrzése, hogy éppen megjelölése, a megfelelő témakört. Ha továbbra is #REF! Hiba, a jelölőnégyzetet a külső tartalom Adatvédelmi központ beállításai című témakörben ismertetett tiltása vagy tiltásának feloldása az Office-dokumentumok külső tartalom.

Megjegyzés: Dynamic Data Exchange (DDE)egy elfogadott protokoll adatcsere Microsoft Windows-alapú programok között.

Makróproblémák

Ha makró függvényt ír a munkalapra, amely a függvény fölött lévő cellára hivatkozik, és a cellára, amely tartalmazza a függvény a sor 1, a függvény visszaadja #REF! mivel nincs cella, sor 1 fölött. Jelölje be a függvényt, hogy ha valamelyik argumentum egy cellát vagy cellatartományt, amely nem érvényes hivatkozik. Ez szükség lehet a makrót a a Visual Basic Editor (VBE) Ablakát figyelembe helyzet állapotba szerkesztése.

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása hibaellenőrzéssel

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×