A #HIÁNYZIK hiba javítása

A #HIÁNYZIK hiba javítása

A #HIÁNYZIK hibaérték általában azt jelzi, hogy egy képlet nem találja, amit meg kellene találnia.

Legjobb megoldás

A #HIÁNYZIK hiba leggyakrabban az FKERES, a VKERES, a KERES és a HOL.VAN függvénnyel jelentkezik, amikor a függvény nem találja az egyik hivatkozott értéket. Például akkor, ha a keresési érték nem található meg a forrásadatokban.

A keresett érték nem létezik.  Az E2 cellában az =FKERES(D2,$D$6:$E$8,2,HAMIS) képlet szerepel.  A Banán érték nem található, ezért a képlet #HIÁNYZIK hibát ad vissza.
Az elem nem található a forrásadatokban

Példánkban a keresőtáblázatban nem található a „Banán” szó, ezért az FKERES függvény a #HIÁNYZIK hibát adja vissza.

Megoldás: Győződjön meg arról, hogy létezik a keresett érték a forrásadatokban, vagy használjon hibakezelő mechanizmust, például a HAHIBA függvényt a képletben. A =HAHIBA(KÉPLET();0) képlet jelentése például a következő:

  • =HA(a képlet kiértékelése hibát ad vissza, akkor a 0 jelenjen meg, ellenkező esetben a képlet eredménye)

Az írógépi idézőjeleket ("") hagyhatja üresen, vagy megadhat egy saját hibaszöveget benne: =HAHIBA(KÉPLET();"Hibaüzenet helye")

Ha nem biztos abban, hogy ekkor mit kell tennie, vagy milyen típusú segítségre van szüksége, rákereshet a hasonló kérdésekre az Excel közösségi fórumában, illetve saját kérdését is közzéteheti.

Hivatkozás az Excel közösségi fórumára

Ha tovább szeretne lépni, az alábbi ellenőrzőlista hibaelhárítási lépéseit követve megállapíthatja, hogy mi okozza a problémát a képletekben.

A keresett érték és a forrásadatok különböző típusúak. Például az FKERES függvénnyel számot keres, de a forrásadatokat a program szövegként tárolja.

Érvénytelen értéktípusok  A példában az látható, hogy egy FKERES függvényt használó képlet #HIÁNYZIK hibát ad vissza, mert a keresett elem számként, a keresési tábla azonban szövegként van formázva.
Eltérő adattípusok okozta #HIÁNYZIK hiba

Megoldás: Gondoskodjon arról, hogy az adattípusok azonosak legyenek. A cellaformátum ellenőrzéséhez jelölje ki az egyik cellát vagy cellatartományt, kattintson rá a jobb gombbal, válassza a Cellaformázás > Szám fület (vagy nyomja le a Ctrl+1 billentyűkombinációt), és szükség esetén módosítsa a formátumot.

A Cellák formázása párbeszédpanel, amelyen a Szám lap Szöveg beállítása van kiválasztva

Tipp: Ha az egész oszlopra szeretné érvényesíteni a formátum módosítását, először állítsa be a kívánt formázást, majd válassza az Adatok > Szövegből oszlopok > Befejezés gombot.

A cellák elejéről és végéről a KIMETSZ függvény használatával távolíthatja el a szóközöket. A következő példában a KIMETSZ függvényt az FKERES függvénybe ágyazva eltávolítjuk az A2:A7 cellákban lévő nevek elől a fölös szóközöket, és eredményként a részleg nevét kapjuk.

Az FKERES és a KIMETSZ függvény használata egy tömbképletben a kezdő/záró szóközök eltávolításához  Az E3 cellában az {=FKERES(D2,KIMETSZ(A2:B7),2,HAMIS)} képlet szerepel; ezt meg kell adni a CTRL+SHIFT+ENTER billentyűkombinációval.

{=FKERES(D2;KIMETSZ(A2:B7);2;HAMIS)}

Megjegyzés: Ez egy tömbképlet, amelyet a Ctrl+Shift+Enter billentyűkombinációval kell megadni. Az Excel automatikusan kapcsos zárójelekbe {} helyezi a képletet. Ha kézzel próbálja megadni a zárójeleket, az Excel szövegként jeleníti meg a képletet.

Alapértelmezés szerint a táblázatokban információt kereső függvényekhez az adatokat növekvő sorrendbe kell rendezni. Az FKERES és a VKERES munkalapfüggvény azonban egy tartományban_keres argumentumot is tartalmaz, amely arra utasítja a függvényt, hogy pontos egyezést keressen akkor is, ha a táblázat nem rendezett. A pontos egyezés kereséséhez a tartományban_keres argumentumnak adja a HAMIS értéket. Fontos tudni, hogy ha az IGAZ argumentumot használja (amely a függvényt közelítő egyezés keresésére utasítja), akkor nemcsak a #HIÁNYZIK hiba léphet fel, hanem hibás eredményt is kaphat, mint az alábbi példában.

Példa arra, hogy az FKERES függvény IGAZ tartományban_keres argumentummal való használata hibás eredményeket okozhat
Az FKERES sikertelen, mert egy rendezetlen táblázatban a közelítőleges egyezésnek megfelelő argumentumot használjuk

Ebben a példában nemcsak a „Banán” keresése okoz #HIÁNYZIK hibát, de a „Körte” keresése is téves árat ad eredményül. Ennek az IGAZ argumentum használata az oka, amely arra utasítja az FKERES függvényt, hogy pontos egyezés helyett közelítő egyezést keressen. A „Banán”-ra nincs pontos egyezés, és betűrendben a „Körte” az „Őszibarack” előtt áll. Ebben az esetben a HAMIS argumentummal használt FKERES függvény a „Körte” keresésére a helyes árat adná vissza, de a „Banán” keresésre továbbra is a #HIÁNYZIK hiba lépne fel, mert a keresőlistában nem található „Banán” érték.

A HOL.VAN függvény használata esetén az egyezés_típus argumentum értékének módosításával adja meg a táblázat rendezési sorrendjét. Pontos egyezéshez az egyezés_típus argumentum értéke legyen 0 (nulla).

A hiba kijavításához ellenőrizze, hogy a tömbképlet által hivatkozott tartományban ugyanannyi sor és oszlop van-e, mint a tömbképletet tartalmazó cellatartományban, vagy a tömbképletet írja kevesebb, illetve több cellába, hogy a képlet tartományhivatkozásának megfeleljen.

Az alábbi példában az E2 cella eltérő méretű tartományokra hivatkozik:

Példa nem egyező tartományi hivatkozások által okozott #HIÁNYZIK hibát jelző tömbképletre  Az E2 cellában a {=SZUM(HA(A2:A11=D2,B2:B5))} képlet szerepel; ezt meg kell adni a CTRL+SHIFT+ENTER billentyűkombinációval.

{=SZUM(HA(A2:A11=D2;B2:B5))}

A képlet akkor fog helyesen működni, ha mindkét tartomány a 2–11. sort foglalja magában.

{=SZUM(HA(A2:A11=D2;B2:B11))}

Megjegyzés: Ez egy tömbképlet, amelyet a Ctrl+Shift+Enter billentyűkombinációval kell megadni. Az Excel automatikusan kapcsos zárójelekbe {} helyezi a képletet. Ha kézzel próbálja megadni a zárójeleket, az Excel szövegként jeleníti meg a képletet.

Példa a cellákba beírt #HIÁNYZIK hibára, amely megakadályozza a SZUM függvényt használó képletek megfelelő kiszámítását

Ebben az esetben a Május és a December oszlop a hibát jelző #HIÁNYZIK értéket tartalmazza, ezért az összeget nem lehet kiszámítani, és az Összeg oszlopban a #HIÁNYZIK hiba jelenik meg.

A hiba kijavításához ellenőrizze a használt függvény képletszintaxisát, és írja be az összes kötelező argumentumot a hibát visszaadó képletbe. Lehet, hogy ehhez meg kell nyitnia a Visual Basic Editor (VBE) ablakát, és ott kell ellenőriznie a függvényt. A VBE elérhető a Fejlesztőeszközök lapról, de az ALT+F11 billentyűkombinációval is megnyitható.

A hiba kijavításához győződjön meg arról, hogy a felhasználó által definiált függvényt tartalmazó munkafüzet meg van nyitva, és a függvény megfelelően működik.

A hiba kijavításához győződjön meg arról, hogy a függvény argumentumai megfelelőek és a megfelelő pozícióban vannak.

A hiba kijavításához a Ctrl+Alt+F9 billentyűkombinációt lenyomva számítsa ki újra a munkalap képleteit.

Ha nem biztos abban, hogy melyik argumentumot kell használnia, a Függvény varázsló segíthet. Jelölje ki a kérdéses képletet tartalmazó cellát, lépjen a menüszalag Képletek lapjára, és válassza a Függvény beszúrása gombot.

Függvény beszúrása gomb

Az Excel automatikusan megnyitja a varázslót:

Példa a Képletkiértékelő varázslóra

Az argumentumokra kattintva az Excel mindegyikről megjeleníti a tudnivalókat.

A #HIÁNYZIK hibaérték hasznos is lehet! A #HIÁNYZIK hibaértéket gyakran használják diagramokban például az alább látható adatok esetében, mert a #HIÁNYZIK hibaértéket a diagram nem ábrázolja. Az alábbi példákban az egyik diagram nullákat (0), a másik a #HIÁNYZIK hibaértéket használja.

Példa 0 értékeket megjelenítő vonaldiagramra

A fenti példában látható, hogy a 0 értékeket a diagram ábrázolja, és egyenes vonalként jeleníti meg alul, amely hirtelen a magasba szökik az Összeg oszlop ábrázolásakor. Az alábbi példában a 0-k helyet a #HIÁNYZIK hibaértéket használjuk.

Példa a #HIÁNYZIK értékeket meg nem jelenítő vonaldiagramra

A különböző képletekben megjelenő #HIÁNYZIK! hibáról további információt az alábbi témakörökben talál:

Vissza a lap tetejére

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Szövegként tárolt számok számmá alakítása

FKERES függvény

VKERES függvény

KERES függvény

HOL.VAN függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

Képletek gyakori hibáinak kijavítása hibaellenőrzéssel

A Windows Excel billentyűparancsai

A Mac Excel billentyűparancsai

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×