A HA függvény használata az ÉS, a VAGY és a NEM függvényekkel

A HA függvénnyel logikailag összehasonlíthat egy értéket egy elvárt értékkel úgy, hogy ellenőrzi egy feltétellel való egyezését, és hogy milyen eredményt ad vissza, ha a feltételre Igaz vagy Hamis értéket ad.

  • =HA(Valami igaz, akkor valami történik, ellenkező esetben pedig valami más)

De mi a teendő, ha egyszerre több feltételt szeretne ellenőrizni, ahol minden feltételnek Igaznak vagy Hamisnak kell lennie (ÉS), vagy csak egyetlen feltételnek kell Igaznak vagy Hamisnak lennie (VAGY), vagy pedig azt szeretné tudni, ha a feltétel NEM felel meg a megadott feltételnek? Mind a 3 függvény használható magában, de sokkal gyakrabban előfordul, hogy a HA függvénnyel párosítják őket.

A HA és az ÉS, VAGY és NEM függvények együttes használatával többszörös kiértékelések végezhetők, hogy a feltételek Igaz vagy Hamis értéket adnak-e.

Szintaxis

  • HA(ÉS()) - HA(ÉS(logikai1; [logikai2];...), érték_ha_igaz; [érték_ha_hamis]))

  • HA(VAGY()) - HA(VAGY)logikai1; [logikai2];...), érték_ha_igaz, [érték_ha_hamis]))

  • HA(NEM()) - HA(NEM(logikai1), érték_ha_igaz, [érték_ha_hamis]))

Argumentum neve

Leírás

logikai_vizsgálat (kötelező)

A vizsgálni kívánt feltétel.

érték_ha_igaz (kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye IGAZ.

érték_ha_hamis (nem kötelező)

A visszaadandó érték, ha a logikai_vizsgálat eredménye HAMIS.

Az alábbiakban egy áttekintést láthat, hogy hogyan érdemes külön-külön felépíteni az ÉS, VAGY és NEM függvényeket. Ha bármelyik függvényt egy HA utasítással kombinálja, a következőképpen fog kinézni:

  • ÉS – =HA(ÉS(Valami igaz, Valami más igaz), Érték ha Igaz, Érték ha Hamis)

  • VAGY – =HA(VAGY(Valami igaz, Valami más igaz), Érték ha Igaz, Érték ha Hamis)

  • NEM – =HA(NEM(Valami igaz), Érték ha Igaz, Érték ha Hamis)

Példák

Az alábbiakban néhány példát talál néhány a gyakori beágyazott HA(ÉS()), HA(VAGY()) és HA(NEM()) utasításokra. Az ÉS és a VAGY függvény legfeljebb 255 különböző feltételt támogatnak, de nem ajánlatos néhánynál több feltételt használni, ugyanis az összetett, beágyazott függvények felépítése, tesztelése és fenntartása nagyon bonyolulttá válhat. A NOT függvény csupán egy feltételt fogad el.

Példák a HA függvény használatára az ÉS, a VAGY és a NEM függvényekkel numerikus értékek és szöveg kiértékeléséhez

Az alábbiakban az összefüggések alapján elmagyarázott képleteket láthatja:

Képlet

Leírás

=HA(ÉS(A2>0,B2<100),IGAZ, HAMIS)

HA az A2 (25) nagyobb, mint 0, ÉS a B2 (75) kisebb, mint 100, akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben mindkét feltétel teljesül, így a képlet az IGAZ értéket adja vissza.

=HA(ÉS(A3="Piros",B3="Zöld"),IGAZ,HAMIS)

HA az A3 ("Kék") = "Piros", ÉS a B3 ("Zöld") egyenlő "Zöld", akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben csak az első feltétel igaz, így a képlet a HAMIS értéket adja vissza.

=HA(VAGY(A4>0,B4<50),IGAZ, HAMIS)

HA az A4 (25) nagyobb, mint 0, VAGY a B4 (75) kisebb, mint 50, akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben csak az első feltétel IGAZ, de mivel a VAGY utasításnál csak egy argumentumnak kell igaznak lennie, a képlet az IGAZ értéket adja vissza.

=HA(VAGY(A5="Piros",B5="Zöld"),IGAZ,HAMIS)

HA az A5 ("Kék") egyenlő "Piros", VAGY a B5 ("Zöld") egyenlő "Zöld", akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben a második argumentum értéke Igaz, ezért a képlet az IGAZ értéket adja vissza.

=HA(NEM(A6>50),IGAZ,HAMIS)

HA az A6 (25) NEM nagyobb, mint 50, akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben 25 nem nagyobb, mint 50, ezért a képlet eredménye IGAZ.

=HA(NEM(A7="Piros"),IGAZ,HAMIS)

HA az A7 ("Kék") NEM egyenlő "Piros", akkor az eredmény IGAZ, egyébként HAMIS.

Ne feledje, hogy a megfelelő feltételek beírása után minden példában szerepel egy zárójel. A hátralévő Igaz/Hamis argumentumok ezután már a külső HA utasításhoz tartoznak. A példákban az IGAZ/HAMIS értékek helyett Szöveg vagy Numerikus értékeket is kérhet eredményként.

Az alábbiakban láthat néhány példát a dátumok kiértékeléséhez az ÉS, a VAGY és a NEM függvényekkel.

Példák a HA függvény használatára az ÉS, a VAGY és a NEM függvényekkel dátumok kiértékeléséhez

Az alábbiakban az összefüggések alapján elmagyarázott képleteket láthatja:

Képlet

Leírás

=HA(A2>B2,IGAZ,HAMIS)

HA az A2 nagyobb, mint B2, akkor az eredmény IGAZ, egyébként HAMIS. 03/12/14 nagyobb, mint 01/01/14, ezért a képlet eredménye IGAZ.

=HA(ÉS(A3>B2,A3<C2),IGAZ,HAMIS)

HA az A3 nagyobb, mint a B2, ÉS A3 kisebb, mint a C2, akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben mindkét argumentum igaz, ezért a képlet az IGAZ értéket adja vissza.

=HA(VAGY(A4>B2,A4<B2+60),IGAZ,HAMIS)

HA az A4 nagyobb, mint a B2, VAGY A4 kisebb, mint B2 + 60, akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben az első argumentum igaz, de a második hamis. Mivel a VAGY utasítás miatt csak az egyik argumentumnak kell igaznak lennie, a képlet az IGAZ értéket adja vissza. Ha a Képletek lap Képletkiértékelő varázslóját használja, láthatja, hogy az Excel hogyan értékeli ki a képletet.

=HA(NEM(A5>B2),IGAZ,HAMIS)

HA az A5 nem nagyobb, mint a B2, akkor az eredmény IGAZ, egyébként HAMIS. Ebben az esetben az A5 nagyobb, mint a B2, ezért a képlet a HAMIS értéket adja eredményül.

Példa a Képletkiértékelő varázslóra

Az ÉS, a VAGY és a NEM függvények használata feltételes formázással

Az ÉS, a VAGY és a NEM függvényekkel és a képletek beállítással Feltételes formázási feltételeket is megadhat. Ha így tesz, elhagyhatja az IF függvényt, és önmagukban használhatja az ÉS, a VAGY és a NEM függvényeket.

Kattintson a Kezdőlap lap Feltételes formázás > Új szabály menüpontjára. Ezután jelölje ki a „A formázandó cellák kijelölése képlettel” beállítást, írja be a képletet, és alkalmazza a választott formázást.

Feltételes formázás > Szabály szerkesztése párbeszédpanel, amely a Képlet módszert jeleníti meg

A korábbi Dátumok példánál maradva így néznének ki a formulák.

Példa az ÉS, a VAGY és a NEM függvények használatára a Feltételes formázási tesztekhez


Képlet

Leírás

=A2>B2

Ha az A2 értéke nagyobb, mint a B2, formázza a cellát, egyébként hagyja.

=ÉS(A3>B2,A3<C2)

Ha az A3 nagyobb, mint a B2, ÉS az A3 kisebb, mint a C2, formázza a cellát, egyébként hagyja.

=VAGY(A4>B2,A4<B2+60)

Ha az A4 nagyobb, mint a B2, VAGY az A4 kisebb, mint B2 plusz 60 (nap), formázza a cellát, egyébként hagyja.

=NEM(A5>B2)

Ha az A5 értéke NEM nagyobb, mint a B2, formázza a cellát, egyébként hagyja. Ebben az esetben az A5 nagyobb, mint a B2, ezért a képlet a HAMIS értéket adja eredményül. Ha a képletet a =NEM(B2>A5) formára módosítaná, akkor IGAZ értéket adna eredményül, és a cella formázva lenne.

Megjegyzés : Gyakori hiba, hogy a képlet egyenlőségjel (=) nélkül kerül a Feltételes formázásba. Ha ebbe a hibába esik, a rendszer a Feltételes formázás párbeszédablakban automatikusan hozzáadja az egyenlőségjelet a képlethez - ="VAGY(A4>B2,A4<B2+60)", így el kell távolítania az idézőjeleket, mielőtt a képlet működőképes lesz.

Vissza a lap tetejére

További segítségre van szüksége?

Bármikor segítséget kérhet az Excel technikai közösségétől és az Answers-közösségtől, az Excel User Voice webhelyen pedig új funkciókra vagy fejlesztésekre tehet javaslatot.

Lásd még

Videó: A HA függvény használata

Függvények egymásba ágyazása a képletekben

HA függvény

ÉS függvény

VAGY függvény

NEM függvény

Az Excel képleteinek áttekintése

Hibás képletek kiküszöbölése

A képlethibák feltárása az Excelben

A Windows Excel 2016 billentyűparancsai

A Mac Excel billentyűparancsai

Logikai függvények (segédlet)

Az Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×