4. lépés – A makró megosztása másokkal

A makrók megosztásával kapcsolatban fontos tudni, hogy a makrókat az Office-fájl tárolja, így ezt a fájlt kell megosztani másokkal. Ha a Wordben hozott létre makrót, a fájlt Makróbarát Word-sablonként (.dotm) vagy Makróbarát Word-dokumentumként (.docm) kell megosztania. Ha az Excelben hozta létre a makrót, a fájlt Makróbarát Excel-munkafüzetként (.xlsm) vagy Makróbarát Excel-sablonként (.xltm) kell megosztania.

Ha Word-makrót hozott létre, végre kell hajtania néhány további lépést a makró megosztásához:

Az üres Word-sablon létrehozása

  1. Nyisson meg egy új Word-dokumentumot.

  2. Kattintson a Fájl menü Mentés másként parancsára.

  3. Adja a fájlnak a global_macros.dotm nevet.

  4. A Formátum legördülő menüből válassza a Makróbarát Word-sablon (*.dotm) elemet formátumként.

  5. Válassza ki, hol szeretné tárolni a fájlt a hálózaton.

  6. Kattintson a Mentés gombra, majd zárja be a sablont.

A Word-makró exportálása a dokumentumból

Az 1. lépésben rögzített makróval kövesse az alábbi lépéseket a makró exportálásához:

  1. Nyissa meg azt a dokumentumot vagy sablont, amely az exportálni kívánt makrót tartalmazza.

  2. Az Eszközök menüben mutasson a Makró elemre, majd kattintson a Makrók lehetőségre.

  3. Jelölje ki az exportálni kívánt makrót, majd kattintson a Szerkesztés elemre. Exportálni kívánt makró kiválasztása

  4. A Visual Basic Editorban kattintson a Fájl > Fájl exportálása parancsra.

  5. Mentse a makrót ugyanabba a mappába, ahol a global_macros.dotm makróbarát sablon található.

A Word-makró importálása az új üres sablonba

  1. Nyissa meg a global_macros.dotm fájlt, majd kattintson az Eszközök > Makró > Visual Basic Editor elemre.

  2. A makró importálásához kattintson a Fájl > Fájl importálása elemre, lépjen abba a mappába, ahová exportálta a makrót, jelölje ki a fájlt, majd kattintson a Megnyitás parancsra.

  3. Mentse a modult, lépjen ki a Visual Basic Editorból, majd lépjen ki a Wordből.

A makrót mostantól megoszthatja másokkal, és tájékoztathatja őket arról, hogy az alábbi lépéseket követve telepíthetik a makrót a számítógépükre.

Sablon telepítése: a Word beállítása a makró használatához

  1. Helyezze a global_macro.dotm fájlt erre a helyre:

    • Mac Word 2011: Macintosh HD: Felhasználók: Felhasználónév: Könyvtár: Application Support: Microsoft: Office: Felhasználói sablonok: My Templates

    • Windows Word 2003 vagy újabb: C:\Documents and Settings\Felhasználónév\Application Data\Microsoft\Word\STARTUP

      Megjegyzés :  A felhasználónév a felhasználó bejelentkezési neve.

  2. A Wordben kattintson a Word > Beállítások… elemre.

Word-beállítások

  1. A Személyes beállítások részen kattintson az Alapkönyvtár elemre. 

  2. Válassza az Indítás elemet az Alapkönyvtár listában, majd kattintson a Módosítás… parancsra.

Fájl helye

  1. Ellenőrizze, hogy a Word ugyanazt a mappát használja-e, ahová a global_macro.dotm fájlt helyezte az Indítás mappában.

  2. Kattintson a Kiválasztás parancsra a Mappa kiválasztása párbeszédpanel bezárásához, majd az OK gombra az Alapkönyvtár párbeszédpanel bezárásához.

Az utolsó lépésben közli a Worddel, hogy a global_macros.dotm fájlt használja az indításkor.

  1. A Wordben kattintson az Eszközök > Sablonok és bővítmények… elemre.

  2. Jelölje ki a global_macros.dotm fájlt a listában, és kattintson az OK gombra.

    Tipp :  Ha nem látja a sablont a listában, akkor a global_macros.dotm fájl nem a Word indítási mappájában található. Lépjen vissza ezen szakasz 1. lépésére, és ellenőrizze, hogy az Indítás mappa ugyanabban a mappában van-e, mint ahova a global_macros.dotm fájlt másolta.

Globális sablon beállítása a Wordben

 1. lépés – Kezdés a Makrórögzítővel

2. lépés – A kód elolvasása és értelmezése

3. lépés – Programozási alapok elsajátítása

4. lépés – A makró megosztása másokkal

5. lépés – Valós példák

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×