#ÉRTÉK! hiba kijavítása az ÖSSZEFŰZ függvényben

Megjegyzés: Szeretnénk, ha minél gyorsabban hozzáférhetne a saját nyelvén íródott súgótartalmakhoz. Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Kérjük, hogy a lap alján írja meg, hogy hasznos volt-e az Ön számára az itt található információ. Az eredeti angol nyelvű cikket itt találja.

Fontos: Az Excel 2016, az Excel Mobile és az Excel Online appban az ÖSSZEFŰZ függvényt a FŰZ függvény váltotta fel. Az ÖSSZEFŰZ függvény kompatibilitási okokból továbbra is elérhető, de tanácsos áttérnie a FŰZ függvény használatára, mivel az jóval megbízhatóbb.

Az ÖSSZEFŰZ függvény használata során az #ÉRTÉK! hiba egyik leggyakoribb oka az, hogy a karakterlánc építésekor egy hibát (például #ÉRTÉK!) tartalmazó cellára hivatkozik.

Az alábbi példában a D2, E2 és F2 cellát szeretnénk összefűzni, de az E2 cellában #ÉRTÉK! hiba szerepel.

#ÉRTÉK! hiba az ÖSSZEFŰZ függvényben

A hiba az E2 okoz a függvény a #VALUE megjelenítendő! Hiba történt. Ahhoz, hogy a munkát sikeresen szüksége lesz a hiba cserélje ki a hiba nem egy értéket. Hibát keres a cellatartománynak a hivatkozását a képlet felépítése, és ha igen, megjelenítheti a szöveges karakterlánc, ahol 0 helyett a hiba jelenik meg (vagy helyettesítheti a saját szövegét 0, de háríthatja el a szöveg tördelése a árajánlatok – "A szöveg").

Használhatja például az alábbi képletet:

=HA(HIBÁS(E2);ÖSSZEFŰZ(D2;" ";0;" ";F2))

A HA és a HIBÁS függvény használata kerülő megoldásként a karakterláncok #ÉRTÉK! hiba esetén való összefűzéséhez

Hogyan működik, amely? A Ha függvény az IFERROR függvény segítségével határozza meg, ha hiba lép fel, az E2, és ha van, az ÖSSZEFŰZ függvény összefűzi a D2, E2 és F2 (a függvény felülírja a hiba 0-val), az értékeket, és megjeleníti az eredményül kapott szöveges karakterlánc. Megjegyzés: a képlet is használja a szóközt ("") az értékek érdekében.

Az #ÉRTÉK! hiba javítása az ÖSSZEFŰZ függvényben az Excel 2003-ban és a régebbi verziókban

Ha a #VALUE! Hiba Office Excel 2003 és régebbi verzióiban, szüksége lesz az áttűnés képlet kiértékelés (TFE) beállítás a Exceltörölje. Kövesse a keret határolja #VALUE! hibaüzenet, amikor a cellákban szereplő a probléma megoldásához.

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel kérdését az Excel közösségi fórumában

Segítsen az Excel továbbfejlesztésében

Vannak javaslatai azzal kapcsolatban, hogy hogyan javíthatjuk az Excel következő verzióját? Ha igen, kérjük, tekintse át a témákat az Excel User Voice webhelyen.

Lásd még

Az #ÉRTÉK! hiba javítása

ÖSSZEFŰZ függvény

FŰZ függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása

Az összes Excel függvényeinek betűrendes listája

Az Excel függvényeinek kategória szerinti listája

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×