#ÉRTÉK! hiba kijavítása az ÖSSZEFŰZ függvényben

Fontos : Az Excel 2016, az Excel Mobile és az Excel Online appban az ÖSSZEFŰZ függvényt a FŰZ függvény váltotta fel. Az ÖSSZEFŰZ függvény kompatibilitási okokból továbbra is elérhető, de tanácsos áttérnie a FŰZ függvény használatára, mivel az jóval megbízhatóbb.

Az ÖSSZEFŰZ függvény használata során az #ÉRTÉK! hiba egyik leggyakoribb oka az, hogy a karakterlánc építésekor egy hibát (például #ÉRTÉK!) tartalmazó cellára hivatkozik.

Az alábbi példában a D2, E2 és F2 cellát szeretnénk összefűzni, de az E2 cellában #ÉRTÉK! hiba szerepel.

#ÉRTÉK! hiba az ÖSSZEFŰZ függvényben

Az E2 cellában lévő hiba miatt a függvény az #ÉRTÉK! hibát fogja megjeleníteni. A képlet sikeres használatához le kell cserélnünk a hivatkozott cellában lévő hibaértéket egy olyan értékre, amely nem hiba. Létrehozhat egy olyan képletet, amely ellenőrzi a hibákat a cellahivatkozásban, és ha hibát észlel, akkor lecseréli azt a 0 értékre (vagy a kívánt szövegre, de szöveg megadása esetén idézőjeleket kell használja – például "Szöveg").

Használhatja például az alábbi képletet:

=HA(HIBÁS(E2);ÖSSZEFŰZ(D2;" ";0;" ";F2))

A HA és a HIBÁS függvény használata kerülő megoldásként a karakterláncok #ÉRTÉK! hiba esetén való összefűzéséhez

Hogyan működik mindez? A HA függvény a HAHIBA függvény segítségével megállapítja, hogy található-e hiba az E2 cellában, és ha igen, akkor az ÖSSZEFŰZ függvény kombinálja a D2, E2 és F2 cella értékét (a függvény a hibát a 0 számmal helyettesíti). Ezután megjelenik az eredményül kapott karakterlánc. Megfigyelheti, hogy a képlet szóközöket (" ") is használ az értékek jobb elkülönítéséhez.

Az #ÉRTÉK! hiba javítása az ÖSSZEFŰZ függvényben az Excel 2003-ban és a régebbi verziókban

Ha az #ÉRTÉK! hibát az Office Excel 2003-ban egy annál még régebbi alkalmazásban kapja, akkor törölnie kell a jelet a „Másodlagos kiértékelési mód” beállítás jelölőnégyzetéből az Excelben. A hiba megoldásához kövesse az #ÉRTÉK! hiba cellák összefűzésekor című témakör lépéseit.

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel a kérdését az Excel közösségi fórumában

Segítsen az Excel továbbfejlesztésében

Vannak javaslatai azzal kapcsolatban, hogy hogyan javíthatjuk az Excel következő verzióját? Ha igen, tanulmányozza a témaköröket az Excel User Voice webhelyen.

Lásd még

Az #ÉRTÉK! hiba javítása

ÖSSZEFŰZ függvény

FŰZ függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

Képletek gyakori hibáinak kijavítása hibaellenőrzéssel

Az Excel összes függvényének betűrendes listája

Az Excel összes függvényének kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×