#ÉRTÉK! hiba kijavítása az ÖSSZEFŰZ függvényben

Fontos: A Excel 2016, a Excel Mobile és a Webes Excel ban a Összefűzés függvényt a FŰZ függvény váltotta fel. Az ÖSSZEFŰZ függvény kompatibilitási okokból továbbra is elérhető, de tanácsos áttérnie a FŰZ függvény használatára, mivel az jóval megbízhatóbb.

A #VALUEt leggyakrabban előforduló esetek egyike. az ÖSSZEFŰZ függvény hibát jelez, ha olyan karakterláncot próbál létrehozni, amely egy hibát tartalmazó cellahivatkozást tartalmaz, például #VALUE!.

Az alábbi példában a D2, E2 és F2 cellát szeretnénk összefűzni, de az E2 cellában #ÉRTÉK! hiba szerepel.

#ÉRTÉK! hiba az ÖSSZEFŰZ függvényben

Az E2 cellában lévő hiba miatt a függvény az #ÉRTÉK! hibát fogja megjeleníteni. A képlet sikeres használatához le kell cserélnünk a hivatkozott cellában lévő hibaértéket egy olyan értékre, amely nem hiba. Létrehozhat egy olyan képletet, amely ellenőrzi a hibákat a cellahivatkozásban, és ha hibát észlel, akkor lecseréli azt a 0 értékre (vagy a kívánt szövegre, de szöveg megadása esetén idézőjeleket kell használja – például "Szöveg").

Használhatja például az alábbi képletet:

=HA(HIBÁS(E2);ÖSSZEFŰZ(D2;" ";0;" ";F2))

A HA és a HIBÁS függvény használata kerülő megoldásként a karakterláncok #ÉRTÉK! hiba esetén való összefűzéséhez

Hogyan működik? A ha függvény használja a HAHIBA függvényt annak megállapításához, hogy az E2 hiba-e, és hogy van-e az ÖSSZEFŰZ függvény a D2, E2 és F2 cellában lévő értékeket kombinálja (a hibát a 0 értékkel helyettesíti), és az eredményül kapott szöveges karakterláncot jeleníti meg. Megjegyzés: a képlet szóközöket ("") is használ az értékek elkülönítéséhez.

Az #ÉRTÉK! hiba javítása az ÖSSZEFŰZ függvényben az Excel 2003-ban és a régebbi verziókban

Ha az #ÉRTÉK! hibát az Office Excel 2003-ban egy annál még régebbi alkalmazásban kapja, akkor törölnie kell a jelet a „Másodlagos kiértékelési mód” beállítás jelölőnégyzetéből az Excelben. Kövesse a következő témakör lépéseit #VALUE! hiba a cellák összefűzése során című témakör lépéseit.

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel kérdését az Excel közösségi fórumában

Segítsen az Excel továbbfejlesztésében

Vannak javaslatai azzal kapcsolatban, hogy hogyan javíthatjuk az Excel következő verzióját? Ha igen, tanulmányozza a témaköröket az Excel User Voice webhelyen.

Lásd még

Az #ÉRTÉK! hiba javítása

ÖSSZEFŰZ függvény

FŰZ függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

A képlethibák feltárása

Az Excel összes függvénye (betűrendes)

Az Excel függvényeinek kategória szerinti listája

Megjegyzés:  Ez az oldal gépi fordítással lett lefordítva, ezért nyelvtani hibákat és pontatlanságokat tartalmazhat. A célunk az, hogy ezek a tartalmak felhasználóink hasznára váljanak. Hasznos volt ez az információ az Ön számára? Itt találja az eredeti angol nyelvű cikket.

Office-jártasság bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×