#ÉRTÉK! hiba kijavítása az ÁTLAG vagy a SZUM függvényben

Ha az ÁTLAG vagy a SZUM függvény olyan cellára hivatkozik, amely #ÉRTÉK! hibát tartalmaz, akkor a képlet eredménye is #ÉRTÉK! hiba lesz.

#ÉRTÉK! hiba az ÁTLAG függvényben

A hibaérték elkerüléséhez létrehozunk egy olyan képletet, amely figyelmen kívül hagyja a hibákat a hivatkozott tartományban, és az átlagot a fennmaradt „normál” értékekből számítja ki.

A képletben az ÁTLAG függvényt a HA és a HIBÁS függvénnyel kombináljuk annak meghatározásához, hogy található-e hiba a megadott tartományban. Ez a megoldás tömbképlet használatát igényli:

=ÁTLAG(HA(HIBÁS(B2:D2);"";B2:D2))

Megjegyzés : Ez egy tömbképlet, amelyet a CTRL+SHIFT+ENTER billentyűkombinációval kell megadni. Az Excel automatikusan kapcsos zárójelekbe {} helyezi a képletet. Ha kézzel próbálja megadni a zárójeleket, az Excel szövegként jeleníti meg a képletet.

Tömbképlet az ÁTLAG függvényben az #ÉRTÉK! hiba javításához

Megjegyzés : A fenti képlet nemcsak az #ÉRTÉK! hibákhoz, de a #HIÁNYZIK, a #NULLA, a #ZÉRÓOSZTÓ! és más hibák esetében is használható.

A SZUM függvényt is használhatja hasonlóképpen:

=SZUM(HA(HIBÁS(B2:D2);"";B2:D2))

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel a kérdését az Excel közösségi fórumában

Segítsen az Excel továbbfejlesztésében

Vannak javaslatai azzal kapcsolatban, hogy hogyan javíthatjuk az Excel következő verzióját? Ha igen, tanulmányozza a témaköröket az Excel User Voice webhelyen.

Lásd még

Az #ÉRTÉK! hiba javítása

ÁTLAG függvény

SZUM függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

Képletek gyakori hibáinak kijavítása hibaellenőrzéssel

Az Excel összes függvényének betűrendes listája

Az Excel összes függvényének kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×