#ÉRTÉK! hiba kijavítása a SZORZATÖSSZEG függvényben

Ez a témakör ismerteti, hogy milyen gyakori esetekben fordulhat elő #ÉRTÉK! hiba a SZORZATÖSSZEG függvény használata során.

Probléma: A tömb argumentumai eltérő méretűek

A tömb összes argumentumának megegyező méretűnek kell lennie. Ha nem megegyező méretűek, akkor #ÉRTÉK! hibát kap. Ha például a Tömb 1 egy 3 sorból és 2 oszlopból álló tartományra hivatkozik, akkor a Tömb 2-nek is ugyanilyen méretű tartományra kell hivatkoznia.

Hibát okozó SZORZATÖSSZEG képlet, =SZORZATÖSSZEG(D2:D13;E2:E10) - az E10 értéket E13 értékre kell módosítani, hogy illeszkedjen az első tartományhoz.
  • =SZORZATÖSSZEG(D2:D13;E2:E10)

Ez a képlet hibát fog adni, mert a hivatkozott tartományok eltérő számú sorból állnak (az első esetében 13, a második esetében pedig csak 10).

Megoldás: Módosítsa a képletet a következőképpen:

  • =SZORZATÖSSZEG(D2:D13;E2:E13)

Most már mindkét tartomány ugyanarra a kezdő és befejező sorra hivatkozik, így a képlet működni fog.

Hárítsa el az adatokban lévő #ÉRTÉK! hibát a SZORZATÖSSZEG hibájának megoldásához

Probléma: A tartomány egy vagy több cellája szöveget tartalmaz

Ha a hivatkozott tartomány egy vagy több cellája szöveget tartalmaz vagy Szöveg típusú formátummal rendelkezik, akkor #ÉRTÉK! hibát kap. A szöveg lehet egy másik képlet számításának eredménye, vagy előfordulhat, hogy néhány cella egyszerűen hibásan van formázva.

Az E15 cellában lévő képlet #ÉRTÉK! hibát jelenít meg, mert egy #ÉRTÉK! hiba van az E oszlopban.

Megoldás: Ellenőrizze a szöveget tartalmazó vagy Szöveg formátumú cellákat, és állítsa át őket a megfelelő adattípusra.

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel a kérdését az Excel közösségi fórumában

Segítsen az Excel továbbfejlesztésében

Vannak javaslatai azzal kapcsolatban, hogy hogyan javíthatjuk az Excel következő verzióját? Ha igen, tanulmányozza a témaköröket az Excel User Voice webhelyen.

Lásd még

Az #ÉRTÉK! hiba javítása

SZORZATÖSSZEG függvény

A képletek áttekintése az Excelben

Hibás képletek kiküszöbölése

Képletek gyakori hibáinak kijavítása hibaellenőrzéssel

Az Excel összes függvényének betűrendes listája

Az Excel összes függvényének kategória szerinti listája

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Részvétel az Office Insider programban

Hasznos volt az információ?

Köszönjük a visszajelzését!

Köszönjük visszajelzését. Jobbnak látjuk, ha az Office egyik támogatási szakemberéhez irányítjuk.

×